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Features

DataStax DevCenter is a free visual query IDE for developers, administrators, and others who want to
create and run Cassandra Query Language (CQL) statements against Apache Cassandra and DataStax
Enterprise.

New features in DevCenter 1.3.1

• Support for Cassandra 2.1.3 CQL features:

• Frozen collections including nested collections and FULL collection indexes.
• Inclusion of IF EXISTS for UPDATE statements.

• Editor and wizard support for the DateTieredCompactionStrategy.
• Additional table options available in the Create and Edit Table wizard:

• default_time_to_live

• gc_grace_seconds

• index_interval

• min_index_interval

• max_index_interval

• memtable_flush_period_in_ms

• populate_io_cache_on_flush

• speculative_retry

Features in DevCenter 1.3.0

• Execute (single or multiple) selected statement(s)
• Wizards

• Keyspace wizard
• Table wizard

• A feedback form has been added

Features in DevCenter 1.2.1

• New features

• Prevent execution of CQL scripts containing syntax errors
• Copy as INSERT now supports collections of UDTs or Tuples

• Bug fixes

• Fix issue on Mac OS/X Yosemite which caused first row of results and query trace table to be hidden
• Fix NPE appearing in log file on some content assist actions

Features in DevCenter 1.2

• Full support for Cassandra 2.1, including:

• user-defined types (UDTs)
• tuples
• IF EXISTS

• Syntax highlighting, representation in Results tab and Schema navigator, validation, content assist,
and code snippets for UDTs and tuples

• A new Query Trace tab, located next to the Results tab, which displays detailed trace event data for
the last executed query to aid in understanding query execution and performance
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• An improved New Connection wizard for creating and managing Cassandra connections

Features in DevCenter 1.1

• Support for Apache Cassandra 2.0.x and DataStax Enterprise 4.0.x (lightweight transactions syntax,
static columns, uuid(), now, etc.)

• New and improved validation and code-assist rules
• Option to use a default keyspace for running a script
• Option to set the maximum number of rows to be returned by a statement
• Copy selected or all results as CSV or CQL inserts
• Option to enabled SSL connection
• See the posting on the DataStax Developer Blog about the DevCenter 1.1 feature set

Features in DevCenter 1.0

• A smart CQL editor that provides

• syntax highlighting
• code auto-completion (both keyword and snippet)
• real-time script validation against the current connection

• Schema explorer view for browsing

• keyspaces
• tables
• other database objects

• Outline view for allowing quick navigating long CQL scripts
• Configuring connections to Cassandra or DataStax Enterprise clusters requiring authorization

http://www.datastax.com/dev/blog/devcenter-1-1-0-adds-support-for-apache-cassandra-2-0-and-datastax-enterprise-4-0
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Installing DevCenter

Installing DevCenter is easy.

Before you begin
DevCenter is a Java application and at a minimum a Java runtime environment (JRE versions 6, 7, or 8 are
supported) is required to run it.

Procedure

1. Download the version appropriate for your operating system.

2. Unzip the downloaded file to a location on your hard drive.

3. Run the executable file, DevCenter.

What to do next

Take the DevCenter tutorial.

http://www.datastax.com/download#dl-devcenter
/en/getting_started/doc/getting_started/gettingStartedUsingDevcenter.html
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Using SSL connections

Connecting DevCenter to an SSL-enabled Cassandra or DataStax Enterprise cluster.

Before you begin

• SSL must be configured and working on your cluster.

• Client-to-node encryption.
• Node-to-node encryption.
• Preparing server certificates.

• Install the Java Cryptography Extension (JSE) on your client system.

Download:

• Java 8
• Java 7
• Java 6

Installation directory (jre lib/security):

• Linux: /usr/lib/jvm/jdk1.major.minor_update/jre/lib/security
• Mac OS X: /Library/Java/JavaVirtualMachines/jdk1.major.minor_update/

Contents/Home/jre/lib/security

• Windows: C:\Program Files\Java\jre7\lib\security

Extract the downloaded file and copy the content of UnlimitedJCEPolicy directory to the jre/lib/
security directory.

• The keytool command to manage encryption keys.

Note:  If you cannot find the keytool command on a Windows system, read these instructions.

About this task

Procedure

Server verification

1. To perform server verification, the client needs to have the public key certificate of each node in the
cluster stored in a local truststore file. This file is password protected (keytool will prompt to create a
password). The truststore file and password will be entered into the DevCenter connection manager
dialog box (see below).

a) Using keytool, create a truststore file on your client by importing the public key certificates from
each node in your cluster.

$ keytool -import -v -trustcacerts -alias node0 -file node0.cer -
keystore .truststore
$ keytool -import -v -trustcacerts -alias node1 -file node1.cer -
keystore .truststore
$ keytool -import -v -trustcacerts -alias node2 -file node2.cer -
keystore .truststore

b) In DevCenter, select File > New > Connection to open the Connection Manager.
c) Add the IP addresses of the nodes in your cluster.
d) Select Next.
e) Select This cluster requires SSL option and enter a full path to (or navigate to) the truststore

file on your machine.

/en/datastax_enterprise/4.6/datastax_enterprise/sec/secClientNodeEncryp.html
/en/datastax_enterprise/4.6/datastax_enterprise/sec/secNodeNodeEncryp.html
/en/datastax_enterprise/4.6/datastax_enterprise/sec/secPrepareCerts.html
http://www.oracle.com/technetwork/java/javase/downloads/jce8-download-2133166.html
http://www.oracle.com/technetwork/java/javase/downloads/jce-7-download-432124.html
http://www.oracle.com/technetwork/java/javase/downloads/jce-6-download-429243.html
http://certificate.fyicenter.com/97_JDK_Keytool_How_to_Find_the_Java_Keytool_on_Windows.html
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f) Enter the truststore password.
g) Select Try to establish a connection link to verify that you can successfully connect to Cassandra

nodes.

Client verification

2. If your cluster requires client verification, you need to perform the following additional steps:

a) Create an SSL certificate for the client host (that is, the system on which DevCenter is installed).

$ keytool -genkey -alias client-host -keystore .keystore
b) Export the client certificate.

$ keytool -export -alias client-host -file client-host.cer -
keystore .keystore

The public certificate is stored in the client-host.cer file.
c) Copy the public certificate and import it into the truststore on all nodes of the Cassandra cluster

which you want DevCenter to be connected to.

$ keytool -import -v -trustcacerts -alias client-host -file /tmp/client-
host.cer -keystore /var/tmp/.truststore

Note:  You may have to ask your cluster administrator if you do not have the proper
permissions to modify the truststore file on the cluster nodes.

d) In DevCenter, right-click your connection and select Properties to edit the connection in the
Connection Manager.

e) In Advanced Settings (under Basic Settings) select the Client authentication required option
and enter location of the keystore file and keystore password.
The Connection manager displays an error if the keystore filepath or password is incorrect.

f) Click the Try to establish a connection link to verify your configuration.
g) Click OK at the bottom of the Connection Manager dialog to create or update the connection.

Now you can enable and have DevCenter communicate with your SSL-enabled cluster.
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Reference

GUI
With DevCenter, you can manage multiple connections to Cassandra or DataStax Enterprise clusters and
edit and run CQL scripts against those clusters.

The default main window for DevCenter has six panes arranged as left-hand and right-hand columns
bordering a central, wider column. The panes are clockwise from the top left-hand corner:

Connection Manager

Used for creating, deleting, opening, and closing cluster connections.

Query Editor

A text editor for writing and executing CQL queries. When more than one file is open, it is a tabbed pane.
The cluster against which the queries are executed appears in a dropdown.

Schema Navigator

Shows the schemas (keyspaces) of the currently active cluster.

CQL Scripts

Used to create, delete, or open for editing a CQL script.

Results

Shows the results of the last run query.

Query Trace

Shows the trace session of the last run query.

Outline

Shows the CQL statements in the currently open CQL script. Double-clicking takes you to the corresponding
statement in the open file.

DevCenter is built using the Eclipse RCP (Rich Client Platform) and allows you to customize the panes
organization as you prefer.
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Connection Manager
The Connection Manager provides a simple and friendly way to add and manage connections to existing
Cassandra and DataStax Enterprise clusters.

When connected, the square brackets to the right of the connection name
display number-of-connected-nodes / number-of-nodes-in-hosts-list.

 New connection

You add a new connection by either selecting File > New > Connection, by clicking the New connection
button in the toolbar of the connection manager view, or typing ##+#+N (Macintosh) / Ctrl+Alt+Shift+N
(Windows, Linux).

The dialog for creating a new connection allows to configure a connection to an existing cluster by
entering:

• a connection name
• one or more IP addresses of nodes in the cluster
• the connection protocol (by default 9042)
• which compression to use (none, Snappy, or LZ4)
• Security configuration

• whether the cluster is using authentication (either internal or Kerberos); if so, supply the
authentication credentials

• whether SSL is to be used for node-to-node encryption

• The Truststore file contains the public certificates from the cluster nodes, and the Truststore
password is used to access the password-protected Truststore file.

• whether client authentication is to be used (that is, if require_client_auth is set to true in
the cassandra.yaml file); supply the authentication credentials

• The Keystore file contains the private certificate for the client, and the Keystore password is
used to access the password-protected Keystore file.

/en/datastax_enterprise/4.5/datastax_enterprise/sec/secIntrnlAuth.html
/en/datastax_enterprise/4.5/datastax_enterprise/sec/secKerberos.html
/en/datastax_enterprise/4.5/datastax_enterprise/sec/secNodeNodeEncryp.html
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 Open connection

You open a connection either by clicking the Open connection button in the toolbar, typing #+F3
(Macintosh) / Ctrl+F3 (Windows, Linux), or double-clicking the connection name.

 Close connection

You close a connection by clicking the Close connection button in the toolbar or typing #+F4
(Macintosh) / Ctrl+F4 (Windows, Linux).

Clone connection

You clone a connection by clicking the Clone connection button in the toolbar or typing #+#+D
(Macintosh) / Ctrl+Shift+D (Windows, Linux).
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 Delete connection

You remove a connection by clicking the Delete connection button in the toolbar or typing DEL
(Macintosh, Windows, Linux).

Editing connection properties

You edit the properties of an existing connection by right-clicking it and selecting Properties or typing
#+I (Macintosh) / Ctrl+I (Windows, Linux). You are presented with the Properties for Connection
'connection-name' dialog.

You can edit the Advanced Settings by expanding the Basic Settings leaf.

The two panes of the Properties dialog are the same as in the New connection dialog.

Query Editor
The Query Editor allows you to create, edit and execute CQL scripts.
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Editing

You create and edit a CQL script in a tab. Each tab is associated with a connection and the CQL script can
be executed with a single click.

Besides normal editing functionality, such as cutting, copying, and pasting, the Query Editor also has:

• syntax highlighting for CQL
• code completion
• real-time error detection (errors are underlined in red, and hovering over the red error icon reveals the

error)

Run using connection

You can associate a tab in the Query Editor to:

• run with any of the connections in the Connection Manager
• use a chosen default keyspace
• limit the number of rows returned by a statement (limit 1000 rows returned)

 Execute CQL Script

You execute all the CQL statements in the current editor tab.

Execute selected statement

You execute a single or multiple statements by highlighting them and pressing #+F11 (Mac OS X) or Alt
+F11 (Linux, Windows). The statement may be partially highlighted also. When you execute a partially
highlighted statement, the entire statement is first selected and then executed.

Code completion

The query Editor has two types of code completion (activated by pressing Ctrl-Spacebar).

• code snippets: predefined complete CQL statements
• keywords and database identifiers: contextual code completion
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You can add your own code snippets by using the Preferences dialog by selecting File > Preferences >
Cql > Templates.

Real-time error detection and correction

Errors are detected by DevCenter in real-time (before a script is executed) based on the selected
connection, keyspace, and other metadata about the cluster. The error is indicated by a red underline. By
hovering the mouse cursor over the error a list containing possible quick fixes displays.

Preventing execution of CQL scripts containing syntax errors

If you try to execute CQL with a syntactic error in it, the code does not execute, and a dialog displays. This
prevents DevCenter from sending incorrect or incomplete CQL statements. A syntax error disables the
execution of the entire script.
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Schema Navigator
The Schema Navigator provides a tree control that displays the structure and details of the schema (for
example, keyspaces, tables) for the current connection.

It displays the schema for the current active tab in the Query Editor pane.

Schema navigator contextual menu

Right-clicking in the Schema navigator pane (with no node selected) displays a contextual menu. The
menu items are:

• New Keyspace: displays the New Keyspace wizard
• New Table: displays the New Table wizard

Keyspace node contextual menu

Right-clicking on a keyspace node in the Schema navigator pane on a selected node displays a contextual
menu. The menu items are:

• New Keyspace: displays the New Keyspace wizard
• New Table: displays the New Table wizard
• Clone Keyspace: displays the New Keyspace wizard with values of fields set to the selected

keyspace's settings
• Edit Keyspace: displays the Edit Keyspace wizard (which contains the same fields as the New

Keyspace wizard) for editing the selected keyspace's settings

Table node contextual menu

Right-clicking on a table node in the Schema navigator pane on a selected node displays a contextual
menu. The menu items are:

• New Keyspace: displays the New Keyspace wizard
• New Table: displays the New Table wizard
• Clone Table: displays the New Table wizard with values of fields set to the selected table's settings
• Edit Table: displays the Edit Table wizard (which contains the same fields as the New Table wizard)

for editing the selected table's settings

When editing a table, only primary key column names can be changed. Likewise, when editing a table's
column, only non-primary key columns may have their types changed.

Wizards resynchronize with database after partial failure

If more than one statement is generated (typically in Edit Keyspace or Edit Table wizards), a statement
may fail although previous ones succeeded. In this situation, the wizard dialog is kept open, and its
contents are resynchronized with the database.
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New Keyspace wizard
The New Keyspace wizard generates a valid CQL statement that creates a new keyspace in the specified
cluster.

To display the New Keyspace wizard:

• select the File > New > Keyspace menu item
• right-click in the schema navigator and select New Keyspace
• press the key shortcut ##+#+K(Mac OS X) or Ctrl+Alt+Shift+K (Linux / Windows)

You navigate between panels using the Previous and Next buttons. A Last button also skips from the
current panel to the Summary panel, if you won't be editing any fields on those panels.

The first panel (Basic Settings) of the New Keyspace wizard displays. There are two panes on this panel:
one that displays keyspace settings and allows editing of them, and a CQL Preview pane that displays the
CQL statement for creating the keyspace generated from the values in the first pane.

The editable fields are:

• Connection: choose an existing connection or create a new one
• Keyspace name: type in a valid keyspace name (invalid names are noted in red)
• Replication strategy: which data replication strategy class (SimpleStrategy single data center or

NetworkTopologyStrategy multiple data centers) to use; the strategy determines where replicas
are placed

• Replication factor: which replication factor to use; the factor is the number of replicas across the
cluster

• Durable writes: by setting this property, data written to the keyspace bypasses the commit logs

After selecting Next, the second panel (Summary) of the New Keyspace wizard displays.

The editable fields are:

• Whether to execute the generated statement(s) using the current connection or not
• Whether to insert the generated statement(s) into
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• a new CQL editor pane
• an existing CQL editor pane

Both panels have an uneditable CQL preview pane showing the CQL statement to be generated
according to the current values of the wizard's editable fields.

New Table wizard
The New Table wizard generates a valid CQL statement that creates a new table in the specified
keyspace.

The New Table wizard consists of five panels:

• Basic Settings
• Primary Key Settings
• Advanced Settings
• Compaction
• Summary

You navigate between panels using the Previous and Next buttons. A Last button also skips from the
current panel to the Summary panel, if you won't be editing any fields on those panels.

To display the New Table wizard:

• select the File > New > Table menu item
• right-click in the schema navigator and select New Table
• press the key shortcut ##+#+T(Mac OS X) or Ctrl+Alt+Shift+T (Linux / Windows)

The first panel (Basic Settings) of the New Table wizard displays. There are four panes on this panel
which display editable table settings and a CQL Preview pane that displays the CQL statement for
creating the table generated from the values in the preceding three panes.

The editable fields are:

• Connection: choose an existing connection or create a new one
• Keyspace: choose an existing keyspace or create a new one
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• Table name: type in a valid table name (invalid names are noted in red)
• Columns: add, remove, or move up or down a column
• Comment: add or edit a comment property for the table

After selecting Next, the second panel (Primary Key Settings) of the New Table wizard displays.

The panel allows you to define the primary key structure for the table. They can be simple or compound.
The editable fields are:

• Available columns: displays the available columns
• Partition keys: displays the partition key for the table (which determines the node on which the data is

stored)
• Clustering columns: displays the clustering columns for the table

/en/cql/3.1/cql/ddl/ddl_compound_keys_c.html
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After selecting Next, the final panel (Advanced Settings) of the New Table wizard displays.

The editable fields are:

• Table options

• Compact storage: whether to store data so as to conserve disk space
• Read repair chance: the basis for invoking read repairs on reads in clusters (a value between 0 and

1)
• DC-local read repair chance: the probability of read repairs being invoked over all replicas in the

current data center
• Bloom filter FP chance: the desired false-positive probability for SSTable Bloom filters
• Replicate on write (Cassandra 2.0 only): if true, replicates writes to all affected replicas regardless

of the consistency level specified by the client for a write request
• Default time to live The default expiration time in seconds for a table. Used in MapReduce

scenarios when you have no control of TTL.
• GC grace seconds Specifies the time to wait before garbage collecting tombstones (deletion

markers). The default value allows a great deal of time for consistency to be achieved prior to
deletion. In many deployments this interval can be reduced, and in a single-node cluster it can be
safely set to zero.

• Minimum index interval The minimum value to control the sampling of entries from the partition
index, configure the sample frequency of the partition summary by changing these properties.

• Maximum index interval The maximum value to control the sampling of entries from the partition
index, configure the sample frequency of the partition summary by changing these properties.

• Index interval (Cassandra 2.0 only): The interval value to control the sampling of entries from the
partition index.

• Memtable flush period Forces flushing of the memtable after the specified time in milliseconds
elapses.

• Speculative retry Overrides normal read timeout when read_repair_chance is not 1.0, sending
another request to read.

/en/cql/3.1/cql/cql_reference/tabProp.html
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• Compression

• SSTable compression: the compression to use (LZ4, Snappy, Default, or None)
• Chunk length: size of block used by compression scheme
• CRC check chance: the probability with which checksums are checked during read

• Reset properties above to their default values.
• See more details above table properties and their default here.

After selecting Next, the Compaction panel of the New Table wizard displays.

The editable fields are:

• Strategy: sets the compaction strategy class to use

• Enabled
• Tombstone threshold
• Tombstone compaction interval
• Unchecked tombstone compaction
• Min threshold
• Max threshold
• Min SSTable size
• Bucket low
• Bucket high
• Cold reads to omit

• Caching (Cassandra 2.1 and higher)

• Keys: ALL or NONE
• Rows per partition: number of CQL rows, NONE, or ALL

• Caching (Cassandra 1.2 and 2.0)

/en/cql/3.1/cql/cql_reference/tabProp.html
/en/cql/3.1/cql/cql_reference/tabProp.html?scroll=tabProp__moreCaching
/en/cql/3.0/cql/cql_reference/tabProp.html
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• Keys: ALL, KEYS_ONLY, ROWS_ONLY, or NONE
• Reset properties above to their default values.
• See more details above table properties and their default here.

After selecting Next, the final Summary panel of the New Table wizard displays.

The editable fields are:

• Execute the generated statement(s) using connection Cassandra 2.1
• Insert the generated statements into:

• a new CQL editor
• an existing CQL editor

/en/cql/3.1/cql/cql_reference/compactSubprop.html


Reference

21

Outline
The Outline lists the statements that make up the CQL script loaded in the current tab in the Query Editor.

The Outline allows for quick navigation within large CQL scripts by selecting the statement in the tree that
section of the Query Editor where the statement occurs is displayed.

 Link to Editor

Toggles between whether the CQL statement is linked to its location in the Query Editor tab or not.

 Order Alphabetically

Toggles between whether the CQL statements are listed in alphabetical order or in the order which they
occur in the CQL script in.

Results
The Results pane shows the latest results from a CQL query executed in the Query Editor tab in tabular
form.

The Results pane has two parts:
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• a tabular grid which displays results from the last query executed
• a status bar which displays pertinent information about executed statements

In the grid display, you can:

• reorder and resize columns
• sort rows by a column by clicking on the column heading
• copy the data from the results by

• a single selected row (click on the row)
• multiple rows #+click (Macintosh) / Ctrl+Click (Windows / Linux)
• all of the rows (either as CSV or an INSERT statement)

Query Trace
The Query Trace pane shows the trace session from the last CQL query executed in the Query Editor tab
in tabular form.

See also:

• Tracing
• Request tracing in Cassandra 1.2
• Advanced request tracing

.

Trace session_id

The Trace session_id uniquely identifies the tracing session. Trace data is saved in Cassandra for 24
hours and can be queried using statements found by clicking the 'more' link. For example,

Tracing session information is stored for 24 hours. Session and session
 event data can be queried with:
SELECT * FROM system_traces.sessions WHERE session_id =
 d6aa92a0-4f48-11e4-8d9b-65dde8fcb188;
SELECT * FROM system_traces.events WHERE session_id =
 d6aa92a0-4f48-11e4-8d9b-65dde8fcb188;

Node information

The Node information section lists each node participating in the query along with a color coding for
easier identification in the trace table results.

/en/cql/3.1/cql/cql_reference/tracing_r.html
http://www.datastax.com/dev/blog/tracing-in-cassandra-1-2
http://www.datastax.com/dev/blog/advanced-request-tracing-in-cassandra-1-2
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Role information

The Role Information section describes the roles that participating nodes may play in each trace event:

C

Coordinator node

R

Replica node

CR

Coordinator and Replica node

.

Trace columns

The columns in the Query trace are:

Activity

Description of the activity in the trace event.

Timestamp

The timestamp of the event on the source node.

Role

The role of the node for this event (Coordinator, Replica, Coordinator and Replica).

Source node

The source node where the event occurred.

Source elapsed (µs)

Elapsed time of the event on the source node in microseconds.

Thread

The name of the thread on the source node that executed the event.

CQL Scripts
The CQL Scripts view provides a simple file manager for creating, editing, and deleting CQL scripts.

There are two types of files: scratchpads (new scripts having a default name) and already saved scripts.
DevCenter saves CQL scripts (both scratchpads and named scripts) in your DevCenter workspace under
these directories:

• scratchpads:  user-home /.devcenter/DevCenter/.default
• CQL scripts:  user-home /.devcenter/DevCenter/CQLScripts

You can select one or more CQL scripts by typing #+click (Macintosh) / Ctrl+Click (Windows / Linux).

Note:  When you open a CQL script for editing using File > Open File ..., any changes you make
are to your workspace copy of the CQL script and not to the original file.

 New CQL script

You create a new CQL script by selecting the File > New CQL Script, typing #+#+N (Macintosh) / Ctrl
+Shift+N (Windows, Linux), or clicking the New CQL Script icon in the toolbar of this view.
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 Open CQL script

You edit an existing script by clicking the Open CQL script action or typing #+F3 (Macintosh) / Ctrl+F3
(Windows, Linux).

You can also import an existing script by selecting File > Open File.

 Delete CQL script

You delete a script by clicking the Delete CQL script icon or typing DEL (Macintosh,, Windows, Linux).

Note:  in case you must delete your DevCenter workspace directory, make sure you have copied or
moved the existing CQL scripts to a different location on your disk.

Properties

You view a CQL script's properties by right-clicking on the script and selecting Properties in the contextual
menu or typing #+I (Macintosh) / Ctrl+I (Windows, Linux).

You see all the file information (for example, the time the file was last modified and its read, write, execute
permissions).

Submit Feedback form
A form for submitting feedback on the DevCenter IDE is included under the Help menu.

By selecting Help > Submit Feedback, you can send feedback directly to DataStax, The only required
field is the Comment textarea. The submitted feedback includes installation details for the computer you
are running DevCenter on.
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Keyboard shortcuts

Macintosh OS X Windows or Linux Description

General

#+N Ctrl+N Generic New wizard.

Editing and running CQL scripts

#+#+N Ctrl+Shift+N New CQL script.

##+#+K Ctrl+Alt+Shift+K New keyspace.

##+#+T Ctrl+Alt+Shift+T New table.

#+F3 Ctrl+F3 Open CQL script.

DEL DEL Delete CQL script.

#+I Ctrl+I Open CQL script properties.

#+F11 Alt+F11 Execute current CQL script. (If
statements are selected then only
execute those statements.)

#+A Ctrl+A Select all CQL scripts.

#+Space Ctrl+Space Display auto-completion popup.

Connections panel

##+#+N Ctrl+Alt+Shift+N New connection.

#+F3 Ctrl+F3 Open connection.

#+F4 Ctrl+F4 Close connection

#+#+D Ctrl+Shift+D Clone connection.

DEL DEL Delete connection.

CQL scripts panel

#+. Ctrl+. Jump to next warning / error.

#+#+. Ctrl+Shift+. Jump to previous warning / error.
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Macintosh OS X Windows or Linux Description

#+1 Ctrl+1 Display quick fixes popup.

#+#+F Ctrl+Shift+F Format code.

#+click Ctrl+click Multiple row selection in results
pane.
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FAQ

Why does DevCenter on Mac OS Yosemite need Java 6?

When launching DevCenter on Mac OS X Yosemite, you might see an error message stating: "To open
'DevCenter' you need to install the legacy Java SE 6 runtime. Click 'More Info...' to visit the legacy Java SE
6 download website". Although DevCenter is compatible with any recent Java version, Mac OS X Yosemite
might force you to use Java SE 6. If this happens, simply follow the link in the message and install Java SE 6.

Why am I seeing the “Failed to load the JNI shared library" error when starting DevCenter?

It's likely to be because you're using a 32-bit application on a 64-bit JVM or vice versa.

Why aren't all of my database objects showing up in the auto-completion popup?

To retrieve an up-to-date view of the database schema, DevCenter requires an active connection to the
cluster, so if you are working offline, only the database objects defined in the current script will be available
for auto-completion.

I just got "an internal error occurred during Xtext validation" dialog. What can I do about it?

Increase JVM MaxHeapSize by adding -Xmx512m or -Xmx1024m to the DevCenter_install_dir/
DevCenter.app/Contents/MacOS/DevCenter.ini (on Macintosh) or DevCenter_install_dir/
DevCenter.ini (on Windows / Linux).

Why can't I see my settings from DevCenter alpha-0?

In order to support connections that require authentication or use compression, we’ve made some changes
to the settings files. There were also other changes to the way we store preferences like color schemes,
font settings, etc. Unfortunately we haven’t been able to find a solution that worked reliably and offered a
friendly migration of the old type of settings.

http://stackoverflow.com/questions/7352493/failed-to-load-the-jni-shared-library-jdk
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Navigating the documents

To navigate, use the table of contents or search in the left navigation bar. Additional controls are:

Hide or display the left navigation.

Go back or forward through the topics as listed in
the table of contents.

Toggle highlighting of search terms.

Print page.

See doc tweets and provide feedback.

\ Grab to adjust the size of the navigation pane.

Appears on headings for bookmarking. Right-click
the ¶ to get the link.

Toggles the legend for CQL statements and
nodetool options.

Other resources

You can find more information and help at:

• Documentation home page
• Datasheets
• Webinars
• Whitepapers
• Developer blogs
• Support

http://docs.datastax.com/en/index.html
http://www.datastax.com/resources/datasheets
http://www.datastax.com/resources/webinars
http://www.datastax.com/resources/whitepapers
http://www.datastax.com/dev/blog
http://www.datastax.com/what-we-offer/products-services/support
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