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1.1 Pman

1 Pman User's Guide

The process manager Pman is a graphical tool used to inspect the Erlang processes executing either locally or on
remote nodes. It is also possible to trace eventsin the individual processes.

1.1 Pman

1.1.1 Introduction

Warning:
The Pman application has been superseded by the Observer application. Pman will be removed in R16.

The process manager Pman is atool for viewing processes executing locally or on remote nodes. Its main purposeis
to locate erroneous code by inspecting the state of the processes and by tracing events. Bottlenecks, unread messages,
and bad memory handling are some of the problems that can be solved with Pman.

Processes may be inspected individually in a process trace window. There the user may dynamically follow the
execution of aprocess by getting trace output for sent and received messages as well as for called functions and some
other process events. Information about source code modules executed by the processes is also accessible. Note that
Pman has some effect on the real time behavior of a running system.

1.1.2 Getting Started with Pman

Start Pman by calling prmman: st art () . It will start the Main Window, showing an overview of al processes running
at the current node.

To trace a certain process, select it by clicking on its line and then chose Trace->Selected Process, or smply double-
click it. Thiswill open a Trace Window. In the Trace Window, there is some information about the process and traced
events are added dynamically.

Which events to trace are selected in the Options Window which is opened by choosing File->Options... in the Main
Window or in a Trace Window. Currently supported trace events are message sending, message receiving, function
calls and process events.

It is possible to by-pass the Main Window and open a Trace Window directly for the process Pi d by calling
prman: proc(Pi d).

1.1.3 The Main Window

The Main Window shows all processes running at the displayed node. The window is automatically updated every 5
seconds. Select which node to display in the window by choosing the node name from the Nodes menu.
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PMAN :Overview on foo@chivas _!

I Eile ¥iew Trace Hodes Help |

Fid Current Function Mame Hsis Reds Size
<0.0.0> init:loop/l init 0 964 ES7
2.0 erl_prim_loader: loop/s erl_prim_ loader 0 BEZ22 1684
) gern_event:loops/d errar_logger 0 162 519
6.0 application_master :main_loops2 0 12 320
7.0 application_master:loop_it/d 0 42 288 =
B0 gen_server:loop/E kernel_sup 1] S04 1684
3.0 gen_server:loop/E r e 1] 2z 286
10,0 |gen_server:loop/E global_name_server |0 g8 375
LA1.0 |gen_server:loop/B net_sup 1] 116 320
12,03 |gen_server:loop/E auth 1] 22 231
.13.0>  |gen_server:loop/E net_kernel 0 544 375
14,03 |net_kernel:tickerl/2 0 48 a7 v |
I .-
I_J Hide system processes _| Auto-Hide New # Hidden: 0

Figure 1.1: The Main Window.

A process can be selected by clicking on itsline. The selected processiis highlighted. Use the arrow keys to move up
and down in the process overview.

The following information is displayed for each process:

e Pid- processidentifier.

e Current Function - the function (Modul e: Funct i on/ Ari t y) the processis currently executing.
e Name - registered name of the process, if any.

*  Msgs- number of messagesin the process mailbox.

» Reds- number of reductions performed. Gives arough estimate of the process work load.

* Size- estimated size of the process, in words, calculated by adding the stack size and the heap size.

At the bottom of the window the following functions and information can be found:

Hide System Processes
This check button controls the display of what Pman consider system processes, that is, processes Pman knows
are part of Erlang/OTP rather than the user's application. If the button is selected, these system processes will
not be shown.

Auto-Hide New
This check button controls the treatment of newly created processes. If it is selected, new processes will not be
shown.

# Hidden
This label displays the number of processes currently executing that are not shown in the process overview.

The File Menu

Options...
Open the Options Window which allows the user to set the trace optionsto use.
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Save Options
Save the options set using the Options Window. The options are stored to the file HOVE/ . er | ang_t ool s/
pman. opt s, where HOVE is the user's home directory, and are automatically |oaded the next time Pman is
started.

Exit
Stop Pman.

The View Menu

This menu mainly contains buttons for controlling what to display in the Main Window. Note that the View Menu
overrides the settings of the check buttons (Hide System processes, Auto-Hide new) in the Main Window.

Hide All Processes
Hide all processes.

Hide Modules...
Opens a dialog window with all loaded modules. If the user selects awindow and clicks OK, the process
overview will not show any processes running code from those modules.

Hide Selected Processs
Hide the selected process.

Module Info...
Given a selected process currently executing afunction in the module Modul e, this menu button opens a
window showing information about the module as returned from Modul e: modul e_i nf o() .

Refresh
Updates the process overview.

Show All Processes
Show all processes, except system processes and/or new processes if Hide System Processes and/or Auto-Hide
New is selected.

Show Processes...
Opens a dialog window with all hidden processes. If the user selects a process and clicks OK, the process
overview will show that process.

The Trace Menu

Kill
Terminates the selected process by callingexit (Pid, kill).

Trace Selected Process
Opens a Trace Window for the selected process. Tracing will start immediately with the default trace flags set
from the Main Window.

Shell Process
Opens a Trace Window for the shell process of node Pman was started at (not the displayed node). If the shell
process dies, the opened Trace Window will find the pid of the automatically started new shell process, and
continue to trace that process.

The Nodes Menu

The Nodes menu contains one entry for each known node. By selecting a hode from the Nodes menu, the process
overview window will change its view, and display the processes running on that node.
The Help Menu

Help
Selecting Help from the Help menu will cause the HTML version of the Pman User's Guide (this document) to
be displayed. Currently this function requires Netscape to be up and running.
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1.1.4 The Trace Window

A Trace Window outputstrace information for atraced process. A Trace Window automatically uses the trace options
set in the Main Window, but it is also possible to change the options for each Trace Window individually.

I PMAN:Shell process <0.32.0= on Node foo@chivas

Eile  M¥iew  Trace Hel

initial_call: shell:evaluatorss
current_function: shell:ewal_loop/2
heap_size: 83

stack_size: 53

reductions: 26

Tinks: [
£0.23.0]

trap_exit: false

G200 | To: file_server Msg: {’$gen_call’, {<0.32.0>, #Ref}, {1ist_
32,030 rec {#Ref, {ok. [".saves-E159-chivas™",
tool_genfd. jam",

~ | P

Figure 1.2: The Trace Window.

0.32.0x: rec  {shell_cmd, <0.23.0>, {eval, [{call,i,{atom,1,1s},[1}]1}}
0.32.0: | To: code_server Msg: {“$gen_call’, {<0.32.0>, #Ref}, {ensur
0.32.0>: rec  {#Ref, {module, erl_internall}

0.32.0: | To: code_server Msg: {“$gen_call’, {<0.32.0>, #Ref}, {ensur
0.32.0%: rec  {#Ref, {module, shell_default}}

]

]

Thereisno limit to how many Trace Windows can be open at the same time. However, notice that if more processes
are traced, the performance degradation of the system will be more noticeable.

The following information is displayed, where applicable:

e initia call - the function (Mbdul e: Functi on/ Ari t y) the process started executing in.

e current function - the function (Modul e: Functi on/ Ari t y) the processis currently executing.
*  messages - the messages in the mailbox.

« dictionary - the contents of the process dictionary.

e heap size - heap sizein words.

* stack size- stack sizein words.

e reductions - number of reductions performed. Gives arough estimate of the process work load.

o links- list of pidsthe processislinked to.

e trap_exit-true if the processtrap exit signals, f al se otherwise.
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In the Trace Window, trace output is continuously added. First in each trace message is the pid of the traced process.
Note that if the inheritance flags for tracing are set, the trace output for the spawned/linked processes will be shown
in the same window as the spawning/linking process.

Each trace message a so has a mnemonic tag:

!
This tag indicates that a message has been sent. Following the To: tag will be a pid/name of the receiver. Next,
following the Msg: tag will be the sent message.

rec
This tag indicates that a message has been received. Following this will be the received message.

call
Thistag indicates a call to afunction. Following thiswill be the actual call, with al the arguments.

link
Thistag indicates that alink between the traced process and another process has been created. Following this
will be the pid of the other process.

spawn
This tag indicates that the traced process has spawned another process. Following thiswill be the pid of the
spawned process.

exit
This tag indicates that traced process has exited. Following thiswill be the exit reason.

The File Menu

Options...

Opens the Options Window which allows the user to set the trace options to use for this specific Trace Window.
Save Buffer...

Opens a dialog that prompts the user for afile name to save the current Trace Window contentsin.
Close

Stops tracing of the process, and closes the Trace Window.

The View Menu

Clear Buffer
Clears the contents of the Trace Window.

Module Info
Opens awindow showing information about the module the process is currently executing code from, as
returned from Mbdul e: nodul e_i nfo() .

The Trace Menu

All Linked Processes
Opens a Trace Window for each of the processes linked to the process being traced in the current Trace
Window.

Linked Process ->
The Linked Process submenu has one entry for each process linked to the process being traced in the current
Trace Window. Select one of the processes to open a new Trace Window for that process.

Kill
Terminates the process being traced in the current Trace Window by callingexi t (Pid, kil l).

The Help Menu

Help
Selecting Help from the Help menu will cause the HTML version of the Pman User's Guide (this document) to
be displayed. Currently this function requires Netscape to be up and running.
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1.1.5 The Options Window

The Options Window allowsthe user to specify the amount of output, and the destination of output for traced processes.

[@] Default Trace Options

Trace output options: Inheritance options:

W Trace send W Inherit on spawn
% A11 zpawns

~» FIrst spawh only

W Trace receive
| Trace functions

e BdEE W Inherit on Tink

& 4171 Tinks
~ First 1ink only

Trace output options:

4 In window

~ To file | |
Ok | Cancel |

Figure 1.3: The Options Window.

In the upper |eft corner of the Options Window, there are check buttons for determining what to output in the Trace
Window:

Trace send
Select this check button to display information about sent messages.
Tracereceive
Select this check button to display information about received messages.
Trace functions
Select this check button to display information about function calls.
Trace events
Select this check button to display information about process events, such as spawn, link and exit.

In the upper right corner of the dialog, there are options for controlling the behaviour of spawned or linked processes:
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Inherit on spawn

The user may select if spawned processes shall also be traced. And if so, if al spawned processes should be
traced, or just the first spawned process.

If a spawned process is traced, it will get the same trace options that are set for the spawning process. And the
output will be shown in the same Trace Window as that of the spawning process.

Inherit on link

The user may select if a process that is being linked to shall be traced. And if so, if al linked processes shall be
traced, or just the first one linked to.

If alinked processistraced, it will get the same trace options that are set for the linking process. And the output
will be shown in the same Trace Window as that of the linked process.

In the lower part of the Options Dialog, the user may select whether the trace information shall be output to afile,
or appear in the trace window.

Sending traceinformation to afileis more efficient than displaying it in the Trace Window. Furthermore, if the amount
of trace datais large, it will not be lost if tracing to afile. The trace information in the Trace Window has an upper
limit (approx. 10,000 lines), after which the output buffer will be cleared.
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2 Reference Manual

The process manager Pman is a graphical tool used to inspect the Erlang processes executing either locally or on
remote nodes. It is also possible to trace eventsin the individual processes.
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pman

Erlang module

Warning:
The Pman application has been superseded by the Observer application. Pman will be removed in R16.

A graphical tool used to inspect the Erlang processes executing either locally or on remote nodes. It is also possible
to trace eventsin the individual processes.

Exports

start()
start(Excluded)
start notimeout()
start notimeout(Excluded)
Types:
Excl uded = [ Modul €]
Modul e = atom()
Starts Pman. It will use the previously saved trace settingsin HOVE/ . er | ang_t ool s/ pman. opt s, where HOVE

is the user's home directory, if such a file exists. Otherwise standard trace settings will be used. The return value
should be ignored.

Excl uded isalist of module names. If the argument is present, processes currently executing in any of these modules
will not be shown by Pman.

start/ 0, 1 will fail unlessthe start-up succeeds within 20 seconds, whereasst art _not i meout / 0, 1 will wait
indefinitely.

proc(Process)
proc(A, B, ()
Types:

Process = pid() | atom()
A =B =C=integer()
Starts a Pman trace window for the specified process. The return value should be ignored.

The process to trace is given either by its pid or by its registered name. It is also possible to use pr oc/ 3 to trace
the pid represented as <A, B, C.
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