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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools > Options menu 
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open Styles & Formatting window
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What is Impress?

Impress is LibreOffice’s slide show (presentations) program. You can create slides that contain 
many different elements, including text, bulleted and numbered lists, tables, charts, clip art, and a 
wide range of graphic objects. Impress also includes a spelling checker, a thesaurus, prepackaged 
text styles, and attractive background styles.

This chapter introduces the Impress user interface and describes how to create a simple slide 
show using the Presentation Wizard.

The rest of this guide illustrates many other features available in Impress that can be used to 
create more sophisticated slide shows.

Note
Drawings are created in the same way with Impress as they are with Draw. Refer to 
the Draw Guide for details on how to use the drawing facilities.

Starting Impress

You can start Impress in several ways:

• If no component of LibreOffice is open, from the Start Center: click on the Presentation 
icon.

• From the system menu or the LibreOffice Quickstarter. Details vary with your operating 
system; see Chapter 1 in the Getting Started guide if you need more information.

• From any open component of LibreOffice: click the triangle to the right of the New icon on 
the main toolbar and select Presentation from the drop-down menu, or choose File > New 
> Presentation from the menu bar.

When you start Impress for the first time, the Presentation Wizard is shown. For detailed 
instructions about how to use the wizard, see “Creating a new presentation” on page 16. 

If you prefer not to use the wizard in future, you can select Do not show this wizard again. 

Click Create to open the main Impress window.

The main Impress window

The main Impress window (Figure 1) has three parts: the Slides pane, the Workspace, and the 
Tasks pane. Additionally, several toolbars can be displayed or hidden during the creation of a 
presentation.

Tip

You can remove the Slides pane or the Tasks pane from view by clicking the X in the 
upper right corner of each pane. You can also show or hide these panes using View 
> Slide Pane or View > Task Pane or by clicking the Hide/Show marker in the 
middle of the vertical separator line (circled in illustration). By hiding these panes, you 
can maximize the Workspace area.
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Figure 1: Main window of Impress

Slides pane
The Slides pane contains thumbnail pictures of the slides in your presentation, in the order they will 
be shown—unless you change the slide show order, as described in Chapter 9, Slide Shows. 
Clicking a slide in this pane selects it and places it in the Workspace. When a slide is in the 
Workspace, you can change it in any way you like.

Several additional operations can be performed on one or more slides simultaneously in the Slides 
pane:

• Add new slides to the presentation.

• Mark a slide as hidden so that it will not be shown as part of the presentation.

• Delete a slide from the presentation if it is no longer needed.

• Rename a slide.

• Duplicate a slide (copy and paste) or move it to a different position in the presentation (cut 
and paste).

It is also possible to perform the following operations, although there are more efficient methods 
than using the Slides pane, as you will see later in this chapter:

• Change the slide transition following the selected slide or after each slide in a group of 
slides.

• Change the sequence of slides in the presentation.

• Change the slide design.

• Change slide layout for a group of slides simultaneously.
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Tasks pane
The Tasks pane has five sections:  To expand the section you wish to use, click on the right-
pointing triangle to the left of the caption. Only one section at a time can be expanded.

Master Pages
Here you define the page style for your presentation. Impress contains prepackaged Master 
Pages (slide masters). One of them—Default—is blank, and the rest have a background and 
styled text.

Tip
Press F11 to open the Styles and Formatting window, where you can modify the 
styles used in any slide master to suit your purposes. This can be done at any time. 
See Chapter 2 for more information.

Layouts
The prepackaged layouts are shown here. You can choose the one you want and use it as it is, 
or you can modify it to meet your own requirements. However, it is not possible to save custom 
layouts.

Table Design
The standard table styles are provided in this area. You can further modify the appearance of a 
table with the options to show or hide specific rows and columns, or to apply a banded 
appearance to the rows and columns. Refer to Chapter 3, Adding and Formatting Text, for 
details on how to work with tables.

Custom Animation
A variety of animations can be used to emphasize or enhance different elements of each slide. 
The Custom Animation section provides an easy way to add, change, or remove animations. 
For additional information, see Chapter 9, Slide Shows, for an overview of how to add and 
customize animations.

Slide Transition
The Slide Transition section provides access to a number of slide transition options. The default 
is set to No Transition, in which the following slide simply replaces the existing one. Many 
additional transitions are available, however.  You can also specify the transition speed (slow, 
medium, fast), choose between an automatic or manual transition, and choose how long the 
selected slide should be shown (automatic transition only).

Workspace
The Workspace (normally in the center) has five tabs, also called View buttons.

Figure 2: Workspace tabs

The Workspace below the View buttons changes depending on the chosen view. The workspace 
views are described in detail on page 12.
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Toolbars
Many toolbars can be used during slide creation; they can be displayed or hidden by clicking View 
> Toolbars and selecting from the menu.

You can also select the icons that you wish to appear on each toolbar. For more information, refer 
to Chapter 11, Setting Up and Customizing Impress.

Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the Draw Guide for 
details on the functions available and how to use them.

Status bar
The status bar, located at the bottom of the Impress window, contains information that you may find 
useful when working on a presentation.

Figure 3: Left end of the Impress status bar

Figure 4: Right end of Impress status bar

From left to right, you will find:

• A general information area, which changes depending on the selection. For example:

– Text area—”TextEdit: Paragraph x, Row y, Column z”

– Charts, spreadsheets—”Embedded object (OLE) ‘ObjectName’ selected”

– Graphics—”Bitmap with transparency selected”

• The position of the cursor or of the top left corner of the selection measured from the top 
left corner of the slide, followed by the width and height of the selection or of the text box 
where the cursor is located.

• A modified flag, showing a star when the file needs saving.

• A flag indicating whether the document is digitally signed.

• The slide number currently displayed in the workspace, and the total number of slides in 
the presentation.

• The slide master or page style associated with the slide, handout, or notes page currently 
in the Workspace.

• The zoom slider and zoom level (percent) of the Workspace.

Note

The sizes are given in the current measurement unit (not to be confused with the 
ruler units). This unit is defined in Tools > Options > LibreOffice Draw > 
General, where you can also change the scale of the page. Another way to 
change the scale is to double-click on the number shown in the status bar.

You can hide the information in the Status Bar by selecting View > Status Bar from the main 
menu.
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Navigator
The Navigator displays all objects contained in a document. It provides another convenient way to 

move around a document and find items in it. To display the Navigator, click its icon  on the 
Standard toolbar, or choose View > Navigator on the menu bar, or press Ctrl+Shift+F5.

The Navigator is more useful if you give your slides and objects (pictures, spreadsheets, and so 
on) meaningful names, instead of leaving them as the default “Object 1” and “Shape 1” shown in 
the example below.

Figure 5: Navigator

Workspace views

Each of the workspace views is designed to ease the completion of certain tasks; it is therefore 
useful to familiarize yourself with them in order to quickly accomplish those tasks.

Normal view
Normal view is the main view for creating individual slides. Use this view to format and design 
slides and to add text, graphics, and animation effects.

To place a slide in the slide design area (Workspace) of the Normal view (Figure 1), either click the 
slide thumbnail in the Slides pane or double-click it in the Navigator (page 12).

Outline view
Outline view contains all of the slides of the presentation in their numbered sequence. It shows 
topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text 
contained in the default text boxes in each slide is shown, so if your slide includes other text boxes 
or drawing objects, the text in these objects is not displayed. Slide names are not included.
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Figure 6: Outline view

Use Outline view for:

1) Making changes in the text of a slide:

• Add or delete text in a slide just as in the Normal view.

• Move the paragraphs of text in the selected slide up or down by 
using the up and down arrow buttons (Move Up or Move Down) 
on the Text Formatting toolbar.

• Change the outline level for any of the paragraphs in a slide using the left and right 
arrow buttons (Promote or Demote).

• Simultaneously move a paragraph and change its outline level using a combination of 
these four arrow buttons.

2) Comparing the slides with your outline (if you have prepared one in advance). If you notice 
from your outline that another slide is needed, you can create it directly in the Outline view, 
or you can return to the Normal view to create it.

Notes view
Use the Notes view (Figure 7) to add notes to a slide. These notes are not seen when the 
presentation is shown.

1) Click the Notes tab in the Workspace.

2) Select the slide to which you want to add notes.

• Click the slide in the Slide pane, or

• Double-click the slide’s name in the Navigator.

3) In the text box below the slide, click on the words Click to add notes and begin typing.

You can resize the Notes text box using the green resizing handles and move it by placing the 
pointer on the border, then clicking and dragging. To make changes in the text style, press the F11 
key to open the Styles and Formatting window.

Chapter 1  Introducing Impress 13



Figure 7: Adding notes in Notes view

Handout view
Handout view is for setting up the layout for a printed handout. Click the Handout tab in the 
workspace, then choose Layouts in the tasks pane. You can then choose to print 1, 2, 3, 4, 6, or 9 
slides per page.

Figure 8: Handout layouts

Use this view also to customize the information printed on the handout. Refer to Chapter 10 of this 
book for instructions on printing slides, handouts, and notes.
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Slide Sorter view
The Slide Sorter view contains all of the slide thumbnails. Use this view to work with a group of 
slides or with only one slide.

Figure 9: Slide Sorter view

Customizing Slide Sorter view
To change the number of slides per row:

1) Check View > Toolbars > Slide View to show or hide the Slide view toolbar.

Figure 10: Slide Sorter and Slide View toolbars

2) Adjust the number of slides (up to a maximum of 15).

Moving a slide using Slide Sorter
To move a slide in a presentation using the Slide Sorter:

1) Click the slide. A thick border is drawn around it.

2) Drag and drop it to the location you want.

• As you move the slide, a black vertical line appears to one side of the slide.

• Drag the slide until this black vertical line is located where you want the slide to be 
moved.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:

• Use the Control (Ctrl) key: Click on the first slide and, while pressing Control, select the 
other desired slides.
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• Use the Shift key: Click on the first slide, and while pressing the Shift key, select the final 
slide in the group. This selects all of the other slides between the first and the last.

• Use the mouse: Click slightly to the left of the first slide to be selected. Hold down the left 
mouse button and drag the mouse pointer to a spot slightly to the right of the last slide to 
be included. (You can also do this right to left.) A dashed outline of a rectangle forms as you 
drag the pointer through the slide thumbnails and a thick border is drawn around the 
selected slides. Make sure the rectangle includes all the slides you want to select.

To move a group of slides:

1) Select the group.

2) Drag and drop the group to their new location. A vertical black line appears to show you 
where the group of slides will go.

Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the Slide pane.

To make changes, right-click a slide and chose any of the following options from the pop-up menu:

• New Slide: Adds a new slide after the selected slide.

• Delete Slide: Delete the selected slide

• Rename Slide: Allows you to rename the selected slide

• Slide Layout: Allows you to change the layout of the selected slide

• Slide Transition: Allows you to change the transition of the selected slide

• Hide Slide: Hidden slides are not shown in the slide show

• Cut: Removes the selected slide and saves it to the clipboard

• Copy: Copies the selected slide to the clipboard without removing it

• Paste: Inserts a slide from the clipboard. This option will also allow you to specify whether 
you want to paste the copied slide Before or After the selected slide

Renaming slides
Right-click on a thumbnail in the Slides pane or the Slide Sorter and choose Rename Slide from 
the pop-up menu. In the Name field, delete the old name of the slide and type the new name. Click 
OK.

Creating a new presentation

This section shows you how to set up a new presentation using the Presentation Wizard.

Tip

The first thing to do is decide on the purpose of the presentation and plan the 
presentation. Although you can make changes as you go, having an idea of who 
the audience will be, the structure, the content, and how the presentation will be 
delivered, will save you a lot of time from the start.
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When you start Impress, the Presentation Wizard appears.

Figure 11. Choosing the type of presentation

Tip

If you do not want the wizard to start every time you start Impress, select the Do not 
show this wizard again option. You can enable the wizard again later under Tools > 
Options > LibreOffice Impress > General > Wizard, and select the Start with 
wizard option.

Leave the Preview option selected, so templates, slide designs, and slide transitions 
appear in the preview box as you choose them.

1) Under Type, choose one of the options:

• Empty presentation creates a blank presentation. 

• From template uses a template design already created as the basis for a new 
presentation. The wizard changes to show a list of available templates. Choose the 
template you want. More details can be found in Chapter 2.

• Open existing presentation continues work on a previously created presentation. The 
wizard changes to show a list of existing presentations. Choose the one you want.

2) Click Next. Figure 12 shows the Presentation Wizard step 2 as it appears if you selected 
Empty presentation at step 1. If you selected From template, an example slide is shown in 
the Preview box.

3) Choose a design under Select a slide design. The slide design section gives you two 
main choices: Presentation Backgrounds and Presentations. Each one has a list of choices 
for slide designs. If you want to use one of these other than <Original>, click it to select it.

The types of Presentation Backgrounds are shown in Figure 12.  When you click an item, a 
preview of the slide design appears in the Preview window. <Original> is an empty 
background.

Impress contains three choices under Presentations:

• <Original> is for a blank presentation slide design.
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• Both Introducing a New Product and Recommendation of a Strategy have their own 
prepackaged slide designs. Each design appears in the Preview window when its name 
is clicked.

Figure 12. Selecting a slide design

To start with a blank presentation, select <Original>. Click an item to see a preview of the 
slide design in the Preview window.

Note
Introducing a New Product and Recommendation of a Strategy are prepackaged 
presentation templates. They can be used to create a presentation by choosing 
From template in the first step (Figure 11).

4) Select how the presentation will be used under Select an output medium. Most often, 
presentations are created for computer screen display, so you would select Screen. You 
can change the page format at any time.

Note
The default Screen page is optimized for a 4:3 display (28cm x 21cm) so it is not 
suitable for modern wide-screen displays. You can change the slide size at any time 
switching to Normal view and selecting Format > Page.

5) Click Next. The Presentation Wizard step 3 appears.

Choose the desired slide transition from the Effect drop-down menu. 

Select the desired speed for the transition between the different slides in the presentation 
from the Speed drop-down menu. Medium is a good choice for now.
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Figure 13: Selecting a slide transition effect

6) Click Create. A new presentation is created.

Tip

You might want to accept the default values for both Effect and Speed unless you 
are skilled at creating presentations. Both of these values can be changed later 
while working with slide transitions and animations. These two are explained in 
more detail in Chapter 9. Slide Shows.

Note
If you selected From template on step 1 of the Wizard, the Next button will be active 
on step 3 and other pages will be available. These pages are not described here.

Caution
Remember to save frequently while working on the presentation, to prevent any 
loss of information should something unexpected occur. You might also want to 
activate the AutoRecovery function (Tools > Options > Load/Save > General). 
Make sure Save AutoRecovery information every is selected and that you have 
entered a recovery frequency.

Formatting a presentation

A new presentation only contains one empty slide. In this section we will start adding new slides 
and preparing them for the intended contents.

Inserting slides
This can be done in a variety of ways; take your pick.

• Insert > Slide.

• Right-click on the present slide, and select Slide > New Slide from the pop-up menu.

• Click the Slide icon in the Presentation toolbar.
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Sometimes, rather than starting from a new slide you want to duplicate a slide you have already 
inserted. To do so select the slide you want to duplicate from the Slides pane and then choose 
Insert > Duplicate Slide.

Selecting a layout
In the Tasks pane, select the Layout drawer to display the available layouts. The Layouts differ in 
the number of elements a slide will contain, from a blank slide to a slide with six contents boxes 
and a title.

Figure 14: Choosing a slide layout

The first slide in a presentation is normally a title slide. The Title Slide (which also contains a 
section for a subtitle) or Title Only are suitable layouts for the first slide, while for most of the slides 
you will probably use the Title, Contents layout.

To create the title, click on Click to add title (assuming the Blank Slide layout was not used) and 
then type the title text. To adjust the formatting of the title, modify the Title presentation style; see 
Chapter 2, Using Slide Masters, Styles, and Templates, for instructions.

If you are using the Title Slide layout, click on Click to add text to add a subtitle. Proceed as above 
to make adjustments to the formatting if required modifying the Subtitle presentation style instead.

Tip

To view the names for the prepackaged layouts, use the Tooltip feature: position the 
cursor on an icon in the Layout section (or on any toolbar icon) and its name will be 
displayed in a small rectangle.

If tooltips are not enabled, choose Tools > Options > LibreOffice > General > 
Help and select the Tips option. If the Extended tips option is also selected, you 
will get more detailed tooltip information, but the tooltip names themselves will not 
be provided.

To select or change the layout, place the slide in the work area and select the desired layout from 
the layout drawer in the Task Pane.
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Several layouts contain one or more content boxes. Each of these boxes can be configured to 
contain one of the following elements: Text, Movie, Picture, Chart or Table.

You can choose the type of contents by clicking on the icon that is displayed in the middle of the 
contents box as shown in Figure 15. If instead you intend to use the contents box for text, just click 
on the “Click to add text” area to get a cursor.

Figure 15: Selecting the desired contents type for a contents box

Note

Text and graphic elements can be readjusted at any time during the preparation of 
the presentation, but changing the layout of a slide that already contains some 
contents can have a dramatic effect. It is therefore recommended that you pay 
particular attention to the layout you select. If you do need to change the layout after 
contents have been added, the contents are not lost though they may need to be 
reformatted.

Modifying the slide elements
At this stage, the slide consists of everything contained in the slide master, as well as in the chosen 
layout slide; you may want to remove unneeded elements and add objects (such as pictures), as 
well as insert text.

Caution Changes to any of the prepackaged layouts should only be made using View > 
Normal. Attempting to make changes by modifying a slide master may result in 
unpredictable results and requires extra care as well as a certain amount of trial 
and error.

1) To add any pictures or objects to the slide. follow these steps:

a) To add a picture to the selected frame:

i. In Normal view, click on the Insert Picture icon. The Insert picture dialog box opens.
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ii. Browse to the location of the picture you want to include. To see a preview of the 
picture, check Preview at the bottom of the Insert picture dialog box.

iii. Select the picture and click Open.

iv. Resize the picture as necessary. Follow the directions in the Caution note below.

b) To add pictures from graphic files without utilizing the Insert Picture icon:

i. Insert > Picture > From File. The Insert picture dialog box opens.

ii. Browse to the graphic file. To see a preview of the picture, check Preview at the 
bottom of the Insert picture dialog box. Select a picture and click Open.

iii. Move the picture to its location.

iv. Resize the picture, if necessary.

c) To add OLE Objects, refer to Chapter 7, Inserting Spreadsheets, Charts, and Other 
Objects, where this advanced technique is described.

Caution

When resizing a graphic, right-click the picture. Select Position and Size from the 
context menu and make sure that Keep ratio is selected. Then adjust the height or 
width to the size you need. (As you adjust one dimension both dimensions will 
change.) Failure to do so will cause the picture to become distorted.

Remember also that resizing a bitmap image will reduce its quality on screen, even 
though the original image is unchanged (Impress stores the original file). A better 
approach is to create an image of the desired size outside of Impress and then 
import it into the presentation.

2) To add text to a slide that contains a text frame, click on Click to add text in the text frame 
and then type your text. The Outline styles are automatically applied to the text as you 
insert it. You can change the outline level of each paragraph as well as its position within 
the text by using the arrow buttons on the Text Formatting toolbar (see “Outline view” on 
page 12).

3) To remove any element on the slide that is not required, click the element to select it. The 
green handles show that it is selected; press the Delete key to remove it.

Modifying the appearance of slides
To change the background and other characteristics of all slides in the presentation, you need to 
modify the slide master or choose a different slide master.

A Slide Master is a slide with a specified set of characteristics that acts as a template and is used 
as the starting point for creating other slides. These characteristics include the background, objects 
in the background, formatting of any text used, and any background graphics.

Note

LibreOffice uses three interchangeable terms for this one concept. Master slide, 
slide master, and master page all refer to a slide that is used to create other slides. 
This book, however, uses only the term slide master, except when describing the 
user interface.

Impress has a range of prepackaged slide masters, found in the Master Pages section of the Tasks 
pane. You can also create and save additional slide masters or add more from other sources. See 
Chapter 2 for information on creating and modifying slide masters.

If all you need to do is to change the background, you can take a shortcut:

1) Select Format > Page and go to the Background tab.

2) Select the desired background between solid color, gradient, hatching, and bitmap. Click 
OK to apply it.
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A dialog box opens, asking if the background should be applied to all the slides. If you click Yes, 
Impress automatically modifies the slide master for you.

Modifying the slide show
By default the slide show will display all the slides in the same order as they appear in the slide 
sorter, using any transition between slides specified in the Presentation Wizard, and you need 
some keyboard or mouse interaction to move from one slide to the next.

Now is a good time to review the entire presentation and answer some questions. Run the slide 
show at least once (see “Running the slide show” on page 24) before answering them. You might 
want to add some questions of your own.

1) Are the slides in the correct order? If not, some of them will need to be moved.

2) Is the information well spaced and visible to members of an audience at the back of a large 
room? They may not be able to see information at the bottom of a slide, so you may need 
to design your presentation to fit the top three-quarters of the screen.

3) Would an additional slide make a particular point clearer? If so, another slide needs to be 
created.

4) Do some of the slides seem unnecessary? Hide or delete them.

5) Would custom animations help some of the slides? (Advanced technique.)

6) Should some of the slides have a different slide transition than others? The transition of 
those slides should be changed.

Caution
If one or more slides seem to be unnecessary, hide the slide or slides, and view the 
slide show a few more times to make sure they aren't needed. To hide a slide, right-
click the slide in the Slides pane and select Hide Slide in the pop-up menu. Do not 
delete a slide until you have done this; otherwise you may have to create that slide 
again.

Once you have answered these and your own questions, make the necessary changes. This is 
done most easily in the Slide Sorter view (see page 15). Use the Slide Show menu to change the 
order of the slides, choose which ones are shown, automate moving from one slide to the next, 
and other settings. To change the slide transition, animate slides, and make other enhancements, 
use the various selections in the Task pane.

Custom animations
If you wish to add a custom animation to a slide, do it now. Custom animations are found in the 
Custom Animation section of the the Tasks pane,. This is an advanced technique and is explained 
in Chapter 9, Slide shows.

Slide transitions
Your first slide show should probably have the same slide transition for all slides. Setting Advance 
slide to On mouse click is the default. If you want each slide to be shown for a specific amount of 
time, click Automatically after and enter the number of seconds. Click Apply to all slides.

Transition choices are found under Slide Transition on the Tasks pane. For more information about 
slide transitions, see Chapter 9, Slide Shows.

Tip
The Slide transition section has a very useful option: Automatic preview. With this 
option selected, when you make any changes in a slide transition, the new slide is 
previewed in the Slide Design area, including its transition effect.
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Running the slide show

To run the slide show, do one of the following:

• Click Slide Show > Slide Show on the main menu bar.

• Click the Slide Show button on the Presentation toolbar or the Slide Sorter toolbar (Figure
10).

• Press F5 or F9. (F9 does not work on a Mac.) 

If the slide transition is Automatically after x seconds, let the slide show run by itself.

If the slide transition is On mouse click, do one of the following to move from one slide to the next.

• Click the mouse button to advance to the next slide.

• Use the arrow keys on the keyboard to go to the next slide or to go back to the previous 
one.

• Press the Spacebar on the keyboard to advance to the next slide.

Right-click anywhere on the screen to open a menu from which you can navigate the slides and set 
other options.

When you advance past the last slide, the message Click to exit presentation... appears. Click the 
mouse or press any key to exit the presentation.

To exit the slide show at any time including at the end, press the Esc key.
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Designing a presentation

In addition to careful planning of the content (as discussed in Chapter 1), you need to plan the 
appearance of the presentation. It is best to do this after you have developed an outline, because 
the outline will determine some of the requirements for the slides’ appearance. For example:

• What color combinations (background and text) will look good and also be easy for your 
audience to read?

• Would a picture help your audience understand the contents better?

• Do you want particular text and a picture to appear on all the slides? (for example a 
company name and logo.) 

• Would the audience benefit from having the slides numbered so that they can quickly refer 
to one of them?

• Do you want a background graphic or gradient? If so, you need to pick something that does 
not interfere or clash with content such as the colors used in charts.

• Will you need one slide master or more than one? Will one slide design suit all of the 
content?

You can change the appearance of slides as you develop the presentation, but planning ahead will 
save you time in the long run.

What are slide masters?

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style 
in Writer: it controls the basic formatting of all slides based on it. A slide show can have more than 
one slide master.

Note
LibreOffice uses three terms for this one concept. Master slide, slide master, and 
master page all refer to a slide which is used to create other slides. This book uses 
the term slide master, except when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or 
gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers 
and footers; placement and size of text frames; and the formatting of text.

All of the characteristics of slide masters are controlled by styles. The styles of any new slide you 
create are inherited from the slide master from which it was created. In other words, the styles of 
the slide master are available and applied to all slides created from that slide master. Changing a 
style in a slide master results in changes to all the slides based on that slide master; it is, however, 
possible to modify each individual slide without affecting the slide master.

Note
Although it is highly recommended to use the slide masters whenever possible, there 
are occasions where manual changes are needed for a particular slide, for example 
to enlarge the chart area when the text and chart layout is used. 

Slide masters have two types of styles associated with them: presentation styles and graphic  
styles. The pre-packaged presentation styles can be modified, but new presentation styles cannot 
be created. However, not only can the pre-packaged graphic styles be modified, but new graphic 
styles can also be created.

Presentation styles are discussed in detail in Chapter 3, Working with Text. The use of graphic 
styles is covered in Chapter 6, Formatting Graphic Objects. See also “Working with styles in
Impress” on page 36.
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Working with slide masters

Impress comes with a collection of prepackaged slide masters. They are shown in the Master 
Pages section of the Tasks pane (Figure 25). This section has three subsections: Used in This 
Presentation, Recently Used, and Available for Use. Click the + sign next to the name of a 
subsection to expand it to show thumbnails of the slides, or click the – sign to collapse the 
subsection to hide the thumbnails.

Each of the slide masters shown in the Available for Use list is from a template of the same name. 
If you have created your own templates, or added templates from other sources, slide masters 
from those templates will also appear in this list. See “Working with templates” on page 37 for more 
about templates.

Creating slide masters
You can create a new slide master in a similar way to modifying the default slide master.

To start, enable editing of slide masters by selecting View > Master > Slide Master. You can also 
right-click on the default slide master in the Master Pages section of the tasks pane, and select 
Edit Master.

On the Master View toolbar, click the New Master icon (highlighted in the figure below).

A second slide master appears in the Slides pane. Modify this slide master to suit your 
requirements. It is recommended that you rename this new slide master. To do that, right-click on 
the slide in the Slides pane and select Rename master from the pop-up menu.

When you are done, close the Master View toolbar to return to normal slide editing mode.

Applying a slide master
In the Tasks Pane, be sure the Master Pages 
section is showing. (See Figure 25.)

To apply one of the slide masters to all slides in 
your presentation, click on it in the list.

To apply a different slide master to one or more 
selected slides:

1) In the Slides Pane, select the slides you 
want to change.

2) In the Tasks Pane, right-click on the slide 
master you want to apply to the selected 
slides, and click Apply to Selected Slides 
on the pop-up menu.
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Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong 
to different templates (the use of templates is explained later in “Working with templates” on page 
37). For example, you may need a completely different layout for the first slide of the presentation, 
or you may want to add a slide from a different presentation to your current presentation (based on 
a template available on the hard disk).

The Slide Design dialog box (Figure 17) makes this possible. Access this dialog box either from the 
menu bar (Format > Slide design) or from the pop-up menu that appears when right-clicking on a 
slide in the Slides pane.

Figure 17: Loading slide masters from a presentation template

The main area in the dialog box shows the slide masters already available for use. To add more:

1) Click the Load button.

2) Select in the new dialog box the template from which to load the slide master. Click OK.

3) Click OK again to close the slide design dialog box.

The slide masters in the template you selected are now shown also in the Master Pages section of 
the Tasks pane in the Available for use subsection.
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Note
The slide masters you have loaded will also be available the next time you load the 
presentation. If you want to delete the unused slide masters, click the corresponding 
checkbox in the Slide Design dialog box.

Tip
To limit the size of the presentation file, you may want to minimize the number of 
slide masters used.

Modifying a slide master

The following items can be changed on a slide master:

• Background (color, gradient, hatching, or bitmap)

• Background objects (for example, add a logo or decorative graphics)

• Text attributes for the main text area and notes

• Size, placement, and contents of header and footer elements to appear on every slide

• Size and placement of default frames for slide titles and content

Refer to Figure 20 for a graphical representation of many of these elements.

Before working on the slide master, make sure that the Styles and Formatting window is open. See 
page 33 for instructions on doing this.

To select the slide master for modification:

1) Select View > Master > Slide Master from the menu bar. This unlocks the properties of the 
slide master so you can edit it.

2) Click Master Pages in the Tasks pane. This gives you access to the pre-packaged slide 
masters.

3) Click on the slide master you want to modify among the ones available (Figure 25).

4) Make changes as described in this chapter, then click the Close Master View icon on the 
Master View toolbar. Save the file before continuing.

Caution
Any changes made to one slide when in Master View mode will appear on all slides 
using this slide master. Always make sure you close Master View and return to 
Normal view before working on any of the presentation slides. Select View > Normal 
from the menu bar, or clicking Close Master View in the Master View toolbar to 
return to the normal slide view.

The changes made to one of the slides in Normal view (for example, changes to the bullet point 
style, the color of the title area, and so on) will not be overridden by subsequent changes to the 
slide master. There are cases, however, where it is desirable to revert a manually modified element 
of the slide to the style defined in the slide master: to do that, select that element and choose 
Format > Default Formatting from the menu bar.

It is also possible to modify the default layout of the slide master, for example by moving the title to 
the side; however, you are restricted to modifications to the “Title, Text” layout (that is, the layout 
containing a title box and a text box).

Sometimes, depending on the contents of the slide, you may want to apply a different layout. The 
title and text boxes will inherit the properties of the slide master, but if you have changed the 
position of these text boxes in the slide master, the layout may appear corrupted and you may 
need to re-position some of the layout elements manually.
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Choosing and applying the background
Backgrounds can be applied to a number of elements in Impress: the page, a default text area, a 
graphic object and so on. The procedures to apply a background are always the same.

The following procedure is used to apply a background to the page.

1) To begin, do one of the following:

• Select Format > Page from the menu bar. On the Page Setup dialog box, choose the 
Background tab.

• Make sure the Presentation Styles icon is selected in the Styles and Formatting window 
(Figure 21), right-click Background and select Modify from the pop-up menu. This 
opens the Background dialog box.

2) Select the type of fill you want for your background from the five choices: None, Color, 
Gradient, Hatching, or Bitmap.

Figure 18: Background choices

A list of choices for the selected fill type then appears (see Figure 19 for an example).

Figure 19: Background colors

3) Select one of the items on the list and click OK. The fill you have chosen is added to the 
slide master, replacing any previously selected fill.
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Tip

You can make custom additions to each type of background, with the obvious 
exception of None. After you create new fills, they are listed in the Background dialog 
box along with the fills provided with LibreOffice. For example, the last color in 
Figure 19, Test Blue, is a custom color. See Chapter 6 for more information.

Adding background objects
This section describes how to add background objects and graphic elements (such as a logo, 
decorative lines, and so on). LibreOffice supports a large number of graphical formats.

When you want the same graphic to appear on every slide of your presentation, the easiest and 
quickest solution is to use the slide master. It saves time while creating the presentation, and also 
when you want to modify or reposition the graphic on the slide. If the graphic is added to each slide 
manually, these operations have to be performed on each individual slide in the presentation.

One of the most common actions in preparing a presentation is to add a picture to the slide master. 
To insert a picture already available on the hard disk, follow these steps:

1) Choose View > Master > Slide Master from the menu bar.

2) Select from the menu bar Insert > Picture > From File.

3) Navigate to the directory where your picture is and select it. If you want to see a preview, 
select the corresponding checkbox in the file browser dialog box.

Caution

LibreOffice offers the option to insert a picture as a link to the file rather than 
embedding it in the document. This can be useful when a presentation is not intended 
to be distributed elsewhere, and where it will remain in the same hierarchical directory 
structure. For example, it could be created on a notebook computer, from which the 
presentation will be given to, typically, a group of clients.

If the presentation file is to be distributed, however, the picture should be embedded to 
avoid the “missing picture” syndrome when the presentation is finally given on a 
different computer.

Once the picture is inserted, you need to move it to the background. To do that, while the picture is 
still selected, right click on the picture and select Arrange > Send to Back from the context menu. 
You may also need to reposition it and modify its size. To do that see Chapter 4, Adding and 
Formatting Pictures.

Tip

If you want the image to blend with the background, you can set the background color 
of the picture as transparent. Select the picture, then chose Tools > Eyedropper from 
the menu bar. Select the first checkbox and then move the mouse cursor on the 
picture and click on the color you want to make transparent. This color appears next to 
the checkbox. Make sure that Replace with... is set to Transparent and click Replace.

Tip
An easy way to make the picture lighter so that the text stands out better against its 
background, is to increase the transparency of the picture or change the gamma. Both 
these adjustments can be quickly made from the Picture toolbar.

In addition to pictures you can add a number of other background objects, for example decorative 
lines, text and shapes. Figure 20 is an example of a slide master with a custom background 
gradient, a background picture, another picture in the top right corner, some decorative lines and 
some customized presentation styles.
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Figure 20: Example of a complex slide with several modifications

Slide master styles
Within the slide master you can define a complete set of styles that define the default appearance 
of text and graphic objects inserted in slides based on that background. If for example your slide 
master has a dark background, you may want to set the font color of the title and text areas to be 
light. Rather than manually changing the font color for every new slide you create, a time-
consuming operation prone to errors and omissions, simply modify the style in the slide master. 
Changes made to styles in the slide master only apply to the slides based on that particular slide 
master.

Styles in Impress are sub-divided into two main categories: Presentation styles and Graphics 
styles.

Presentation styles
Presentation styles affect three elements of a slide master: the background, background objects 
(such as icons, decorative lines, and text frames), and the text placed on the slide. Text styles are 
further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline styles are 
used for the different levels of the outline to which they belong. For example, Outline 2 is used for 
the sub-points of Outline 1, and Outline 3 is used for the sub-points of Outline 2.

The pre-packaged presentation styles can be modified, but new presentation styles cannot be 
created.

Graphics styles
Graphics styles apply to lines, shapes and text boxes created using the Impress drawing tools and 
define the formatting of such objects. 

There are 15 pre-packaged graphics styles to choose from. You can create additional styles or 
modify the pre-packaged styles.
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Note

The presence of text and title styles both in the Presentation and Graphics styles may 
seem confusing. This apparent duplication is due to the fact that Impress facilitates the 
operation of adding structured text to the slides by means of special text boxes where 
the Presentation styles apply (AutoLayout boxes). The title and other text styles in the 
Graphics styles group continue to apply to other text boxes you may want to add, or to 
the text associated to shapes or lines.

The Styles and Formatting window
To work on the slide master styles, start by opening the Styles and Formatting window shown in 
Figure 21. Either press F11 or select Format > Styles and Formatting from the main menu.

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or other groups of styles, for example applied styles or (in 
the case of Graphics styles), custom styles.

You can dock or undock the Styles and Formatting window by holding down the Control key while 
double-clicking the top of the window between the icons (see Figure 21). Press F11 to close the 
Styles and Formatting window when you do not need it: LibreOffice will remember its position the 
next time you re-open it.

Figure 21: Styles and Formatting window

Modifying default text areas
When a slide master is opened for editing, it contains five areas, as shown in Figure 22.

• Title area for AutoLayouts

• Object area for AutoLayouts

• Date area

• Footer area

• Slide number area
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Figure 22: Slide master showing five editable areas

Click with the left mouse button on any of these areas to display eight green squares (handles) 
around the rectangle. Use these handles to modify the size and position of the area.

1) To change the position, move the mouse towards one of the edges, away from the green 
handles, until the cursor changes shape1, then click the left mouse button and drag the 
area to the desired position.

2) To modify the shape and size of one of the rectangular areas, use one of the 8 green 
handles: the ones in the corners modify both the sides of the rectangle simultaneously 
while those in the middle of the sides modify only one dimension at a time. The shape of 
the mouse cursor usually changes when over the handle, giving a clear visual indication of 
how it will affect the shape of the rectangular area.

Tip
To keep the ratio between the sides of the rectangular area constant, move the 
mouse to one of the 4 green handles at the corner of the area and keep the Shift key 
pressed while dragging the handle with the mouse.

To accurately control the shape and size as well as the position of the default text area, it is better 
to use the Position and Size dialog box than the mouse. First select the rectangular area by 
clicking on any point inside it, then press F4 or choose Format > Position and Size. The dialog 
box shown in Figure 23 is displayed.

The functions of this dialog box are explained in the Draw Guide, so only a short description of the 
most important fields is provided in this chapter.

Use the Position section to specify the X (horizontal) and Y (vertical) position of the rectangular 
area. The values represent the distance of the base point (selected on the right hand side) relative 
to the top left corner of the slide.

1 The shape of the cursor to move and resize objects is operating system specific.
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Figure 23: The Position and Size dialog box

Use the Size section to specify the width and height of the rectangular area. Select in the Base 
point section the part of the rectangular area you do not want to move while resizing. The default 
setting (top left corner) means that the position of the top left corner of the area will not change 
after resizing.

You can also use the Rotation tab of the dialog box to rotate the default text area. For example, 
you can place the footer area on the side by rotating each text area by 90 degrees, and obtain a 
more modern-looking layout. In general it is preferable to use only right angles for ease of editing, 
although the program does not impose restrictions on the values that can be used.

Further modifications to the default text areas
Besides the shape, size and position, it is also possible to modify other aspects of the 5 areas of 
the slide master, such as the background, border, alignment relative to the slide, and position 
relative to other objects.

While the background style and line style of an area can be accessed from the Format menu, in 
order to access the Alignment and Arrange menus you need either to open the Drawing toolbar or 
to use the context menu. To display the Drawing toolbar (Figure 24), select View > Toolbars > 
Drawing; to open the context menu, right-click on the edge of the rectangular area after selecting 
it. On the Drawing toolbar, click the arrow next to the Alignment or Arrange icon (highlighted in 
Figure 24) to display choices. See the Draw Guide for details.

Figure 24: Location of Alignment and Arrange icons on the Drawing toolbar

The date area and slide number area do not automatically appear on every slide, even though you 
have defined them. In order to show them, you need to close the Master View and select the 
desired field from the menu bar: Insert > Page number or Insert > Date and time. This procedure 
is explained in detail in Chapter 8, Adding and Formatting Slides, Notes, and Handouts.
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Adding text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text objects 
to the master page for your slides to act as a header or a footer.

1) Choose View > Master > Slide Master from the menu bar.

2) On the Drawing toolbar (see Figure 24), select the Text icon.

3) Click once and drag in the master page to draw a text object, and then type or paste your 
text into the object or add fields as described below.

4) Choose View > Normal when you are finished.

To add a field, such as the date or page number, to a text object in the header or footer, choose 
Insert > Fields. and select the required field from the submenu. If you want to edit a field in your 
slide, select it and choose Edit > Fields. See Chapter 3, Adding and Formatting Text, for more 
information.

The fields you can use in Impress are:

• Date (fixed)

• Date (variable) —updates automatically when you reload the file

• Time (fixed)

• Time (variable)—updates automatically when you reload the file

• Author—First and last names listed in the LibreOffice user data

• Page number (slide number)

• File name

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field, 
choose Format > Page and then select a format from the list in the Layout Settings 
area. 

To change the author information, go to Tools > Options > LibreOffice > User Data.

Working with styles in Impress

If you are familiar with styles in Writer, you will find both similarities and differences in Impress. The 
presentation styles are similar to paragraph styles in Writer and are used in a very similar fashion. 
You cannot create new presentation styles but you can fully configure the existing ones. Note that, 
as with the Heading styles in Writer, the Outline styles are hierarchically linked, so that a change in 
the Outline 1 will cascade through all the other Outline levels.

In Impress you will also find the graphics styles very useful. They define the characteristics of a 
graphic object (including a text object). If, for example, you need to create a organization chart 
diagram in one of the slides of your presentation, you will likely want all of the boxes to have a 
consistent appearance, meaning the same line style, same font type, maybe the same shadow, 
and so on. The easiest way to achieve this result with the minimum effort is to create a graphics 
style for the boxes and apply it to each box. The major benefit is that if later on you decide to 
modify, say, the background color of the boxes, all you need to do is modify the style rather than 
each individual box.

Presentation styles are discussed in detail in Chapter 3, Working with Text. The use of graphics 
styles is covered in Chapter 6, Formatting Graphic Objects.
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Working with templates

All documents in LibreOffice are based on templates. However, Impress is a little different from 
other LibreOffice components, in that it starts with the Presentation Wizard unless you have 
elected to turn the Wizard off.

When you choose File > New > Presentation from the menu bar, if the Presentation Wizard is 
active, the Wizard offers several choices for a new presentation, one of which is From template.

If you have turned the Presentation Wizard off, when you start a new presentation by choosing File 
> New > Presentation from the menu bar, LibreOffice uses the default presentation template. If 
you have not defined your own default template, LibreOffice uses a blank template supplied with 
the program.

Using templates supplied with LibreOffice
Impress comes with a set of predefined templates. Two are in the Presentations folder and the 
others are in the Presentation backgrounds folder. The difference between them is that 
Presentation templates include a series of slides with sample titles and topics, while Presentation 
background templates have only backgrounds and background objects. Both types have 
predefined presentation and graphics styles.

You can create a new presentation from a previously saved presentation template by choosing File 
> New > Templates and Documents from the menu bar. This opens the Templates and 
Documents – Templates dialog box. To open a new presentation based on a template, double-click 
that template’s name in the list.

Using templates from other sources
If you have created your own templates, or imported templates from another location, they are 
probably stored in the My Templates folder in the Templates and Documents – Templates dialog 
box. Templates installed using the Extension Manager may be installed in their own folders. You 
can use them in the same way as the templates installed with Impress.

See page 41 for information on importing templates into LibreOffice.

Installing templates using the Extension Manager
The Extension Manager provides an easy way to install collections of templates, graphics, macros, 
or other add-ins that have been “packaged” into files with a .OXT extension.

Although individual extensions can be found in different places, this page lists many of them: 
http://extensions.libreoffice.org/. Some extensions are free of charge; others are available for a fee. 
Check the descriptions to see what licenses and fees apply to the ones that interest you.

For more about the Extension Manager and some extensions of interest to Impress users, see 
Chapter 11, Setting Up and Customizing Impress.

To install a collection of templates packaged as an extension:

1) Download the extension and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension 
Manager dialog, click Add.

3) A file browser window opens. Find and select the extension you want to install and click 
Open. The extension begins installing. You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog 
box.
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The slide masters from the templates will now appear in the list of Available Master Pages in the 
Tasks Pane.

Tip

To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions here link. You do not need to download 
them separately as in step 1 above.  It is also advised that you use the Extension 
Manager to check for any new Impress updates.

Creating your own templates
To create a template from a presentation:

1) Open the presentation that you want to use for a template.

2) From the main menu, choose File > Templates > Save. The Templates dialog box opens.

3) In the New template field, type a name for the new template.

4) In the Categories list, click the folder in which you want to store the template. This is 
usually the My Templates folder, unless you have created other folders.

To learn more about template folders, see “Organizing templates” on page 40.

5) Click OK. LibreOffice saves the new template and the Templates dialog box closes.

Figure 25. Saving a new template

Note
All the slide masters used in the template become available for use in other 
presentations.

Setting a default template
You can set a custom presentation template to be the default template. You can reset the default 
later if you choose. 

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in the 
Template Management dialog box.
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To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template Management 
dialog box opens.

Figure 26. Template Management dialog box

2) In the box on the left, double-click the folder containing the template that you want to set as 
the default, then select the template.

3) Click the Commands button.

4) From the drop-down menu, choose Set As Default Template. The next time that you 
create a document by choosing File > New the document will be created from this 
template.

Resetting the default to Impress’s built-in Default template
To re-enable Impress’s Default presentation background template as the default:

1) In the Template Management dialog box, in the box on the left, click the Presentation 
Backgrounds folder.

2) Click the Commands button.

3) From the drop-down menu, choose Reset Default Template > Presentation.

Note
Use the instructions in this section only if you have customized the presentation 
template.

Modifying a template
You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s 
styles to documents that were created from that template.

Note You can only reapply styles. You cannot reapply content.
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To edit a template:

1) From the main menu, choose File > Templates > Edit. A standard file browser window 
opens.

2) Find and select the template that you want to edit, and then click Open. The selected 
template opens in Impress.

3) Edit the template just as you would any other presentation. To save your changes, choose 
File > Save from the main menu.

The next time that you open a presentation that was created from the changed template, the 
following message appears.

Figure 27. Update styles message

Click Update Styles to apply the template’s changed styles to the document. Click Keep Old 
Styles if you will never want to apply the template’s changed styles to the document. Whichever 
option you choose, the message box closes and the presentation opens in Impress.

Organizing templates
LibreOffice can only use templates that are in LibreOffice template folders. You can create new 
LibreOffice template folders and use them to organize your templates. For example, you might 
have separate template folders for different purposes or projects. You can also import and export 
templates.

To begin, choose File > Templates > Organize from the main menu. The Template Management 
dialog box (Figure 18) opens.

Note
All the actions made by the Commands button in the Template Management dialog 
box can be made as well by right-clicking on the templates or the folders.

Creating a template folder
To create a template folder:

1) In the Template Management dialog box, click any folder.

2) Click the Commands button and choose New from the drop-down menu. A new folder 
called Untitled appears.

3) Type a name for the new folder, and then press Enter. LibreOffice saves the folder with the 
name that you entered.

Deleting a template folder
You cannot delete the template folders supplied with LibreOffice or installed using the Extension 
Manager; you can only delete folders that you have created.

To delete a template folder that you have created:

1) In the Template Management dialog box, select the folder that you want to delete.

2) Click the Commands button and choose Delete from the drop-down menu. A message box 
appears and asks you to confirm the deletion. Click Yes.
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Moving a template
To move a template from one template folder to another:

1) In the Template Management dialog box, double-click the folder that contains the template 
you want to move. A list of all the templates contained in that folder appears underneath the 
folder name.

2) Click the template that you want to move and drag it to the desired folder. If you do not 
have the authority to delete templates from the source folder, this action copies the 
template instead of moving it.

Deleting a template
You cannot delete the templates supplied with LibreOffice or installed using the Extension 
Manager; you can only delete templates that you have created or imported.

To delete a template:

1) In the Template Management dialog box, double-click the folder that contains the template 
you want to delete. Click the template that you want to delete.

2) Click the Commands button and choose Delete from the drop-down menu. A dialog box 
appears and asks you to confirm the deletion. Click Yes.

Importing a template
If the template that you want to use is in a different location, you must import it into an LibreOffice 
template folder.

To import a template into a template folder from another location on your computer:

1) In the Template Management dialog box, click the folder into which you want to import the 
template.

2) Click the Commands button and choose Import Template from the drop-down menu. A 
standard file browser window opens.

3) Find and select the template that you want to import and click Open. The file browser 
window closes and the template appears in the selected template folder.

4) If you want, type a new name for the template, and then press Enter.

Exporting a template
To export a template from a template folder to another location:

1) In the Template Management dialog box, double-click the folder that contains the template 
you want to export. 

2) Click the template that you want to export.

3) Click the Commands button and choose Export Template. from the drop-down menu. The 
Save As window opens.

4) Find the folder into which you want to export the template and click Save.
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Introduction

This chapter describes the different ways to add text to slides and format the text.

Text in slides is contained in text boxes.

There are two ways to add text boxes to a slide:

• Choose a predefined layout from the Layouts section of the Tasks pane, containing text 
elements as described in Chapter 1. These text boxes are called AutoLayout text boxes.

• Create a text box using the text tool  in the Drawing toolbar.

This chapter describes how to create, modify, use, and delete text boxes. It also discusses the 
various types of text that can be inserted and explains how to format the text. Finally, it provides 
information on how to insert special forms of text such as numbered or bulleted lists, tables, fields 
and hyperlinks.

Working with text boxes

Using text boxes created from the Layout pane
In Normal view:

1) Click in the text box that reads Click to add text.

2) Type or paste your text in the text box.

These text boxes are known as AutoLayout text boxes. See also “Creating bulleted and numbered
lists” on page 55.

Using text boxes created from the text box tool
In Normal View:

1) Click on the Text icon  on the Drawing toolbar. The default position of the drawing 
toolbar is towards the bottom of the screen. If the toolbar with the text icon is not visible, 
choose View > Toolbars > Drawing.

2) Click and drag to draw a text box on the slide. This sets the width. Do not worry about the 
height—the text box will expand if needed as you type. To reposition the text box to a 
different part of the slide, see “Moving a text box” on page 44; to change the width, see 
“Resizing a text box” on page 45.

3) Release the mouse button when finished. The cursor appears in the text box, which is now 
in edit mode (gray hashed border; see Figure 28).

4) Type or paste your text in the text box.

5) Click outside the text box to deselect it.

Note

In addition to the normal text boxes where text is horizontally aligned, it is possible to 
insert text boxes where the text is aligned vertically. This choice is available only 
when Asian languages are enabled in Tools > Options > Language Settings > 
Languages.

Click on the  icon in the drawing toolbar to create a vertical text box. Note that 
when editing the contents, the text is displayed horizontally.
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Figure 28: Selected text box showing the green resizing handles and Text toolbar

Moving a text box
In Normal view, notice how the pointer changes from an arrow to an I-beam as you move it over 
the text in a text box.

1) Click when the pointer becomes an I-beam. The text box is now in edit mode. In this mode 
a gray border is visible around the text box edges.

2) Move the I-beam (or pointer) over the gray border. Notice how it changes shape, becoming 
the usual “move” symbol on your operating system (for example, a hand).

3) When the “move” symbol appears, click once. Blue selection handles appear.

4) Click anywhere in the text box or on the gray border (except for the blue handles) and drag 
to move the text box. A semi-transparent copy of the text box shows where your text box 
will be placed. See Figure 29.

5) Release the mouse button when the text box is in the desired position. To return to edit 
mode, click outside the text box area and then repeat step 1) of this procedure.

Figure 29: Moving a text box
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Resizing a text box
In Normal view, enter edit mode by clicking on the text box, then move the mouse to the gray edge 
of the text box. When the cursor shape changes, click the left mouse button again. The text box 
should now display blue resizing handles. Move the pointer over any handle. Notice how the 
pointer changes shape, indicating in what direction the text box will be resized. The corner handles 
change the two dimensions of the text area simultaneously, while the four handles at the center of 
each side modify only one dimension.

When the two-headed arrow is displayed, click and drag to resize the text box.

Tip
To maintain the proportions of a text box while resizing, press and hold the Shift key, 
then click and drag. Make sure to release the mouse button before releasing the 
Shift key.

Figure 30: Resizing a text box

Impress also provides a different type of text box which resizes horizontally to automatically fit the 

text as it is inserted. To insert an auto-resizing text box, click on the  icon in the text toolbar 
(see Figure 28) and then click on the place in the slide where you want the first letter of the text to 
appear. If the text toolbar is not visible, choose View > Toolbars > Text.

For more accurate control over the shape, size and position of the text box, instead of using the 
mouse, use the Position and Size dialog box. Select the text box, then press F4 or select Format > 
Position and Size from the menu bar. The use of this dialog box is explained in Chapter 2.

Deleting a text box
1) Click the text once to display the gray border.

2) Move the cursor to the edge of the text box and click the left mouse button. The gray border 
now shows blue selection handles.

3) Press Delete.

Tip
Sometimes it is faster to to delete a text box by dragging a selection rectangle around 
the text box and then hitting the Delete key. Take care to avoid selecting and 
accidentally deleting other text boxes or shapes.

Chapter 3  Adding and Formatting Text 45



Inserting text

Pasting text
Text may be inserted into the text box by copying it from another document and pasting it into 
Impress. However, the pasted text will probably not match the formatting of the surrounding text or 
that of the other slides in the presentation. This may be what you want on some occasions; 
however in most cases you want to make sure that the presentation style is consistent. There are 
several ways to ensure consistency; these methods are explained below.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply the formatting later. To paste 
without formatting, either press Control+Shift+V and then select Unformatted text from the dialog 
box that appears, or click on the small black triangle next to the paste symbol in the standard 

toolbar  and select Unformatted text. The unformatted text will be formatted with the outline 
style at the cursor position in an AutoLayout text box or with the default graphic style in a normal 
text box.

Formatting pasted text
If pasting the text into an AutoLayout area, then to give the pasted text the same look and feel of 
the rest of the presentation apply the appropriate outline style to the text. To do so:

1) Paste the text in the desired position. Do not worry if it does not look right: it will in a 
minute.

2) Select the text you have just pasted (see “Selecting text” on page 48 for details on how to 
do that).

3) Select Format > Default formatting from the menu bar. This operation will assign one of 
the nine Presentation styles to the text (depending on where the insertion is made).

4) Use the four arrow buttons in the Text Formatting toolbar  to move the text 
to the appropriate position and give it the appropriate outline level. The button with the 
arrow pointing left promotes the list entry by one level (for example from Outline 3 to 
Outline 2), the right arrow button demotes the list entry by one level, the up and down 
arrow buttons move the list entry.

5) Apply manual formatting as required to sections of the text (to change font attributes, tabs, 
and so on).

If you are pasting text into a text box, you can still use styles to quickly format the text. Note that 
only one graphic style can be applied to the copied text. To do this:

1) Paste the text in the desired position.

2) Select the text you have just pasted (see “Selecting text” on page 48 for details).

3) Select the desired graphic style.

4) Apply manual formatting as required to sections of the text.

Tip Presentation styles are very different from Writer styles and are applied in quite a 
different way. Refer to ”Using styles to format text on page 49 for details.
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Inserting special characters
To insert special characters, such as copyright, math, geometric, or monetary symbols, or 
characters from another language:

1) Click in the place in the text where you want to insert the character.

2) Choose Insert > Special Character. The Special Characters dialog box appears. See 

Figure 31. Alternatively if the  icon is visible, you can click this to bring up the Special 
Characters dialog box.

Tip
To show toolbar buttons that are not visible, click on the small down-arrow on the 
right end of the tool bar, move the cursor over Visible Buttons and then click on the 
icon you wish to make visible.

3) Choose the font and character subset from the Font and Subset drop-down menus.

4) Click the character you want to insert. You may have to scroll to find the one you want.

5) Click OK.

Figure 31: Special Characters dialog box

Characters you select will be inserted in the order they were selected.  If you accidentally click the 
wrong character, clicking another character will only add it to the ones being inserted. Click Delete 
(all the characters selected will be deleted), then click the correct characters. Alternatively, you can 
also go ahead and insert all the selected characters and delete any unwanted ones from the 
document, as special characters behave like any other character.

Inserting non-breaking spaces and hyphens
Where it is not desirable for words separated by a space or by a hyphen to span over two lines, or 
where an optional hyphen is desired, you can insert a special formatting mark.

To access the Formatting marks options, select from the menu bar Insert > Formatting marks. 
Impress supports three formatting marks:

• Non-breaking space: A non-breaking space between two words prevents these two words 
being separated over two lines. Press Control+Shift+Spacebar on the keyboard to insert a 
non-breaking space.

• Non-breaking hyphen: A non-breaking hyphen keeps the two words separated by the 
hyphen on the same line.

• Optional hyphen: An invisible hyphen that is activated (thus breaking the word) only when 
the word is too long to fit on one line.
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Introduction to formatting text

The appropriate use of text formatting can give a presentation a consistent look and a dynamic 
feel, and it can even enhance the audience’s understanding of your message by preventing 
distracting elements.

When you enter text, either in an AutoLayout text box or in a normal text box, it is formatted with a 
set of predefined attributes known as a style. The style used depends on the outline level of the 
point where the text was entered for AutoLayout text boxes (for example, if you are entering a level 
2 item, Impress will format it according to the Outline 2 presentation style) or the Default Graphic 
style for text boxes.

Tip

Sometimes, as seen also in the “Pasting text” section on page 46, it is very useful to 
re-apply the baseline style to a selection of text, thus eliminating any manual 
formatting applied to it (particularly if you made a mistake and you do not know how 
to undo it). To do this, select the manually formatted text, and then select Format > 
Default formatting from the menu bar.

Broadly speaking, formatting text may require some intervention in three areas:

• The character attributes (for example the font color)

• The paragraph attributes (for example the alignment)

• The list attributes (for example the type of bullet)

In some cases it is quicker and more efficient to apply manual formatting; but in situations where 
you need to perform the same modifications to many different parts of the presentation, the use of 
styles is recommended. Both these techniques are described here.

Note

Unlike in Writer, where it is recommended to try to use styles whenever possible, in 
Impress manual formatting needs to be used more often. This is because 
presentation styles are fixed; therefore it is not possible, for example, to have two 
different level 1’s or different types of bullet points for the same outline level.

Also, the lack of support for character styles forces the use of manual formatting to 
modify sections of the text.

Selecting text
Text must be selected before it can be formatted.

• To format all the text in a text box, click once on the text, then click once on the border of 
the text box. The green resizing handles are displayed. Now any formatting changes will 
apply to all the text in the text box.

• To format only part of the text, click once on the text, then select the text to be formatted by 
clicking and dragging (highlighting) over it. You can also use keyboard combinations to 
select text: move the cursor where you want to begin your selection, press Shift and then 
use the arrow buttons to extend your selection. Formatting changes will apply only to the 
selected text.

Tip

To select text word by word, instead of by character, press the Control key and Shift 
key together.  To speed up the selection even further, you can combine the Shift key 
with the Home key or the End key to extend the selection up to the start or end of the 
line in which the cursor is positioned, respectively.
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Using styles to format text

Impress has two categories of styles: presentation styles and graphics styles. Presentation styles 
are used on text inserted into an AutoLayout area, slide master backgrounds, and background 
objects. However, for text inserted in a text box or a graphic object, you need to apply a graphic 
style.

In this chapter we focus mostly on Presentation styles. For information on graphic styles, see 
Chapter 6, Formatting Graphic Objects.

Modifying a presentation style
To modify a presentation style, follow these steps:

1) Open the Styles and Formatting window by pressing F11 or selecting Format > Styles and 
Formatting from the menu bar.

2) Select the style category by clicking on either the Presentation Styles icon  at the top of 
the Style and Formatting window.

3) Right-click on the style to be modified and select Modify from the pop-up menu.

The top portion of the dialog box for a presentation style is shown in Figure 32.

Figure 32: The dialog box for a presentation style

This dialog box consists of 14 pages, which can be divided in two groups: those that determine the 
formatting of the text and those that determine the properties of the slide master background and 
the background objects.

There is no difference between the parameters that characterize a style and the attributes given 
manually to portions of text; in fact the pages that open when applying formatting manually are the 
same that you configure in the style dialog box. Therefore once you master the formatting of text, 
you will know how to create and modify a style. In particular:

• For the Font and Font Effects style pages, refer to “Formatting characters” on page 50.

• For the Indents and Spacing, Alignment, and Tabs style pages, refer to “Formatting
paragraphs” on page 53.

• For the Bullet and numbering type, Graphics, Customize style pages, refer to “Creating
bulleted and numbered lists” on page 55.

The other tabs of the Presentation Style dialog box are all related to formatting the background and 
background objects and are described in detail in Chapter 6.

Updating a style from a selection
To update a style from a selection:

1) Select an item that has the format you want to adopt as a style.

2) In the Styles and Formatting window, select the style you want to update, and then click the 
Update Style icon (see Figure 33).
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Figure 33. Updating a style from a selection

Applying a presentation style
To apply a presentation style, move the paragraph to the appropriate outline level as described in 
“Changing the order or the outline level lines” on page 60.This is different from Writer, where you 
select the desired style from the Styles and Formatting window.

Formatting characters

To view the character formatting options, select Format > Character or click the Character button 

 on the Text Formatting toolbar. (If a toolbar with the text icon is not visible, choose View > 

Toolbars > Text Formatting.) The Character dialog box appears. Note that character styles do not 
exist in Impress.

Font page
Use the Font page to select the desired font type, its base attributes (Italic, Bold, etc.) as well as 
the size. A sample of the font is displayed in the lower part of the dialog box. You can also specify 
the language of this style.

Figure 34: The dialog box to set the basic font attributes
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Tip

When writing a presentation in multiple languages, you can make the best of the 
language setting by creating two styles that only differ in the language but are 
otherwise the same. This allows you to check the spelling of all of the contents 
without affecting the appearance.

This page is available when creating or modifying a presentation style or a graphics style.

If Asian language support has been enabled (Tools > Options > Language Settings > 
Languages), the Font page looks like Figure 35.

Figure 35: The Font page when Asian language support is enabled

The page is divided into three parts. The top and bottom parts have the same functionality as 
described above, while in the middle part you can specify the Asian text font and its attributes.

Font Effects page
Use the Font Effects page to apply special effects to the text, such as overlining and underlining, 
color, shadow and so on. As for the Font page, a sample of the text is displayed in the lower part of 
the dialog box allowing a quick visual check of the effects applied. This page is available when 
creating or modifying a presentation style or a graphics style.

Figure 36: Advanced options for the character can be set in the Font Effects page
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Position page
The Position page has advanced options to customize text. This page is not available when 
creating or modifying a presentation style or a graphics style.

Use this page to set the text position relative to the baseline when you need to insert subscripts or 
superscripts.

To create a superscript or a subscript do the following:

1) Select Superscript or Subscript as applicable.

2) Specify the amount by which the text should be raised (superscripts) or lowered 
(subscripts).

3) Specify the dimensions of the character relative to the baseline character size (in 
percentage).

The amount by which the text is raised or lowered can be set to automatic by selecting Automatic.

Figure 37: Setting the character position attributes

Two more position attributes can be set on this page:

• The (width) scaling of the text, which specifies the percentage of the font width by which to 
compress or expand the individual characters of the selected text.

• The spacing between the characters of the font, which can be defined in number of points. 
Selecting the Pair kerning check-box causes LibreOffice to automatically adjust the 
spacing between certain pairs of characters to visually improve the appearance. For 
example, when writing a V followed by an A (VA) the spacing between the two letters is 
reduced (strong kerning) as can be easily seen when compared with, say, VS which is not 
a kerning pair.
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Formatting paragraphs

To view the paragraph formatting options, select Format > Paragraph or click the Paragraph 

button  on the Text Formatting toolbar. If a toolbar with the text icon is not visible, choose View 
> Toolbars > Text Formatting. The Paragraph dialog box is shown. It contains three pages that 
are described in detail below. If Asian language support has been activated, a page called Asian 
Typography is also displayed.

Indents and Spacing page
The Indents and Spacing page, shown in Error: Reference source not found, has four sections: 

• Indent: modifies the indentation of the text (before and after) as well as the indentation of 
the first line.

• Spacing: defines the space before and after each paragraph formatted with the style.

• Line spacing: determines the spacing between two lines formatted with the style. Note that 
selecting Proportional spacing requires specifying the percentage of a line to be used as 
spacing; 100% corresponds to a single line, 200% to a double line, 50% to half a line. If 
Leading is selected, specify the amount of line spacing in your default unit of measurement.

• Preview area: provides a visual representation of the settings before you apply them.

Figure 38: The paragraph formatting dialog box

Tip
Setting the line spacing to less than 100% is a good method to cram a lot of text into 
a text box, however care must be taken as too small a value will make the text hard 
to read.

Tip
You can change the default unit of measurement, for example from inches to 
centimeters, from Tools > Options > LibreOffice Impress > General.

The Indents and Spacing page is also available when creating or modifying a graphics style or 
when modifying a presentation style.
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Alignment page
Use the Alignment page to determine the text alignment: Left, Right, Center, or Justified. A preview 
shows the effects of the changes. If Asian language support has been enabled, a Text direction list 
appears under Properties at the bottom on the page.

Figure 39: Alignment tab of paragraph style

The same alignment options can be accessed from the Text Formatting toolbar. 

The Alignment page is also available when creating or modifying a graphics style, or modifying a 
presentation style.

Tabs page
Use the Tabs page to set tab stops. To delete an existing tab stop, select it in the list and click the 
Delete button. To delete all the tab stops, click the Delete All button.

To create a new tab stop:

1) Set the size of the tab stop in the edit box on the left.

2) Select the type. If you set the type to Decimal, specify in the box below the character to be 
regarded as the decimal point.

3) Select a fill character which will be drawn from the tab insertion point up to the tab stop. 
You can choose any character to act as fill character.

4) Click the New button to apply the new tab stop.

This page is available in the Format > Paragraph dialog box and in the Graphics Styles dialog 
box.
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Figure 40: Tabs page for a paragraph

Asian Typography page
Use the Asian Typography page, shown in Figure 41, to set the following properties relative to line 
changes:

• Apply list of forbidden characters to the beginning and end of lines

• Allow hanging punctuation

• Apply spacing between Asian, Latin and Complex text

The use of these options is self-explanatory.

Figure 41: The Asian Typography page

Creating bulleted and numbered lists

The procedure to create a bulleted or numbered list varies depending on the type of text box used, 
although the tools to manage the list and customize the appearance are the same.

In text boxes created automatically by Impress (called AutoLayout), the outline styles available are 
by default bulleted lists, while for normal text boxes an additional step is required to create a 
bulleted list.
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Creating lists in AutoLayout text boxes
Every text box included in the available layouts is already formatted as a bulleted list, therefore to 
create a bulleted list the only necessary steps are:

1) From the Layout pane, choose a slide design that contains a text box. Those are easily 
recognizable from the thumbnail.

2) Click in the text box that reads Click to add an outline.

3) Type the text, then press Enter to start a new bulleted line.

The default list type is a bulleted list. To customize the list appearance or to change from bulleted 
to numbered and vice versa, refer to “Changing the appearance of the list ” on page 56.

Tip

Press Shift+Enter to start a new line without creating a new bullet or number. The 
new line will have the same indentation as the previous line. Click the bullets icon 
on/off on the text formatting toolbar for a line without bullet. If the text formatting 
toolbar is not showing, enable it by selecting View > Toolbar > Formatting in the 
menu bar.

Creating lists in other text boxes
To create a list in a text box, follow these steps:

1) Place the cursor in the text box.

2) Click the Bullets On/Off button  in the text formatting toolbar. 

3) Type the text and press Enter to start a new bulleted line.

The way to change the appearance of a list is explained on page 56.

Creating a new outline level
1) If necessary, press Enter to begin a new line.

2) Press Tab or click the indentation arrows in the Text Formatting toolbar.  Each time 
you press Tab or click the right arrow, the line indents to the next outline level. 
Pressing Enter creates a new line at the same level as the previous one. To return to the 
previous level, press Shift+Tab or click the left arrow.

In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a 
different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline 
3 style and so on. As a consequence, a change in the level also produces other changes (for 
example font size, bullet type, and so on).

Caution Do not try to change the outline level by selecting the text and then clicking the 
desired outline style as you would in Writer. Due to the way that presentation styles 
work, it is not possible to apply them in this way.

Changing the appearance of the list 
You can fully customize the appearance of a list, changing the bullet type or numbering for the 
entire list or for single entry. All the changes can be made using the Bullets and Numbering dialog 
box, which is accessed by selecting Format > Bullets and Numbering or by clicking on the 

Bullets and Numbering icon  on the text formatting toolbar.
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Selecting the entries
For the entire list:

1) Select the entire list or click on the gray border of the text box so that just the green 
resizing handles are displayed.

2) Select Format > Bullets and Numbering or click on the Bullets and Numbering icon 

.

3) The Bullets and Numbering dialog box (Figure 40) contains five tabs: Bullets, Numbering 
type, Graphics, Position, and Customize.

• If a bulleted list is needed, select the desired bullet style from the six default styles 
available on the Bullets page.

• If a graphics style is needed, select one from those available on the Graphics page.

• If a numbered list is needed, select one of the 6 default numbering styles on the 
Numbering type page.

Later in this section is an explanation on how to add further bullets and numbering styles to the 
existing ones.

For a single line in the list:

1) Click anywhere in the line to place the cursor in it.

2) Follow steps 2–4 of the previous instruction set.

If the list was created in an AutoLayout text box, then an alternative way to change the entire list is 
to modify the Outline styles. Changes made to the outline style will apply to all the slides using 
them, so be careful before using this command. The pages related to list management are 
described below.

Figure 42: The Bullets and Numbering dialog box
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Position page
Use the Position page, shown in Figure 39, to fine tune the indentation and spacing of the bullet 
point and its text. This page is particularly effective when used in combination with the Customize 
page.

To set up an outline level, first select it from the list on the left hand side of the page. Select level 1 
– 10 to modify all the levels simultaneously. Then set the Indent, which is the spacing between the 
bullet or number and the text. If you select the Relative option, the indent value will be measured 
relative to the previous level and not from the margin.

The numbering alignment is only useful when creating a numbered list; use it to specify the 
alignment of the numbers. For example, you may want to align them to the right to line up one- and 
two-digit numbers in a pleasing way.

Tip
To fully appreciate how the Numbering alignment works, try to create a numbered list 
with more than 10 elements and make sure that enough room has been made for a 
two (or more) digit number using the Width of numbering field.

The Position page is not available if you are modifying a presentation style or graphics style, 
however the same effects can be obtained by using the Indents and Spacing page of the dialog 
box for creating or modifying a slide (see Error: Reference source not found).

Figure 43: The Position page used to set list indentation

Customize page

Use the Customize page, shown in Figure 38, to alter the style of all the outline levels.

The options available on this page depend on the type of marker selected for the list. Select first 
the level you want to modify on the left hand side of the box. To modify all levels at once, select 1 – 
10 as the level. Because the levels are arranged in a hierarchical structure, changing for example 
the font attribute of one of the levels ripples through all the lower levels.
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Figure 44: The Customize page for the list outline

Depending on the numbering style selected in the Numbering box (bullet, graphic, numbering), 
some of the following options may become available on the page:

• Before: Enter any text to appear before the number (for example, Step).

• After: Enter any text to appear after the number (for example, a punctuation mark).

• Color: Pick the color for the list marker (number or bullet character).

• Relative size: Specify the size of the number relative to the size of the characters in the 
paragraph of the list.

• Start at: Enter the first value of the list (for example, you might want the list to start at 4 
instead of 1).

• Character button: Click this button to select the character for the bullet.

• Graphics selection button: Opens a gallery of available graphics or allows the selection 
of a file on the hard disk to be used as a marker. 

• Width and Height: Specify the dimensions of the graphic marker.

• Keep ratio checkbox: If selected, the ratio between the width and the height of the graphic 
marker is fixed.

The right hand side of the screen shows a preview of the modifications made. To revert to the 
default values, click the Reset button in the bottom right corner.

Using the Customize page, you can create complex structured layouts, for example a nested list 
with numbering followed by bullets, as in Figure 37.
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Figure 45: Nested list with mixture of numbers and bullets

Changing the order or the outline level lines
Click once in a line of text to place the cursor in it, then click on the Outline tab (to the right of the 
Normal tab) in the Workspace and use the Promote/Demote buttons in the Text Formatting toolbar 
to move the text to the appropriate position and give it the appropriate outline level.

 The button with the arrow pointing left promotes the list entry by one level (for 
example from Outline 3 to Outline 2), the right arrow button demotes the list entry by one level, the 
up and down arrow buttons move the list entry. Numbering adjusts automatically.

Tip
You can also use the Tab key and Shift + Tab keys to promote and demote the 
outline level of a line in a list.

Using tables

Tables are a powerful mechanism to convey structured information quickly, so they represent an 
important tool when creating a presentation. You can create tables directly in Impress; there is no 
need to embed a Calc spreadsheet or a Writer text table, although in some circumstances it makes 
sense to do so as the functionality provided by a Calc spreadsheet is far superior to that provided 
by an Impress table.

Many predefined table designs are available in the Table design section of the task pane.
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Figure 46: The Table Design task pane

Creating a table
When working with tables it is useful to know the number of rows and columns needed as well as 
the look and feel. The parameters can be adjusted later, but this is  more laborious than setting the 
correct table dimensions from the beginning. 

To insert a table, proceed as follows:

1) Position the slide which will contain the table in the work area. If necessary modify the slide 
layout in order to reserve the place for the table.

2) If the task pane is already open select Table Design. If the task pane is not visible, select 
View > Task pane, then select the Table Design task.

3) Select one of the predefined styles, which only differ in the color scheme. You will be able 
to change the table colors later on; however, it is recommended that you select a color 
scheme similar to the one you want. Selecting a style opens the dialog box of Figure 36 
where you can specify the number of rows and columns.

Chapter 3  Adding and Formatting Text 61



Figure 47: Insert Table dialog box

The table is placed initially at the center of the slide, but you can move it by selecting it and then 
dragging it to the new position, or by using the method described in “Position and size” on page 65.

You can also create a table directly by selecting Insert > Table from the main menu or with the 
Insert Table button in the Standard toolbar. When using this method, the default style and settings 
are applied to the newly created table. The use of the Insert Table button is described more in 
detail later in this section.

Modifying a table
Once the table is added to the slide, you can control its appearance, size, position and so on using 
a combination of the task pane options, the Table toolbar and the Table properties dialog box.

Task pane options
The following options are available in the Show section of the task pane:

• Header Row: selected by default, it adds a first row with a different background from the 
rest of the table.

• Total Row: the opposite of Header row; if selected, it changes the background of the last 
row to make it stand out from the other rows.

• Banded Rows: selected by default, this option colors alternate rows with different 
backgrounds making it easier to ready data presented in rows.

• First Column: highlights the first column of the table by allocating a darker background to it.

• Last Column: does the same to the last column.

• Banded Columns: when selected, alternate columns are colored differently.

Table toolbar
When a table is selected, 8 blue square handles appear around the edges and the Table toolbar 
should be displayed. If necessary, you can open the toolbar using View > Toolbars > Table. By 
default the toolbar will float, but you can dock it at any time to the side or top edge of the work 
area.
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1 Create Table 7 Merge Cells 13 Insert Row

2 Line Style 8 Split Cells 14 Insert Column

3 Line Color (border) 9 Optimize 15 Delete Row

4 Borders 10 Top alignment 16 Delete Column

5 Area style 11 Center alignment 17 Table Design

6 Fillings 12 Bottom alignment 18 Table Properties

Figure 48: The Table Toolbar

The Table toolbar contains the majority of the tools you need to manipulate a table; these are 
described below.

Table
Use to create a new table on the selected slide. Opens the Insert Table dialog box where you 
can select the desired number of rows and columns. Click on the small black triangle next to 
the button to open the graphic tool for inserting a table. To use the tool, move the mouse to the 
right and down in the grid until you reach the cell you want to be the last and click there.

Figure 49: Creating a 5x4 
table with the graphic tool

Note
Any newly inserted table is given a set of default attributes such as color scheme, 
banded rows, header row and so on. Currently such defaults are hard coded in 
LibreOffice and cannot be changed.

Line Style
Use to change the style of the line of the selected cells. Opens a new dialog box where you 
can choose from a range of predefined styles.

Line Color
Open a color selection dialog box where you can choose the color of the lines around the 
selected cells.
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Borders
Use to select among some predefined border configurations. The borders are applied to the 
selected cells. If the desired border pattern is not available, you will need to use the Table 
properties dialog box.

Area filling
In the drop-down menu, first choose how the selected cells should be filled: Invisible, Color, 
Gradient, Hatching, or Bitmap. Depending on the selection, the Available Fillings drop-down 
menu is populated with the available schemes. Refer to Chapter 6 (Formatting Graphic 
Objects) for details on how to manage area filling styles.

Merge cells
Merges the selected cells. Note that the contents of the merged cells are also merged.

Split cells
The opposite operation of Merge cells. Make sure that the cursor is positioned on the cell you 
want to split, then click to open the Split Cells dialog box.

Figure 50: Split cell dialog box

Select the number of resulting cells from the split as well as whether the cell should be split 
horizontally or vertically. When splitting horizontally, you can select the “into equal proportions” 
option to get all cells of equal size. The contents of the split cell are kept in the original cell (the 
one on the left or the top).

Optimize
Evenly distributes the selected cells either horizontally or vertically.  If you want to optimize the 
whole table, you can evenly distribute rows or columns by right-clicking on the table edge and 
selecting  Row > Space Equally or Column > Space Equally from the pop-up menu.

Vertical Alignment
You can select the vertical alignment of the text on a cell by cell basis between Top, Center and 
Bottom. The chosen setting only applies to the selected cells. The alignment commands can be 
applied to all the cells of the table by right-clicking on the edge of the table, choosing Cell from 
the pop-up menu, and then choosing the required alignment.

Insert or delete rows and columns
Use the Table toolbar to insert or delete rows and columns of your table. Rows and columns 
are inserted below and to the right of the selected cell. You can insert rows and columns at the 
end of the table using the pop up menu that opens by right clicking on the edge of the table. 
The insert commands are under the Row or under the Column menu.

Table Design
The only purpose of this button is to open the Table Design pane in the task pane.
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Table properties
Click the Table Properties icon to open the Format Cells dialog box, which contains the following 
pages:

• Font: see “Font page” on page 50 for a description of the available options.

• Font Effects: see “Font Effects page” on page 51 for a description of the available options.

Figure 51: The Format Cells dialog box showing the Borders page

• Borders: here you can set advanced properties not available from the Table Toolbar, such 
as the spacing between the text and the border as well as setting the style of each 
individual border of the table separately. This page also provides the same options as the 
line style and line color buttons of the Table Toolbar.

Note It is currently not possible to define diagonal borders for Impress tables.

• Background: changes the background of the selected cells and provides the same 
functionality as the Area Style Filling and Available Filling drop down menus of the Table 
Toolbar.

Note
The Table Properties dialog box can also be accessed from the pop-up menu that 
opens when right-clicking on the table.

Position and size
Impress treats tables just like any other graphic object; it is therefore possible to change their 
position on the slide as well as their size by using the mouse or, for more accurate control, with the 
Position and size dialog box. You can open the dialog box by pressing F4 when the table is 
selected or by right-clicking on the table and then selecting Position and Size from the pop-up 
menu. The functions provided in this dialog are described in Chapter 6 (Formatting Graphic 
Objects).

Note Unlike other graphic objects, tables cannot be rotated.
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Deleting a table
To delete a table, select it and then press the Delete key on the keyboard.

Using fields

Fields allow the automatic insertion of text  into the slide. You can think of a field as a kind of 
formula which is calculated when the document is loaded or printed, and the result is written to the 
document.  Fields are commonly used when creating templates and slide masters, as explained in 
Chapter 2. Examples of fields include: date/time, slide number, file name and author.

Inserting a field
To insert a field into a slide, move the cursor where the field will be and then select from the menu 
bar Insert > Fields followed by one of these choices:

• Date (fixed): inserts the date at the time of inserting the field.

• Date (variable): The field is updated to contain the date at the time of opening the file.

• Time (fixed): a field displaying the time of insertion.

• Time (Variable): a field which is updated to the time of opening the file.

• Author: The author of the presentation. This information is derived from the value recorded 
in the general options. To modify this information go to Tools > Options > LibreOffice 
section then select User Data.

• Page number: inserts the page number of the slide.

• Page Count: inserts the total number of the slides.

• File name: a field with the name of the file.

By default, fields are displayed with a gray background when you are in edit mode. To remove the 
shading, go to View in the menu bar and deselect Field Shading; alternatively, press Control+F8.

Customizing fields
The appearance of all the fields, excluding the page number field, can be customized from the 
corresponding field editor. To access the field editor (Figure 34):

1) Move the cursor to the field and select it.

2) Select Edit > Fields from the menu bar.

3) Select the desired format in the dialog box that appears.

4) Click OK when satisfied.

Tip
A similar list of format choices can be accessed by selecting the field and 
right-clicking.

Modifications to the page number fields can be done in two ways:

• Select the field and apply the formatting manually.

• Switch to the slide master editing mode (View > Master > Slide Master), then modify the 
Background object style as desired. Once back in Normal view, insert the page numbers 
from the Insert > Page Number box. See Chapter 2 for more information about editing a 
slide master.
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Figure 52: Setting the Time format for a time field

Using hyperlinks

When inserting text (such as a website address or URL) that can be used as a hyperlink, Impress 
formats it automatically, creating the hyperlink and applying a color and underlining. If you do not 
want Impress to do that, select Edit > Undo Insert from the menu bar or press Control+Z 
immediately after the formatting has been applied.

You can also insert hyperlinks manually.

Tips

To prevent LibreOffice from automatically turning website addresses (URLs) into 
hyperlinks, go to Tools > AutoCorrect > Options and deselect the URL Recognition 
checkbox.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > 
Appearance, scroll to Unvisited links and/or Visited links, select the checkboxes, 
pick the new colors and click OK. Caution: this will change the color for all hyperlinks 
in all components of LibreOffice—this may not be what you want.

To insert a hyperlink, or to customize the appearance of a hyperlink, select Insert > Hyperlinks 
from the menu bar. The dialog box shown in Figure 30 opens.

On the left hand side, select one of the four types of hyperlinks:

• Internet: a web address, normally starting with http://

• Mail & News: for example an email address.

• Document: the hyperlink points to another document or to another place, commonly 
referred to as a bookmark, in the presentation.

• New document: the hyperlink creates a new document. 
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Figure 53: Dialog box to edit hyperlinks

The top right part of the dialog box changes according to the choice made for the hyperlink type. A 
full description of all the choices, and their interactions, is beyond the scope of this chapter. Here is 
a summary of the most common choices used in presentations:

• For an Internet type hyperlink, choose the type of hyperlink (choose between Web, FTP or 
Telnet), and enter the required web address (URL). 

• For a Mail and News type hyperlink, specify whether it is a mail or news link, the receiver 
address and for email, also the subject.

• For a Document type hyperlink, specify the document path (the Open File button opens a 
file browser); leave this blank if you want to link to a target in the same presentation. 
Optionally, you can specify the target in the document (for example a specific slide). Click 
on the Target icon to open the Navigator where you can select the target, or if you know 
the name of the target, you can type it into the box.

Note 
For navigation within a presentation it is generally better to use the object interaction 
menu that you can find either in the Drawing toolbar or in the pop-up menu that opens 
when right-clicking on an object.

• For a New Document type hyperlink, specify whether to edit the newly created document 
immediately or just create it (Edit later) and the type of document to create (text, 
spreadsheet, etc.). For a presentation, Edit now is the more likely choice. The Select path 
button opens a directory picker.

The Further settings section in the bottom right part of the dialog box is common to all the hyperlink 
types, although some choices are more relevant to some types of links.

• Set the value of Frame to determine how the hyperlink will open. This applies to documents 
that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button. See “Working with
hyperlink buttons” for more information.

• Text specifies the text that will be visible to the user.

• Name is applicable to HTML documents. It specifies text that will be added as a NAME 
attribute in the HTML code behind the hyperlink.

• Event button: this button will be activated to allow LibreOffice to react to events for which 
the user has written some code (macro). This function is not normally needed in Impress.
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Editing text hyperlinks
To edit a text hyperlink, select it (by dragging across the text, not clicking on it), then choose Edit > 
Hyperlink from the main menu bar. Make changes as needed and click Apply when done. If you 
need to edit several hyperlinks, you can leave the Hyperlink dialog box open until you have edited 
all of them. Be sure to click Apply after each one. When you are finished, click Close.

Working with hyperlink buttons
A hyperlink button is inserted in the center of the current slide. In most cases, that is not 
where you want it to appear. To edit the text or size of a hyperlink button, or to move it 
to another place on the slide, first display the Form Controls toolbar (View > Toolbars > 
Form Controls). Select the Design Mode On/Off icon (upper right corner of the 
toolbar).

Now you can click on the button and drag it to another position, or right-click to open a 
dialog box where you can change the text on the button, the size of the button, and 
other properties.

When you have finished editing the button, click the Design Mode On/Off icon again to 
make the button active again. For a detailed description of the button properties and on 
how to work with Form Controls refer to the Writer Guide.
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Introduction

Pictures are often used in presentations as they can convey a large amount of information more 
quickly than the written word. They can also give the presentation a professional look by adding a 
company logo. You may also want to use Impress to create a presentation consisting only of 
pictures, such as a slideshow of holiday snapshots to share with friends.

This chapter describes how to insert and format pictures.

Inserting pictures

This section describes several ways to insert a picture from an external source into the 
presentation. Once the picture has been inserted, it can be formatted extensively as explained later 
in this chapter.

Inserting a picture from a file
Inserting a picture from a file is quick and easy. First choose the slide layout, as described in 
Chapter 1, Introducing Impress. Most layouts include an set of icons for inserting objects, but you 
can insert a picture into any slide.

Figure 54: Slide with a placeholder for inserting objects

Whether you are using an AutoLayout for the placement of the picture, or you are just inserting a 
picture, follow these steps:

1) Click on the Insert Picture icon or choose Insert > Picture > From file from the menu bar.

2) In the Insert picture dialog box, navigate to the directory containing the desired picture.

3) Select the file. LibreOffice recognizes a large number of image types. If the Preview option 
(in the lower left-hand area) is selected, a thumbnail of the selected file will be displayed in 
the preview pane on the right (not shown below).

4) Click Open to place the picture on the current (selected) slide. The picture is now displayed 
on the slide with green resizing handles around it.
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Figure 55: Inserting a picture from a file

Notice in the Insert picture dialog box the two options Link and Preview. Their position is 
determined by the operating system, but they are normally in the bottom-left part of the dialog box.

Select the Link option to insert the picture as a link to the file rather than embedding the file itself. 
In general it is preferable to embed images so that the presentation can be copied to other 
computers; however, on some occasions it makes sense to link the image rather than embed it. 
These include:

• When the image file is quite large (linking rather than embedding will dramatically reduce 
the size of the presentation file)

• When the same image file is used in many presentations (for example when using the 
same background image for all the presentations created)

• When the linked file will be available when loading the presentation (for example if the 
presentation is a slide show of holiday pictures)

Inserting a picture from a scanner
Inserting an image from a scanner is normally fairly straightforward. Make sure that the scanner is 
supported by the SANE system if you are running the Linux (or other UNIX-like) operating system, 
or TWAIN if you are using a Windows version, and that it is already configured on the machine on 
which LibreOffice is running. In case more than one scanner or equivalent devices are present, 
select the source from Insert > Picture > Scan > Select Source.

To insert an image from the scanner:

1) Prepare the image in the scanner and make sure that the scanner is ready.

2) Choose Insert > Picture > Scan > Request.

3) The rest of the procedure depends on the scanner driver and interface. You will normally be 
required to specify the resolution, a scan window and other parameters. Consult the 
scanner’s documentation for more information.

4) When the image is ready, Impress places it in the slide. At this point it can be edited as any 
other image.
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Inserting a picture from the Gallery
The Gallery contains a collection of images that you can use in a presentation. You can also add 
your own images to the Gallery, making it an essential tool for creating presentations quickly and 
with a consistent look. The Gallery is available in all components of LibreOffice. For an introduction 
to the Gallery, see Chapter 11, Graphics, the Gallery, and Fontwork, in the Getting Started guide.

Choose Tools > Gallery or click the Gallery icon  on the Drawing toolbar.

The Gallery displays categories of themes with images stored under each category. Select a theme 
from the left pane and then scroll as necessary through the right pane to find a suitable image. 
Click on the image and drag it onto the workspace. Figure 54 shows an example.

Figure 56. Inserting an image from the Gallery

At this point the image will be in your slide, but may not be of a satisfactory size; if necessary, 
resize it as described in “Resizing a picture” on page 76.

Positioning the Gallery
To expand the Gallery, position the pointer over the line that divides it from the top of the 
workspace. When the pointer changes to parallel lines with arrows, click and drag downward. The 
workspace will resize in response.

By default, the Gallery is docked above the Impress workspace. To undock it , hold down the 
Control key and double-click on the upper part of the Gallery next to the View icons. Double-click in 
the same area to dock it again (restore it to its position over the workspace).

When the Gallery is docked, to hide it and view the full Impress workspace, click the Hide/Show 
button in the middle of the thin bar separating the Gallery from the workspace (see Figure 57). The 
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Hide/Show button lets you keep the Gallery open for quick access while you create your slide 
show, yet out of the way when you need it to be.

Figure 57: The Gallery with the Hide/Show selector circled

Managing the Gallery themes

Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and 3D Effects. The box 
on the left of the gallery window lists the available themes. Click on a theme to see its graphics 
displayed in the Gallery window.

The default themes are locked; no items can be added or deleted from these themes. The locked 
themes are easily recognizable by right-clicking on them; the only available option in the pop-up 
menu is Properties.

In a default installation, only the My themes theme is customizable: you can add your own graphics 
to this gallery or add new themes as explained on page 75.

Adding images to the Gallery
You can add new images to themes which you created, or to themes like My themes that can be 
edited:

1) Right-click on the theme name in the list of themes and choose Properties from the pop-up 
menu.

2) Click the Files tab, if necessary.

3) Click Add.

4) Select a file and click Open. The image is added to the theme.

Deleting images from the Gallery
To delete an image from a theme:

1) Right-click on the image in the Gallery window.

2) Choose Delete from the pop-up menu. A message appears, asking if you want to delete 
this object.

3) Click Yes.

Note The image is deleted from the Gallery only. The original image file is not deleted.

All the images in a gallery are actually linked files. From time to time it is beneficial to update the 
gallery theme to make sure that all the files are still there. To do so, right-click on the theme where 
you added at least one file and then select Update from the pop-up menu.
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Adding a new theme to the Gallery
1) Click the New Theme button above the list of themes.

2) Click the General tab and type a name for the new theme.

3) Click the Files tab (Figure 58).

4) Click Find Files. The Select Path dialog box opens. Navigate to the folder that contains the 
image files for the new theme and click Select.

5) Back on the Files tab, either click on Add All to install all of the files in the selected folder, 
or use File Type and/or select one or more files from the displayed list, and click on Add to 
install a selection of files to the new theme.

6) Click OK when finished.

7) The new theme will now be displayed on the list of themes in the Gallery, under the name 
New Theme. You will have to rename it manually by right-clicking the theme name and 
selecting Rename.

Figure 58. Setting up a new theme in the Gallery  

Formatting pictures

This section discusses the formatting of pictures inserted with one of the methods explained in 
“Inserting pictures” on page 71.

Moving a picture
1) Click the picture, if necessary, to show the green resizing handles.

2) Move the pointer over the picture until the pointer changes shape. On most operating 
systems, the cursor associated with moving objects is a four headed arrow, but it may also 
be a hand or some other symbol.

3) Click and drag the picture to the desired position.

4) Release the mouse button.

For a more accurate placement of the picture, use the Position and Size dialog box described in 
Chapter 6, Formatting Graphic Objects.
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Resizing a picture
1) Click the picture to show the green resizing handles.

2) Position the pointer over one of the green resizing handles. The pointer changes shape 
giving a graphical representation of the direction of the resizing.

3) Click and drag to resize the picture.

4) Release the mouse button when satisfied with the new size.

The corner handles resize both the width and the height of the graphic object simultaneously, while 
the other four handles only resize one dimension at a time.

Tip
To retain the original proportions of the graphic, Shift+click one of the corner handles, 
then drag. Be sure to release the mouse button before releasing the Shift key.

For more accurate resizing of the graphic object, use the Position and Size dialog box described in 
Chapter 6, Formatting Graphic Objects.

Caution
Be aware that re-sizing a bit-mapped (raster) image will adversely affect the 
resolution, causing some degree of blurring. It is better to use a specialized graphics 
manipulation program to correctly scale the picture to the desired size before inserting 
it into your presentation. We recommend you use a tool such as Gimp 
(http://www.gimp.org/).

Rotating a picture
As with the position of the image on the page, rotation of a picture can be done manually or using a 
dedicated dialog box. The Rotation dialog box is described in Chapter 6, Formatting Graphic 
Objects. To rotate a picture manually, do as follows:

1) Select the picture if necessary so that the green handles around it show.

Figure 59: Shape showing the red rotating handles

2) Click the Rotate button  on the Drawing toolbar. This toolbar is usually located at the 
bottom the screen, but it can be undocked and used as a floating toolbar. If the toolbar is 
not showing, select View > Toolbars > Drawing. The Drawing toolbar is discussed in detail 
in Chapter 5, Managing Graphic Objects.

At this stage a black crosshair with a circle appears in the middle of the picture: this 
represents the pivot point for the rotation. Normally the center of the picture will be just fine, 
but on some occasions you may wish to rotate around a corner or even around a point 
outside the picture; to do this, click on the crosshair and drag it to the desired position 
before applying the rotation, as shown in Figure 59.
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Note

The icons representing the functions in the toolbars are different, depending on the 
operating system used and on whether LibreOffice has been customized for the 
Linux distribution in use or not. When in doubt, hover the mouse over the icons and 
wait for the tooltip to appear showing the name of the button.

3) Eight red circular handles replace the green square handles, as shown in Figure 59. Move 
the mouse over one of the corner handles and the mouse cursor shape will change. Click 
the mouse and move in the direction in which you want to rotate the picture.

4) When satisfied, release the mouse button.

To restrict the rotation angles to multiples of 15 degrees, press the Shift key while rotating the 
graphic. This is very handy to rotate pictures of right angles, for example from portrait to landscape 
or vice versa.

Formatting using the Picture toolbar
When a picture is selected, the Picture toolbar becomes available. This toolbar provides a number 
of formatting options which are described in this section. If the picture toolbar does not appear 
when an image is selected, display it by selecting View > Toolbars > Picture from the menu bar.

Figure 60: The Picture toolbar

Applying filters

Use the  icon on the toolbar to apply various filters to the 
selected picture. The best way to judge if a filter works for your picture 
is to try it. To apply a filter:

1) Select the image so that the green handles around it are 
displayed.

2) Click on the  icon in the Picture toolbar. The toolbar will 
expand to show the icons in Figure 60.

3) Select the filter you wish to apply. To show the name of the 
filter, hover the mouse pointer over the icon and wait for the 
tooltip to appear.

If you are not satisfied with the effect obtained or you want to try a different one, before doing 
anything else click the Undo button or select Edit > Undo: Bitmap Graphic Filter from the menu 
bar or press Control+Z.

Table 1 describes briefly each of the available graphic filters and their effects. See the Draw Guide 
for examples of the effects.

Table 1: Graphic filters and their effects

Icon Name Effect

Invert Inverts the color values of a color image, or the brightness values of 
a grayscale image.

Smooth Softens the contrast of an image.
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Icon Name Effect

Sharpen Increases the contrast of an image.

Remove noise Removes single pixels from an image.

Solarization Mimics the effects of too much light in a picture. A further dialog box 
opens to adjust the parameters.

Aging Simulates the effects of time on a picture. Can be applied several 
times. A further dialog box will open to adjust the aging level.

Posterize Makes a picture appear like a painting by reducing the number of 
colors used.

Pop Art Modifies the picture dramatically.

Charcoal Displays the image as a charcoal sketch.

Relief A dialog box is displayed to adjust the light source that in turn will 
create the shadow and hence the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Changing the graphics mode

Use the graphics mode drop-down list  in the Picture toolbar to change the mode 
of the image. Choose between:

• Default: no changes to the graphic object.

• Grayscale: the image is converted to scales of gray.

• Black/White: each pixel of the image is converted to black or white depending on the 
brightness value.

• Watermark: adjusts the brightness of the image making it suitable to be used as a 
watermark. For more information on inserting watermarks in the presentation, refer to 
Chapter 2, Slide Masters.

Adjusting the color

Clicking the color adjustment button  on the Picture toolbar opens 
the color adjustment dialog box.

Use this dialog box to modify the individual color components of the 
image (red, green, blue) as well as the brightness, contrast, and 
gamma of the image. If the result is not satisfactory, press Control+Z 
to restore the default values.

Increasing the gamma value of a picture makes it more suitable to be 
used as a background or watermark as it will interfere less with a dark 
text.
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Setting the object transparency

Modify the percentage value in the Transparency box  on the Picture toolbar to make 
the image more transparent. Note that this is different from the transparency settings for a line or a 
shape (described in Chapter 5). As with the gamma value, increasing the transparency of a picture 
makes the picture blend more smoothly in the background, making the overlay text easier to read.

Adjusting the line, area and shadow settings
These settings are not very commonly used for images, with the exception of the shadow setting, 
which applies a shadow to the image.

Cropping pictures
Impress provides two ways to crop a picture: interactively or using a dialog box. The interactive 
method is easier to use, but the dialog box provides more precise control. You can use both 
methods: first cropping interactively, then using the dialog box to fine tune the result.

To crop a selected picture interactively, click the Crop icon  on the Picture toolbar (Figure 60). 
A set of crop marks appears around the picture.

Figure 63: Interactive crop marks 

When you place the cursor over any of the crop marks, the cursor changes shape. Drag the mark 
to crop the picture. Click outside the picture to deactivate cropping mode.

Press the Shift button while working on the crop marks to produce the following effects:

• For a corner mark, the two sides of the picture forming the corner are cropped 
proportionally with the picture anchored to the opposite corner mark.

• For a side mark, both dimensions are changed proportionally with the image anchored to 
the opposite side mark. 

The interactive crop mode operates in Keep Scale mode (see below).

To crop using the dialog box, right-click a selected picture and choose Crop Picture (or choose 
Format > Crop Picture from the menu bar).

The Crop dialog box (Error: Reference source not found) has the following options:

• Keep scale / Keep image size buttons: when Keep scale is selected (default), cropping 
the image does not alter the scale of the picture. When Keep image size is selected, 
cropping produces enlargement (for positive cropping values), shrinking (for negative 
cropping values), or distortion of the image so that the image size remains constant.

• Left, Right, Top, and Bottom: the function of these boxes changes according to the choice 
made between Keep scale and Keep image size. In both cases, when a value is entered in 
one of these boxes, the image is cropped by that amount. For example, a value of 3cm in 
the Left box will cut 3cm from the left side of the picture.

When Keep scale is selected, the size of the image also changes, so in this example the 
width will be reduced by 3 cm. If Keep image size is selected instead, the remaining part of 
the image is enlarged (positive values for cropping) or shrunk (negative values for 
cropping) so that the width and height of the image remains unchanged.
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Figure 64: The options available when cropping a picture

Note that the Width and Height fields change as you enter the values when in this mode. 
Use the thumbnail next to these fields to determine the correct amount by which to crop.

• Scale Width and Height: specify in percentages the scaling of the picture. The size of the 
image changes accordingly.

• Image size: specify the size of the image in your preferred unit of measurement. The 
image enlarges or shrinks accordingly.

• Original size: when clicked, restores the original image size.

Deleting a picture
1) Click on the picture, if necessary, to show the green resizing handles.

2) Press Delete.

Creating an image map

An image map defines areas of the image (called hotspots) associated with a URL (a web address 
or a file on the computer). Hotspots are the graphic equivalent of text hyperlinks. Clicking on a 
hotspot causes Impress to open the linked page in the appropriate program (for example, the 
default browser for an HTML page; LibreOffice Writer for a .ODT file; a PDF viewer for a PDF file). 
You can create hotspots of various shapes, and include several hotspots in the same image.

To use the image map tool:

1) Select the picture where the hotspots will be defined.

2) Choose Edit > ImageMap from the menu bar. The ImageMap Editor dialog box opens. The 
main part of the dialog box shows the image on which the hotspots will be defined. On this 
image an active hotspot is indicated by a white shading, while an inactive hotspot is 
identified by a red border but no shading.

3) Use the tools and fields in the dialog box to define the hotspots and links necessary.

4) Click the Apply icon  to apply the settings.

5) When done, click the Save icon  to save the imagemap to a file, then click the X in the 
upper right corner to close the dialog box.
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Figure 65: The dialog box to create or edit an image map

The top part of the dialog box contains the following tools:

• Apply button: click this button to apply the changes.

• Load, Save, and Select icons.

• Tools for drawing a hotspot shape: these tools work in exactly the same way as the 
corresponding tools in the Drawing toolbar (described in Chapter 5).

• Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a 
polygon hotspot. Select the Edit Points tool to activate the other tools.

• Active icon: toggles the status of the hotspot activating a   selected hotspot or deactivating 
it if active.

• Macro: associates a macro with the hotspot instead of a hyperlink.

• Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar, specify for the selected hotspot:

• Address: the address pointed by the hyperlink. You can also point to an anchor in a 
document such as a specific slide number; to do this, write the address in this format: 
file:///<path>/document_name#anchor_name

• Text: enter the text that will be displayed when the mouse is moved over the hotspot.

• Frame: where the target of the hyperlink will open: pick among _blank (opens in a new 
browser window), _self (opens in the active browser window), _top or _parent.

Tip
The value _self for the target frame will work just fine in the vast majority of the 
occasions. It is therefore not recommended to use the other values unless absolutely 
necessary.
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Introduction

This chapter describes how to manage graphic objects and in particular how to rotate, distort, 
arrange, and position them on the slide. Though this chapter focuses on the shapes that can be 
created with the available tools in Impress, some of the techniques described in this chapter are 
also applicable to images imported into slides.

The Drawing toolbar contains the majority of the tools normally used to create graphic objects. If 
this toolbar is not visible, select View > Toolbars > Drawing from the main menu bar.

The toolbar can be divided into two parts. The first part contains drawing objects, as shown in 
Figure 66. The second part of the toolbar, shown in Figure 68 on page 85, contains more generic 
tools.

1 Select 5 Ellipse 9 Connector 12 Basic shapes 16 Callouts

2 Line 6 Text 10 Lines and 
Arrows

13 Symbol shapes 17 Stars

3 Arrow 7 Vertical text 14 Block arrows

4 Rectangle 8 Curve 11 3D Objects 15 Flowcharts

Figure 66: First section of Drawing toolbar

The tools in the first part of the Drawing toolbar are as follows. If you do not see a tool, go to the 
arrow at the end of the toolbar (shown in Figure 68), choose Visible Buttons, and then select the 
missing tools.

1) Select: selects objects. To select a group of objects, click on the top left object and, drag 
the mouse to the bottom right object of the intended selection while keeping the mouse 
button pressed. A “marching ants” rectangle identifying the selection area is displayed. It is 
also possible to select several objects by pressing the Shift button while selecting the 
individual objects.

2) Line: draws a straight line from the point where you click the mouse, to the point where you 
drag the mouse pointer and release the mouse button. Press the Shift key to restrict the 
angle of the line to multiples of 30°; use  the Control  key to detach the end point of the line 
from the grid (see “Snapping objects to grid or snap guides“ on page 93).

3) Arrow: draws a straight line ending with an arrowhead. The arrowhead is placed where you 
release the mouse button. The Shift and Control keys have the same effect as for the Line 
tool.

4) Rectangle: draws a rectangle when you drag the mouse from the top left to the bottom 
right corner. Press the Shift button to draw a square.

5) Ellipse: draws an ellipse. Press the Shift button to draw a circle.

6) Text: creates a text box with text aligned horizontally.

7) Vertical text: creates a text box with text aligned vertically. This tool is available only when 
Asian language support has been enabled in Tools > Options > Language Settings > 
Languages.

8) Curve: draws a curve. Click the black triangle for more options 
(shown at right), including polygons. Note that the title of the submenu 
when undocked is Lines.
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9) Connector: draws a connector line between two figures. Click the black 
triangle for additional connectors. Their use is described in “Working
with connectors“ on page 95.

10) Lines and Arrows: draws a line ended in an arrow. Click the black 
triangle for additional choices. When torn off, this toolbar is titled 
Arrows.

11) —17) Basic Shapes, Symbol Shapes, Block Arrows, Flowcharts, Callouts, Stars: click 
the black triangle to open a toolbar showing the available shapes in that category. The 
default shapes are shown in Figure 67. Select the desired shape, then draw  it by dragging 
the mouse to define an enclosing rectangle. Keep the Shift key pressed to obtain a shape 
where the height and width are equal.

Figure 67: Available shapes for Impress
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1 Edit Points 4 From File 7 Alignment 10 Interaction

2 Glue Points 5 Gallery 8 Arrange 11 Visible buttons

3 Fontwork 6 Rotate 9 Extrusion On/Off

Figure 68: The second section of the drawing toolbar with utility tools

The tools in the second part of the Drawing toolbar are:

1) Edit points: to edit the individual points that form the shape or line, select this tool, and 
then select a shape or a line.

2) Glue points: to edit the glue points of a graphic object, select this tool. Glue points are the 
positions where connector lines terminate or start. See “Managing glue points” on page 95 
for instructions.

3) Fontwork: opens the Fontwork gallery. See “Using Fontwork” on page 101 for further 
information.

4) From file: equivalent to Insert > Picture > From file on the main menu. See Chapter 4 for 
details.

5) Gallery: opens the gallery. Equivalent to Tools > Gallery on the main menu. See Chapter 
4 for details.

6) Rotate: select this tool to rotate an object. As rotation is considered a formatting attribute; 
this is discussed in Chapter 6 of this book.

7) Align object: see “Aligning shapes“ on page 93.

8) Arrange object: see “Arranging shapes“ on page 94.

9) Extrusion On/Off: switches 3D effects on or off for the selected object. Clicking this button 
also opens the 3D settings toolbar. See “Working with 3D shapes” on page 96 for details.

10) Interaction: opens a dialog box where you can specify the interaction between the user 
and the object. See “Setting up interaction with a shape” on page 98.

11) Visible buttons: use the black triangle on the far right of the toolbar to open a menu from 
which you can add or subtract buttons on the toolbar. See Chapter 1, Introducing Impress, 
for more information.

Creating lines and shapes

To create shapes and lines:

1) Select the desired line or shape tool.

2) Click and drag to create the object on the slide.

When drawing a freehand polygon (that is, when you create a 
shape segment by segment from one of the tools on the 
Curves toolbar, shown on page 83), keep the Shift key 
pressed to restrict the angle between the segments to 
multiples of 45 degrees. To finish drawing a polygon, double-
click on the last part of the segment. If a closed polygon was 
selected, Impress draws the line connecting the last point to 
the start point and fills the inside area with the default color.
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When drawing certain shapes, one or more yellow dots are displayed along with the green resizing 
handles. These dots perform a different function according to the shape they are applied to. With 
the basic shapes the yellow dot (or dots) is used for the following purposes:

• Rounded rectangle and Rounded square shapes: use the yellow dot to change the size of 
the curve replacing the corners.

• Circle Pie: use the two yellow dots to change the size of the filled sector.

• Isosceles triangle: move the yellow dot on one vertex to modify the triangle type.

• Trapezoid, Parallelogram, or Octagon: move the yellow dot to change the angle between 
the sides.

• Cross: use the yellow dot to change the thickness of the four sides.

• Ring: use the yellow dot to change the internal diameter.

• Block arc: use the yellow dot to change both the internal diameter and the size of the filled 
area.

• Cylinder and Cube: use the yellow dot to change the perspective.

• Folded corner: use the yellow dot to change the size of the corner.

• Frame: use the yellow dot to change the internal rectangle diagonal.

Grouping shapes together

It is often convenient to group shapes together so that they are treated as a single shape by 
Impress. A group of shapes can be formatted as if it was a single shape, moved, rotated, deleted 
and so on. To group shapes together, do as follows:

1) Select the shapes to be grouped. To do this, use the selection tool on the drawing toolbar 
and draw a rectangle around the shapes to be grouped, or click on each shape to be added 
to the group while pressing the Shift key.

2) When the green resizing handles show, select Format > Group > Group or press 
Control+Shift+G on the keyboard or right-click within the group and select Group.

Once the group is defined, click on any of the shapes in the group to select the group. To edit only 
the shapes in the group, press F3 when the group is selected or select Format > Group > Enter 
Group from the menu bar or right-click and select Enter Group. Notice that any shapes not part of 
the group are grayed out and that only the shapes belonging to the group can be edited. Use this 
function when you need to apply a particular format to a single member of the group. To exit from 
group mode, press Control+F3 or select Format > Group > Exit group from the menu bar or right-
click and choose Exit Group.

For more about working with grouped objects, see Chapter 5, Combining Multiple Objects, in the 
Draw Guide.

To ungroup objects:

1) Select the group of shapes.

2) When the green resizing handles show, select Format > Group > Ungroup from the menu 
bar or press Control+Alt+Shift+G or right-click and choose Ungroup.

Tip

If you use the group and ungroup commands often, why not add them to one of the 
toolbars shown by default so that the commands are readily available? To do so, you 
will need to customize the selected toolbar. See Chapter 11, Setting Up and 
Customizing Impress.
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Moving graphic objects

1) Click the graphic object, if necessary, to show the green resizing handles.

2) Move the pointer over the graphic object until the pointer changes shape. On most 
operating systems, the pointer associated with moving objects is a four-headed arrow, but it 
may also be a hand or some other symbol.

3) Click and drag the graphic object to the desired position (you can also use the arrow keys).

4) Release the mouse button.

Tip

By default Impress makes the objects snap to the grid. If you need to position the 
object between two points of the grid, hold down the Control key, then click on the 
object and move it to the desired position.

Alternatively, you can modify the grid resolution from Tools > Options > LibreOffice 
Impress > Grid.

For a more accurate placement of the graphic object, use the Position and Size dialog box shown 
in Figure 70. First select the graphic object by clicking on it; when the resizing green handles are 
displayed, either press F4 or select Format > Position and Size from the menu bar.

Figure 70: Fine adjustment of position and size of the graphic object

Use the Position section of the dialog box to specify the X (horizontal) and Y (vertical) position of 
the graphic object. The values represent the distance of the base point (selected  on the right hand 
side of the dialog box) relative to the top left corner of the slide.

To prevent accidental modification of the position of the graphic object, select the Position option 
in the Protect section (bottom left) of the dialog box.

The unit of measurement for this and the other dialog boxes in this section is set in Tools > 
Options > LibreOffice Impress > General.
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Resizing graphic objects

1) Click the graphic object to show the green resizing handles.

2) Position the pointer over one of the green resizing handles. The pointer changes shape, 
giving a graphical representation of the direction of the resizing.

3) Click and drag to resize the graphic object.

4) Release the mouse button to complete resizing.

The corner handles resize both the width and the height of the graphic object simultaneously, while 
the other four handles resize only one dimension at a time.

Tip
To retain the original proportions of the graphic, Shift+click one of the corner handles, 
then drag. Be sure to release the mouse button before releasing the Shift key.

For more accurate resizing of the graphic object, use the Position and Size dialog box (Figure 70). 
Select as the base point the part of the graphic object that you would like to anchor to the page. 
The default setting (top left corner) means that when resizing, the position of the top left corner of 
the object will not change. Now modify either the Width value or the Height value of the object. To 
maintain the proportions between width and height, select the Keep ratio option before modifying 
any value. When Keep ratio is selected, changes to one of the dimension result in automatic 
changes to the other.

To prevent accidental modifications of the size, make sure that the Size option is 
selected in the Protect section in the bottom left part of the dialog box.

Applying special effects

Besides the basic actions of moving and resizing an object, a number of special 
effects can also be applied to the objects in Impress.  Several of these effects are 
readily available in the Mode toolbar. If the Mode toolbar is not showing, select it 
from View > Toolbars > Mode.

1 Rotate 4 Set in Circle (perspective) 7 Transparency

2 Flip 5 Set to Circle (slant) 8 Gradient

3 In 3D Rotation Object 6 Distort

Figure 71: Mode toolbar

This section describes how to rotate, flip, distort and two ways of setting an object in a circle. The 
transparency and gradient tools that are more specific to formatting are discussed in Chapter 6.
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Rotating graphic objects
Rotation of an object can be carried out manually or using a dedicated dialog box, just like 
changing object position and size. To rotate a graphic manually:

1) Select the graphic object if necessary so that the green handles show around it.

2) Click the Rotate button  in the Drawing toolbar or in the Mode toolbar.

Note

The icons representing the functions in the toolbars are different depending on the 
operating system used and on whether LibreOffice has been customized for the 
Linux distribution in use or not. When in doubt, hover the mouse over the icons and 
wait for the tooltip to appear showing the name of the button. The tooltip for the sub-
toolbar containing the Rotate function is Effects.

3) Eight red handles replace the green square handles, as shown in Figure 72. Move the 
mouse over one of the corner handles and the mouse cursor shape will change. Click the 
mouse and move in the direction in which you want to rotate the graphic object.

4) When satisfied release the mouse button.

At step 2) a black crosshair with a circle appears in the middle of the picture: this represents the 
pivot point for the rotation. Normally the center of the picture will be just fine, but on some 
occasions you may wish to rotate around a corner or even around a point outside the picture; to do 
that, click on the crosshair and drag it to the desired position.

To restrict the rotation angles to multiples of 15 degrees, press the Shift key while rotating the 
graphic. This is very handy for rotating pictures through a right angle, for example from portrait to 
landscape or back.

 

Figure 72: Shape showing the red rotating handles. Only the corner  
ones are active. The black crosshair indicates the rotation pivot.

Instead of rotating a graphic object manually, you can use the Rotation dialog box shown in Figure
73. To display this dialog box, select the graphic object so that the green resizing handles are 
shown, then press F4 or select Format > Position and Size and select the Rotation page.

In the upper part of the dialog box, select the position of the pivot point relative to the top left corner 
of the page. The default position of the pivot point is the center of the figure.

In the lower part of the dialog box select the angle by which to rotate the graphic object. To the 
right of the Angle text box, 8 default rotation values can be easily selected.
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Figure 73: The Rotation page of the Position and Size dialog box

Flip an object

Select an object and click on the Flip icon . You will see a dashed line 
through the middle of the object.

This dashed line is the axis of symmetry. The object will be reflected 
about this line. Move one or both ends of the line with your mouse to set 
the orientation of the axis.

Then, grab any one of the eight green handles and move it across to the 
other side of the dashed line. The new position of the figure is shown faintly 
until the mouse is released.

Note
If you press the Shift key while moving the line, the line will rotate in 45-degree 
increments.
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Mirror copies
This useful command does not exist in Draw or Impress. It can, however, be easily emulated.

Move the axis of symmetry to the desired location of the mirror axis. Copy the object to the 
clipboard. Flip the object, then click on an empty area of the page in order to deselect the object. 
Paste from the clipboard to put a copy of the object in its original location and now you have a 
mirror copy.

       

Figure 74: Making a mirror copy of an object

Distorting an image
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the 
image.

The Distort tool distorts an object in perspective, the Set to Circle (slant) and Set in Circle 
(perspective) tools both create a pseudo three-dimensional effect. In all three cases you are 
initially asked if you want to transform the object to a curve. This is a necessary first step, so click 
Yes. Then you can move the object handles to produce the desired effect.

The results of using these tools are shown in the following figures.

Distort an object

Select an object and click on the Distort icon .  After converting to a curve as requested, move 
the  handles to stretch the object.

The corner handles distort, as shown in Figure 75. The vertical midpoint handles distort the figure 
horizontally and the horizontal ones distort it vertically.

Figure 75: Distort an image
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Set in circle (perspective)

Select an object and click on the Set in Circle (perspective)  icon.  After converting to a 
curve , move the object handles to give a pseudo three-dimensional perspective).

Figure 76: Set an image in a circle with perspective

Set to circle (slant)

Select an object and click on the Set to Circle (slant)  icon.  After converting to a curve, move 
the object handles to give a pseudo three-dimensional slant perspective.

Figure 77: Set an image to a circle with slant perspective

Note
Transforming an object into a curve is a safe operation, but it cannot be reversed 
other than by clicking the Undo button.
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Aligning shapes

Use the alignment tools to adjust the relative position of a graphic object 
compared to another object. Clicking on the arrow beside the Alignment icon in 
the Drawing toolbar opens the extended toolbar. The same alignment options are 
available from the right-click menu.

The toolbar has six icons. The first three determine the horizontal alignment of the 
selected objects (Left, Center, Right); the other three determine the vertical 
alignment of the selected objects (Top, Middle, Bottom). If only one object is 
selected, it is aligned to the page; however when several objects are selected 
together,  single objects are aligned to the group selection border.

Snapping objects to grid or snap guides

Sometimes it is important to align objects to specific points of the page or to make sure that objects 
that appear on multiple slides are placed in exactly the same position. For this purpose Impress 
provides two mechanisms: the Grid and the Snap Guides (also called Snap Lines).

Using the grid
Options for the grid are available in the menu that opens by right-clicking on an empty part of the 
page in Normal view and choosing Grid or by selecting View > Grid from the menu bar. In both 
cases a submenu with three options opens:

• Visible Grid: displays the grid.

• Snap to Grid: the anchor points of an object will always be placed on a grid when the 
object is moved or resized.

• Grid to Front: displays the grid in the foreground.

To set up the grid spacing and snapping options, choose Tools > Options > LibreOffice Impress 
> Grid from the menu bar.

Using snap guides
Options for the guides are available in the menu that opens by clicking on an empty part of the 
page in Normal view and choosing Snap Lines or by selecting View > Guides from the menu bar. 
A submenu with three options opens:

• Display Guides (Snap Lines Visible): the guides are shown on the slide.

• Snap to Guides (Snap to Snap Lines): the anchor points of the objects snap to the 
guides when the object is moved or resized.

• Guides to Front (Snap Lines to Front): the guides are brought to the foreground and 
cover the objects.

Note The main menu uses the term Guides, but the pop-up menu refers to Snap Lines.

To create a new guide:

1) Right-click on an empty part of the work area and select Insert Snap Point/Line from the 
pop-up menu.

2) In the dialog box that appears, specify the type (Point, Vertical line, or Horizontal line).

3) Depending on the choice made, the two edit fields X and Y become active; enter the 
position of the guide.

4) Click OK to close the dialog box.
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Tip
When positioning the Snap Guides, it is useful to display the rulers. To do so, select 
View > Rulers.

Tip
Drag a Snap Guide directly onto the slide by clicking on the ruler and then dragging 
onto the slide.

To edit a guide:

1) Right-click next to or on the guide to be edited.

2) Select Edit Snap line from the pop-up menu.

3) Enter the new value (or values) and click OK. 

To delete a guide:

1) Right-click next or on the guide to be deleted.

2) Choose Delete Snap line from the pop-up menu.

Figure 78 show the three types of guides, the grid on a slide, and the dialog box to create a new 
guide.

Figure 78: Gridline, snap lines, and snap point on a slide

Arranging shapes

Arrange determines the stacking order of the selected object. Draw and Impress organize objects 
in a stack so that the objects on a high level of the stack cover the objects on lower levels if 
overlapping occurs. To modify the position of an object in the stack, click the small triangle on the 
side of the Arrange icon to open the extended toolbar. The same arrange options described below 
are available from the right-click menu.
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The first four tools determine the position of the selected object:

• Bring to front: the selected object is moved on top of any other 
object.

• Bring forward: the selected object is moved one level up in the 
stack.

• Send backwards: the selected object is moved one level down in the 
stack.

• Send to back: the selected object is given the lowest position in the stack.

The other three tools determine the relative positions of the selected object and of a second 
selected object:

• In front of object:  brings the first selected object in front of the second selected object.

• Behind object: brings the first selected object behind the second selected object.

• Reverse: swaps the stacking order of two selected objects.

To use the In front of object and Behind object tools:

1) Select the first object by clicking on it.

2) When the green handles show, select the desired arrange action.

3) The mouse pointer changes to a pointing hand. Click on the second object.

Working with connectors

Connectors are lines that can be anchored to particular places, called glue points, on the graphic 
object. The advantage of connectors is that when the graphic object to which the connector is 
attached is moved or resized, the connector automatically adjusts to the change. When creating a 
flowchart, org chart, schematics or diagrams, it is highly recommended to use connectors instead 
of simple lines.

Impress offers a wide variety of predefined connectors, which differ in the termination shape (none, 
arrow, custom) and in the way the connector is drawn (straight, line, curved).

When a connector is drawn or selected Impress displays red handles which are not shown for 
normal lines; in particular, the termination points are identified by red circles, while square handles 
are used to modify the routing of a connector (where applicable).

Draw a connector in a similar way to drawing any object. First select the connector style from the 
Connector toolbar, then move the mouse cursor over one of the objects to be connected. When the 
cursor is over the object, small black crosses appear around it; these represent the glue points to 
which the connector can be attached. Click on the required glue point to attach one end of the 
connector, then hold the mouse button down and drag the connector to the second object. When 
the cursor is over the glue point of the target object release the mouse button.

For instructions on how to format a connector, refer to the corresponding section in Chapter 6, 
Formatting Graphic Objects.

Managing glue points
As described above, a glue point is the point of attachment for a connector to a shape or graphic 
object. Each shape has a number of predefined glue points, but it is possible to define new ones as 
well as edit them, using the Gluepoints toolbar.
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1 Insert point 4 Exit right 7 Horizontal left 10 Vertical left

2 Exit left 5 Exit bottom 8 Horizontal center 11 Vertical top

3 Exit top 6 Relative 9 Horizontal right 12 Vertical right

Figure 79: The Gluepoints toolbar

Use the first tool to insert a new glue point. The next four tools determine the exit direction of the 
connector terminating at the glue point. To maintain the relative position of the glue point when 
resizing the object, make sure that the Glue point relative icon (highlighted in  Figure 79) is 
selected. Deselecting the Glue point relative icon activates the remaining six icons on the toolbar; 
use these to fix the position of the glue point during the resizing of the object. Hover the mouse 
over the buttons to obtain a tooltip giving a short description of its function.

To delete a custom glue point, select it with the mouse and press the Delete key.

Setting custom glue points is particularly useful where multiple connectors terminate on the same 
side of a shape or where the default glue point position is not satisfactory.

To move a predefined or newly inserted glue point:

1) Select the glue point tool from the drawing toolbar (see Figure 68).

2) Click on the glue point you want to move. The glue point should now be highlighted.

3) Keep the mouse button pressed and drag the glue point to the desired position. Release 
the mouse button.

Tip

Glue points are placed by default on the grid (see “Snapping objects to grid or snap
guides“ on page 93 for information), however it is sometimes necessary to fine tune 
the position of the glue point depending on the shape. To do this, keep the Control 
key pressed while dragging the glue point to the new position.

Working with 3D shapes

3D graphic objects can be created in different ways in Impress:

• From the 3D-Objects toolbar. The 3D-Objects tool is not included in 
the default Drawing toolbar. To include it, click on the small triangle at 
the end of the toolbar, select Visible Buttons, and select 3D-Objects 
from the list. On the Drawing toolbar, click on the triangle by the 3D-
Objects icon to display the extended 3D Objects toolbar.

• From the Convert sub-menu. Select a shape, right-click on it and  in 
the Convert sub menu choose either To 3D to add thickness to the object or To 3D 
Rotation Object to create a 3D shape resulting from the rotation of the object around an 
axis.

• From the Extrusion on/off icon on the drawing toolbar. Select the shape to which to apply 

a 3D effect, then click the  button on the Drawing toolbar (see Figure 80).
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Caution
You can not apply extrusion to rectangular and oval shapes created by using the 
rectangle or oval tools. Instead, select the desired shape from the basic shapes 
menu to create a rectangle or oval with 3D effects. Alternatively, right-click on the 
object, then select Convert > To 3D. Note that in this case the Extrusion on/off 
menu will not be enabled.

Although Impress offers advanced functions to manipulate 3D objects, this book describes only the 
3D settings applicable to an object with Extrusion enabled. For additional information on how to 
use advanced 3D effects such as geometry and shading, refer to the Draw Guide.

Click on  to activate the extrusion. The shape changes and a default thickness is added to it. At 
the same time the 3D-Settings toolbar should become visible. If the toolbar does not appear, select 
View > Toolbars > 3D-Settings.

Figure 80: The 3D-Settings toolbar

Use the tools to change the appearance of the 3D object.

Extrusion On/Off: adds thickness to an object and activates the 3D properties.

Tilt Down: tilts the object downwards around an horizontal axis.

Tilt Up: tilts the object up around an horizontal axis.

Tilt Left: tilts the object left around a vertical axis.

Tilt Right: tilts the object right around a vertical axis.

Depth: determines the thickness of the shape. An extended toolbar opens where some 
default values are given. If none of them is satisfactory, select Custom and then enter the 
desired thickness.

Direction: opens an extended toolbar that lets you pick the direction of the perspective 
as well as the type (parallel or perspective)..

 Lighting: opens an extended toolbar that lets you specify the direction and intensity of 
light.

 Surface: choose between Wire frame (useful when manipulating the object), Matt, 
Plastic or Metal.

3D Color: select the color of the object thickness.

Most of the Fontwork shapes (see “Using Fontwork” on page 101) have 3D properties and can be 
manipulated with the 3D-Settings toolbar.

Note that when rotating a 3D object, in addition to the corner red handles, four handles on the 
sides of the frame become available.
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Figure 81 is an example of a customized 3D object.

Figure 81: Example of 3D object

Converting an object to a different type

You can convert an object into a different type. Right-click on the object and select Convert to 
display a menu containing the following options:

• To Curve: converts the selected object to a Bézier curve. Choose Edit Points to edit the 
Bézier curve.

• To Polygon: converts the selected object to a polygon. After the conversion choose Edit 
Points to edit the shape. A polygon always consists of straight segments.

• To Contour: for basic shapes, this is equivalent to converting to polygon. For more 
complex shapes (or for text objects) this conversion creates a group of polygons that you 
can then manipulate by pressing F3 to enter the group.

• Convert to 3D: converts the selected object to a three-dimensional (3D) object.

• Convert to 3D Rotation Object: creates a three-dimensional shape by rotating the 
selected object around its vertical axis.

• To Bitmap: converts the selected object to a bitmap.

• To metafile: converts the selected object to Windows Metafile Format (WMF), containing 
both bitmap and vector graphic data.

Note
In most cases the conversion to a different type does not produce immediately visible 
results.

Setting up interaction with a shape

You can associate a shape or an image with some action to be performed when the user clicks on 
it. To create an interaction:

1) Select the graphic object for which an interaction will be created.

2) When the green handles show, select from the Drawing toolbar (Figure 68) the Interaction 

button  or right-click on the object and select Interaction from the pop-up menu.

3) The dialog box shown in Figure 76 is displayed. Select the interaction type and the 
parameters (if applicable). Click OK to close the dialog box.

To remove an interaction from a graphic object follow the steps 1–5, above taking care to select No 
action as the interaction type at step 4.

The possible actions and their parameters are described in Table 2.
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Figure 82: dialog box to set the interaction with a graphic object

Table 2: Interactions and their parameters

Interaction type Parameters

Go to Previous slide No parameters.

Go to Next slide No parameters.

Go to First slide No parameters.

Go to Last slide No parameters.

Go to Page or Object Specify the target from the list in the Target box. You can search 
for a specific target in the Document box at the bottom of the 
screen.

Go to Document Select the document in the Document box. Use the Browse button 
to open a file picker dialog box. If the document to be opened is in 
Open Document Presentation format, the target list will be 
populated allowing the selection of the specific target in the 
document.

Play sound Select the file containing the sound to be played. Use the Browse 
button to open a file picker dialog box.

Run program Select the program to execute. Use the Browse button to locate it.

Run Macro Select a macro that will run during the presentation. Use the 
Browse button to open the macro browser dialog box.

Exit presentation When the mouse is clicked over the graphic object, the 
presentation will terminate.

Animating images

 An animated image consists of a sequence of images (frames) that are displayed in succession. 
Each frame may contain one or multiple drawing objects. To start creating a custom animated 
image, open the Animation dialog box from Insert > Animated Image.
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Figure 83: The Animation dialog box

Creating an animation
Several mechanisms can be used to create an animated image. This chapter describes only two of 
them, which should be sufficient to understand the functions offered.

Frame by frame animation
1) Create the image you intend to animate using the drawing tools.

2) Select the image and click the Apply Object  button. This copies the object (or 
objects) into the upper part of the Animation dialog box.

3) Apply some desired transformation to the object: for example, rotate it or change the color; 
if you are animating text, add or subtract a letter and so on.

4) When you are ready, create the second frame of the animation and click the Apply Object 
button again.

5) Repeat steps 3 and 4 until you have created all the desired frames of the animation.

6) Select Bitmap object in the Animation group section of the Animator dialog box. This 
allows you to customize the timing of each of the frames and the number of repetitions for 
the animation (set the value to Max to obtain an  infinite loop).

7) Click Create to place the animated image on the slide.

Note

If the image to be copied in the Animator consists of several objects, you can choose 
to treat each object as a separate frame. In this case click the Apply objects 

individually button . Remember that each object will be centered in the 
animation. 
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Animated image in one step
For some simple animations it is possible to create all the animation frames in advance, and place 
them on the slide. This method works well for a rotating line, a shape gradually changing color, 
shapes increasing or decreasing size. In most of these occasions it is convenient to use the Edit > 
Duplicate command.

When all the frames are already prepared, use the Apply objects individually  to create one 
frame for each of the objects.

It is easy to obtain for example a rotating line segment:

1) Draw a fairly thick horizontal segment  (use Format > Line or the Line and Filling toolbar to 
add thickness).

2) Open the Duplicate dialog box by selecting Edit > Duplicate and set the number of copies 
to 5, the X and Y axis to 0.1, the angle to 30, the enlargement width and height to 0, and 
press the OK button.

3) Select the 6 segments created by Impress and open the Animator (Insert > Animated 
image from the main menu bar).

4) On the Animator dialog box, click Apply objects individually.

5) Select Bitmap object in the lower part of the dialog box, 

6) Create a new empty slide to contain your animation, then click the Create button.

Other functions of the Animator

You can review the animation at any time by clicking the Play button  as well as navigate the 
various frames using the other controls available.

If you are not satisfied with a particular frame, you can remove it. To do so:

1) Navigate to the frame by using the Image Number box with the spin buttons (just to the 
right of the play controls).

2) Click the Delete current image button .

You can also delete the whole animation by clicking the Delete all images button .

Tip
If you want to work on the animation frames a bit more, you can copy them into the 
Impress work area by selecting Group object and then clicking Create.

Tip

Since all the objects are centered in the animation window, to animate an object off 
the center of the image, create a blank rectangle of the same size of the final image 
and select it along with the object to be animated. Make sure that Group object is 
selected before clicking the Apply object button.

Using Fontwork

Use Fontwork to obtain special text effects. For more about this topic, see Chapter 11, Graphics, 
the Gallery, and Fontwork, in the Getting Started guide.

To start using Fontwork:

1) Open the Fontwork Gallery by clicking the  icon on the Drawing toolbar or on the 
Fontwork toolbar (Figure 86). If the Drawing toolbar is not showing, you can go directly to 
the Fontwork toolbar by selecting View > Toolbars > Fontwork from the main menu bar.
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2) Select the preferred style from the Fontwork Gallery (Figure 84) and click OK. You can 
modify it later, so pick one providing an effect similar to the desired one. The text Fontwork 
in the selected style appears on the slide.

Figure 84: The Fontwork gallery

3) Double-click the object to edit the Fontwork text. Type your own text in place of the black 
Fontwork that appears over the object.

Figure 85. Editing Fontwork text

4) Press the Esc key or click outside the area with the green resizing handles to exit.

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use 
the Fontwork toolbar or other options as described in the next section.
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Using the Fontwork toolbar
Make sure that the Fontwork toolbar, is visible on the workspace. If not, select View > Toolbars > 
Fontwork from the main menu bar.

Figure 86: The Fontwork toolbar

In addition to the Fontwork Gallery icon, this toolbar contains the following icons:

 Fontwork shape: to change the shape of the selected object, choose a shape from the 
extended toolbar.

 Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles 
between normal height (some characters taller than others, for example capital letters, d, h, l 
and others) and all letters the same height.

Figure 87. Left: normal letters; right: same letter heights

 Fontwork Alignment: specify the alignment of the text within the 
frame from the choices available. The effects of the text alignment can 
only be appreciated if the text spans over two or more lines. In the 
Stretch Justify mode all the lines are filled completely.

Chapter 5  Managing Graphic Objects 103



 Fontwork Character Spacing: select the desired spacing and 
whether kerning pairs should be used. For custom spacing, input a 
percentage value: 100% is normal spacing; less than 100% is tight 
spacing; more than 100% is expanded spacing.

Modifying Fontwork text as a shape
It is possible to treat Fontwork text as a shape and therefore to apply to it all the formatting that has 
been described in this chapter. Assign line properties only to Fontwork which does not have a 3D 
effect, otherwise the changes will not be visible.

Tip
Change the Fontwork color quickly using the Area fill color swatch on the Line and 
Filling toolbar.

You can modify some of the Fontwork shapes just as you modify the angles of 
Trapezoids and Parallelogram basic shapes by moving the yellow dot that is displayed 
along with the green resizing handles.
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Formatting objects

This chapter describes how to format the graphic objects created with the available drawing tools.

The format of each graphic object, in addition to its size, rotation and position on the slide, is 
determined by a number of attributes that define the line, text and area fill of each object. These 
attributes (among others) also contribute to a graphics style. Although this chapter discusses 
mainly the manual formatting of objects, it concludes by showing how to create, apply, modify and 
delete graphics styles.

Formatting lines
In LibreOffice the term line indicates both a freestanding segment and the outer edge of a shape. 
In most cases the properties of the line you can modify are its style (solid, dashed, invisible, and so 
on), its width and its color. All these options can be applied with a few clicks of the mouse. Select 
the line you need to format and then use the controls on the Line and Filling toolbar to select your 
desired options.

Figure 88: Common line options (style, width, color) highlighted

If you need to fine tune the appearance of a line, choose Format > Line from the menu bar, or 
right-click on the line and select Line from the pop-up menu, or select the Line icon from the Line 
and Filling toolbar. These methods open the Line dialog box shown in Figure 89, where you can 
set all the properties of the line at once.

The dialog box consists of four pages: Line, Line Styles, Shadow, and Arrow Styles.

General line settings
The Line page is where you can set the basic parameters of the line. It is subdivided into 4 parts.

Figure 89: Main line formatting dialog box

106 LibreOffice 3.3 Impress Guide



The Line Properties section (left side) is the most important. It includes the following parameters:

• Line style: a variety of line styles is available in the drop-down list, but more can be 
defined if needed.

• Color: choose among the  predefined colors or refer to “Adding custom colors” on page 
114 to create a new one.

• Width: specifies the thickness of the line.

• Transparency: sets the transparency value of the line, a useful property when you do not 
want to hide the background completely. Figure 90 illustrates the effects on a line of 
different degrees of transparency.

Figure 90: The vertical lines have different  
levels of transparency (0%, 25%, and 50%).

The Arrow styles section of this page is only applicable to line segments; it has no effect on the line 
that forms the border of a shape or of a polygon. Use this section to set the styles of the two ends 
of the segment. You can configure the two ends independently, selecting for each of them the 
arrow shape (Style drop-down menu), the Width, and the termination style (Center option). 
Selecting the Center option moves the center of the arrowheads to the end point of the line. Figure
91 shows  the effects of selecting this option. To make the two ends  identical, select the 
Synchronize ends option. To create new arrowheads, use the Arrow styles page, as described in 
the following section.

Figure 91: Default arrowheads (left)  
vs centered arrowheads (right)

The Corner style section of this page determines how the connection between two segments 
should look. There are four available options in the drop-down menu. To appreciate the difference 
between corner styles, choose a thick line style and observe how the preview changes.

The bottom part of the page previews the applied style for a single line and  two different corners 
so that the corner style choice can be quickly evaluated. 

A faster way to set the arrowheads for a selected line is to click on the Arrow Style  icon in 
the Line and Filling toolbar (Figure 88). This opens the Arrowheads menu, where you can choose 
one of the many predefined arrowhead styles for the start and termination of the selected segment.
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Figure 92: Arrowheads menu

Creating line styles
Use the Line Styles page of the Line dialog box to create new line styles as well as to load 
previously saved line styles. Normally it is not a good practice to modify the predefined styles; 
instead, create new ones when necessary.

Figure 93: Advanced options for creating line styles

To create a new line style:

1) Choose Format > Line from the menu bar.

2) Click on the Line Styles tab.

3) Select from the Line style drop-down menu a style similar to the desired one.
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4) Click Add. On the pop-up dialog box, type a name for the new line style and click OK.

5) Now define the new style. Start by selecting the line type for the new style. To alternate two 
line types (for example, dashes and dots) within a single line, select different types in the 
two Type boxes.

6) Specify the number and length (not available for dot style) of each of the types of line 
selected, set the spacing between the various elements, and decide if the style should fit to 
the line width (length).

The new line style is available only in the current document. If you want to reuse the line style in 

other presentations, click the Save Line Styles icon  and type a memorable name. This saves 
all of the line styles in this presentation. (Saved styles have a file extension of .sod.)

To make previously saved line styles available in the current presentation, click the Load Line 
Styles icon, select the saved list of styles, and click Open.

Use the Modify button to change the name of the style.

Creating arrow styles
Use the third page of the Line dialog box to create new arrow styles such as the ones in the figure 
below, to modify existing arrow styles, or load previously saved arrow styles.

1) First draw a curve with the shape you want for the arrowhead.

Note
The arrowhead must be a curve. A curve is something you could draw without lifting a 

pencil. For example,  is a curve but  is not a curve. You can however draw 
shapes which are not curves and then at the end convert them to a curve.

The top part of the shape will point in the direction of the line. In Figure 94 the corner at the 
top of the shape will point towards the “outside” of the line.

Figure 94: To create your own arrowhead,  
first draw a curve.

2) Select the curve. With the resizing handles showing, select Format > Line from the menu 
bar, or right-click and choose Line from the pop-up menu.

3) Go to the Arrow styles page (Figure 95), click the Add button, type a name for the new 
arrow style, and click OK.

4) Now you can access the new style from the Arrow style list. When you select the name of 
the new style, it is shown at the bottom of the dialog box.

Line shadow
Use the Shadow page of the Line dialog box to add and format the line shadow. The settings on 
this page are the same as those for shadows applied to other objects and are described in 
“Formatting shadows” on page 121.
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A faster way to apply a shadow to the line is using the last button of the Line and Filling toolbar of 
Figure 88. The main disadvantage of using the toolbar button is that the shadow appearance will 
constrained by the shadow settings of the default graphics style.

Figure 95: Advanced options for creating arrow styles

Formatting the fill area

The term area fill refers to the inside of an object, which can be a uniform color, a gradient, a 
hatching pattern, or an image. An area fill can be made partly or wholly transparent and can throw 
a shadow.

Figure 96: Different types of area fill

The Line and Filling toolbar has the majority of the tools normally used to format graphic objects. If 
this toolbar is not showing, choose View > Toolbars >Line and Filling from the menu bar. You 
can also use the Area dialog box, described on page 112.

Figure 97: Common fill options
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To format the area of an object, select it so that the green resizing handles show. A wide number of 
default fillings are readily available from the Line and Filling toolbar. Select first from the pull-down 
menu to the right of the paint can icon the type of fill. If you want no fill at all, select Invisible.

Once you have decided on a predefined or custom fill, you can further refine it by adding a shadow 
or transparency.

Uniform color
Select the object you wish to edit. On the Line and Filling toolbar, select Color on the pull down list 
at the right of the paint can, and then choose a color from the drop-down menu.

Figure 98: Filling with a color

Fill with a gradient
A gradient fill provides a smooth transition from one color to another. The transition pattern may 
vary from a simple linear transition to a more complex radial transition.

Select the object you wish to edit. On the Line and Filling toolbar, select Gradient and then choose 
a gradient from the drop-down menu.

Figure 99: Filling with a gradient
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Fill with a line pattern (hatching)
Select the object you wish to edit. On the Line and Filling toolbar, select Hatching and then choose 
a hatching fill from the drop-down menu. A hatching fill is applied throughout the area.

Figure 100: Filling with a line pattern

Fill with an image
You can fill an object only with a bitmap image (as opposed to a vector graphic image). Select the 
object you wish to edit. On the Line and Filling toolbar, select Bitmap and then choose a bitmap fill 
from the drop-down menu.

Figure 101: Filling with an image

Using the Area dialog box
In addition to using the Line and Filling toolbar, you can use the Area dialog box to apply existing 
fills and create your own. To open it, choose Format > Area from the menu bar, or click on the 
paint bucket icon on the Line and Filling toolbar, or right-click on the object and select Area.

Use the Area tab to apply predefined fills, both those supplied with LibreOffice and those you 
create yourself. Use the Colors, Gradients, Hatching, and Bitmaps tabs to define new fills, as 
described in “Creating new area fills” on page 114. The Transparency tab is discussed on page 
122. To make the object cast a shadow, see page 121.

To apply an area fill, first select in the top left drop-down list the required fill type. The page 
changes to show in the middle section the list of predefined styles for that fill type.
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Figure 102: Area page of the area formatting dialog box

Note In the Area dialog box, the choice for no fill is None rather than Invisible.

When using the Area tab of the Area dialog box, some additional options may become available 
once you have selected the fill type and one of the available fill styles.

• For gradient fills, you can override the number of steps (increments) that should be applied 
to the transition from one color to the other. To do so, select Gradient on the Area tab and 
deselect the Automatic option under Increments. Then enter the number of steps required 
in the box to the right.

• For hatching, you can apply a different background color by selecting the Background 
color option and choosing a color from the drop-down list.

• For bitmaps, you can customize a large number of parameters. Refer to “Working with
bitmap fills” on page 118 for additional information.
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Creating new area fills

The following sections describe how to create new fills and how to apply them.

Although you can change the characteristics of an existing fill and then click the Modify button, it is 
recommended that you create new fills or modify custom fills rather than  the predefined ones, as 
these may be reset when updating LibreOffice.

Adding custom colors
On the Colors page, shown in Figure 103, you can modify existing colors or create your own.

You can specify a new color either as a combination of the three primary colors Red, Green, and 
Blue (RGB notation) or by the percentage of Cyan, Magenta, Yellow, and Black (CMYK notation).

Figure 103: A custom color has been added to the list

To create a new color:

1) Enter the name for the color in the Name box.

2) Select whether to define the color in RGB or CMYK. For RGB Specify the red, green and 
blue component on a 0 to 255 scale. For CMYK specify the Cyan, Magenta, Yellow and 
black (K) components, from 0% to 100%.

3) Click the Add button. The color is now added to the list on the Area page.

To modify a color:

1) Select the color to modify from the list.

2) Enter the new values that define the color (if necessary change the settings between RGB 
and CMYK).

3) Modify the name as required.

4) Click the Modify button.

Alternatively, use the Edit button (this will open a new dialog box), modify the color components as 
required and click OK to exit the dialog box.

Use the Load and Save buttons in the dialog to use a different color palette or to save your own 
custom colors.
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Tip
You can also add custom colors using Tools > Options > LibreOffice > Colors. This 
method makes the color available to all components of LibreOffice, whereas colors 
created using Format > Area > Colors are only available for Impress.

Creating gradients
To create a new gradient or to modify an existing one, select the Gradients tab from the Area dialog 
box. Several types of gradients are predefined and in most cases changing the From and To colors 
will be sufficient to obtain the desired result.

Figure 104: The Gradients page of the Area dialog box

It is highly recommended that you create a new gradient even if you just want to change the two 
colors, rather than modifying the predefined ones, which should be used only as starting points.

To create a new gradient:

1) First choose the From and To colors.

Figure 105: Gradient transition color selection
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2) Then choose a type of gradient from the list: Linear, Axial, Radial, Ellipsoid, Square or 
Rectangular.

A preview of the gradient type is shown under the available gradients list in the middle of 
the dialog box. Figure 106 shows an example.

Figure 106: Center option in a radial gradient

3) Depending on the chosen type some options will be grayed out. Set all the properties as 
desired (very often the default values will work well). The properties to set to create a 
gradient are summarized in Table 3.

4) Click the Add button to add the newly created gradient to the list. 

Tip
The newly created gradients remain available to all the LibreOffice components and 
also for future presentations. It pays to give them memorable names.

Table 3: Gradient properties

Property Meaning

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the vertical offset of the gradient center.

Angle For all the gradient types, specifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
shape.

From
The start color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

To
The end color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.
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Creating hatching patterns
You can create new hatching patterns or modify existing ones. Start by selecting the Hatching tab 
of the Area dialog box.

Figure 107: The Hatching tab of the Area fill dialog box

As with gradients and colors, it is better to create a new pattern rather than to modify a predefined 
one.

To do so:

1) Select as a starting point a pattern similar to the one that will be created..

2) Modify the properties of the lines forming the pattern. A preview is displayed in the window 
below the available patterns.

3) Click the Add button and choose a name for the newly created hatching.

The properties that can be set for a hatching pattern are shown in Table 4.

Table 4: Properties of hatching patterns

Property Meaning

Spacing Determines the spacing between two lines of the pattern. As the value is 
changed the preview window is updated.

Angle Use the mini map below the numerical value to quickly set the angle formed 
by the line to multiples of 45 degrees. If the required angle is not a multiple of 
45 degrees, just enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the pattern.

Line color Use the list to select the color of the lines that will form the pattern.
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Working with bitmap fills
On the Area tab, chose Bitmap from the drop-down list. Select from the list of bitmaps the one to 
be used to fill the area. Note that any imported bitmaps will become available in the list.

Set the size, position and offset parameters (as applicable) in the right hand side of the page, and 
then click OK to close the dialog box.

As Figure 108 shows, there are quite a number of parameters to be configured when using a 
bitmap fill. These are described in Table 5.

Figure 108: Advanced formatting for bitmap fill

Table 5: Bitmap fill properties

Property Meaning

Size – Original Select this box to retain the original size of the bitmap.

Size – Relative To rescale the object, deselect the Original option and select this one. 
The Width and Height edit boxes are enabled.

Size – Width When Relative is selected 100% means that the bitmap original width 
will be resized to occupy the whole fill area width, 50% means that the 
width of the bitmap will be half that of the fill area.

Size – Height When Relative is selected 100% means that the bitmap original height 
will be resized to occupy the whole fill area height, 50% means that 
the height of the bitmap will be half that of the fill area.

Position – Anchor Map Select from the map the place within the area to which the bitmap 
should be anchored.

Position – Tile When this option is selected, the bitmap will be tiled to fill the area. 
The size of the bitmap used for the tiling is determined by the Size 
settings.
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Property Meaning

Position – X offset When Tile is enabled, enter in this box the offset for the width of the 
bitmap in percentage values. 50% offset means that Impress will 
place the middle part of the bitmap at the anchor point and start tiling 
from there.

Position – Y offset This will have a similar effect to the X offset, but will work on the 
height of the bitmap.

Position – Autofit Stretches the bitmap to fill the whole area. Selecting this option 
disables all the size settings.

Offset – Row If Tile is enabled, offsets the rows of tiled bitmaps by the percentage 
entered in the box so that two subsequent rows are not aligned.

Offset – Column If Tile is enabled, offsets the columns of tiled bitmaps by the 
percentage entered in the box so that two subsequent columns of 
bitmaps are not aligned.

The best way to acquire understanding of these parameters is to use them. Figure 109 shows 
some examples of bitmap fills and the parameters used.

Figure 109: Examples of bitmap fill

Chapter 6  Formatting Graphic Objects 119



Creating and importing bitmaps
You can add (import) new bitmap fills or create your own pattern on a 8x8 grid, using the Bitmaps 
tab of the Area dialog box (shown in Figure 110).

To create a bitmap fill:

1) Start with the Blank bitmap type on top of the list to activate the Pattern editor.

2) Select the Foreground and Background colors.

3) Start creating the pattern by clicking with the left mouse button the squares (pixels) that you 
want to be painted in the foreground color. Use the right mouse button to apply the 
background color. Check the preview window to see if the desired effect is achieved.

4) When done, click Add to save the pattern.

Figure 110: The Bitmaps page of the Area fill dialog box

To import a bitmap created in Draw or another program:

1) Click the Import button.

2) A file picker dialog box is displayed. Browse to the directory containing the bitmap file and 
select it, then click Open.

3) Type a name for the imported bitmap and click OK.

Note
Bitmaps generally have an extension .bmp or .png. To create a bitmap image with 
Draw, select File > Export, choose PNG from the pull-down list of file formats, give 
the file a name, and save it.
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Formatting shadows
Shadowing can be applied to both lines and areas. To apply a shadow to an area, first select the 
object to which shadowing should be applied, then select Format > Area.

Shadows can also be applied to lines. One way is to click the Shadow icon  on the Line and 
Filling toolbar (the last tool on the right-hand end). The other way is to apply a style to the line that 
uses a shadow (see “Working with graphics styles” on page 127 for additional information on using 
styles).

Using the first method, you cannot customize the shadow; it is applied according to the default 
settings. The second method offers the opportunity to configure the shadow properties. 

The dialog box to customize a shadow is shown in Figure 111.

Figure 111: Dialog box for customizing the shadowing of graphic objects

When the Use shadow option is selected, the following parameters can be set:

• Position: the selected point in the mini map determines the direction in which the shadow 
is cast.

• Distance: determines the distance between the object and the shadow.

• Color: sets the color of the shadow.

• Transparency: determines the amount of transparency for the shadow.

Tip
When the transparency value is set above 0%, the shadow does not completely hide 
the objects below. This produces a pleasant visual effect, as shown in Figure 97.

Figure 112: Shadows with different levels of  transparency
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Transparency formatting
Transparency is applicable to lines and areas as well as shadows. To apply transparency to lines, 
refer to “Formatting lines” on page 106; for shadows, refer to “Formatting shadows” above.

To apply transparency to areas, select Format > Area and then go to the Transparency page 
shown in Figure 113.

Figure 113: Setting the object transparency

The two types of transparency are uniform transparency and gradient transparency. To obtain 
uniform transparency, select Transparency and then select the percentage of transparency 
required. For a gradient transparency (so that the area becomes gradually transparent) select 
Gradient and then set the parameters of the gradient. Refer to Table 5 on page 118 for a 
description of most of the settings. In the Transparency tab, specify the Start value and the End 
value for the transparency gradient. 0% is fully opaque, 100% means fully transparent.

An example of gradient transparency is shown in Figure 114.

More information on gradient transparency, including an example of combining color gradient with 
gradient transparency, can be found in “Advanced gradient controls” on page 123.
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Figure 114: Example of gradient transparency

Advanced gradient controls
As discussed in “Creating gradients” on page 115 and “Transparency formatting” on page 122, 
gradient properties can be configured using the parameters in Table 5 on page 118. 

Impress also provides a graphical interface for modifying the gradient parameters using only the 

mouse. To use these tools, click on the Transparency icon  or the Gradient icon  in the 
Mode toolbar.

When an object with a gradient fill is selected, click on the Gradient icon to display a dashed line 
connecting two squares colored as the “From” color and the “To” color of the gradient, as shown in 
the examples below.
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Figure 115: Green to magenta gradient

Figure 116: Transparency gradient (note how the background becomes visible close 
to the white square)

For linear gradients, move the square corresponding to the From color to change where the 
gradient starts (that is the Border property). Move the square corresponding to the To color to 
change the orientation (Angle property).

For axial gradients, you can move only the To color to change both the angle and the border 
properties of the gradient.

For radial gradients, move the From color to modify the border property (that is how “wide” the 
gradient circle is). Move the To color to change the point where the gradient ends (Center X and 
Center Y values).

For ellipsoid gradients, move the From color to modify the border property (the size of the 
gradient ellipsoid). Move the To color to change the angle of the ellipsoid axis and the axis itself.

For square and rectangular gradients, move the From color to modify the border (the size of the 
gradient square or rectangle) and the angle of the gradient shape. Move the To color to change the 
center of the gradient.
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The same actions can be performed for transparency gradients, with the difference that the two 
squares activated by the Transparency icon represent the fully opaque point (black square) and the 
fully transparent point (white square).

These icons are grayed out by default and are only activated when an object with gradient filling, 
gradient transparency, or both is selected.

In both cases a dashed line connecting two small squares appears on top of the object. Click 
outside the object to set the gradient.

Note
Moving the squares will have different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.

Formatting text

Impress provides two dialog boxes related to text formatting: Format > Character and Format > 
Text.

To modify formatting such as font and font effects, select the text in the shape and then go to 
Format > Character. For more information, see Chapter 3, Adding and Formatting Text. This 
section covers the formatting of the overall shape of text which is added to a line or to a shape.

To add text to an object (a shape or a line):

1) Select the object to which text will be added.

2) With the green resizing handles showing, double-click on the object and wait for the cursor 
to become an I-beam or just start typing.

3) Type the text. When finished, click somewhere outside the object or press Esc.

To format the text in a shape:

4) Select the object to which text was added.

5) Select Format > Text or right-click on the shape and select Text from the pop-up menu. 
The Text dialog box is displayed.

The top section of the page (Text) offers several options in the form of checkboxes. Some of the 
options will be grayed out, depending on the object to which the text will be attached.

• Select Fit width to text to expand the width of the shape or line if the text is too long for it.

• Select Word wrap text in shape to start a new line automatically  when the edge of the 
shape is reached.

• Select Fit height to text to expand the object height whenever it is smaller than the text 
(set by default for lines).

• Select Resize shape to fit text to expand a custom shape when the text inserted in the 
shape is too large.

• Select Fit to frame to expand the text so that it fills all the available space.

• Select Adjust to contour to make the text follow a curved line.
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Figure 117: Main dialog box to set the text properties

In the Spacing to borders section, specify the amount of space to be left between the border of the 
shape or line and the text; this is similar to the settings for indentation and spacing for paragraphs.

The text anchor grid in the bottom right corner of the dialog box is used to decide where to anchor 
the text. The Full width option determines if the anchoring should be performed to the full width of 
the shape.

Text animation
Use the Text Animation page to add special effects to the text. Choose between the four options on 
the list and when applicable, the direction of the effect by picking one of the four arrow buttons to 
the right. The available effects are:

• Blink: the text will blink on the screen.

• Scroll through: the text will move into the shape and then out following the chosen 
direction.

• Scroll back and forth: the text will move first in the chosen direction but will bounce back 
at the shape border.

• Scroll in: the text will scroll in towards the given direction starting from the edge of the 
shape and stop in the center.

The default is no animation.

The other properties that can be set are:

• Start inside option: when set the animation will start from inside the shape.

• Text visible when editing option: set this box to see the text while editing.

• Animation cycles: includes three further options to set the frequency of the animation, the 
increments between two positions of the animation and finally the delay before the 
animation starts.

To see some of the animations in action, it is necessary to start the presentation. Press F9 or 
select Slide Show > Slide Show from the main menu. To return to the edit mode, press Esc.
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Formatting connectors

Connectors are lines that join two shapes. Connectors always start from a glue point on the 
shape. Refer to Chapter 5, Managing Graphic Objects, for a description of the use of connectors.

Connector properties can be accessed and modified in two ways:

• Manual formatting: right-click on the connector line and select Connector in the pop-up 
menu.

• Style-based formatting: select one of the available graphics styles or create a new one.

Both methods open the Connector dialog box where you can set the style of the connectors. 
Choose between Standard (the default), Line, Straight, and Curved connector. Whenever multiple 
connectors overlap, use the Line skew section of the dialog box to distance the lines. It is possible 
to customize the distance between 4 different lines.

In the Line spacing section of the dialog box, set the horizontal and vertical space between the 
connector and the object at each end of the connector.

Figure 118: Setting up the connector properties

Working with graphics styles

To achieve consistency in the style across the slides of a presentation (or a presentations 
portfolio), or simply to apply the same formatting to a large number of objects, the best approach is 
to use graphics styles.

Graphics styles are the equivalent for graphic objects of paragraph styles for text. A graphics style 
groups all the formatting attributes that a graphic object can have and associates this with a name, 
making them quickly reusable. If a style is modified (for example, by changing the area 
transparency), the changes are automatically applied to all the graphics with that style.

If you use Impress frequently, a library of well-defined graphics styles is an invaluable tool for 
speeding up the process of formatting your work according to your taste or any style guidelines you 
may need to follow (company colors, fonts and so on).

Use the Styles and Formatting window to access styles you will need often. If the window is not 
visible, press F11, or click the Styles and Formatting icon at the left-hand end of the formatting bar, 
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or select Format > Styles and Formatting from the menu bar. Press F11 again when the dialog 
box is not needed, to maximize the workspace area.

Linked graphic styles
Graphic styles support inheritance; that is, a style can be linked to another (parent) style so that it 
inherits all the formatting settings of the parent. You can use this property to create “families” of 
styles.

For example, if you need multiple boxes that differ in color but are otherwise identically formatted, 
the best way to proceed is to define a generic style for the box including borders, area fill, font, and 
so on and a number of hierarchically dependent styles which differ only in the fill color attribute. If 
later you need to change the font size or the thickness of the border, it is sufficient to change the 
parent style and all the other styles will change accordingly.

Creating graphics styles
You can create a new graphics style in two ways:

• Using the Style dialog box

• From a selection

Creating a new graphic style using the Style dialog box

Choose the Graphics Styles icon  at the top of the Styles and Formatting window.

To link a new style with an existing style, first select that style, and then right-click and choose 
New. Otherwise, select Default, then right-click and choose New.
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Figure 119: Linking a new style 
with an existing style

As discussed in the preceding section, when styles are linked, changing the font will change it in all 
the linked styles. Sometimes this is exactly what you want; at other times you do not want the 
changes to apply to all the linked styles. It pays to plan ahead.

Figure 120: Top of dialog box to create a new graphics style

The Graphics style dialog box consists of 14 pages (15 if Asian language support has not been 
enabled) that may be grouped as follows:

• The Organizer page contains a summary of the style and its hierarchical position.

• The Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian typography pages 
set the properties of the text inserted in a text box or in an graphic object.

• The Dimensioning page is used to set the style of dimension lines.

• The Text, Text animation, Connector, Line, Area, Shadowing, and Transparency pages 
determine the formatting of a graphic object and are discussed elsewhere in this chapter.

Note
In most cases you will not need to configure the parameters of every page; for 
example, to create a simple line style you will probably only use 3 of the 15 pages.

Creating a new graphics style from a selection
You can create a new style from manually formatted text or graphics:

1) Select the item you want to save as a style. If the selected object is already styled, then the 
new style will be linked to such style.

2) In the Styles and Formatting window, click the New Style from Selection icon, highlighted 
in Figure 121.
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Figure 121: New style from selection

3) In the Create Style dialog box that pops up, type a name for the new style. The list shows 
the names of existing custom styles of the selected type. Click OK to save the new style.

Figure 122: Naming a new style created from a selection

Modifying a graphics style
To change an existing style, right-click on it in the Styles and Formatting window and choose 
Modify from the pop-up menu.

The dialog box for the modification of a graphic style is the same as the one for creating a new 
graphic style.

Make the required changes to the style and then click OK to save them.

Updating a graphics style from a selection
To update a style from a selection:

1) Select an item that has the format you want to adopt as a style.

2) In the Styles and Formatting window, select the style you want to update, and then click the 
Update Style icon.

Figure 123. Updating a style from a selection

Tip

Any changes you make to a style are effective only in the document on which you are 
working. The changes do not go into any associated template. If you want the 
changes to apply to more than one document, you need to change the template (see 
Chapter 2).
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Applying graphics styles
You can apply a graphics style in two ways, both starting from the Styles and Formatting window. 
First make sure that the graphic styles are shown, then do one of the following:

• Select the object to which you want to apply a graphic style and double-click on the name 
of the style you want to apply.

• Click the Fill Format mode icon . The mouse pointer changes to this icon. Position the 
moving icon on the graphic object to be styled and click the mouse button. This mode 
remains active until you turn it off, so you can apply the same style to several objects. To 
quit Fill Format mode, click the Fill Format mode icon again or press the Esc key.

• When Fill Format mode is active, a right-click anywhere in the document undoes the last 
Fill Format action. Be careful not to accidentally right-click and thus undo actions you want 
to keep.

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or groups of styles such as applied styles or (in the case of 
graphics styles) custom styles.

Deleting graphics styles
You cannot delete any of the predefined styles, even if you are not using them.

You can delete any user-defined (custom) styles, but before you do, you should make sure the 
styles are not in use. If an unwanted style is in use, replace it with a substitute style.

To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting window 
and click Delete on the pop-up menu. Click Yes in the message box that pops up.

Assigning styles to shortcut keys
LibreOffice provides a set of predefined keyboard shortcuts which allow you to quickly apply styles 
while typing in a document. You can redefine these shortcuts or define your own, as described in 
Appendix A, Keyboard Shortcuts.
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Using spreadsheets in Impress

A spreadsheet embedded in Impress includes most of the functionality of a spreadsheet in Calc 
and is therefore capable of performing complex calculations and data analysis. However, if you 
plan to use complex data or formulas, you are better off performing the necessary operations in a 
separate Calc spreadsheet and use Impress only to display the embedded spreadsheet with the 
results.

You may also be tempted to use spreadsheets in Impress for creating complex tables or presenting 
data in a tabular format. However, the Table Design feature (described in Chapter 3) is often more 
suitable and faster.

To include spreadsheet cells in an Impress slide, you can either insert an existing file  or insert a 
new table.

Inserting a spreadsheet from a file
When you insert an existing spreadsheet into your slide, subsequent changes that are made to the 
original spreadsheet file do not affect your slide. You can,however, make changes to the 
spreadsheet within your slide.

1) Go to the slide where you want to insert the spreadsheet.

2) Choose Insert > Object > OLE Object from the menu bar.

3) On the Insert OLE Object dialog box, choose Create from file . The dialog box changes to 
show a File field. Click Search.

Figure 124: Inserting a spreadsheet file

4) On the Open dialog box, locate the file you want to insert, and then click OK.

5) Choose the Link to file option if you wish to insert the file as a live link.

The entire spreadsheet is inserted into your slide. If the spreadsheet contains more than one sheet 
and the one you want is not visible, double-click the spreadsheet and then select a different sheet 
from the row of sheet tabs at the bottom.

Inserting a blank spreadsheet
To add a blank spreadsheet to a slide:

1) Go to the slide where you want to insert the spreadsheet.

2) Choose Insert > Object > OLE Object from the menu bar.

3) On the Insert OLE Object dialog box, choose Create new and LibreOffice 3.3 
Spreadsheet, then click OK.
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Figure 125: Inserting a blank spreadsheet

This inserts a blank spreadsheet in the center of a slide, as shown in Figure 126. The spreadsheet 
is in edit mode, so you can insert data and modify the formatting. See “Entering data” and 
“Formatting spreadsheet cells” both on page 136.

Figure 126: A spreadsheet in edit mode. Note the active cell and the small  
black resizing handles on the gray border

Editing a spreadsheet
When editing a spreadsheet, some of the items on the menu bar change, as does the Formatting 
toolbar (see Figure 127), to show entries and tools that support working with spreadsheets.

One of the most important changes is the presence of the Formula bar, just below the Formatting 
toolbar. The Formula bar contains (from left to right):

• The active cell reference or the name of the selected range

• The Formula Wizard button

• The Sum and Formula buttons or the Cancel and Accept buttons (depending on the 
contents of the cell)

• A long edit box to enter or review the contents of a cell

If you are familiar with Calc, you will immediately recognize the tools and the menu items since 
they are much the same.
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Figure 127: The menu bar and the formatting toolbar in spreadsheet editing mode

Resizing and moving a spreadsheet
When resizing or moving a spreadsheet, ignore the first row and the first column (easily 
recognizable because of their light gray background) and the horizontal and vertical scroll bars). 
They are only used for editing purposes and will not be included in the visible area of the 
spreadsheet on the slide.

To resize the area occupied by the spreadsheet:

1) Double-click to enter edit mode, if it is not already active. Notice the black handles found in 
the gray border surrounding the spreadsheet (see Figure 126).

2) Move the mouse over one of the handles. The cursor changes shape to give a visual 
representation of the effects applied to the area.

3) Click and hold the left mouse button and drag the handle. The corner handles move the two 
adjacent sides simultaneously, while the handles at the midpoint of the sides modify one 
dimension at a time.

You can move the spreadsheet (change its position within the slide) whether in edit mode or not. In 
both cases:

1) Move the mouse over the border until the cursor changes to a four-headed arrow.

2) Click and hold the left mouse button and drag the spreadsheet to the desired position.

3) Release the mouse button.

When selected, the spreadsheet object is treated like any other object; therefore resizing it 
changes the scale rather than the spreadsheet area. This is not recommended, because it may 
distort the fonts and picture shapes.

Navigating the spreadsheet

How a spreadsheet is organized
A spreadsheet consists normally of multiple tables (called sheets) which in turn contain cells. 
However, in Impress only one of these tables can be shown at any given time on a slide.

The default for a spreadsheet embedded in Impress is one single table called Sheet 1. The name 
of the table is shown at the bottom of the spreadsheet area (see Figure 126).

If required, you can add other sheets. To do that:

1) Right-click on the bottom area near the existing tab.

2) Select Insert > Sheet from the pop-up menu.

Just as in Calc, you can rename a sheet or move it to a different position using the same pop-up 
menu or the Insert menu on the main menu bar.
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Note
Even if you have many sheets in your embedded spreadsheet, only one sheet—the 
one which is active when leaving the spreadsheet edit mode—is shown on the slide.

Each of the sheets is further organized into cells. Cells are the elementary units of the 
spreadsheet. They are identified by a row number (shown on the left hand side on a gray 
background) and a column letter (shown in the top row also on a gray background). For example, 
the top left cell is identified as A1, while the third cell in the second row is C2. All data elements, 
whether text, numbers or formulas, are entered into a cell.

Moving the cursor to a cell
To move around the spreadsheet and select an active cell , you can:

• Use the arrow keys.

• Left-click with the mouse on the desired cell.

• Use the combinations Enter and Shift+Enter to move one cell down or one cell up 
respectively; Tab key and Shift+Tab key to move one cell to the right or to the left 
respectively. 

Other keyboard shortcuts are available to move quickly to certain cells of the spreadsheet. Refer to 
Chapter 5, Getting Started with Calc, in the Getting Started guide for further information.

Entering data
Keyboard input is received by the active cell, identified by a thick black border (see Figure 126 
where cell B3 is active). The cell reference (or coordinates) is also shown on the left hand end of 
the formula bar.

To insert data, first select the cell to make it active, then start typing . Note that the input is also 
added to the main part of the formula bar where it may be easier to read.

Impress will try to automatically recognize the type of contents (text, number, date, time, and so on) 
of a cell and apply default formatting to it. Note how the formula bar icons change according to the 

type of input, displaying Accept and Reject buttons ( ) whenever the input is not a formula. 
Use the green Accept button to confirm the input made in a cell or simply select a different cell. In 
case Impress wrongly recognizes the type of input, you can change it using the toolbar shown in 
Figure 127, or from Format > Cells in the main menu bar.

Tip

Sometimes it is useful to treat numbers as text (for example, telephone numbers) and 
to prevent Impress from removing the leading zeros or right align them in a cell. To 
force Impress to treat the input as text, type a single apostrophe  '  (U + 00B4) before 
entering the number.

Formatting spreadsheet cells
Often, for the purposes of a presentation, it may be necessary to increase the size of the font 
considerably or to match it to the style used in the presentation.

The fastest and most flexible way to format the embedded spreadsheet is to make use of styles. 
When working on an embedded spreadsheet, you can access the cell styles created in Calc and 
use them. However, a better approach is to create specific cell styles for presentation 
spreadsheets, as the Calc cell styles are likely to be unsuitable when working within Impress.
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To apply a style to a cell or group of cells simultaneously (or manually format their cell attributes), 
first select the range to which the changes will apply. A range consists of one or more cells, 
normally forming a rectangular area. A selected range consisting of more than one cell can be 
recognized easily because all its cells are shaded. To select a multiple-cell range:

1) Click on the first cell belonging to the range (either the left top cell or the right bottom cell of 
the rectangular area).

2) Keep the left mouse button pressed and move the mouse to the opposite corner of the 
rectangular area which will form the selected range.

3) Release the mouse button.

To add further cells to the selection, hold down the Control key and repeat the steps 1 to 3 above.

Tip
You can also click on the first cell in the range, hold down the Shift key, and click in 
the cell in the opposite corner. Refer to Chapter 5, Getting Started with Calc, in the 
Getting Started book for further information on selecting ranges of cells.

Some shortcuts are very useful to speed up selection and are listed below:

• To select the whole visible sheet, click on the blank cell between the row and column 
indexes, or press Control+A.

• To select a column, click on the column index at the top of the spreadsheet.

• To select a row, click on the row index on the left hand side of the spreadsheet.

Once the range is selected, you can modify the formatting, such as font size, alignment (including 
vertical alignment), font color, number formats, borders, background and so on. To access these 
settings, choose Format > Cells from the main menu bar (or right-click and choose Format Cells 
from the pop-up menu). This command opens the dialog box shown in Figure 128.

Figure 128: The Format Cells dialog box consists of 7 pages (8 if you have Asian language 
support enabled)
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If the text does not fit the width of the cell, you can increase the width by hovering the mouse over 
the line separating two columns until the mouse cursor changes to a double-headed arrow; then 
click the left button and drag the separating line to the new position. A similar procedure can be 
used to modify the height of a cell (or group of cells).

To insert rows and columns in a spreadsheet, use the Insert menu or right-click on the row and 
column headers and select the appropriate option from the pop-up menu. To merge multiple cells, 
select the cells to be merged and select Format > Merge cells from the main menu bar. To split a 
group of cells, select the group and deselect Format > Merge Cells (which will now have a 
checkmark next to it).

When you are satisfied with the formatting and the appearance of the table, exit edit mode by 
clicking outside the spreadsheet area. Note that Impress will display exactly the section of the 
spreadsheet that was on the screen before leaving edit mode. This allows you to hide additional 
data from view, but it may cause the apparent loss of rows and columns. Therefore, take care that 
the desired part of the spreadsheet is showing on the screen before leaving edit mode.

Tip To get back into edit mode, right click and select Edit.

Inserting a chart

The use of charts is described in detail in Chapter 3, Creating Charts and Graphs, of the Calc 
Guide.

To add a chart to a slide:

1) Select the Insert Chart icon on the slide layout (see Figure 129) or use Insert > Chart, or 

click the Insert Chart icon  on the Standard toolbar.

2) A full-sized chart appears; it contains arbitrary sample data (see Figure 130).

3) To enter your own data in the chart, see “Entering chart data” on page 141.

Figure 129: Slide with a placeholder for inserting objects
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Figure 130: Chart made with sample data

Choosing a chart type
Your data can be presented using a variety of different charts; choose a chart type that best suits 
the message you want to convey to your audience (see “Chart types” on page 140).

To choose a chart type:

1) Double-click the sample chart. The window changes; the side panes are gone and the main 
toolbar shows tools specific for charts. The chart itself now has a gray border. (If the main 
toolbar is not showing, select View > Toolbars > Main Toolbar.)

2) Click the Chart Type icon  or select Format > Chart Type, or right-click on the chart 
and choose Chart Type. The Chart Type dialog box appears.

Figure 131: Chart Type dialog box showing two-dimensional charts
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3) As you change selections in the left-hand list, the chart examples on the right, and the chart 
in the main window, both change. If you move the Chart Type dialog box to one side, you 
can see the full effect in the main window.

4) As you change chart types, other selections become available on the right-hand side. For 
example, some chart types have both three-dimensional and two-dimensional variants; 3D 
charts have further choices of shape for the columns or bars.

5) Choose the chart characteristics you want, and then click OK. The Chart Type dialog box 
closes and you return to the edit window.

Now you can continue to format the chart, add data to the chart, or click outside the chart to return 
to normal view.

Chart types
The following summary of the chart types available will help you choose a type suitable for your 
data. For more detail, see Chapter 3, Creating Charts and Graphs, in the Calc Guide.

Column charts
Column charts are commonly used for data that shows trends over time. They are best for 
charts that have a relatively small number of data points. (For large time series, a line chart 
would be better.) This is the default chart type.

Bar charts
Bar charts are excellent for giving an immediate visual impact for data comparison where time 
is not important, such as comparing the popularity of a few products in a marketplace.

Pie charts
Pie charts are excellent when you need to compare proportions, for example, comparisons of 
departmental spending: what the department spent on different items or what different 
departments spent. They work best with smaller numbers of values, about half a dozen; more 
than this and the visual impact begins to fade.

This is one of the charts that can  be made into a 3D chart. It can then be tilted, given shadows, 
and generally turned into a work of art. You can choose to explode the pie chart, but this is an 
all or nothing option, giving you no control over the degree of separation of the segments.

Area charts
An area chart is a version of a line or column graph. It may be useful where you wish to 
emphasize volume of change. Area charts have a greater visual impact than a line chart, but 
the data you use will make a difference. You may need to use transparency values in an area 
chart.

Line charts
A line chart is a time series with a progression. It is ideal for raw data, and useful for charts with 
plentiful data showing trends or changes over time, where you want to emphasize continuity. 
On line charts, the x-axis is ideal for representing time series data. 3D lines confuse the viewer, 
so just using a thicker line often works better.

Scatter or XY charts
Scatter charts are great for visualizing data that you have not had time to analyze, and they 
may be the best for data when you have a constant value for comparison: for example weather 
data, reactions under different acidity levels, conditions at altitude, or any data which matches 
two numeric series. The x-axis usually plots the independent variable or control parameter 
(often a time series).
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Bubble charts
A bubble chart is used to represent three variables: two identify the position of the center of a 
bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.

Net charts
A net chart is similar to polar or radar graphs. They are useful for comparing data that are not 
time series, but show different circumstances, such as variables in a scientific experiment. The 
poles of the net chart are the y-axes of other charts. Generally, between three and eight axes 
are best; any more and this type of chart becomes confusing.

Stock charts
A stock chart is a specialized column graph specifically for stocks and shares. You can choose 
traditional lines, candlestick, and two-column charts. The data required for these charts is quite 
specialized, with series for opening price, closing price, and high and low prices. The x-axis 
represents a time series.

Column and line charts
A column and line chart is a combination of two other chart types. It is useful for combining two 
distinct but related data series, for example sales over time (column) and the profit margin 
trends (line).

Entering chart data

Opening a chart data window
1) If the chart is not already in edit mode (with a gray border), double-click it. The main toolbar 

now shows tools specifically for charts. (If the main toolbar is not showing, select View > 
Toolbars > Main Toolbar.)

2) Click the Chart Data icon  or select View > Chart Data Table, or right-click on the 
chart and choose Chart Data Table. The Data Table dialog box (Figure 132) appears.

Tip
If you drag the Data Table dialog box so that your chart is visible, you can then 
immediately see the results of each change after clicking in a different cell.

Figure 132: Data Table dialog box
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Entering data
Enter data in the Data Table dialog box. Type or paste information into the boxes within the desired 
rows and columns. 

You can use the buttons in the top left corner for large-scale editing:

• The two Insert buttons insert a row or column (series).

• The Delete buttons remove a selected row or column (series) with its data.

• The Move buttons move the contents of the selected column to the right, or the contents of 
the selected row down.

Adding or removing elements from a chart
The default chart includes only two elements: the chart wall and 
the legend (also known as the key). You can add other elements 
using the Insert menu (Figure 133). The various choices open 
dialog boxes in which you can specify details.

Formatting the chart
The Format menu (Figure 134) has many options for formatting and fine-tuning the look of your 
charts.

Double-click the chart so that it is enclosed by a gray border indicating edit mode, then select the 
chart element that you want to format. Choose Format from the menu bar, or right-click to display 
a pop-up (context) menu relevant to the selected element.

Figure 134: Chart format menu
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The formatting choices are as follows:

• Format Selection opens a dialog box in which you can specify the area fill, borders, 
transparency, characters, font effects, and position of the selected element of the chart.

• Position and Size opens the Position and Size dialog box (see “Resizing and moving the
chart”).

• Arrangement provides two choices: Bring Forward and Send Backward, of which only 
one may be active for specific items. Use these choices to arrange overlapping data series.

• Title formats the titles of the chart and its axes.

• Legend formats the location, borders, background, and type of the legend.

• Axis formats the lines that create the chart as well as the font of the text that appears on 
both the X and Y axes.

• Grid formats the lines that create a grid for the chart.

• Chart Wall, Chart Floor, and Chart Area are described in the following sections.

• Chart Type changes what kind of chart is displayed and whether it is two- or three-
dimensional.

• 3D View formats the various viewing angles of 3D chart.

Note
Chart Floor and 3D View are available only for a 3D chart. These options are 
unavailable (grayed out) if a 2D chart is selected.

A chart has two main areas: the chart wall and the chart area. These control different settings and 
attributes for the chart. Knowing the difference is helpful when formatting a chart.

• Chart wall contains the graphic of the chart displaying the data.

• Chart area is the area surrounding the chart graphic. The (optional) chart title and the 
legend (key) are in the chart area.

Figure 135: The Chart wall and Chart area

Note
Format > Chart Floor is only available for 3D charts and has the same formatting 
options as Chart Area and Chart Wall.
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Resizing and moving the chart
You can resize or move all elements of a chart at the same time, in two ways: interactively, or by 
using the Position and Size dialog box. You may wish to use a combination of both methods.

To resize a chart interactively:

1) Click on the chart to select it. Green sizing handles appear around the chart.

2) To increase or decrease the size of the chart, click and drag one of the corner handles. To 
maintain the correct aspect ratio, hold the Shift key down while you click and drag.

To move a chart interactively:

1) Click on the chart to select it. Green sizing handles appear around the chart.

2) Hover the mouse pointer anywhere over the chart other than on a handle. When it changes 
shape, click and drag the chart to its new location.

3) Release the mouse button when the element is in the desired position.

To resize or move a chart using the Position and Size dialog box:

1) Click on the chart to select it. Green sizing handles appear around the chart.

2) Choose Format > Position and Size from the menu bar, or right-click and choose 
Position and Size from the pop-up menu, or press F4. For more about the use of this 
dialog box, see Chapter 6, Formatting Graphic Objects.

Moving chart elements
You may wish to move or resize individual elements of a chart, independent of other chart 
elements. For example, you may wish to move the legend to a different place. Pie charts allow 
individual wedges of the pie to be moved (in addition to the choice of “exploding” the entire pie).

1) Double-click the chart so that is enclosed by a gray border.

2) Click any of the elements—the title, the legend, or the chart graphic—to select it. Green 
resizing handles appear.

3) Move the pointer over the selected element. When it changes shape, click and drag to 
move the element.

4) Release the mouse button when the element is in the desired position.

Note

If your graphic is 3D, round red handles appear which control the three-dimensional 
angle of the graphic. You cannot resize or reposition the graphic while the round red 
handles are showing. Shift + Click to get back to the green resizing handles. You can 
now resize and reposition your 3D chart graphic. See the following tip.

Tip
You can resize the chart graphic using its green resizing handles (Shift + Click, then 
drag a corner handle to maintain the proportions). However, you cannot resize the 
title or the key.

Changing the chart area background
1) The chart area is the area surrounding the chart graphic, including the (optional) main title 

and key.

2) Double-click the chart so that it is enclosed by a gray border.

3) Select Format > Chart Area.

4) In the Chart Area dialog box, choose the desired format settings.
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Figure 136: Chart Area dialog box

Changing the chart graphic background
The chart wall is the area that contains the chart graphic.

1) Double-click the chart so that it is enclosed by a gray border.

2) Select Format > Chart Wall. The Chart Wall window appears. It has the same formatting 
options as described in “Changing the chart area background” above.

3) Choose your settings and click OK.

Inserting other objects

Impress offers the capability of inserting in a slide various types of objects such as music or video 
clips, Writer documents, Math formulas, generic OLE objects and so on. A typical presentation may 
contain movie clips, sound clips, OLE objects and formulas; other objects are less frequently used 
since they do not appear during a slide show.

This section covers the part of the Insert menu shown in Figure 137: Movie and Sound, and 
Object.

Figure 137: Part of the Insert menu
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Movies and sound
To insert a movie clip or a sound into a presentation:

1) Click the Insert Movie icon on the slide layout (see Figure 129) or choose Insert > Movie 
and Sound from the menu bar.

2) In the Insert Movie and Sound dialog box, select the media file to insert, and click Open to 
place the object on the slide.

Tip

To see a list of audio and video file types supported by Impress, open the drop-down 
list of file types near the bottom of the Insert Movie and Sound dialog box. This list 
defaults to All movie and sound files, enabling you to choose an unsupported type 
such as .MOV.

To insert media clips directly from the Gallery:

1) If the Gallery is not already open, choose Tools > Gallery from the menu bar.

2) Browse to the Theme containing media files (for example the Sounds theme).

3) Click on the movie or sound to be inserted and drag it into the slide area.

The Media Playback toolbar (Figure 138) is automatically opened (by default, at the bottom of the 
screen, just above the Drawing toolbar; it can also be made to float). You can preview the media 
object as well as resize it. If the toolbar does not open, select View > Media Playback.

Figure 138: The media playback toolbar (movie clip)

The Media Playback toolbar contains the following tools:

• Add button: opens a dialog box where you can select the media file to be inserted.

• Play, Pause, Stop buttons: control the media playback.

• Repeat button: if pressed, the media will restart when finished.

• Playback slider: selects the position within the media clip.

• Timer: displays the current position of the media clip.

• Mute Button: when selected, the sound will be suppressed.

• Volume Slider: adjusts the volume of the media clip.

• Scaling drop-down menu: (only available for movies) allows scaling of the movie clip.

The movie will start playing as soon as the slide is shown during the presentation.

Note that Impress will only link the media clip, not embed it. Therefore if the presentation is moved 
to a different computer, the link will be broken and the media clip will not play. To prevent this from 
happening:

1) Place the media file which is to be included in the presentation in the same folder where 
the presentation is stored.

2) Insert the media file in the presentation.

3) Send both the presentation and the the media file to the computer which is to be used for 
the presentation and place both files in the same folder on that computer.

Impress offers the possibility to preview the media clips that are to be inserted by means of the 
embedded media player. To open it select Tools > Media Player. The media player is shown in 
Figure 136. Its toolbar is the same as that of the Media Playback toolbar described above.
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Figure 139: The embedded media player

OLE objects
Use an OLE (Object Linking and Embedding) object to insert in a presentation either a new 
document or an existing one. Embedding inserts a copy of the object and details of the presumed 
source program in the target document; this is the program which is associated with the file type by 
the operating system. The major benefit of an OLE object is that it is quick and easy to edit the 
contents just by double-clicking on it. You can also insert a link to the object that will appear as an 
icon rather than an area showing the contents itself.

To create and insert a new OLE object:

1) Select Insert > Object > OLE object from the main menu. This opens the dialog box 
shown in Figure 125 on page 134.

2) Select Create new and select the object type among the available options.

3) Click OK. An empty container is placed in the slide.

4) Double-click on the OLE object to enter the edit mode of the object. The application 
devoted to handling that type of file will open the object.

Note

If the object inserted is handled by LibreOffice, then the transition to the program to 
manipulate the object will be seamless; in other cases the object opens in a new 
window and an option in the File menu becomes available to update the object you 
inserted.

To insert an existing object:

1) Select Insert > Object > OLE object from the main menu.

2) In the Insert OLE Object dialog box, select Create from file. The dialog box changes to 
look like Figure 124 on page 133.

3) To insert the object as a link, select the Link to file option. Otherwise, the object will be 
embedded.

4) Click Search, select the required file in the file window, then click Open. A section of the 
inserted file is shown on the slide.
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Other OLE objects
Under Windows, the Insert OLE Object dialog box has an extra entry, Further objects.

1) Double-click on the entry Further objects to open the dialog box shown in Figure 140.

Figure 140: Advanced menu to insert an OLE object under Windows
 

2) Select Create New to insert a new object of the type selected in the Object Type list, or 
select Create from File to create a new object from a file.

3) If you choose Create from File, the dialog box shown in Figure 141 opens. Click Browse 
and choose the file to insert. The inserted file object is editable by the Windows program 
that created it.

If instead of inserting an object, you want to insert a link to an object, select the Display As 
Icon checkbox.

Figure 141: Insert object from a file

148 LibreOffice 3.3 Impress Guide



Formulas
Use Insert > Object > Formula to create a Math object in a slide. When editing a formula, the 
main menu changes into the Math main menu.

Care should be taken about the font sizes used in order to make them compatible with the font size 
used in the rest of the slide. To change the font attributes of the Math object, select Format > Font 
Size from the main menu bar. To change the font type, select Format > Fonts from the main menu 
bar.

For additional information on how to create formulas, refer to Chapter 9, Getting Started with Math, 
in the Getting Started guide, or the Math Guide.

Note
Unlike formulas in Writer, a formula in Impress is treated as an object; therefore it 
will not be automatically aligned with the rest of the text. The formula can be 
however moved around (but not resized) like any other object.

Inserting the contents of a file

You can insert the contents of certain files into a presentation. The types of file accepted are 
LibreOffice Draw file, HTML files, or plain text files.

Select Insert > File from the main menu to open a file picker window. If there is an internet 
connection, it is also possible to insert  a URL in the file name field. Select the file and click Insert.
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Introduction

This chapter describes how to add new slides to the presentation and how to format them. It also 
explains how to format both the Notes and Handouts views. Notes are generally used as prompts 
for the person giving the presentation. Handouts are normally used for providing a printout of the 
slides to your audience.

Two pop-up menus are quite useful when performing the operations on the slides described in this 
chapter. One menu (shown in Figure 142) is displayed by right-clicking on a slide in Normal view 
and then selecting Slide. The other menu appears by right-clicking on the slide thumbnail in the 
Slides pane, as shown in Figure 143.

Figure 142: Slide pop-up submenu

Figure 143: (Left) Pop-up menu on the Slides Pane
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Adding, renaming, and removing slides

Adding a new slide
You can add a slide to a presentation in several ways:

• Select Insert > Slide (works in Normal and Outline view).

• Right-click on the Slides pane and select New Slide from the pop-up menu (works in 
Normal, Outline, and Notes view).

• Right-click on the main work area while in Slide Sorter view and select New Slide from the 
pop-up menu.

• On the work area in Normal view, right-click on the active slide and select Slide > New 
Slide.

The new slide is inserted after the current slide or in the position where the mouse was clicked.

If multiple slide masters are used in the presentation, the new slide will apply the master of the 
previous slide in the sequence.

Inserting a slide from another presentation
You can insert slides from other presentations in three ways:

• Using Insert > File. With this method, you can optionally link the slides instead of copying 
(embedding) them into the presentation.

• Copying and pasting.

• Dragging and dropping, to copy or move slides.

To insert a slide from another presentation:

1) In Normal view, select the slide after which you want to insert the new slide, then choose 
Insert > File from the menu bar.

2) In the file browser, locate the file containing the slide that you want to insert, and click 
Insert.

3) In the Insert Slides/Objects dialog box (Figure 144), click the plus sign next to the icon for 
the presentation file, and then select the slides that you want to insert.

Figure 144: Inserting slides from another presentation
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4) Optionally select the Link option.

5) Click OK. The slides are inserted after the selected slide in the presentation.

Tip
Figure 144 highlights the importance of giving descriptive names to the slides in the 
presentation. Refer to “Renaming a slide” on page 153 for the instructions on how to 
perform this operation.

To copy and paste slides between presentations:

1) Open the presentations that you want to copy from and paste into.

2) In the presentation containing the slides that you want to copy, choose View > Slide 
Sorter.

3) Select the slides, and then choose Edit > Copy, or click the Copy button on the main 
toolbar, or press Control+C.

4) Change to the presentation where you want to paste the slides, and then choose View > 
Normal.

5) Select the slide that you want the copied slides to follow, and then choose Edit > Paste, or 
click the Paste button on the main toolbar, or press Control+V.

To move slides between presentations:

1) Open the presentations that move slides between. Arrange the windows so both 
presentations are visible. Choose View > Slide Sorter in each window.

2) In the presentation containing the slides that you want to  move, select the required slides. 
To move the slides, drag and drop them into the other presentation.

Tip
If you hold down the Control key while dragging and dropping, the slide gets copied in 
the target presentation.

Duplicating a slide
Duplicating a slide is a convenient way to add slides, since the new slide will inherit formatting, 
layout and animations from the selected slide. To duplicate a slide:

1) Go to Normal view either by clicking on the tab on the work area or selecting View > 
Normal from the menu bar.

2) Make sure that the slide to be duplicated is on the work area.

3) Select Insert > Duplicate Slide from the menu bar.

The duplicated slide is inserted after the original slide and is displayed in the work area.

Tip
Duplicating a slide is a good way to prevent having slides with too much information 
crowded on them. Try duplicating the “busy” slide and split the points over two or more 
slides. All the formatting, backgrounds, and so on will be preserved.

Renaming a slide
To rename a slide, do one of the following:

• Right-click on the slide thumbnail in the Slides pane or in the main area when in Slide 
Sorter view and select Rename Slide from the pop-up menu.

• In Normal view, right-click on the slide in the work area, then select Slide > Rename Slide 
from the pop-up menu.

In the Rename Slide dialog box, type a new name for the slide and then click OK.
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Expanding a slide
Sometimes you will have a slide with too many sub-points to fit in the space available. Instead of 
reducing the font size or using other methods to squeeze more text into the space, it is usually 
better to subdivide the contents of the slide into two or more slides.

As mentioned in the Tip above, you can duplicate the slide and manually split the points. Another 
way is to “expand” the contents of the slide. To do this:

1) [optional] Duplicate the slide (in case it is needed later).

2) Choose Insert > Expand Slide from the menu bar. Impress creates a new slide for each 
highest level of the outline. The outline text becomes the title of the new slide. Outline 
points below the top level on the original slide are moved up one level on the new slide.

3) If required, repeat steps 2 and 3 on any slide where level 2 entries of the outline exist, to 
expand those as well.

Figure 145 shows a slide with an outline consisting of three high level points and two second-level 
points under bullet point 2. The Expand command has generated three slides, each having as title 
the first level outline and (if present) the second level points in the text area.

Caution For the Expand command to work, ensure that the slide layout contains only one text 
AutoLayout box. If the layout of the slide is not suitable for expansion, the menu item 
is grayed out.

Figure 145: Slide 1 is expanded in slides 2, 3 and 4
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Creating a summary slide
It is also possible to “reverse” the Expand operation to create summaries. The Summary command 
is useful to create an agenda for the presentation.

1) Select the slide that will be the first one to appear in the summary. Do this by clicking on it 
in the Slides Pane or in Slide Sorter view.

2) Select Insert > Summary Slide. Impress creates a new slide at the end of the presentation 
where all the titles of the slides from the following one to the last slide are written as bullet 
points in the body of the slide.

3) Move this slide to wherever you want it to appear in the presentation.

Deleting a slide
To delete a slide, use the most convenient among these methods:

• In Normal, Outline or Slide Sorter view, select a slide and then click Edit > Delete Slide or 
press the Delete key.

• In the Slides Pane (not available in Slide Sorter view) select the slide to be deleted and 
right-click it and select Delete Slide from the pop-up menu, otherwise just select the slide 
and then press the Delete key.

• In Normal view, right-click on the work area, then select Slide > Delete Slide from the 
pop-up menu.

Tip
When working in the Slide sorter view (View > Slide sorter) it is possible to delete 
multiple slides simultaneously by selecting them with the mouse and pressing the 
Delete key.

Creating slides from an outline

When planning a presentation it may be useful to develop an outline using LibreOffice Writer. Once 
the outline is ready, you will probably want to create one or more separate slides for each of the 
top level outline elements. You can do this in several ways:

• Sending the outline from Writer to Impress (creates a new presentation)

• Sending an autoabstract from Writer to Impress (creates a new presentation)

• Copying and pasting the outline from Writer to Impress

Sending an outline from Writer to Impress
If a text document in Writer contains headings formatted with the default Heading paragraph styles, 
you can choose File > Send > Outline to Presentation to create a new presentation containing 
the headings as an outline.

The new presentation opens in Outline view, as shown in Figure 146.

Click on the Normal tab to populate the slides in the Slides pane.

As shown in Figure 147, some outline levels may have too many points to fit on one slide. You can 
expand those slides as described in “Expanding a slide” on page 154, or duplicate the slides and 
manually change their contents, as described in “Duplicating a slide” on page 153.
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Figure 146: Outline created from a Writer document

Figure 147: Slides created from an outline may have too many points to fit the space
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Sending an AutoAbstract from Writer to Impress
To send an AutoAbstract from Writer to Impress, the text must contain headings formatted with the 
default Heading paragraph styles. Use the AutoAbstract feature to copy the headings and a 
number of subsequent paragraphs to a new presentation. You can specify the number of outline 
levels as well as the number of paragraphs displayed.

1) Choose File > Send > AutoAbstract to Presentation.

2) On the Create AutoAbstract dialog box (Figure 148), choose the number of outline levels to 
be copied to the presentation. For example, if you choose 4 levels, all paragraphs 
formatted with Heading 1 to Heading 4 are included, along with the number of paragraphs 
specified in Subpoints per level.

3) The new presentation opens in Outline view. Click on the Normal tab to populate the slides 
in the Slides pane.

4) If an outline has too many points to fit on one slide, see “Expanding a slide” on page 154 or 
duplicate the slides and manually change their contents as described in “Duplicating a
slide” on page 153.

Figure 148: Choosing outline levels for an autoabstract

Copying and pasting an outline
Use this method to add slides from an outline to an existing presentation.

1) Create a new slide and choose the “Title, Content” layout (see “Choosing a
slide layout from the list” on page 160).

2) Paste in the text area the outline created with Writer. Do not worry if the text 
does not fit the space on the slide.

3) When pasting, the hierarchical structure of the outline may be lost. If necessary, use the 

Demote button  on the Text Formatting toolbar to recreate it so that the outline points 
are at the correct hierarchical level.

Tip
It may be useful to open the Style and Formatting window at the Presentation styles 
page to track the outline level of each item.

If some outline levels have too many points to fit on one slide, see “Duplicating a slide” or 
“Expanding a slide” on page 153.
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Modifying slides

Use slide masters to avoid manually changing the formatting of individual slides. Multiple slide 
masters can be used in a single presentation to avoid  modifying slide backgrounds or other 
features.  See Chapter 2 (Slide Masters, Styles, and Templates) for details about using slide 
masters.

Formatting the slide or page area
The Page Setup dialog box (Figure 149) can be used  to set up the page layout for different views 
in Impress such as Notes or Handouts (see pages 163 and 166).

Note

Any changes to the page format (size, margins, orientation, and so on) apply to all 
slides in the presentation. You cannot define more than one page style in Impress, as 
you can in Writer or Calc.

You can change the background of individual slides, as described on page 159.

To start, click the Normal tab in the main work area or select View > Normal in the menu bar. 
Select Format > Page from the menu bar, or right-click and choose Page Setup to open the Page 
Setup dialog box shown in Figure 149. The Page tab has three sections: Paper format, Margins, 
and Layout settings. Settings on this tab affect all slides in the presentation.

Figure 149: The Page Setup dialog box

In the Paper format section, select the preferred Paper format from the drop-down list. The 
dimensions change automatically when a standard format is selected. The list contains selections 
for displaying the slides as well as printing them on paper.

The default values for the Screen settings are optimized for screen presentation (4:3 ratio). If your 
computer uses a wide-screen monitor, you may wish to take advantage of that by selecting the 
User format and editing the Width and Height manually.
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In the Margins section, change the spacing between the edges of the page and the contents of the 
slide.

In the Layout settings section, select the page number format in the Format drop-down list. To 
allow resizing the slide objects and fonts to fit the paper, select the Fit object to paper format 
checkbox.

Printing slides
You can also select the orientation of the slide or paper (Portrait or Landscape) and the paper tray 
to be used. Note that in Impress you cannot specify different trays for different pages (slides), as 
you can in Writer; however, you can specify different trays for printing slides, notes, and handouts. 
This is useful if, for example, you want to print slides on transparencies and handouts on ordinary 
paper. For more about printing presentations, see Chapter 10.

Choosing a slide master from the list
In the Task Pane, select the Master Pages tab.

To apply one of the slide masters to all slides in your presentation, click on it in the list.

To apply a different slide master to one or more selected slides:

1) In the Slide Pane or the Slide Sorter view, select the slides you want to change.

2) In the Task Pane, right-click on the slide master you want to apply to the selected slides, 
and click Apply to Selected Slides on the pop-up menu.

Chapter 2  (Slide Masters, Styles, and Templates) discusses slide masters (also called “master 
slides” and “master pages”) in detail.

Changing the background of a slide
This section describes how to modify the background of a single slide.

Tip
For easy maintenance it is recommended that slide masters are used to modify the 
slides background by creating additional slide masters as required.

Note
Applying a background to individual slides is no different from filling the area of a 
shape. See Chapter 6, Formatting Graphic Objects, for detailed instructions.

To change the background for a slide:

1) Switch to Normal view by clicking the tab in the main work area or select View > Normal.

2) Select the slide you want to change.

3) Select Format > Page from the menu bar, or right-click and choose Slide > Page Setup  to 
open the Page Setup dialog box. Choose the Background tab.

4) Follow the instructions in “Formatting areas” in Chapter 6.

5) Click OK to save the changes. A pop-up message asks if you want to change the 
background on all slides. To change only the selected slide, click No. If you press Yes, 
Impress will apply the new background to all the slides used in the presentation.
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Choosing a slide layout from the list
After creating a new slide, decide what this slide will contain and what layout is most suitable for 
the purpose. Impress offers various types of predefined layouts that can be applied to a slide; 
these layouts are shown in Figure 150.

To apply a layout to a slide:

1) In the Task pane, select the Layouts tab. If the Task pane is not visible, select first View > 
Task Pane.

2) Hover the mouse cursor over the layout thumbnail to get a tooltip with a summary of the 
contents included in the layout.

3) Click on the selected layout to apply it to the slide.

Note
If the layout is changed when the slide already contains contents, Impress will not 
delete the contents but just reposition it according to the chosen layout. This may 
result in slide elements to overlap.

If  these layouts do not fit the presentation style,  the elements can be rearranged on an individual 
slide and duplicated as often as needed by copying to another presentation or saving it as  a 
template.

All the techniques in Chapter 3 (Adding and Formatting Text) for working with text boxes can be 
applied to the Title and AutoLayout text elements of the slide, while the placeholder for images can 
be moved and resized as discussed in Chapter 4 (Adding and Formatting Pictures). Chapter 7 
describes how to include and modify spreadsheets, charts, and other objects.

Figure 150: Automatic layouts for slides
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Adding comments

When creating a presentation in a collaborative environment, it is often useful to add comments to 
the presentation for the benefit of the other people working on it.

To add a comment, switch to Normal view and select the slide where you want the comment to 
appear. Select Insert > Comment from the main menu to display the comment box of Figure 151 
in the top left corner of the slide. Once you are finished typing your comment you can close the 
comment box by clicking anywhere outside the comment box.

Each comment is color coded and marked with the initials of the author as well as a sequential 
number and is shown in the top left corner of the slide in Normal view. Clicking on a comment box 
displays the full text of the comment. The size of the comments box is fixed and scroll bars when 
needed.

Figure 151: Comments text box in action

Editing, deleting and replying to comments
You can only edit the comments if you created them. You can reply to a comment created by a 
different personby selecting the Reply from the comments menu described below.

A limited set of options is available for formatting the comment text; these can be accessed by 
right-clicking on the comment box. Use the pop-up menu to apply one or more font attributes (bold, 
italic, underline, strikethrough) and to paste the contents of the clipboard.

When a comment box is open, you can click on the small triangle pointing down in the lower right 
part of the comments box to display the comments menu shown in Figure 152. Use this menu to 
delete the current comment, delete all the comments from the author of the selected comment, or 
delete all the comments in the presentation. If the comment you opened was created by a different 
author the menu also displays the option to reply to the comment.
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Figure 152: Comments menu

Adding and formatting notes

Notes view provides a convenient way to create reminders or add extra information to the slides in 
the presentation. Notes are not displayed during a slide show, so with the dual monitor support 
feature, you can use notes as a presentation cue. You can also print the notes pages and use 
them as handouts.

Note

If you regularly give presentations in public using a projector, you may want to 
consider installing the Presenter Console, an extension that allows you to display on 
your screen the slide notes, the next slide, and other useful information while only the 
slide is shown through the projector. The extension may be installed with your copy 
of LibreOffice, or you can download it from http://extensions.libreoffice.org/.

Adding notes to a slide
To add notes to a slide:

1) In the Slides pane, select the slide to which you want to add notes.

2) Switch to Notes view by clicking the tab in the main work area or select View > Notes.

Figure 153: The work area in Notes view
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3) Click in the text box showing “Click to add notes” and type or paste text or graphics as 
needed.

4) To add notes to another slide, select it in the Slides pane. The Notes view changes to show 
the selected slide.

5) When done entering notes, return to Normal view.

Formatting notes
It is highly recommended to use the Notes Master and the Notes Presentation style to format the 
appearance of notes, rather than formatting them for each slide individually.

All the formatting guidelines given in this section can be applied to either the Notes Master or to the 
Notes Presentation style.

To open the Notes Master, choose View > Master > Notes Master from the menu bar.

Figure 154: Notes Master View

Formatting the Notes page
To format the Notes page:

1) Switch to Notes view by clicking the tab in the main work area or select View > Notes .

2) Select Format > Page from the menu bar, or right-click and choose Page Setup to open 
the Page Setup dialog box, shown in Figure 153.

3) Set the desired parameters. The Page Setup dialog box for notes is the same as the dialog 
box for slides. Refer to “Formatting the slide or page area” on page 158 for a description of 
this dialog box. The only difference is that by default the Notes page orientation is set to 
portrait and the format is A4.

4) Click OK to close the dialog box.
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Figure 155: The Page Setup dialog box for notes  

Setting automatic layout options
In Notes view, Impress creates four areas  input information about the presentation:

• Header area

• Date and Time area

• Footer area

• Slide number area

To customize these fields, proceed as follows:

1) Switch to Notes view from the corresponding tab in the work area or by selecting View > 
Notes from the main menu, or open the Notes Master (View > Master > Notes Master).

2) Choose Insert > Date and Time for the Date and time. Choose between Fixed (enter in 
the edit box the date and time that should be displayed) or Variable (the date and time of 
the slide creation will be inserted in the notes pages). Use the two drop-down menus to 
select the format of the date and the language.

3) Choose Insert > Page Number from the main menu to display the Header and Footer 
dialog box. Select the Notes and Handouts tab (Figure 156).

4) Select the checkboxes to activate the corresponding areas. For the Header and Footer, 
type the text in the edit fields.

If the Page number checkbox is activated, to format the type of numbering refer to 
“Formatting the Notes page” on page 163).

5) Click the Apply to All button to save these settings and close the dialog box.
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Figure 156: The dialog box to set up header and footer for notes

Text formatting
When text is inserted in the Notes text box, it is automatically formatted using the predefined Notes 
style that you can find in the Presentation styles. The best way to format the notes text is therefore 
to modify this style to suit your needs. Refer to Chapter 2 (Slide Masters, Styles, and Templates) to 
learn how to work with styles.

If manual formatting is required, for example to highlight a particular section of the notes, the 
guidelines given in Chapter 3 (Adding and Formatting Text) apply.

Advanced Notes formatting
You can make other changes to the Notes pages. For example, you can:

• Move the text box and the slide image around the page

• Resize the slide image and text box (only from the Slide Master view).

• Add other text boxes to the page.

Printing notes
1) Choose File > Print from the menu bar.

2) On the Print dialog box, in the Print section of the General tab, select Notes from the 
Document list.

3) Make any other needed changes and then click OK to print.

For more about printing slides, notes, and handouts, see Chapter 10.

Figure 157: Select Notes for printing
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Exporting notes to PDF
1) Choose File > Export as PDF from the menu bar.

2) In the PDF Options dialog box, choose the General tab.

3) Under General, make sure that Export notes pages is checked, and then click OK.

4) In the Export dialog box, give the file and name, select the folder in which to save it, and 
click Export.

Figure 158: Exporting Notes to PDF

The Notes pages follow the presentation in the PDF (that is, if your presentation has 10 slides, the 
PDF contains 20 pages: 10 pages of individual slides, followed by 10 pages with notes formatted 
for paper). If you want only the Notes pages, you will need to use some other program to remove 
the unwanted pages of slides from the PDF.

Creating handouts

A handout is a special view of the presentation suitable to be printed and distributed to the 
audience. Each handout page contains from one to nine thumbnails of the slides so that the 
audience can follow what is presented as well as use it as reference. This section explains how to 
customize the handout page. An example is shown in Figure 155.

Note that the Handout view consists of only one page regardless of the number of slides in the 
presentation or the number of pages of slides that will be printed.

Changing the layout
When creating handouts, first decide how many slide thumbnails you want printed on each 
handout page.

1) Select the Handout view either by clicking on the tab in the work area or by selecting View 
> Handout Page from the menu bar.

2) If the Task pane is not visible, select View > Task Pane from the menu bar.

Tip
As for any other toolbar, you can undock the Task pane by holding down the Control 
key and double-clicking on an empty part of the pane.

166 LibreOffice 3.3 Impress Guide



Figure 159: Example of handout with four slide thumbnails

3) In the Task pane select the Layouts tab, which looks like Figure 154 in Handout view.

4) Choose the preferred layout. The main work area changes to reflect the choice.

Figure 160: Layouts for handouts

Formatting handouts
You can format several aspects of the handout, from the page style to the elements that appear on 
the page. You cannot format individual handout pages; any changes apply to all handouts in the 
presentation file.

Formatting the page
To format the handout pages:

1) Be sure you are in Handouts view. Click the Handouts tab in the work area or select View > 
Handout Page from the menu bar.

2) Select Format > Page from the main menu, or right-click on the handout and select Slide > 
Page Setup from the pop-up menu.
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3) On the Page Setup dialog box (Figure 153 on page 162), set the paper size, orientation 
(portrait or landscape), margins, and other parameters. Click OK.

Setting automatic layout options
In Handout view, as in Notes view, Impress creates four areas where you can put information about 
the presentation:

• Header area

• Date and Time area

• Footer area

• Slide number area

Note
The information in these areas does not show in Handout view, but it does appear 
correctly on the printed handouts.

The way to access and customize these areas is the same as for the Notes and uses the same 
dialog box. Refer to “Setting automatic layout options” on page 164 for information.

Moving thumbnails and adding graphics
You can move (but not resize) the slide thumbnails and add lines, boxes, and other graphic 
elements to the handouts. See Chapter 5 (Managing Graphic Objects) for instructions on using the 
graphics tools.

Tip

After designing a handout, you may wish to save it in a template so you can reuse it 
whenever you want. See “Working with templates” in Chapter 2 (Slide Masters, 
Styles, and Templates) for instructions on saving templates and starting a new 
presentation from a template.

Caution If you click on one of the other handout layouts and then return to the one you have 
reformatted, the slide thumbnails return to their original positions, although any lines 
or other graphics you have added remain where you put them. You will need to move 
the thumbnails back to where you want them.

Printing handouts
1) Choose File > Print from the menu bar.

2) On the General page of the Print dialog box, in the Print section, select Handouts in the 
Document list. Specify the number of slides per page and the order in which to print 
multiple slides.

Figure 161: Select Handouts for printing

3) To select which slides to include in the handouts, in the Range and copies section of the 
General page, select Slides and specify the slide numbers to be included.
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Figure 162: Choose which slides to print

For more about printing slides, notes, and handouts, see Chapter 10.

Exporting handouts to PDF
At present there is no way to export handouts to PDF; if you try, you get the slides (one per page) 
instead. However, you can print to a PostScript file (if you have a suitable printer driver installed) 
and then use another program (such as Ghostscript or Adobe Distiller) to create a PDF from the 
PostScript file.

To create a PostScript file follow the steps below:

1) Choose File > Print.

2) On the Options page, select the Print to file option. The Print button changes to Print to 
File.

Figure 163: Printing to a PostScript file

3) You may see the following message regarding transparencies. Confirm either Yes or No for 
whether transparencies should be reduced. The file will then be created and given an 
extension of .ps.
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Putting together a slide show

LibreOffice Impress gives you the tools to organize and display a slide show, including:
• Which slides to show and in what sequence
• Whether to run the show automatically or manually
• Transitions between slides
• Animations on individual slides
• Interactions: what happens when you click a button or link

Most tasks associated with putting together a slide show are best done in Slide Sorter view. 
Choose View > Slide Sorter from the menu bar or click the Slide Sorter tab at the top of the 
workspace. All of your slides appear in the workspace; you may need to scroll to see them all.

Choosing basic settings for a slide show
Basic settings for a slide show include which slide to start from, the way you advance the slides, 
the type of presentation, and pointer options.

Choose Slide Show > Slide Show Settings. The Slide Show dialog box appears.

Figure 164: Choosing slide show settings

In the Range section, choose which slides to include in the slide show:

• All slides includes all of the slides except for those marked Hidden (see “Hiding slides” on 
page 172). Slides are shown in the sequence they occur in the file. To change the 
sequence, either rearrange the slides in the slide sorter or choose a custom slide show 
(see below).

• From: starts the show at a slide other than the first. For example, you might have several 
slides at the beginning that describe you and your company, but when you present this 
show to your work colleagues, you want to skip that introduction.

• Custom Slide Show shows the slides in a different sequence that you have previously set 
up. This choice is not available until after you set up a custom slide show (see “Showing
slides in a different order” on page 173). You can set up as many different custom shows as 
you wish from one set of slides; they will appear in the drop-down list under this choice.

Chapter 9  Slide Shows 171



In the Type section, choose how the slides will be displayed:

• Default shows the slides full screen, without the LibreOffice program controls visible, and 
exits the show after the last slide.

• Window runs the slide show in the LibreOffice program window and exits the show after 
the last slide.

• Auto restarts the slide show after the last slide. A pause slide is displayed between the last 
slide and the start slide. Press the Esc key to stop the show.

In the box under this choice, specify the length of time before the show restarts. If you enter 
zero, the show restarts immediately without showing a pause slide.

The Show Logo option shows the LibreOffice logo on the pause slide.

In the Options section:

• Change slides manually prevents slides from changing automatically even if an automatic 
transition has been set up.

• Mouse pointer visible shows the mouse pointer during a slide show. If you do not have a 
laser pointer or other device to highlight items of interest during the show, this can be quite 
useful.

• Mouse pointer as pen enables you to write or draw on slides during the presentation. 
Anything you write with the pen is not saved when you exit the slide show. The color of the 
pen cannot be changed.

• Navigator visible displays the Navigator during the slide show. For more about the 
Navigator, see Chapter 1 (Introducing Impress).

• Animations allowed displays all frames of animated GIF files during the slide show. If this 
option is not selected, only the first frame of an animated GIF file is displayed. (This has 
nothing to  do with the slide animations described in “Using slide animation effects” on page 
177.)

• Change slides by clicking on background advances to the next slide when you click on 
the background of a slide. (Other ways of advancing to the next slide include pressing the 
spacebar on the keyboard.)

• Presentation always on top prevents any other program window from appearing on top of 
the presentation.

In the Multiple displays section:

• You can choose which display to use for full screen slide show mode, if the current desktop 
is displayed on more than one monitor. 

• If the current desktop spans only one monitor, or if the multiple-display feature is not 
supported on the current system, you cannot select another display. 

• By default the primary display is used for slide show mode.

Note
This multiple displays setting is not a property saved in the document, but is instead 
saved as a local setting in the user configuration. This means that if you open the 
presentation on a different computer the local settings are applied.

Hiding slides
You may not want to show all of the slides in a particular show. You can either hide some of the 
slides or set up a custom slide show; which method is best depends on your needs. For example, 
you may have draft slides that you do not want to show until they are finished, or you may have 
some slides that contain information for yourself, but not your audience.
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To hide a slide:

1) In the Slides pane, or in Slide Sorter view, select the slides that you want to hide.

2) Click the Show/Hide Slide icon on the Slide View toolbar, right-click and select Hide Slide 
from the context menu, or choose Slide Show > Show/Hide Slide. The slide number is 
now in a box with a diagonal line through it, to indicate that it is hidden. The slide remains in 
the file.

Figure 165: Slide 2 is hidden

To show a hidden slide:

1) In the Slides pane, or in Slide Sorter view, select the hidden slides that you want to show.

2) Click the Show/Hide Slide icon on the Slide View toolbar, right-click and select Show 
Slide from the context menu, or choose Slide Show > Show/Hide Slide.

Showing slides in a different order
To show the slides in a different order, you can either rearrange them in the slide sorter, or set up a 
custom slide show. You can define as many custom slide shows as you need from one set of 
slides. 

In a custom slide show, you can choose which slides to include as well as the order in which they 
are shown. Any slides marked Hidden will not appear in a custom show.

Setting up a custom slide show
To set up a new custom slide show:

1) Choose Slide Show > Custom Slide Show from the menu bar.

2) On the Custom Slide Shows dialog box, click New.

Figure 166: Start here to define or change a custom slide show
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3) On the Define Custom Slide Show dialog box, type a name for the new custom show. Then, 
in the Existing slides list, select the slides to include in the show. Click the >> button to 
include the slides in the Selected slides list. In Figure 167, Title Slide and Slide 4 have 
been included; Slide 2 has been selected but not yet included.

Figure 167: Defining a custom slide show

You can select and include several slides at the same time. Hold down the Shift key and 
click the first and last slide in a group to select that group (for example, slides 3 through 7), 
or hold down the Control key and click on individual slides to select them (for example, 
slides 3, 5, and 9).

Note

If you include several slides at the same time, they are added to the Selected slides 
list in numerical order regardless of the order in which you selected them. In other 
words, if you click on slides 3, 9, and 5 in that order and add them all at the same 
time, they will be included in the Selected slides list in this order: 3, 5, 9. To put them 
in a different order, either select and include them one at a time or select and drag 
them up or down the list. You can also use the Slide Sorter view to rearrange the 
order of slides.

Tip

Slides are added to the Selected slides list after whichever slide is currently 
highlighted in that list. The last slide added is highlighted unless you select a different 
one. For example, you may have added slides 1, 2, 3 and 9, in that order. Slide 9 will 
be highlighted. If you now want to add slide 15 between slides 2 and 3, select slide 2 
in the Selected slides list, then select slide 15 in the Existing slides list and click >>.

You can also add slide 15 at the end of the Selected slides list and then drag it up to 
where you want it in the sequence.

4) When you have finished arranging the order of the slides, click OK to save this custom 
show and return to the Custom Slide Shows dialog box.

5) To activate a custom show, select it in the list in the Custom Slide Shows dialog box and 
then select the Use Custom Slide Show option at the bottom.

Editing, deleting, or copying a custom slide show
To edit a custom slide show (add, remove, or change the order of slides, or change the name of 
the show), select it in the Custom Slide Shows dialog box (Figure 166) and click Edit.
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To delete a custom slide show, select it in the Custom Slide Shows dialog box and click Delete. 
Deletion is immediate; no confirmation message appears.

To create a copy of a slide show, select it in the Custom Slide Shows dialog box and click Copy. 
You can now edit the copy to rename it  and add, remove, or change the order of slides in it.

You can run a custom slide show (for example, to test it) from the Custom Slide Shows dialog box, 
if the Use Custom Slide Show checkbox is selected. Select the slide show from the list and click 
Start.

When you have finished working with custom slide shows, click Close to save all changes and 
close the Custom Slide Shows dialog box.

Using slide transitions

Slide transitions are the effects that take place when one slide gives way to the next one in the 
presentation, like Roll down from top or Fly in from left. They add dynamic flair to a slideshow, 
smoothing the transition between slides.

1) In the Tasks pane, choose Slide Transition.

2) In the Slides pane or Slide Sorter view, select the 
slides to which you want to apply the transition. If you 
want the transition to apply to all slides, you do not 
need to select them first.

3) In the Apply to selected slides list, select a 
transition.

4) Modify the selected transition by changing the speed 
or adding a sound, in the Modify transition area. If you 
choose to play a sound, select it in the Sound list. 
The Loop until next sound  option now becomes 
active. Select this option to play the sound repeatedly 
until another sound starts. If you select this option 
and there are no subsequent sounds in your slide 
show, the sound will play continuously for the 
remainder of the show.

5) Choose next how to advance to the next slide: 
manually (on mouse click) or automatically. If you 
choose automatically, you can specify how long the 
slide remains visible before it automatically advances 
to the next slide.

• If you want the transition to apply to all slides, 
click the Apply to All Slides button.

• To start the slide show from the current slide (so 
you can see all the transitions), click the Slide 
Show button.

6) If the Automatic preview checkbox is marked, the 
effect of a selected transition is immediately displayed 
in the work area. You can replay the effect at any time 
by pressing the Play button.

You can apply a single type of transition to all slides in the presentation or apply a different 
transition to any single slide, even having a different transition for every slide in the show. While 
using many different transitions may be fun to do, it may not give your show a professional 
appearance.
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Tip
If you want most of the slides to have the same transition, but a few to be different, 
you may find it easier to apply one transition to all slides and then change only the 
ones you want to be different.

Setting the timing of automatic slide changes
You can set up a slide show to run automatically, either unattended or while you speak. To set the 
default time for slides to be displayed before changing to the next slide, go to the Slide Transition 
drawer of the Tasks pane (Figure 187), leave the transition effect set to No Transition, choose 
Automatically after in the Advance slide section, set a time, and click the Apply to All Slides 
button.

To vary the timing for some slides, choose Slide Show > Rehearse Timings from the menu bar, or 
click the Rehearse Timings icon on the Slide Show toolbar. The slide show begins in full-screen 
mode, and a timer appears in the lower left-hand corner of the screen.

When you want to advance to the next slide, click the timer. To keep the default setting for this 
slide, click the slide, not the timer. Continue for all slides in your presentation. Impress records the 
display time for each slide. When you next look at the time set under Automatically after, you will 
see that the times have changed to match what you set when rehearsing.

If you want the whole presentation to auto-repeat, open the menu Slide Show > Slide Show 
Settings. Click Auto and OK.

Playing a sound throughout the presentation
You can use the Slide Transition pane to set up Impress so that a sound or a song is played 
throughout the presentation. To do that:

1) Select the slide where you want the sound to start and go to the Slide Transition pane.

2) In the Modify transition section, select the entry Other sound from the Sound drop-down 
menu.

3) Select the Loop until next sound checkbox if you want the sound to restart once it is 
finished.

Caution
Do not click the Apply to all button; otherwise your selected sound will restart at 
every slide.

Note

The sound file is linked to the presentation rather than embedded; therefore if you 
plan to display the presentation on a different machine, remember that you also have 
to make the sound file available on the machine where the presentation will be 
played, and re-establish the link to the local sound file before starting the slideshow.

Removing a transition effect
1) Select the desired slides.

2) Choose No Transition in the list on the Slide Transition page of the Tasks pane.
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Using slide animation effects

Slide animations are similar to transitions, but they are applied to individual elements on a single 
slide—a title, chart, shape, or individual bullet point. Animations can make a presentation more 
lively and memorable. Just as with transitions, heavy use of animations can be fun, but distracting 
and even annoying for an audience expecting a professional presentation.

Animation effects need to be applied from Normal view so that you can select individual objects on 
a single slide.

Note

At present it is not possible to apply animation effects to the slide master elements. 
This means that if you want to display the items in a text box one by one, and use the 
same animation on more than one slide, you need to apply the effects to each slide, 
or alternatively copy the text box from one slide to another.

Applying an animation effect
In Normal view, display the desired slide. Select the text or object you want to animate. An object 
such as a graphic or an entire text box will have green handles around it when selected. If you 
choose only a portion of the text in a text box, you may not see any green handles.

1) In the Tasks pane, choose Custom Animation 
(Figure 169).

2) Click Add. The Custom Animation dialog box 
(Figure 170) appears. Choose an effect from one 
of the pages of this dialog box, and choose the 
speed or duration of that effect. See the example 
on page 179 for some hints on how to combine 
multiple effects.

3) To choose the animation to be applied when the 
object is placed on the screen, use an effect from 
the Entrance page, for example, Fly In or Dissolve 
In.

4) Use the Emphasis page to apply a basic effect, 
such as changing the font color, or to  add special 
effects such as blinking text.

5) To choose the effect to be applied when the object 
is leaving the screen, use the Exit page.

6) If you want the object to move along a line or 
curve, select an animation from the Motion Paths 
page. An example of this type of animation is 
provided in “Example: Setting up a motion path” on 
page 182.

7) Click OK to save the effect and return to the 
Custom Animation page on the Task pane. Here 
you can choose how to start the animation, 
change the speed, and apply some additional 
properties  to the selected effect.

Figure 169: Task pane, showing 
Custom Animation page
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Figure 170: Custom Animation dialog box. Choices may vary depending on the 
selected object; for example, pictures and text have different Emphasis choices.

Starting an animation effect
You have three choices for starting an animation effect:

On click —the animation does not start until you click the mouse.

With previous—the animation runs at the same time as the previous animation.

After previous—the animation runs as soon as the previous animation ends.
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Choosing additional properties of an animation effect
Many animations have a set of properties that you can set or change. For example, if you choose 
the Change Font Color effect on the Emphasis page, you can specify the font color. If you choose 
Fly In on the Entrance page, you can specify the direction from which the object flies in.

The label on the properties box changes depending on the choices available for each effect. For 
example, a Fly In effect has a box labelled Direction and a Change Font Color effect has a box 
labelled Font color.

Example: Using multiple animation effects
To illustrate how you can set up multiple effects, let’s look at a common animation: list items fly in 
one at a time from the bottom of the slide, and as each new item appears, the previous items 
change to a different color. Here is how to create these effects:

Step 1. Apply the “fly in” effect to individual list items.

1) Display the Custom Animation page of the Task pane.

2) Create a slide with several items in a bullet list. Our example slide (Figure 171) has four.

Figure 171: Example slide for multiple animations

3) Select all four items. Click Add on the Custom Animation pane.

4) On the Entrance page of the Custom Animation dialog box (Figure 172), select Fly In, 
optionally change the Speed to Medium, and click OK.

5) The four effects you have just set up are listed in the animations list on the Custom 
Animation page, as shown in Figure 173.
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Figure 172: Choosing an entrance effect

Figure 173: Animation list, showing four items
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Step 2. Apply the “change font color” effect to some list items.

Now we want to set each of the first three list items to change color when the following item 
appears on the slide. To do this:

1) Select the first three items on the slide (not the animations list) and click Add in the Custom 
Animation pane. This time we go to the Emphasis page of the Custom Animation dialog box 
and choose Change Font Color, as shown in Figure 174. Click OK to save this effect.

Figure 174: Choosing an emphasis effect

2) Notice that the three new animations are listed at the bottom of the animations list, and the 
“type of effect” icon for these three effects (in the second column) is different from the icon 
for the first four effects (see Figure 175). 

Figure 175: Animation list after adding a 
second set of animations

3) You could, if you wish, select any of the last three items and choose a different color from 
the Font color list on the Custom Animation pane.

4) Use the Change order: up-arrow button to move each of the last three items up the list to 
just under the other item with the same name. The animation list will now look like Figure
176.
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Figure 176: Animation list after moving items 
into required sequence

Step 3. Change the timing for some list items from With previous to On click

Notice that all of the items on the animations list (except for the two “Point one” items) are set to 
start at the same time as the previous item. However, it is best if when you click to  make the next 
point appear the previous point is dimmed. We will therefore set the color change of the previous 
point and the entrance of the new point to run on mouse click simultaneously.

1) Select the color change animations and choose On click from the Start list, then select the 
entrance animations (except the first) and choose With Previous from the Start list. The 
animation list now looks like Figure 177.

2) Test this set of animations by clicking the Slide Show button.

Figure 177: Final list of animations

Example: Setting up a motion path
The Motion path effect moves an object along a path consisting of a combination of straight and 
curved lines. Several pre-packaged paths are provided in LibreOffice, but it is not difficult to create 
your own custom path. Start by selecting the object you want to animate and selecting a pre-
packaged motion path animation  that is similar to the effect you want to obtain. Alternatively use 
the Polygon or Curve animation to create a new path.

Select the object to show the animation path, which will be displayed as a thin gray line with a 
triangle showing the starting point and another indicating the end point. Click on any point on the 
line so that blue handles are displayed around it. When the blue handles around the path are 
shown, you can move or resize the path  the same way  you would perform these operations on a 
graphic object.

Note
When moving a path, remember to also move  the object on that path; otherwise the 
animation will start with a jump. Currently it is not  possible to rotate a path.
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If instead you want to modify the individual points on the line, select the Points tool  from the 
Drawing toolbar while the path is selected. The Edit Points toolbar of Error: Reference source not
found should be displayed; if not, select it from View > Toolbars > Edit Points.

1  Points 5  Split Curve   9  Symmetric Transition
2  Move Points 6  Convert to Curve 10  Close Bézier
3  Insert Points 7  Corner Point 11  Eliminate Points
4  Delete Points 8  Smooth Transition

Figure 178: Edit Points toolbar

Once a point is selected, you can add an additional point, delete it, move it and so on. For a 
detailed explanation on how to manipulate the points on a curve, see the Draw Guide. Once you 
are satisfied with the shape of the curve and its speed, click anywhere on the screen to deselect 
the object and continue normal editing.

Figure 179 shows a polygon motion path with a curved section.

You can combine a motion with other effects such as spinning or changing of size or colors to 
create dramatic effects.

Figure 179: Object set to move along a polygon and curve path
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Advanced animation effects
Click the Effect Options button [...] next to the Properties drop-down list to display the Effect 
Options dialog box.

Note

What you see in the Effect Options dialog box depends on the selected animation 
object. For example, the dialog box has three pages for text objects but only two 
pages for picture objects (the Text Animation page does not appear). The Settings 
section on the Effect page also varies. Figure 180 shows the Effect page for a 
Direction effect, and Figure 181 shows the Settings section for a Font Color effect. For 
picture objects, the Text animation box on the Effect page is unavailable.

On the Effect page of the Effect Options dialog box (Figures 180 and 181), you can choose a 
sound to play, whether to dim or hide the object after animation, and (in the case of text objects) 
whether to animate the text all at once or word by word or letter by letter.

Figure 180: Effect options settings for a direction effect

Figure 181: Effect options settings for a font color effect

On the Text Animation page of the Effect Options dialog box (Figure 182), you can group text in 
other ways: as one object, all paragraphs at once, or by first-level paragraphs (that is, one list item 
together with its sub-items, if any).
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Figure 182: Text Animation effect options

The choices on the Timing page of the Effect Options dialog box, shown in Figure 183,  allow you 
to change the speed, delay, and other aspects of the effect's timing.

Figure 183: Timing page of Effect Options dialog box

Removing animation effects
1) On the Custom Animation page of the Task pane, select the desired object.

2) Click the Remove button.

Using interactions

Interactions are things that happen when you click on an object in a slide. They are typically used 
with buttons or images, but text objects can also have interactions. Possible interactions include: 
go to previous slide, go to next slide, go to first slide, go to last slide, go to page or object (that is, a 
specific slide or named object in a slide), go to document, play sound, or run a macro.

To apply an interaction to an object (or change an interaction applied to an object), right-click on 
the object and choose Interaction from the pop-up menu. The Interaction dialog box (Figure 184) 
appears. Select an interaction from the Action at mouse click drop-down list.

With some interactions, after you select one, the dialog box changes to offer more choices. For 
example, Figure 185 shows the Interaction dialog box after choosing Go to page or object.
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Tip
A sound interaction can be also applied using the Effect Options dialog box 
(Figure 180).

Figure 184: Dialog box before choosing an interaction

Figure 185: Dialog box after choosing the “Go to page or object” interaction, showing 
choices for the target slide or object

Running a slide show

To run the slide show, do one of the following:

• Press F5 or F9. (F9 does not work on a Mac.)

• Click Slide Show > Slide Show on the main menu bar.

• Click the Slide Show button on the Presentation toolbar or the Slide Sorter toolbar.

If the slide transition is Automatically after x seconds, let the slide show run by itself.

If the slide transition is On mouse click, do one of the following to advance from one slide to the 
next.

• Press the down arrow key, the right arrow key, or the Page Down key on the keyboard.

• Click the left mouse button.

• Press the Spacebar.

To go backwards through the show one slide at a time, press the up arrow key, the left arrow key, 
or the Page Up key. For more complex navigation, use the right-click menu (see below).
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Custom animations on a slide are run in the specified order when performing one of the above 
actions.

When you advance past the last slide, the message Click to exit presentation... appears. Click 
the left mouse button or press any key to exit the presentation.

To exit the slide show and return to the Impress workspace at any time, including at the end, press 
the Esc key.

Navigating using the right-click menu
If your presentation consists of more than one slide, right-clicking anywhere on the screen brings 
up a menu. The choices are:

Next: Moves to the next slide in the defined sequence.

Previous: Move to the previous slide in the defined sequence.

Go to Slide: Displays a submenu allowing to quickly navigate through the presentation. 
Choices on the submenu include First slide, Last Slide, or any slide in the show. This 
illustrates why giving the slides meaningful names, rather than leaving them at the default Slide 
1, Slide 2, and so on, can be very helpful.

Screen: Displays a submenu with two choices. Each choice blanks the screen, showing it as 
either all black or all white. This can be useful if you want to pause the show for awhile 
(perhaps during a break or to demonstrate something on another computer).

End Show: Ends the presentation and returns you to the Impress workspace. This is the same 
effect as pressing the Esc key.

Controlling a slide show using the Presenter Console

Most installations of LibreOffice Impress come with the Presenter Console extension built in. If it is 
not included, you can also get the extension and install it as described in Chapter 11, Setting up 
and Customizing Impress.

The Presenter Console provides extra control over slide shows (presentations) through different 
views on the presenter’s computer screenand on the projection that the audience sees. The 
presenter’s view includes the current slide, the upcoming slide, the slide notes, and a presentation 
timer.

Note
The Presenter Console works only on operating systems that support two displays, 
and only when two displays are connected (one may be the laptop’s built-in screen).

The Presenter Console provides three easily changeable views:

• The first view displays the current slide, including the effects, and the upcoming slide 
(Figure 186).

• The second view shows the speaker's notes in large, scalable type, plus the current and 
upcoming slide (Figure 187).

• The third view is a slide sorter view with the slide thumbnails. Here you can clear on a 
thumbnail to jump to a slide out of sequence (Figure 188).

• Lastly, the presenter can display a set of help notes with navigational and other information 
(Figure 189).
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Figure 186: Default Presenter Console view

Figure 187: View showing speaker's notes
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Figure 188: View showing slide thumbnails

Figure 189: Help for presentations as seen on the Presenter Console
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Introduction

This chapter provides information about printing, exporting, and e-mailing documents from 
LibreOffice Impress.

Quick printing

Click the Print File Directly icon  to send the entire document to the default printer defined for 
your computer.

Note

You can change the action of the Print File Directly icon to send the document to 
the printer defined for the document instead of the default printer for the computer. 
Go to Tools > Options > Load/Save > General and select the Load printer 
settings with the document option.

Controlling printing

Impress provides many options for printing a presentation: with multiple slides on one page, with a 
single slide per page, with notes, as an outline, with date and time, with page name, and more.

For more control over printing a presentation, choose File > Print to display the Print dialog box.

Figure 190. The Print dialog box
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The Print dialog box has four tabs, from which you can choose a range of options, as described in 
the following sections.

Note

The options selected on the Print dialog box apply to this printing of this document 
only.

To specify default printing settings, go to Tools > Options > LibreOffice – Print and 
Tools > Options > LibreOffice Impress – Print. See “Selecting default print options” 
on page 195 for more information.

Selecting general printing options
On the General tab of the Print dialog box (Figure 190), you can choose:

• The printer (from the printers available)

• Which slides to print, the number of copies to print, and whether to collate multiple copies 
(Range and copies section)

• Whether to print slides, notes, handouts, or an outline of the presentation.

• For handouts, how many slides per printed page and in what order (see page 194 for 
details).

Click the Properties button to display a dialog box where you can choose portrait or landscape 
orientation, which paper tray to use, and the paper size to print on.

The Options tab of the Print dialog provides other choices, as shown in Figure 191.

Figure 191: General print options

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

1) In the Print dialog, select the Page Layout tab (Figure 192).

2) In the Layout section, select from the drop-down list the number of pages to print per sheet. 
The preview panel on the left of the Print dialog shows how the printed document will look.

3) When printing more than 2 pages per sheet, you can choose the order in which they are 
printing across and down the paper. The two pictures in Figure 192 show the difference.

4) In the Page sides section, select whether to print all pages or only some pages.

5) Click the Print button.
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Figure 192: Printing multiple pages per sheet of paper

Selecting slides to print
In addition to printing a full presentation, you can choose to print individual slides, ranges of slides, 
or a selection of slides, using the Ranges and copies section of the General page of the Print 
dialog box. 

Be sure Slides is selected in the Document box in the Print section.

Figure 193: Ranges and copies section of Print dialog box

To print an individual slide or several slides, do either of the following:

• Open the Print dialog box, choose the Slides option in the Ranges and copies section, type 
the slide number, and click Print. Multiple slides may be represented by a list (for example 
1,3,7,11) or a range (for example 1-4).

• Select the slide in the Slides pane or the Slide Sorter view, then open the Print dialog box 
and choose Selection in the Ranges and copies section, and click Print.
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Selecting other information to print
On the LibreOffice Impress tab of the Print dialog box, you can choose:

• What to print in addition to the slides: Slide name, date and time, and hidden slides 
(pages).

• Whether to print in color, grayscale, or black and white (on a color printer).

• What size to print slides.

Figure 194: Selecting other information to print

Printing in black and white (on a color printer)
You may wish to print slides in black and white or grayscale on a color printer. To do this, choose 
either Grayscale or Black & white in the Color section on the LibreOffice Impress tab of the Print 
dialog box (Figure 194).

Printing handouts, notes, or outlines in Impress
The Document box also gives you the option of printing Handouts, Notes, or an Outline.

Handouts prints the slides in reduced size on the page, from one to nine slides per page. The 
slides can be printed horizontally (landscape orientation) or vertically (portrait orientation) on the 
page.

Notes prints a single slide per page with any notes entered for that slide in Notes View.

Outline prints the title and headings of each slide in outline format.

To print handouts, notes, or outlines:

1) Choose File > Print from the menu bar.

2) In the Print section of the Print dialog box, select the required option from the Document 
box.
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3) For Handouts, you can then choose how many slides to print per page, and the order in 
which they are printed.

4) Click the Print button.

Figure 195: Printing handouts

Selecting default print options
Selections on the Print dialog box over-ride any default settings. To specify default settings for 
printing, use Tools > Options > LibreOffice Impress > Print.

Other printer settings are found in Tools > Options > LibreOffice > Print, as shown in Figure 194. 
Use this page to specify quality settings for printing, and whether to have Impress warn you if the 
paper size or orientation of your document does not match the printer settings.

See Chapter 11, Setting Up and Customizing Impress, for details.

Printing a brochure

You can print a presentation with two slides on each side of a sheet of paper, arranged so that 
when the printed pages are folded in half, the slides are in the correct order to form a booklet or 
brochure.

To print a brochure on a single-sided printer:

1) Choose File > Print.

2) In the Print dialog, click Properties.

3) Check the printer is set to the same orientation (portrait or landscape) as specified in the 
page setup for your document. Usually the orientation does not matter, but it does for 
brochures. Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog (Figure 196).

5) Select the Brochure option.

6) In the Page sides section, select Back sides / left pages option from the Include drop-down 
list.

Tip If your printer can print double-sided automatically, choose All pages.

7) Click the Print button.

8) Take the printed pages out of the printer, turn the pages over, and put them back into the 
printer in the correct orientation to print on the blank side. You may need to experiment a bit 
to find out what the correct arrangement is for your printer.

9) On the Print dialog, in the Page sides section, select Front sides / right pages option from 
the Include drop down box. Click the Print button.
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Figure 196: Printing a brochure from Impress

Exporting to PDF

Impress can export presentations to PDF (Portable Document Format). This industry-standard file 
format for file viewing is ideal for sending the file to someone else to view using Adobe Reader or 
other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire presentation using the default PDF 
settings. You are asked to enter the file name and location for the PDF file, but you do not get a 
chance to choose a page range or the print quality.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF. The 
PDF Options dialog box opens. This dialog box has five pages, described in this section. Make 
your selections, and then click Export. Then you are asked to enter the location and file name of 
the PDF to be created, and click Save to export the file.

General page of PDF Options dialog box
On the General page, you can choose which pages (slides) to include in the PDF, the type of 
compression to use for images (which affects the quality of images in the PDF), and other options.

Range section
• All: Exports the entire document.

• Pages: To export a range of slides, use the format 3-6 (pages 3 to 6). To export single 
slides, use the format 7;9;11 (slides 7, 9, and 11). You can also export a combination of 
slide ranges and single slides, by using a format like 3-6;8;10;12.

• Selection: Exports whatever material is selected.
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Figure 197: General page of PDF Options dialog box

Images section
• Lossless compression:  Images are stored without any loss of quality. Tends to make 

large files when used with photographs. Recommended for other kinds of images or 
graphics.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% tends to work 
well with photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower-DPI (dots per inch) images have lower quality. For 
viewing on a computer screen generally a resolution of 72dpi (for Windows) or 96dpi 
(GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or 
600 dpi, depending on the capability of the printer. Higher dpi settings greatly increase the 
size of the exported file.

Note
EPS (Encapsulated PostScript) images with embedded previews are exported only 
as previews. EPS images without embedded previews are exported as empty 
placeholders.
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General section
• PDF/A-1: PDF/A is an ISO standard for long-term preservation of documents, by 

embedding all the information necessary for faithful reproduction (such as fonts) while 
forbidding other elements (including forms, security, and encryption). PDF tags are written. 
If you select PDF/A-1, the forbidden elements are grayed-out (not available).

• Tagged PDF: Tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens, and 
when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form - Submit format: Choose the format of submitting forms from within the 
PDF file. This setting overrides the control’s URL property that you set in the document. 
There is only one common setting valid for the whole PDF document: PDF (sends the 
whole document), FDF (sends the control contents), HTML, and XML. Most often you will 
choose the PDF format.

• Export bookmarks: Exports slide names as “bookmarks” (a table of contents list displayed 
by some PDF readers, including Adobe Reader).

• Export comments: Exports comments as PDF notes. You may not want this!

• Export notes pages: Exports a set of Notes pages after the set of slides.

• Export automatically inserted blank pages: Not used in Impress.

• Embed standard fonts: Normally the 14 standard PostScript fonts are not embedded in a 
PDF file, because PDF reader software already contains these fonts. However, you can 
choose to embed these fonts in all PDF documents created by LibreOffice to enhance 
display accuracy in PDF viewers. Font embedding may also be required by some printers.

• Create hybrid file: When the PDF Import Extension is installed, this option exports the 
document as a .PDF file containing two file formats: PDF and ODP.

Initial View page of PDF Options dialog box
On the Initial View page, you can 
choose how the PDF opens by 
default in a PDF viewer. The 
selections should be self-
explanatory.

If you have Complex Text Layout 
enabled (in Tools > Options > 
Language settings > 
Languages), an additional 
selection is available under 
Continuous facing: First page is 
left (normally, the first page is on 
the right when using the 
Continuous facing option).
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User Interface page of PDF Options dialog box
On the User Interface page, you can choose more settings to control how a PDF viewer displays 
the file. Some of these choices are particularly useful when you are creating a PDF to be used as a 
presentation or a kiosk-type display.

Figure 199: User Interface page

Window options section
• Resize window to initial page. Causes the PDF viewer window to resize to fit the first 

page of the PDF.

• Center window on screen. Causes the PDF viewer window to be centered on the 
computer screen.

• Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a 
smaller window.

• Display document title. Causes the PDF viewer to display the document’s title in the title 
bar.

User interface options section
• Hide menubar. Causes the PDF viewer to hide the menu bar.

• Hide toolbar. Causes the PDF viewer to hide the toolbar.

• Hide window controls. Causes the PDF viewer to hide other window controls.

Transitions section
Includes Impress slide transition effects as the respective PDF effects.

Bookmarks section
Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected on 
the General page.
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Links page of PDF Options dialog box
On the Links page, you can choose how links are exported to PDF.

Figure 200: Links page of PDF Options dialog box

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this 
option exports them as “named destinations” to which Web pages and PDF documents can 
link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as 
.ODT, .ODS, and .ODP), this option converts the files names to .PDF in the exported PDF 
document.

Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files.

Security page of PDF Options dialog box
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and 
apply some digital rights management (DRM) features.

Note Permission settings are effective only if the user’s PDF viewer respects the settings.

• With an open password set, the PDF can only be opened with the password. Once opened, 
there are no restrictions on what the user can do with the document (for example, print, 
copy, or change it).

• With a permission password set, the PDF can be opened by anyone, but its permissions 
can be restricted. See the options on Figure 195.

• With both the open password and permission password set, the PDF can only be opened 
with the correct password, and its permissions can be restricted.

Figure 197 shows the pop-up dialog box displayed when you click the Set passwords button on 
the Security page of the PDF Options dialog box.

After you set a permission password, the other choices on the Security page (shown in Figure 195) 
become available. These selections should be self-explanatory.
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Figure 201: Security page

Figure 202: Setting a password to encrypt a PDF
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Exporting as a Flash file

Macromedia Flash file format (.SWF) was created to store animation for web pages. Because 
almost all browsers play Flash movies (the Adobe Flash Player is available as a free download for 
those without Flash-capable browsers), these files can be viewed by just about anyone. With 
LibreOffice, you can export your Impress slide show as a .SWF file. To download the latest Adobe 
Flash Player for your operating system, go to: http://www.adobe.com/products/flashplayer/

Note Saving in Flash format does not retain animation and slide transitions.

To export the presentation as a Flash (.SWF) file:

1) Choose File > Export.

2) Select the location where you want the file saved and type a name for the file.

3) Under File Format, choose Macromedia Flash (SWF) (.swf) and click Save.

Exporting as web pages (HTML files)

You can export presentations as a series of web pages that can be viewed in any browser.

Note Saving as web pages (HTML format) does not retain animation and slide transitions.

1) Select File > Export and choose HTML Document as the file type.

2) Create a folder for the files, supply a name for the resulting HTML file, and click Save. The 
HTML Export Wizard opens.

Figure 203: HTML Export – Choose a design

3) Choose a design for all of the pages, either from an existing design or by creating a new 
one. If you have not previously saved a design, the Existing Design choice is not available.
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4) Click Next to select the type of web pages to create.

• Standard HTML: one page for each slide, with navigation links to move from slide to slide.
• Standard HTML with frames: one page with a navigation bar on the left-hand side; 

uses slide title as navigation links. Click on links to display pages in right-hand side.

• Automatic: one page for each slide, with each page set with the Refresh meta tag so a 
browser automatically cycles from one page to the next.

• WebCast: generates an ASP or Perl application to display the slides. Unfortunately 
LibreOffice has no direct support for PHP yet.

Figure 204: HTML Export – Choose publication type

5) Decide how the images will be saved (PNG, GIF or JPG) and what resolution to use. When 
choosing a resolution, consider what the majority of your viewers might have. If you use a 
high resolution, then a viewer with a medium-resolution monitor will have to scroll sideways 
to see the entire slide—probably not desirable.

Figure 205: HTML Export – Choose graphics type

6) If Create title page was chosen in step 4, supply the information for it on the next page. The 
title contains an author name, e-mail address and home page, along with any additional 
information you want to include.

This page of the Wizard does not display if Create title page was not chosen.
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Figure 206: HTML Export – Title page information

7) Choose the navigation button style to use to move from one page to another. If you do not 
choose any, LibreOffice will create a text navigator.

Figure 207: HTML Export – Choose navigation style

8) Select the color scheme for the web pages. Available schemes include the document’s 
existing scheme, one based upon browser colors, and a completely user-defined scheme. 
You can save a new scheme so that it will appear on the first page of the HTML export 
wizard.
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Figure 208: HTML Export – Choose color scheme

9) Click Create to generate the HTML files. If this is a new design, a small dialog box pops up. 
If you might want to reuse this design, you can give it a name and save it. Otherwise, click 
Do Not Save.

Figure 209: Naming the design

E-mailing a presentation

LibreOffice provides several ways to quickly and easily send a Writer document as an e-mail 
attachment in one of three formats: .ODP (OpenDocument Presentation, LibreOffice’s default 
format), .PPT (Microsoft PowerPoint format), or PDF.

To send the current document in .ODP format:

1) Choose File > Send > Document as E-mail. LibreOffice opens a new e-mail in your 
default e-mail program. The document is attached.

2) In your e-mail program, enter the recipient, subject and any text you want to add, then send 
the e-mail.

File > Send > E-mail as OpenDocument Presentation has the same effect.

If you choose E-mail as Microsoft PowerPoint Presentation, LibreOffice first creates a .PPT file 
and then opens your e-mail program with the .PPT file attached. The .PPT file is not saved on your 
computer.

Similarly, if you choose E-mail as PDF, LibreOffice first creates a PDF using your default PDF 
settings (as when using the Export Directly as PDF toolbar button) and then opens your e-mail 
program with the .PDF file attached. The PDF file is not saved on your computer.
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Tip
If you want to keep a copy of the .PPT or .PDF file as well as e-mailing it to someone, 
first save or export the presentation into the required format, then attach it to an e-mail 
in the usual way.

Digital signing of documents
To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the 
document’s content plus your personal key. The checksum and your public key are stored together 
with the document. 

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. In addition, 
the program can show you the public key information from the certificate. You can compare the 
public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On 
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For 
a more detailed description of how to get and manage a certificate, and signature validation, see 
“Using Digital Signatures” in the LibreOffice Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If you have not saved the document since the last change, a message appears. Click Yes 
to save the file.

3) After saving, you see the Digital Signatures dialog box. Click Add to add a public key to the 
document.

4) In the Select Certificate dialog box, select your certificate and click OK.

5) You see again the Digital Signatures dialog box, where you can add more certificates if you 
want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon to view the 
certificate.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn) 
you when files contain certain information and remove personal information automatically when 
saving the file or when creating a PDF.

To remove personal and some other data from a file, go to File > Properties. On the General tab, 
uncheck Apply user data and then click the Reset button. This removes any names in the created 
and modified fields, deletes the modification and printing dates, and resets the editing time to zero, 
the creation date to the current date and time, and the version number to 1. Be sure to click OK to 
save the changes.
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Opening and saving a PowerPoint file

LibreOffice’s Impress file format is highly compatible with Microsoft’s PowerPoint format. You can 
open a PowerPoint presentation in Impress, edit it, then save it in its original PowerPoint format or 
in Impress’s OpenDocument Presentation format. You can also create a new presentation in 
Impress and save it as a PowerPoint file.

Caution There are some differences between OpenDocument (.odp) and PowerPoint (.ppt, 
.pptx) files in text and graphics formatting, animations, transitions, and fields. For 
best results, avoid using features that are not fully supported in both formats.

Saving an Impress file as a PowerPoint file
1) Choose  File > Save As from the menu bar.

2) Select the location where you want the PowerPoint file saved and type a name for the file.

3) Under File type, choose Microsoft PowerPoint 97/2000/XP (.ppt) or Microsoft 
Powerpoint 2007 XML (.pptx).

4) Click Save. If you have the “Warn when not saving in ODF or default format” option set in 
Options > Load/Save > General, the message shown in Figure 193 appears. Click Keep 
Current Format to confirm that you want to save the file in Microsoft PowerPoint format. 
You can deselect the Ask when not saving in ODF format checkbox to not show the 
message again unless you re-enable it in the Options.

Figure 210: Warning message when saving in Microsoft PowerPoint format

Tip

Always save your work in Impress OpenDocument format (.odp) before saving in 
Microsoft format. Keep the Impress file as your working copy: if you need to change 
the presentation, change it in the Impress version and then save it again as 
PowerPoint. You are much less likely to have problems than if you open a file 
previously saved in PowerPoint format, edit it, and save it again.

Opening a PowerPoint file in Impress
If you receive a file from someone in PowerPoint format and need to edit it in Impress, here is how:

1) In LibreOffice, choose File > Open from the menu bar.

2) Under File type, choose All files (*.*) or Presentations or Microsoft PowerPoint 97/2000/XP 
from the drop-down list.

3) Navigate to the PowerPoint file, select it, and click Open.

The PowerPoint file can now be edited and saved as an Impress file or a PowerPoint file. To save 
the file as an Impress file, choose OpenDocument Presentation (.odp) as the File Type.
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Choosing options that affect all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice and are of 
most interest to users of Impress. Other general options are discussed in Chapter 2, Setting Up 
LibreOffice, in the Getting Started guide.

1) Click Tools > Options (LibreOffice > Preferences on a Mac). The list on the left-hand 
side of the Options – LibreOffice dialog box varies depending on which component of 
LibreOffice is open. The illustrations in this chapter show the list as it appears when 
Impress is open.

2) Click the expansion marker (+ or triangle) by LibreOffice on the left-hand side. A list of 
subsections drops down.

Figure 211: LibreOffice options

Note
The Back button has the same effect on all pages of the Options dialog box. It resets 
the options to the values that were in place when you opened LibreOffice.

User Data options
Impress uses the first and last name stored in the User Data page to fill in the Created by and 
Modified by fields in the document properties, the optional Author field often used in the footer of a 
presentation, and the name associated with comments. You will want to ensure that your name 
appears there. To do this:

1) In the Options dialog box, click LibreOffice > User Data.

2) Fill in the form on the LibreOffice – User Data page or delete any existing incorrect 
information.

Print options
On the LibreOffice – Print page, set the print options to suit your default printer and your most 
common printing method. 

You can change these settings at any time, either through the Options dialog box or during the 
printing process (by clicking the Options button on the Print dialog box).

See Chapter 10, Printing, e-mailing, exporting, and saving slide shows, for more about the options 
on this page.
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Color options
On the LibreOffice – Colors page, you can specify colors to use in LibreOffice documents. You can 
select a color from a color table, edit an existing color, and define new colors. These colors are 
stored in your color selection palette and are then available in all components of LibreOffice. You 
can also define colors within Impress by choosing Format > Area on the menu bar, or through the 
Line and Filling toolbar, but those colors will not be available to other components of LibreOffice.

Figure 212. Defining colors to use in color palettes in LibreOffice

Appearance options
On the LibreOffice – Appearance page, you can specify which items are visible and the colors used 
to display various elements of the user interface.

Figure 213. Changing the color of grid points in Impress and Draw

The only choice specific to Impress (and Draw) is the color of the grid points. Scroll down in the 
page until you find Drawing/Presentation.

To change the default color for grid points, click the down-arrow by the color and select a new color 
from the pop-up box.

If you wish to save your color changes as a color scheme, click Save, type a name in the Scheme 
box, then click OK.
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Choosing options for Impress

In the Options dialog box, click the expansion marker to the left of LibreOffice Impress on the left-
hand side. A list of subsections drops down.

Figure 214: Options for Impress

General options
In the Options dialog box, click LibreOffice Impress > General.

Figure 215: Specifying general options for Impress

Text objects section
Allow quick editing sets Impress to immediately switch to the text editing mode when you click a 

text object. You can also activate the text editing mode through the Allow Quick Editing icon  
on the Options toolbar.
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Only text area selectable sets Impress to select a text frame when you click on text. In the area of 
the text frame that is not filled with text, an object behind the text frame can be selected. You can 

also activate this mode through the Select Text Area Only icon  on the Options toolbar.

New document section
Start with Wizard sets Impress to start with the Presentation Wizard when creating a new 
presentation with File > New > Presentation or other methods.

Settings section
Use background cache sets Impress to use the cache for displaying objects on the master page. 
This setting speeds up the display. Unmark this box if you want Impress to draw the background 
every time you display a slide.

y when moving automatically creates a copy when you move, rotate or resize an object while 
holding down the Ctrl key (  key for Mac)⌘ . The original object will remain in its current position and 
size.

Objects always movable lets you move an object with the Rotate tool enabled. If this box is not 
marked, the Rotate tool can only be used to rotate an object.

Unit of measurement determines the unit of measurement for presentations.

Tab stops defines the spacing between tab stops.

Start presentation section
Always with current page specifies that a presentation starts with the current slide. Unmark this box 
to always start a presentation with the first page.

Compatibility section
The settings in this area are valid for the current document only.

Use printer metrics for document formatting applies printer metrics for printing and for formatting 
the display on the screen; some formatting will depend on the printer selection or default printer on 
your computer and may vary if the presentation is moved to a different computer. If this box is not 
checked, a printer-independent layout is used for screen display and printing.

Add spacing between paragraphs (in current document) calculates the paragraph spacing in 
Impress exactly as Microsoft PowerPoint does. Microsoft PowerPoint adds the bottom spacing of a 
paragraph to the top spacing of the next paragraph to calculate the total spacing between both 
paragraphs. Impress normally uses only the larger of the two spacings.

View options
In the Options dialog box, click LibreOffice Impress > View.

Figure 216: Specifying view options for Impress
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Rulers visible displays the rulers at the top and the left of the work area.

Guides when moving displays dotted guides that extend beyond the box containing the selected 
object and which cover the entire work area, helping you position the object when moving it. You 

can also use the Guides when moving icon  on the Options toolbar.

All control points in Bézier editor displays the control points of all Bézier points if you have 
previously selected a Bézier curve. If this box is not marked, only the control points of the selected 
Bézier points will be visible.

Contour of each individual object displays the contour line of each individual object when moving 
the object. This enables you to see if single objects conflict with other objects in the target position. 
If you do not mark this box, Impress displays only a square contour that includes all selected 
objects.

Grid options
The Grid page defines the grid settings for Impress. Using a grid helps you determine the exact 
position of your objects. You can also set this grid in line with the snap grid.

In the Options dialog box, click LibreOffice Impress > Grid.

Figure 217: Specifying grid options for Impress

Grid section
Snap to grid activates the “snap” function.

If you have activated the snap grid but wish to move or create individual objects without snap 
positions, you can press the Ctrl key to deactivate the snap grid for as long as needed.

Visible grid displays grid points on the screen. These points will not display or print as part of a 
presentation.

Chapter 11  Setting Up and Customizing Impress 213



Resolution section
Here you can set the unit of distance for the spacing between horizontal and vertical grid points 
and subdivisions (intermediate points) of the grid.

Synchronize axes applies any changes to the Resolution or Subdivision settings to both axes.

Snap section
To snap lines snaps the edge of a dragged object to the nearest snap line when you release the 

mouse button. You can also use the Snap to Guides icon  on the Options toolbar.

To the page margins aligns the contour of the graphic object to the nearest page margin. The 
cursor or a contour line of the graphic object must be in the snap range. You can also use the 

Snap to Page Margins icon  on the Options toolbar.

To object frame aligns the contour of the graphic object to the border of the nearest graphic object. 
The cursor or a contour line of the graphic object must be in the snap range. You can also use the 

Snap to Object Border icon  on the Options toolbar.

To object points aligns the contour of the graphic object to the points of the nearest graphic object. 
The cursor or a contour line of the graphic object must be in the snap range. You can also use the 

Snap to Object Points icon  on the Options toolbar.

Snap range defines the snap distance between the mouse pointer and the object contour. Impress 
snaps to a snap point if the mouse pointer is nearer than the distance selected in the Snap range 
box.

Snap position section
When creating or moving objects restricts graphic objects vertically, horizontally or diagonally (45°) 
when creating or moving them. You can temporarily deactivate this setting by pressing the Shift 
key.

Extend edges controls how a square or circle is drawn with the drawing tool.  When the Extend 
edges box is marked, the sides of the square drawn when the Shift key is pressed before you 
release the mouse button will be equal to the longer side of a rectangle. This also applies to the 
ellipse tool: when the Shift key is pressed before you release the mouse button a circle will be 
created based on the longest diameter of the ellipse. When the Extend edges box is not marked, 
a square or a circle will be created based on the shorter side or diameter.

When rotating restricts the rotation of graphic objects within the rotation angle that you select in the 
When rotating box. If you want to rotate an object outside of the defined angle, press the Ctrl key 
(Shift key on Mac) when rotating. Release the key when the desired rotation angle is reached.

Point reduction defines the angle for point reduction. When working with polygons, you might find it 
useful to reduce their editing points.

Print options
In the Options dialog box, click LibreOffice Impress > Print.

See Chapter 10, Printing, e-mailing, exporting, and saving slide shows, for more about the options 
on this page.
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Figure 218: Specifying print options for Impress

Customizing the user interface

Customizing the menu font
If you want to change the menu font from that supplied by LibreOffice to the system font for your 
operating system, do this:

1) Choose Tools > Options > LibreOffice > View.

2) Check Use system font for user interface and click OK.

Customizing menu content
You can customize menus: add and rearrange items on the menu bar, add items to menus, and 
make other changes.

1) Choose Tools > Customize.

2) On the Customize dialog box, pick the Menus page.

3) In the Save In drop-down list, choose whether to save this changed menu for Impress or 
for a selected document (for example, MySlideShow.odp).

4) In the section LibreOffice Impress Menus, select from the Menu drop-down list the menu 
that you want to customize.

5) To customize the selected menu, click on the Menu or Modify buttons. You can also add 
commands to a menu by clicking on the Add button. These actions are described in the 
following sections. Use the up and down arrows next to the Entries list to move the 
selected menu item to a different position.

6) When you have finished making all your changes, click OK to save them.
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Figure 219. The Menus page of the Customize dialog box

Creating a new menu
In the Menus page of the Customize dialog box, click New to display the dialog shown in Figure
211.

1) Type a name for your new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into the required position on 
the menu bar.

3) Click OK to save.

The new menu now appears on the list of menus in the Customize dialog box. (It will appear on the 
menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 217.
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Figure 220: Adding a new menu

Modifying existing menus
To modify an existing menu, select it in the Menu list and click the Menu button to drop down a list 
of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the 
entries in the Menu list. For example, Rename and Delete are not available for the menus supplied 
by LibreOffice.

To move a menu (such as File), choose Menu > Move. A dialog box similar to the one shown in 
Figure 211 (but without the Menu name box) opens. Use the up and down arrow buttons to move 
the menu into the required position.

To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in 
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the 
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list 
by a small black triangle on the right hand side of the name.

In addition to renaming, you can specify a keyboard shortcut that allows you to select a menu 
command when you press Alt+ an underlined letter in a menu command.

1) Select a menu or menu entry.

2) Click the Modify button and select Rename.

3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to 
select the Save All command by pressing Alt+V (after opening the File menu using Alt+F), 
enter Sa~ve All.

Caution Be careful when using these shortcuts. In the example above, if the File menu is 
not already open, then pressing Alt+V opens the View menu; if some other menu is 
open, Alt+V might activate some other command.

Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. In the Customize 
dialog box, select the menu in the Menu list and click the Add button in the Menu Content section 
of the dialog.
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On the Add Commands dialog, select a category and then the command, and click Add. The 
dialog remains open, so you can select additional commands. When you have finished adding 
commands, click Close. Back in the Customize dialog box, you can use the up and down arrow 
buttons to arrange the commands in your preferred sequence.

Figure 221: Adding a command to a menu

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

To begin, select the menu or submenu in the Menu list near the top of the Customize page, then 
select the entry in the Entries list under Menu Content. Click the Modify button and choose the 
required action from the drop-down list of actions. Most of the actions should be self-explanatory. 
Begin a group adds a separator line after the highlighted entry.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible, and 
locking the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice, of the 
Getting Started guide. This section describes how to create new toolbars and add other icons 
(commands) to the list of those available on a toolbar.

To get to the toolbar customization dialog, do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize > Toolbars tab from the menu bar.
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Figure 222. The Toolbars page of the Customize window

To customize toolbars:

1) In the Save In drop-down list, choose whether to save this changed toolbar for Impress or 
for a selected document.

2) In the LibreOffice Impress Toolbars section, select from the Toolbar drop-down list the 
toolbar that you want to customize.

3) Click the Toolbar button on the right to display a drop-down list of choices.

4) To display or hide commands, select or deselect the checkboxes in the Toolbar Content – 
Commands section.

5) To change the position of commands on a toolbar, select a command and click the big up 
and down arrows to the right of the lists.

6) You can create a new toolbar by clicking on the New button, or customize existing toolbars 
by clicking on the Toolbar or Modify buttons, and add commands to a toolbar by clicking on 
the Add button. These actions are described below.

7) When you are done customizing toolbars, click OK to save your changes.
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Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.

2) Click New. In the Name dialog, type the new toolbar's name and choose from the Save In 
drop-down list where to save this changed menu: for Impress or for a selected document.

Figure 223: Dialog box used to create a new toolbar

The new toolbar now appears on the list of toolbars in the Customize dialog box. After creating a 
new toolbar, you need to add some commands to it, as described below.

Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that 
toolbar, you can add commands.

1) On the Toolbars page of the Customize dialog box, select the toolbar in the Toolbar list and 
click the Add button in the Toolbar Content section of the dialog.

2) The Add Commands dialog is the same as for adding commands to menus. Select a 
category and then the command, and click Add. The dialog remains open, so you can 
select additional commands. When you have finished adding commands, click Close. If 
you insert an item which does not have an associated icon, the toolbar will display the full 
name of the item; the next section describes how to choose an icon for a toolbar command.

3) Back on the Customize dialog box, you can use the up and down arrow buttons to arrange 
the commands in your preferred sequence.

4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the 
Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign 
it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the 
Import button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in size 
and cannot contain more than 256 colors.
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Figure 224: Change Icon dialog

Customizing keyboard shortcuts 
The Appendix to this book lists the default keyboard shortcuts supplied with Impress. You can 
change these defaults or add new shortcuts. You can assign shortcuts to standard Impress 
functions or your own macros and save them for use with Impress only, or with the entire 
LibreOffice suite.

Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined 
shortcut keys. Many key assignments are universally understood shortcuts, such as 
F1 for Help, and are always expected to provide certain results. Although you can 
easily reset the shortcut key assignments to the LibreOffice defaults, changing some 
common shortcut keys can cause confusion, frustration and possible data loss or 
corruption, especially if other users share your computer.

As an example, suppose you wish to assign a shortcut key to easily insert a duplicate slide in your 
presentation. You could assign the Insert key as a logical shortcut for this purpose, as described 
below:

1) Choose Tools > Customize.

2) On the Customize dialog box, pick the Keyboard page (Figure 213).

3) As the shortcut key assignment is only relevant with Impress, and not LibreOffice in 
general, select the Impress button (at the upper right corner of the Keyboard tab).

4) Next select Insert in the Category list and Duplicate Slide in the Function list.

5) Now select the shortcut key Insert in the Shortcut keys list and click the Modify button at 
the upper right.

6) Click OK to accept the change. Now the Insert shortcut key will insert a duplicate slide 
immediately after the currently selected slide.
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Figure 225: Customizing keyboard shortcuts

Note

All existing shortcut keys for the currently selected Function are listed in the Keys 
selection box. Since there was no currently assigned shortcut for the 
Insert > Duplicate Slide function the Keys list was empty. If it had not been, and you 
wished to reassign a shortcut key combination that was already in use, you would 
first have had to Delete the existing Key.

Shortcut keys that are greyed out in the listing on the Customize dialog box, such as 
F1 and F10, are not available for reassignment.

Saving changes to a file
Changes to the shortcut key assignments (and other configurations) can be saved in a keyboard 
configuration file for use at a later time, thus permitting you to create and apply different 
configurations as the need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button near the bottom 
right of the Customize dialog box.

2) In the Save Keyboard Configuration dialog box, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an 
existing file from the list. If you need to, browse to find a file from another location.
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4) Click Save. A confirmation dialog box will appear if you are about to overwrite an existing 
file; otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button near the bottom right of the Customize dialog box, and then select the configuration file from 
the Load Keyboard Configuration dialog box.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button beneath the 
Save button on the right side of the Customize dialog box. Use this feature with care as no 
confirmation dialog box will be displayed; the defaults will be set without any further notice or user 
input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly 
user-defined; none are built in. For information on macros, see Chapter 13, Getting started with 
macros, in the Getting Started guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality.

Although individual extensions can be found in different places, the official LibreOffice extension 
repository is at http://extensions.libreoffice.org/. Some extensions are free of charge; others are 
available for a fee. Check the descriptions to see what licenses and fees apply to the ones that 
interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension 
Manager dialog box (Figure 212), click Add.

3) A file browser window opens. Find and select the extension you want to install and click 
Open. The extension begins installing. You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip
To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions here link.

Note
To install a shared extension, you need write access to the LibreOffice installation 
directory. 
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Figure 226: Installing an extension

Using extensions
This section describes some of the more important and popular extensions to Impress. In each 
case, you need to first install the extension as described in the previous section.

Presenter Console
(Bundled with most installations of LibreOffice.) Provides extra control over slide shows 
(presentations); for example, the presenter has the ability to see the upcoming slide, the slide 
notes, and a presentation timer—while the audience sees only the current slide. The Presenter 
Console displays the elements in three easily changeable views:

• The first view displays the current slide, including the effects, and the upcoming slide.

• The second view shows the speaker's notes in large, clear, and scalable type, plus the 
current and upcoming slide.

• The third view is a slide sorter view with the slide thumbnails.

See Chapter 9, Slide Shows, for more about using Presenter Console.

Note
The Presenter Console works only on an operating system that supports multiple 
displays and only when two displays are connected (one may be the laptop’s built-in 
screen).

Presentation Minimizer
(Bundled with most installations of LibreOffice.) Reduces the file size of the current presentation. 
Images are compressed, and data that is no longer needed is removed. Can optimize the image 
quality size. Presentations designed for screen or projector do not require the same high quality as 
presentations designed for print. 

224 LibreOffice 3.3 Impress Guide



Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. Available in several languages. 
After you have installed this extension, you will find the templates under File > New > Templates 
and Documents. 

Template Changer
Adds two new items to the File > Templates menu that allow you to assign a new template to a 
folder of presentations. All styles and formatting will be loaded from that template and the 
document will behave as if it were created using that template.
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Introduction

You can use LibreOffice without requiring a pointing device, such as a mouse or trackball, by using 
its built-in keyboard shortcuts. Tasks as varied and complex as docking and un-docking toolbars 
and windows, or changing the size or position of objects can all be accomplished with only a 
keyboard. Although LibreOffice has its own extensive set of keyboard shortcuts, each component 
provides others which are specific to its work.

For help with LibreOffice’s keyboard shortcuts, or using LibreOffice with a keyboard only, search 
the LibreOffice Help using the “shortcut” or “accessibility” keywords.

In addition to using the built-in keyboard shortcuts (listed in this Appendix), you can also define 
your own. You can assign shortcuts to standard Impress functions or your own macros and save 
them for use with Impress only, or with the entire LibreOffice suite.

To adapt shortcut keys to your needs, use the Customize dialog box as described in this section 
and in “Customizing keyboard shortcuts” in Chapter 11, Setting Up and Customizing Impress.

Tip for Macintosh users
Some keystrokes are different on a Mac from those used in Windows and Linux. The following 
table gives some common substitutions for the instructions in this book. For a more detailed list, 
see the application Help.

Windows/Linux Mac equivalent Effect

Tools > Options menu 
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open Styles and Formatting window
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Function keys for Impress

Shortcut Keys Effect

F2 Select text tool

F3 Enter group

Ctrl+F3 Exit group

Shift+F3 Duplicate graphic object

F4 Open Position and Size dialog box

F5 View slide show

Ctrl+Shift+F5 Open Navigator

F7 Start spelling checker

Ctrl+F7 Open thesaurus

F8 Edit points

Ctrl+Shift+F8 Fit text to frame

F11 Open the Styles and Formatting window
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Other shortcut keys for Impress

Shortcut Keys Effect

Arrow key Move the selected object or the page view in the direction of the 
arrow.

Ctrl+Arrow key Move the slide in the normal view.

Shift+drag Constrain the movement of the selected object horizontally or 
vertically.

Ctrl+drag 
(with Copy when moving 
option active)

Hold down Ctrl and drag an object to create a copy of the object.

Alt key Hold down Alt to draw or resize objects by dragging from the centre of 
the object outward.

Alt+click Select the object behind the currently selected object.

Alt+Shift+click Select the object in front of the currently selected object.

Shift+click Select adjacent items or a text passage. Click at the start of a 
selection, move to the end of the selection, and then hold down Shift 
while you click.

Shift+drag 
(when resizing)

Hold down Shift while dragging to resize an object to maintain the 
proportions of the object.

Tab Select objects in the order in which they were created.

Shift+Tab Select objects in the reverse order in which they were created.

Escape Exit current mode.

Enter Activate a place-holder object in a new presentation (only if the frame 
is selected).

Ctrl+Enter Move to the next text object on the slide.

If there are no text objects on the slide, or if you reached the last text 
object, a new slide is inserted after the current slide. The new slide 
uses the same layout as the current slide.

Navigating in the Slide Sorter

Shortcut Keys Effect

Escape Moves the focus to the first slide.

Arrow key Moves the focus to the next slide.

Spacebar Makes the slide with the focus the current slide.
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Shortcut keys in the Normal view

Shortcut Keys Effect

Plus(+) key Zoom in.

Minus(-) key Zoom out.

Times(×) key 
(number pad)

Fit page in window.

Divide(÷) key 
(number pad)

Zoom in on current selection.

Shift+Ctrl+G Group selected objects.

Shift+Ctrl+Alt+A Ungroup selected group.

Ctrl+click Enter a group, so that you can edit the individual objects of the 
group. Click outside the group to return to the normal view.

Shift+Ctrl+K Combine selected objects.

Shift+Ctrl+K Split selected object. This combination only works on an object that 
was created by combining two or more objects.

Ctrl+Plus key Bring to front.

Shift+Ctrl+Plus key Bring forward.

Ctrl+Minus key Send backward.

Shift+Ctrl+Minus key Send to back.

Shortcut keys in slide shows

Shortcut Keys Effect 

Esc End presentation.

Spacebar or Right arrow or 
Down arrow or Page Down or 
Enter or Return or N 

Play next effect (if any, else go to next slide).

Alt+Page Down Go to next slide without playing effects.

[number] + Enter Type the number of a slide and press Enter to go to the slide.

Left arrow or Up arrow or 
Page Up or Backspace or P

Play previous effect again. If no previous effect exists on this 
slide, show previous slide.

Alt+Page Up Go to the previous slide without playing effects.

Home Jump to first slide in the slide show.

End Jump to the last slide in the slide show.

Ctrl+Page Up Go to the previous slide.

Ctrl+Page Down Go to the next slide.

B or . Show black screen until next key or mouse wheel event.

W or , Show white screen until next key or mouse wheel event.
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A  
accessibility  227
adding pictures  71
agenda, creating  155
alignment of text  54
Alignment toolbar  93
alignment tools  93
animation effects  

applying  177
multiple  179
properties  179
removing  185
starting  178

appearance options  210
area fill, editing  110
area fills  

gradients  111
hatching  112

arrow styles  107, 109
Asian language support  83
Asian languages enabled  43
Asian typography  55
Author field  66
AutoAbstract  155, 157
AutoLayout  43

B  
background  

adding objects and graphics  31
choosing  30

Bézier curve  213
bitmap image  112
bitmaps, creating and importing  120
black and white printing  194
blink  126
block arc  86
brochure printing  195
bulleted list  55
Bullets and Numbering dialog box  57

C  
cache  212
cell address  136
cell selection (spreadsheet)  136
certificate  206
chart  

choosing type  139
entering data  141
formatting  142
inserting  138
moving elements  144
resizing  144

circle pie  86
color adjustment  78
color fill  111

color options  210
compatibility options  212
connectors  

advantages  95
drawing  95
formatting  127
toolbar  84

content boxes (Impress)  21
contour lines  213
copy when moving option  212
Create AutoAbstract dialog box  157
Create Style dialog box  130
crop  79
cross  86
cube  86
curve  109
curves  

toolbar  83
Custom Animation dialog box  178
custom slide show  173
Custom Slide Shows dialog box  173
cylinder  86

D  
date (fixed or variable) field  66
decimal point character  54
default formatting  29, 46
default settings  195
Define Custom Slide Show dialog box  174
deleting pictures  80
depth tool  97
digital signature  206
distorting an image  91
Drawing toolbar  83
duplicate  101

E  
e-mail attachment  205
Edit Points toolbar  183
Effect Options  184
encryption of PDF  200
expand slide  154
export directly as PDF  196
exporting to PDF  196
Extension Manager  37
extensions  223
extrusion on/off tool  96
eyedropper  31

F  
FDF  198
fields  36

customizing  66
inserting  66

file name field  66
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file, inserting  149
Fill Format mode  131
filters  77
Flash export  202
flip an object  90
folded corner  86
font effects  51
font selection  50
Fontwork  101
Fontwork toolbar  103
Format Cells dialog box  137
formatting  

chart  142
connectors  127
spreadsheet cells  136

formatting   
text  125

Formatting marks options  47
formatting pictures  75
formulas, inserting  149
frame  86
frame by frame animation  100
function keys  228

G  
Gallery  

adding a theme  75
adding images  74
deleting images  74
displaying  73
Hide/Show button  73
themes  74

general options for Impress  211
glue points  

custom  96
inserting  95
moving  96

gradient fill  111
graphic filters  77
graphic styles  32

creating  128
new style from selection  129

graphics  
3D tools  96
duplicate  101
interaction  98
resizing  88
rotating  89

graphics mode  78
graphics styles  127
graphics styles  

formatting text  46
grayscale mode  78
grid  93
grid options  213
grid points, color  210
guides  213

H  
handles  34
Handout view  14, 166
handouts  

automatic layout options  168
creating  166
formatting  167
layout  166
printing  168
template  168
thumbnails  166, 168

hatching patterns, creating  112
Hide/Show button  73
HTML Export Wizard  202
hyperlink  

button  69
editing  69
inserting  67

I  
image  112
image map  80
image quality in PDF  197
Impress  

content boxes  21
slide elements, modifying  21
starting  8

indents and spacing  53
Insert picture dialog box  71
inserting pictures  71
interaction  98
interactions  185

K  
keyboard configuration  223
keyboard shortcuts  227
keyboard shortcuts, customizing  221

L  
Layout pane  43
layout settings  159
lighting tool  97
line pattern, fill  112
line properties  107
line spacing  53
line styles  108
lines  

creating  85
formatting  106

M  
macros  223
main Impress window  8
margin settings  159
Master Pages  27
master slides  22
Math formulas, inserting  145
Media Playback toolbar  146
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Media Player  146
menu font, customizing  215
menus  

adding commands  217
creating  216
modifying  217
modifying entries  218

menus, customizing  215
mirror copies  91
modifying styles  130
moving pictures  75
music objects, inserting  145

N  
name and initials of user  209
Navigator  12
new slide  152
new style from selection  129
non-breaking hyphens  47
non-breaking spaces  47
Normal view  12
notes  

adding  162
automatic layout options  164
exporting to PDF  166
fields  164
formatting  163, 165
printing  165
text formatting  165

Notes Master  163
Notes view  13, 162
numbered list  55

O  
objects  

converting  98
objects always moveable option  212
octagon  86
OLE objects, inserting  145, 147
optional hyphen  47
orientation settings  159
outline  

copying and pasting  157
outline from Writer  155
outline level  56, 58, 60
Outline view  12, 155
OXT extension  37

P  
page number field  66
Page Setup dialog box  158, 164
page style  158
paper format settings  158
parallelogram  86
passwords for PDF  200
pasting unformatted text  46
PDF  

embed standard fonts  198

form  198
PDF export  196

image quality  197
initial view  198
quality  196
range of slides  196

PDF options  196
encryption  200
passwords  200
security  200
user interface  199

PDF/A-1  198
personal data, removing  206
personal key  206
perspective tool  97
Picture toolbar  77
pictures  

AutoLayout  71
color adjustment  78
crop  79
deleting  80
filters  77
formatting  75
inserting from a file  71
inserting from a scanner  72
inserting from Gallery  73
moving  75
resizing  76
rotating  76
transparency  79

pivot point for rotation  89
polygon  85
Position and Size dialog box  87, 90
Position and Size dialog box than the mouse  34
position of text  52
PowerPoint format  

opening  207
save as  207

presentation  
backgrounds  17
designing  26
formatting  19
modifying  23
title slide  20
transitions  18

Presentation Minimizer extension  225
presentation styles  

AutoLayout area  49
Presentation Wizard  212
Print dialog box  191
print file directly  191
print options  209, 214
printing  

black and white  194
brochure  195
default settings  195
general options  192
handouts  194
multiple pages per sheet  192
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notes (Impress)  194
page orientation  192
selecting what to print  193

Professional Template Pack extension  224

Q  
quick editing option  211
Quickstarter  8

R  
range selection (spreadsheet)  137
Rehearse Timings  176
remove manual formatting  29
removing personal data  206
resizing pictures  76
resolution options  214
ring  86
rotating pictures  76
rounded rectangle  86
rulers  213

S  
Screen settings  158
security of PDF  200
set in circle (perspective)  92
set to circle (slant)  92
settings options  212
shadows  121
11)shapes  84

3D  96
aligning  93
arranging  94
convert  98
creating  85
grouping  86

shared extension  223
shortcut keys  229
Show/Hide Slide icon  173
Slide Design dialog box  28
slide elements, modifying  21
slide master  22

adding text  36
apply  27
author information  36
create  27
description  26
fields  36
loading additional  28
modifying  29

Slide pop-up submenu  151
slide show  

custom  173
hide slides  172
organizing  171
Rehearse Timings  176
running  24
settings  171
timing of automatic slide changes  176

transitions  24, 186
Slide Sorter view  15
slide transition effects  199
slides  

adding to a presentation  152
animations  177
background, changing  159
copy and paste from another presentation  153
creating from an outline  155
deleting  155
duplicating  153
expanding  154
hide  23
inserting from other presentations  152
layouts  20
master  22, 26
modifying  22, 158
move  15
rename  16
renaming  153
select  15
slide master, applying  159
subdividing  154
summary slide  155
transitions  175

Slides pane  9
Slides Pane pop-up menu  151
snap grid  213
snap guides  93
snap options  214
snap position options  214
snap to grid  93
special characters  47
spreadsheet  

cell selection  136
cells  136
entering data  136
formatting cells  136
Formatting toolbar  134
inserting  133
moving  135
range  137
resizing  135

start with current page option  212
start with wizard option  212
Style dialog box  128
styles  

applying  131
arrow  109
creating graphic styles  128
deleting  131
description  26
Fill Format mode  131
formatting text  46
graphic styles  32
graphics  127
graphics styles  128
lines  108
modifying  49, 130
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new style from selection  129
spreadsheet cell  136
Styles and Formatting window  33
updating from selection  49, 130

Styles and Formatting window  33
Styles and Formatting window   127
summary slide  155
surface tool  97
SWF export  202
symbols, inserting  47
synchronize axes  214
system font  215

T  
tab stops  54
Tasks pane  10
Template Changer extension  225
Template Management   39
templates  

create a template folder  40
create from a presentation  38
delete a template folder  40
deleting  41
exporting  41
from other sources  37
importing  41
installing using Extension Manager  37
moving  41
organizing  40
supplied with LibreOffice  37
using  37

text  
alignment  54
animation  126
Asian typography  55
bulleted or numbered list  55
character formatting  50
default formatting  46
formatting  48, 125
formatting pasted text  46
indents and spacing  53
inserting  46
line spacing  53
outline level  56
paragraph formatting  53
pasting  46
position  52
selecting  48
tab stops  54

text animation  126, 184
text areas  

handles  34
modifying  33

position and size  35
rotation  35

text box  
auto-resizing  45
AutoLayout  43, 56
creating  43
deleting  45
graphics styles  49
moving  44
resizing  45
vertical alignment of text  43

text box tool  43
Text Formatting toolbar  46, 50
themes  74
three-dimensional objects  96
tilt tools  97
time (fixed or variable) field  66
timing of automatic slide changes  176
title slide  20
toolbar  110
toolbars  11

adding commands  220
choosing icons for commands  220
creating  220
Edit Points  183

toolbars, customizing  218
tooltips  20
transition effects  

removing  176
transparency  79, 122
trapezoid  86
triangle  86

U  
unformatted text, pasting  46
unit of measurement  212
user data options  209
user interface, customizing  215

V  
vertical alignment of text  43
vertical text  83
video objects, inserting  145
view options  212
visible grid  93, 213

W  
web page export  202
Windows Metafile Format (WMF)  98
Workspace  10

Y  
yellow dot  86
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