
LibreOffice 3.4
Impress Guide

Presentations in LibreOffice



Copyright

This document is Copyright © 2012 by its contributors as listed below. You may distribute it and/or 
modify it under the terms of either the GNU General Public License 
(http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution 
License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later. All trademarks in this 
guide belong to their legitimate owners.

Contributors
Peter Schofield
Michele Zarri
T. Elliot Turner
Jean Hollis Weber
Hazel Russman
Chad D. Lines
Low Song Chuan
Muhammad Sufyan Zainalabidin
Jaimon Jacob

Feedback
Please direct any comments or suggestions about this document to: 
documentation@global.libreoffice.org

Acknowledgments
This book is adapted and updated from the OpenOffice.org 3.3 Impress Guide. The contributors to 
that book are:

Michele Zarri Jean Hollis Weber Dan Lewis
Agnes Belzunce Peter Hillier-Brook Gary Schnabl
Claire Wood Rachel Kartch Hazel Russman
Jared Kobos Martin J Fox Paul Miller
Nicole Cairns Rachel Kartch

Publication date and software version
Published 27 May 2012. Based on LbreOffice 3.4.

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation

http://www.libreoffice.org/get-help/documentation
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html


Contents
Copyright..................................................................................................................................... 2

Preface.................................................................................................................................. 7
Who is this book for?................................................................................................................... 8

What's in this book?..................................................................................................................... 8

Where to get more help............................................................................................................... 8

What you see may be different.................................................................................................... 9

Using LibreOffice on a Mac.......................................................................................................... 9

What are all these things called?............................................................................................... 10

Who wrote this book?.................................................................................................................11

Acknowledgements.................................................................................................................... 11

Frequently asked questions....................................................................................................... 11

Chapter 1  
Introducing Impress...........................................................................................................13

What is Impress?....................................................................................................................... 14

Starting Impress......................................................................................................................... 14

The main Impress window......................................................................................................... 15

Workspace views....................................................................................................................... 18

Formatting a presentation.......................................................................................................... 25

Running the slide show.............................................................................................................. 29

Controlling a slide show using the Presenter Console............................................................... 30

Chapter 2  
Using Slide Masters, Styles, and Templates................................................................... 31

Designing a presentation........................................................................................................... 32

What are slide masters?............................................................................................................ 32

Working with slide masters........................................................................................................ 33

Modifying a slide master............................................................................................................ 35

Working with styles in Impress................................................................................................... 42

Working with templates.............................................................................................................. 43

Printing a list of styles defined in a template.............................................................................. 48

Chapter 3  
Adding and Formatting Text............................................................................................. 49

Introduction................................................................................................................................ 50

Working with text boxes............................................................................................................. 50

Inserting text.............................................................................................................................. 53

Introduction to formatting text.................................................................................................... 55

Using styles to format text.......................................................................................................... 56

Formatting characters................................................................................................................ 58

Formatting paragraphs...............................................................................................................60

Creating bulleted and numbered lists......................................................................................... 62

Using tables............................................................................................................................... 67

Using fields................................................................................................................................ 72

Using hyperlinks........................................................................................................................ 74

LibreOffice 3.4 Impress Guide 3



Chapter 4  
Adding and Formatting Pictures...................................................................................... 77

Introduction................................................................................................................................ 78

Inserting pictures....................................................................................................................... 78

Managing Gallery themes.......................................................................................................... 81

Formatting pictures.................................................................................................................... 83

Creating an image map..............................................................................................................89

Chapter 5  
Managing Graphic Objects............................................................................................... 91

Introduction................................................................................................................................ 92

Drawing toolbar.......................................................................................................................... 92

Creating lines and shapes......................................................................................................... 97

Grouping objects together.......................................................................................................... 98

Moving graphic objects.............................................................................................................. 99

Resizing graphic objects.......................................................................................................... 100

Applying special effects........................................................................................................... 100

Aligning shapes....................................................................................................................... 106

Snapping objects to grid or snap guides.................................................................................. 106

Arranging objects..................................................................................................................... 108

Working with connectors.......................................................................................................... 109

Working with 3D shapes...........................................................................................................110

Converting an object to a different type.................................................................................... 112

Setting up interaction with an object......................................................................................... 113

Using Fontwork........................................................................................................................ 114

Animations............................................................................................................................... 115

Chapter 6  
Formatting Graphic Objects........................................................................................... 123

Formatting objects................................................................................................................... 124

Formatting lines....................................................................................................................... 124

Formatting the fill area............................................................................................................. 129

Creating new area fills............................................................................................................. 133

Formatting text......................................................................................................................... 143

Formatting connectors............................................................................................................. 145

Working with graphics styles.................................................................................................... 146

Chapter 7  
Including Spreadsheets, Charts, and Other Objects...................................................151

OLE objects............................................................................................................................. 152

Spreadsheets........................................................................................................................... 153

Charts...................................................................................................................................... 157

Movies and sound.................................................................................................................... 165

Formulas.................................................................................................................................. 166

Drawings, text files, HTML files and other objects....................................................................167

4 LibreOffice 3.4 Impress Guide



Chapter 8  
Adding and Formatting Slides, Notes, and Handouts.................................................169

Introduction.............................................................................................................................. 170

Adding, renaming, and removing slides................................................................................... 170

Creating slides from an outline.................................................................................................174

Modifying slides....................................................................................................................... 176

Adding comments.................................................................................................................... 179

Adding and formatting notes.................................................................................................... 180

Creating handouts................................................................................................................... 185

Chapter 9  
Slide Shows...................................................................................................................... 189

Putting together a slide show................................................................................................... 190

Using slide transitions.............................................................................................................. 194

Using slide animation effects................................................................................................... 196

Using interactions.................................................................................................................... 202

Running a slide show............................................................................................................... 203

Controlling a slide show using the Presenter Console............................................................. 204

Chapter 10  
Printing, E-mailing, Exporting, and Saving Slide Shows............................................205

Introduction.............................................................................................................................. 206

Quick printing........................................................................................................................... 206

Controlling printing................................................................................................................... 206

Printing a brochure.................................................................................................................. 210

Exporting to PDF..................................................................................................................... 210

Exporting as a Flash file........................................................................................................... 216

Exporting as web pages (HTML files)...................................................................................... 216

E-mailing a presentation.......................................................................................................... 220

Removing personal data.......................................................................................................... 221

Opening and saving a PowerPoint file..................................................................................... 221

Chapter 11  
Setting Up and Customizing Impress............................................................................ 223

Selecting options affecting LibreOffice..................................................................................... 224

Choosing options for Impress.................................................................................................. 226

Customizing the user interface.................................................................................................231

Adding functionality with extensions........................................................................................ 238

Appendix A  
Keyboard Shortcuts.........................................................................................................241

Introduction.............................................................................................................................. 242

Function keys for Impress........................................................................................................ 243

Other shortcut keys for Impress............................................................................................... 244

Navigating in the Slide Sorter...................................................................................................244

Shortcut keys in the Normal view............................................................................................. 245

Shortcut keys in slide shows.................................................................................................... 245

Index.................................................................................................................................. 247

LibreOffice 3.4 Impress Guide 5



6 LibreOffice 3.4 Impress Guide



Preface



Who is this book for?

Anyone who wants to get up to speed quickly with LibreOffice Impress will find this book valuable. 
You may be new to presentation software, or you may be familiar with another program such as 
Microsoft PowerPoint.

What's in this book?

This book covers the main features of Impress, the presentations (slide show) component of 
LibreOffice. Using Impress, you can create slides that contain text, bulleted and numbered lists, 
tables, charts, clip art, and other objects.

Impress comes with prepackaged text styles, slide backgrounds, and Help. It can open and save to 
Microsoft PowerPoint formats and can export to PDF, HTML, Adobe Flash, and numerous graphic 
formats.

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems 
assume that you are familiar with your computer and basic functions such as starting a program, 
opening and saving files.

Help system
LibreOffice comes with an extensive Help system. This is your first line of support for using 
LibreOffice.

To display the full Help system, press F1 or select LibreOffice Help from the Help menu. In 
addition, you can choose whether to activate Tips, Extended tips, and the Help Agent (using Tools 
> Options > LibreOffice > General). 

If Tips are enabled, place the mouse pointer over any of the icons to see a small box (“tooltip”) with 
a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's 
This? and hold the pointer over the icon.

Free online support
The LibreOffice community not only develops software, but provides free, volunteer-based support. 
See Table 1 and this web page: http://www.libreoffice.org/get-help/ 

Users can get comprehensive online support from the community through mailing lists. Other 
websites run by users also offer free tips and tutorials. This forum provides community support for 
LibreOffice and other programs: http://user.services.openoffice.org/en/forum/ 

Paid support and training

Alternatively, you can pay for support services. Service contracts can be purchased from a vendor 
or consulting firm specializing in LibreOffice.
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Table 1: Free support for LibreOffice users

Free LibreOffice support

FAQs
Answers to frequently asked questions
http://www.libreoffice.org/get-help/faq/
http://wiki.documentfoundation.org/Faq

Documentation
User guides, how-tos, and other documentation. 
http://www.libreoffice.org/get-help/documentation/
https://wiki.documentfoundation.org/Documentation/Publications 

Mailing lists
Free community support is provided by a network of experienced users
http://www.libreoffice.org/get-help/mailing-lists/

International support

The LibreOffice website in your language.
http://www.libreoffice.org/international-sites/

International mailing lists
http://wiki.documentfoundation.org/Local_Mailing_Lists

Accessibility options
Information about available accessibility options. 
http://www.libreoffice.org/get-help/accessibility/

What you see may be different

LibreOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several 
versions and can be customized by users (fonts, colors, themes, window managers).

The pictures in this book were taken from a variety of computers and operating systems. Some 
pictures will therefore not look exactly like what you see on your computer.

Using LibreOffice on a Mac

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu 
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Open a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open the Styles and Formatting window
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What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see 
and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for 
most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input 
from you, or both. It provides controls for you to use to specify how to carry out an action. The 
technical names for common controls are shown in Figure 1; not shown is the list box (from which 
you select an item). In most cases we do not use the technical terms in this book, but it is useful to 
know them because the Help and other sources of information often use them.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog 
remains open. When you close the dialog after use (usually, clicking OK or another button saves 
your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog 
and your document. An example of this type is the Find & Replace dialog.

Figure 1: Dialog showing common controls:
1 = Tabbed page (not strictly speaking a control)
2 = Radio buttons (only one can be selected at a time)
3 = Checkbox (more than one can be selected at a time)
4 = Spin box (click the up and down arrows to change the number shown in the text 
box next to it, or type in the text box)
5 = Thumbnail or preview
6 = Drop-down list from which to select an item
7 = Push buttons
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Who wrote this book?

This book was written by volunteers from the LibreOffice community. Profits from sales of the 
printed edition will be used to benefit the community.

Acknowledgements

This book is adapted and updated from OpenOffice.org 3.3 Impress Guide. The contributors to that 
book are:

Michele Zarri Jean Hollis Weber Dan Lewis
Agnes Belzunce Peter Hillier-Brook Gary Schnabl
Claire Wood Rachel Kartch Hazel Russman
Jared Kobos Martin J Fox Paul Miller
Nicole Cairns Rachel Kartch

Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Lesser General 
Public License (LGPL). The LGPL license is available from the LibreOffice website: 
http://www.libreoffice.org/download/license/ 

May I distribute LibreOffice to anyone?
Yes.

How many computers may I install it on?
As many as you like.

May I sell it?
Yes.

May I use LibreOffice in my business?
Yes.

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at 
the beginning of this book. You do not have to request special permission. In addition, we 
request that you share with the project some of the profits you make from sales of books, in 
consideration of all the work we have put into producing them.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do 
not need to be a programmer. For example, you can help with producing and maintaining 
written user documentation, producing video tutorials, and other user support services. To start, 
check out this webpage: http://www.documentfoundation.org/contribution/
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What is Impress?

Impress is the presentation (slide show) program included in LibreOffice. You can create slides that 
contain many different elements, including text, bulleted and numbered lists, tables, charts, and a 
wide range of graphic objects such as clip-art, drawings and photographs. Impress also includes a 
spelling checker, a thesaurus, text styles, and background styles.

This chapter introduces the Impress user interface and describes how to create a simple slide 
show using the Presentation Wizard. The other chapters in this guide explain all the features 
available in Impress that can be used to create more sophisticated slide shows.

To use Impress for more than very simple slide shows requires some knowledge of the elements 
which the slides contain. Slides containing text use styles to determine the appearance of that text. 
Creating drawings in Impress is similar to using the Draw program included in LibreOffice. See the 
Draw Guide for more details on how to use the drawing tools.

Starting Impress

You can start Impress in several ways:

• From the LibreOffice Start Center, if no component is open: click on the Presentation icon.

• From the system menu, the standard menu from which most applications are started. On 
Windows, it is called the Start menu. On Linux with a Gnome desktop, it is called the 
Applications menu; on a KDE desktop, it is identified by the KDE logo. On Mac OS X, it is 
the Applications menu. Details vary with your operating system; see Chapter 1 in the 
Getting Started Guide.

• From the LibreOffice Quickstarter, if it is present on your operating system.

• From any open component of LibreOffice: click the triangle to the right of the New icon on 
the main toolbar and select Presentation from the drop-down menu, or choose File > New 
> Presentation from the menu bar.

Note
When LibreOffice was installed on your computer, in most cases a menu entry for 
each component was added to your system menu. The exact name and location of 
these menu entries depend on the operating system and graphical user interface.

When you start Impress for the first time, the Presentation Wizard is shown. Here you can choose 
from the following options:

• Empty presentation, which gives you a blank document

• From template, which is a presentation designed with a template of your choice

• Open existing presentation

• Click Create to open the main Impress window.

For detailed instructions about how to use the Presentation Wizard, see “Creating a new
presentation” on page 23.

If you prefer not to use the Presentation Wizard, select the Do not show this wizard again option 
before clicking Create. You can enable the wizard again later under Tools > Options > LibreOffice 
Impress > General > New document, and select the Start with wizard option.
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The main Impress window

The main Impress window (Figure 2) has three parts: the Slides pane, the Workspace, and the 
Tasks pane. Additionally, several toolbars can be displayed or hidden during the creation of a 
presentation.

Figure 2: Main window of Impress; ovals indicate the Hide/Show markers

Tip

You can close the Slides pane or the Tasks pane by clicking the X in the upper right 
corner of the pane or by choosing View > Slide Pane or View > Tasks Pane to 
deselect the pane. To reopen a pane, choose View > Slide Pane or View > Tasks 
Pane again.

You can also maximize the Workspace area by clicking on the Hide/Show marker in 
the middle of the vertical separator line (indicated by ovals in Figure 2). Using the 
Hide/Show marker hides, but does not close, the Slides and Tasks panes. To restore 
the pane, click again on its Hide/Show marker.

Slides pane
The Slides pane contains thumbnail pictures of the slides in your presentation, in the order the 
slides will be shown—unless you change the slide show order, as described in Chapter 9, Slide 
Shows. Clicking a slide in this pane selects it and places it in the Workspace. When a slide is in the 
Workspace, you can make any changes you like.

Several additional operations can be performed on one or more slides simultaneously in the Slides 
pane:

• Add new slides to the presentation.

• Mark a slide as hidden so that it will not be shown as part of the presentation.

• Delete a slide from the presentation if it is no longer needed.
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• Rename a slide.

• Duplicate a slide (copy and paste) or move it to a different position in the presentation (cut 
and paste).

It is also possible to perform the following operations, although there are more efficient methods 
than using the Slides pane, as you will see later in this chapter:

• Change the slide transition following the selected slide or after each slide in a group of 
slides.

• Change the sequence of slides in the presentation.

• Change the slide design.

• Change slide layout for a group of slides simultaneously.

Tasks pane
The Tasks pane has five sections. To expand the section you wish to use, click on the title bar of 
each section. Only one section at a time can be expanded.

Master Pages
Here you define the page (slide) style for your presentation. Impress includes several designs 
of Master Pages (slide masters). One of them—Default—is blank, and the rest have 
background and styled text.

Tip
Press F11 to open the Styles and Formatting window, where you can modify the 
styles used in any master page to suit your purposes. This can be done at any time. 
See Chapter 2 for more information.

Layouts
The layouts included in Impress are shown here. You can choose the one you want and use it 
as it is, or you can modify it to meet your own requirements. However, it is not possible to save 
custom layouts.

Table Design
The standard table styles are provided in this section. You can further modify the appearance 
of a table with the options to show or hide specific rows and columns, or to apply a banded 
appearance to the rows and columns. Refer to Chapter 3, Adding and Formatting Text, for 
details on how to work with tables.

Custom Animation
A variety of animations can be used to emphasize or enhance different elements of each slide. 
The Custom Animation section provides an easy way to add, change, or remove animations. 
See Chapter 9, Slide Shows, for an overview of how to add and customize animations.

Slide Transition
The Slide Transition section provides access to a number of slide transition options. The default 
is set to No Transition, in which the following slide simply replaces the existing one. However, 
many additional transitions are available. You can also specify the transition speed (slow, 
medium, fast), choose between an automatic or manual transition, and choose how long the 
selected slide should be shown (automatic transition only).
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Workspace
The Workspace (normally in the center) has five tabs: Normal, Outline, Notes, Handout, and 
Slide Sorter (Figure 3). These five tabs are called View buttons. The Workspace below the View 
buttons changes depending on the chosen view. The workspace views are described in detail on 
page 18.

Figure 3: Workspace tabs

Toolbars
Many toolbars can be used during slide creation; they can be displayed or hidden by clicking View 
> Toolbars and selecting from the menu.

You can also select the icons that you wish to appear on each toolbar. For more information, refer 
to Chapter 11, Setting Up and Customizing Impress.

Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the Draw Guide for 
details on the functions available and how to use them.

Status bar
The status bar, located at the bottom of the Impress window, contains information that you may find 
useful when working on a presentation. You can hide the Status Bar by choosing View > Status 
Bar from the main menu.

Note
The sizes are given in the current measurement unit (not to be confused with the 
ruler units). This unit is defined in Tools > Options > LibreOffice Impress > 
General.

Figure 4: Status bar

From left to right, you will find:

• Information area, which changes depending on the selection. For example:

Example selection Examples of information shown

Text area Text Edit: Paragraph x, Row y, Column z

Charts, spreadsheets Embedded object (OLE) “ObjectName” selected

Graphics Bitmap with transparency selected
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• Cursor position: the position of the cursor or of the top left corner of the selection measured 
from the top left corner of the slide, followed by the width and height of the selection or text 
box where the cursor is located.

• Unsaved changes: an icon indicating that the file needs saving. Double-clicking on this icon 
opens the Save or Save As dialog.

• Digital signature: an icon indicating whether the document is digitally signed. After the file 
has been saved, double-clicking on this icon opens the digital signatures dialog.

• Slide number: the slide number currently displayed in the Workspace and the total number 
of slides in the presentation.

• Page (slide) style: the style associated with the slide, handout, or notes page currently in 
the Workspace. Double-clicking on the style name opens the slide design dialog.

• Zoom slider: adjusts the zoom percentage of the Workspace displayed.

• Zoom percentage: indicates the zoom percentage of the Workspace displayed. Double-
clicking on zoom percentage opens the zoom and layout dialog.

Navigator
The Navigator displays all objects contained in a document. It provides another convenient way to 
move around a document and find items in it. To display the Navigator, click its icon  on the 
Standard toolbar, or choose View > Navigator on the menu bar, or press Ctrl+Shift+F5.

The Navigator is more useful if you give your slides and objects (pictures, spreadsheets, and so 
on) meaningful names, instead of leaving them as the default “Slide 1” and “Shape 1”.

Figure 5: Navigator

Workspace views

Each of the Workspace views is designed to ease the completion of certain tasks; it is therefore 
useful to familiarize yourself with them to quickly accomplish those tasks.

Note
Each Workspace view displays a different set of toolbars when selected. These 
toolbar sets can be customized by going to View > Toolbars, then check or 
uncheck the toolbar you want to add or remove.
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Normal view
Normal view is the main view for creating individual slides. Use this view to format and design 
slides and to add text, graphics, and animation effects.

To place a slide in the slide design area of the Normal view (Figure 2), either click the slide 
thumbnail in the Slides pane or double-click it in the Navigator (page 18).

Outline view
Outline view contains all of the slides of the presentation in their numbered sequence. It shows 
topic titles, bulleted lists, and numbered lists for each slide in outline format. Only the text 
contained in the default text boxes in each slide is shown. If you have added text boxes or graphic 
objects to the slides, then these objects are not displayed. Slide names are not included.

Figure 6: Outline view

Use Outline view for:

1) Making changes in the text of a slide:

• Add or delete text in a slide just as in the Normal view.

• Move the paragraphs of text in the selected slide up or down by using the up and down 
arrow buttons (Move Up or Move Down) on the Text Formatting toolbar.

• Change the outline level for any of the paragraphs in a slide using the left and right 
arrow buttons (Promote or Demote) on the Text Formatting toolbar (Figure 7).

• Simultaneously move a paragraph and change its outline level using a combination of 
these four arrow buttons.

2) Comparing the slides with your outline (if you have prepared one in advance). If you notice 
from your outline that another slide is needed, you can create it directly in the Outline view, 
or you can return to the Normal view to create it.

Figure 7: Text Formatting toolbar

Notes view
Use the Notes view (Figure 8) to add notes to a slide. These notes are not seen when the 
presentation is shown.

1) Click the Notes tab in the Workspace.

2) Select the slide to which you want to add notes.
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• Click the slide in the Slide pane, or

• Double-click the slide name in the Navigator.

3) In the text box below the slide, click on the words Click to add notes and begin typing.

You can resize the Notes text box using the green resizing handles and move it by placing the 
pointer on the border, then clicking and dragging. To make changes in the text style, press the F11 
key to open the Styles and Formatting window.

Figure 8: Adding notes in Notes view

Handout view
Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab 
in the workspace, then choose Layouts in the tasks pane. You can then choose to print 1, 2, 3, 4, 
6, or 9 slides per page.

Figure 9: Handout layouts

Use this view also to customize the information printed on the handout. Refer to Chapter 8 (Adding 
and Formatting Slides, Notes, and Handouts) for more information.

Select from the main menu Insert > Page Number or Insert > Date and Time and the Header 
and Footer dialog opens. Click on the Notes and Handouts tab (Figure 10) and use this dialog to 
select the elements you want to appear on each handout page and their contents.
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Figure 10: Dialog to set the page information for handouts and notes

Slide Sorter view
The Slide Sorter view (Figure 11) contains all of the slide thumbnails. Use this view to work with a 
group of slides or with only one slide.

Figure 11: Slide Sorter view
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Customizing Slide Sorter view
To change the number of slides per row:

1) Check View > Toolbars > Slide Sorter and Slide View to show or hide the slide sorter and 
view toolbars (Figure 12).

2) Adjust the number of slides (up to a maximum of 15).

Figure 12: Slide Sorter and Slide View toolbars

Moving a slide using Slide Sorter
To move a slide in a presentation using the Slide Sorter:

1) Click the slide to highlight it (see Figure 11).

2) Drag and drop it to the location you want.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:

• Use the Control (Ctrl) key: Click on the first slide and, while pressing the Control key, select 
the other desired slides.

• Use the Shift key: Click on the first slide, and while pressing the Shift key, select the final 
slide in the group. This selects all of the other slides between the first and the last.

• Use the mouse: Click slightly to one side (left or right) of the first slide to be selected. Hold 
down the left mouse button and drag the mouse pointer until all of the slides you want to 
select are highlighted.

To move a group of slides:

1) Select a group of slides.

2) Drag and drop the group to their new location.

Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the Slide pane.

To make changes, right-click a slide and chose any of the following options from the pop-up menu:

• New Slide: add a new slide after the selected slide.

• Delete Slide: delete the selected slide.

• Rename Slide: rename the selected slide.

• Slide Layout: change the layout of the selected slide.

• Slide Transition: change the transition of the selected slide.

– For one slide, click the slide to select it and then add the desired transition.

– For more than one slide, select the group of slides and add the desired transition.

• Hide Slide: hidden slides are not shown in the slide show.

• Cut: remove the selected slide and save it to the clipboard.

• Copy: copy the selected slide to the clipboard without removing it.

• Paste: insert a slide from the clipboard. You can also specify whether you want to paste the 
copied slide before or after the selected slide.

22 LibreOffice 3.4 Impress Guide



Creating a new presentation
This section shows you how to set up a new presentation using the Presentation Wizard.

Tip

The first thing to do is decide on the purpose of the presentation and plan the 
presentation. Although you can make changes as you go, having an idea of who 
the audience will be, the structure, the content, and how the presentation will be 
delivered, will save you a lot of time from the start.

When you start Impress, the Presentation Wizard appears.

Figure 13. Choosing the type of presentation

1) Under Type, choose one of the options:

• Empty presentation creates a blank presentation. 

• From template uses a template design already created as the basis for a new 
presentation. The wizard changes to show a list of available templates. Choose the 
template you want. More details can be found in Chapter 2.

• Open existing presentation continues work on a previously created presentation. The 
wizard changes to show a list of existing presentations. Choose the one you want.

2) Click Next. Figure 14 shows the Presentation Wizard step 2 as it appears if you selected 
Empty presentation at step 1. If you selected From template, an example slide is shown in 
the Preview box. Choose a design under Select a slide design. The slide design section 
gives you two main choices: Presentation Backgrounds and Presentations. Each one has a 
list of choices for slide designs. If you want to use one of these other than <Original>, click 
it to select it.

• The types of Presentation Backgrounds are shown in Figure 14. Click an item to show 
a preview of the slide design in the Preview window. Impress contains three choices 
under Presentations: <Original>, Introducing a New Product, and Recommendation of  
a Strategy.

• <Original> is for a blank presentation slide design.
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Figure 14. Selecting a slide design

• Both Introducing a New Product and Recommendation of a Strategy have their own 
prepackaged slide designs. Each design appears in the Preview window when its 
name is clicked.

Note
Introducing a New Product and Recommendation of a Strategy are included 
presentation templates. They can be used to create a presentation by choosing 
From template in the first step (Figure 13).

3) Select how the presentation will be used under Select an output medium. Most often, 
presentations are created for computer screen display, so you would select Screen. You 
can change the page format at any time.

Note
The default Screen page is optimized for a 4:3 display (28cm x 21cm) so it is not 
suitable for modern wide-screen displays. You can change the slide size at any time 
switching to Normal view and selecting Format > Page.

4) Click Next. The Presentation Wizard step 3 appears (Figure 15).

• Choose the desired slide transition from the Effect drop-down menu.

• Select the desired speed for the transition between the different slides in the 
presentation from the Speed drop-down menu. Medium is a good choice for now.

5) Click Create. A new presentation is created.

Tip

You can accept the default values for both Effect and Speed unless you are skilled 
at creating presentations. Both of these values can be changed later while working 
with Slide transitions and animations. These two features are explained in more 
detail in Chapter 9. Slide Shows.

Note
If you selected From template on step 1 of the Wizard, the Next button will be active 
on step 3 and other pages will be available. These pages are not described here.
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Figure 15: Selecting a slide transition effect

Caution
Remember to save frequently while working on the presentation, to prevent any 
loss of information should something unexpected occur. You might also want to 
activate the AutoRecovery function (Tools > Options > Load/Save > General). 
Make sure Save AutoRecovery information every is selected and that you have 
entered a recovery frequency.

Formatting a presentation

A new presentation only contains one empty slide. In this section we will start adding new slides 
and preparing them for the intended contents.

Inserting slides
This can be done in a variety of ways; take your pick.

• Insert > Slide.

• Right-click on the present slide, and select Slide > New Slide from the pop-up menu.

• Click the Slide icon  in the Presentation toolbar.

Sometimes, rather than starting from a new slide you want to duplicate a slide you have already 
inserted. To duplicate a slide, select the slide you want from the Slides pane and then choose 
Insert > Duplicate Slide.

Selecting a layout
In the Tasks pane, select the Layout drawer to display the available layouts (Figure 16). The 
Layouts differ in the number of elements a slide will contain, from a blank slide to a slide with six 
contents boxes and a title.
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Figure 16: Available slide layouts

The first slide in a presentation is normally a title slide. The Title Slide (which also contains a 
section for a subtitle) or Title Only are suitable layouts for the first slide, while for most of the slides 
you will probably use the Title, Contents layout.

To create the title, click on Click to add title (assuming the Blank Slide layout was not used) and 
then type the title text. To adjust the formatting of the title, modify the Title presentation style; see 
Chapter 2, Using Slide Masters, Styles, and Templates, for instructions.

If you are using the Title Slide layout, click on Click to add text to add a subtitle. Proceed as above 
to make adjustments to the formatting if required, modifying the Subtitle presentation style.

Note

Text and graphic elements can be readjusted at any time during the preparation of the 
presentation, but changing the layout of a slide that already contains some contents 
can have a dramatic effect. It is therefore recommended that you pay particular 
attention to the layout you select. If you do need to change the layout after contents 
have been added, the contents are not lost though they may need to be reformatted.

Tip

To view the names for the included layouts, use the Tooltip feature: position the 
cursor on an icon in the Layout section (or on any toolbar icon) and its name will be 
displayed in a small rectangle.

If tooltips are not enabled, choose Tools > Options > LibreOffice > General > 
Help and select the Tips option. If the Extended tips option is also selected, you 
will get more detailed tooltip information, but the tooltip names themselves will not  
be provided.

To select or change the layout, place the slide in the work area and select the desired layout from 
the layout drawer in the Task Pane.

Several layouts contain one or more content boxes. Each of these boxes can be configured to 
contain one of the following elements: Text, Movie, Picture, Chart or Table.

You can choose the type of contents by clicking on the icon that is displayed in the middle of the 
contents box as shown in Figure 17. If instead you intend to use the contents box for text, just click 
on the “Click to add text” area to get a cursor.
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Figure 17: Selecting contents type

To select or change the layout, place the slide in the work area and select the desired layout from 
the layout drawer in the Task Pane.

If you have selected a layout with one or more contents boxes, this is a good time to decide what 
type of contents you want to insert.

Modifying the slide elements
At this stage, the slide contains elements that were included in the slide master, as well those 
elements included in the selected slide layout. You may want to remove any elements that are not 
required or insert objects such as text and graphics.

Although Impress does not have the functionality to create new layouts, it allows you to resize and 
move the layout elements. It is also possible to add slide elements without being limited to the size 
and position of the layout boxes.

To resize a contents box, click on the outer frame so that the 8 resizing handles are displayed. To 
move it place the mouse cursor on the frame so that the cursor changes shape. You can now click 
the left mouse button and drag the contents box to its new position on the slide.

To remove any unwanted elements, do this:

1) Click the element to highlight it. The green resizing handles show it is highlighted.

2) Press the Delete key to remove it.

Caution Changes to any of the layouts included in Impress can only be made using View > 
Normal, which is the default. Attempting any changes by modifying a slide master,  
although possible, may result in unpredictable results and requires extra care as 
well as a certain amount of trial and error.

Adding text to a slide
To add text to a slide that contains a text frame, click on Click to add text in the text frame and then 
type your text. The Outline styles are automatically applied to the text as you insert it. You can 
change the outline level of each paragraph as well as its position within the text by using the arrow 
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buttons on the Text Formatting toolbar (see “Outline view” on page 19). For more information on 
text, see Chapter 3, Adding and Formatting Text.

Adding pictures or objects to a slide
To add any pictures or objects to a slide, for example a picture, clipart, drawing, photograph, or 
spreadsheet, click on Insert then select from the drop down menu what type of insert you require. 
For more information, see the following chapters:

• For pictures, see Chapter 4, Adding and Formatting Pictures.

• For graphic objects, see Chapter 5, Managing Graphic Objects and Chapter 6, Formatting 
Graphic Objects.

• For OLE and other objects, see Chapter 7, Including Spreadsheets, Charts, and Other 
Objects.

Modifying the appearance of slides
To change the background and other characteristics of all slides in the presentation, you need to 
modify the master page or choose a different master page.

A Slide Master is a slide with a specified set of characteristics that acts as a template and is used 
as the starting point for creating other slides. These characteristics include the background, objects 
in the background, formatting of any text used, and any background graphics.

Note

LibreOffice uses three interchangeable terms for this one concept. Master slide, 
slide master, and master page. These terms all refer to a slide that is used to 
create other slides. This guide, however, uses only the term slide master, except 
when describing the user interface.

Impress has included a range of slide masters, found in the Master Pages section of the Tasks 
pane. You can also create and save additional slide masters or add more from other sources. See 
Chapter 2 for information on creating and modifying slide masters.

If all you need to do is to change the background, you can take a shortcut:

1) Select Format > Page and go to the Background tab.

2) Select the desired background between solid color, gradient, hatching, and bitmap. Click 
OK to apply it.

A dialog box opens, asking if the background should be applied to all the slides. If you click Yes, 
Impress automatically modifies the master page for you.

Modifying the slide show
By default the slide show will display all the slides in the same order as they appear in the slide 
sorter, using any transition between slides specified in the Presentation Wizard, and you need 
some keyboard or mouse interaction to move from one slide to the next.

Now is a good time to review the entire presentation and answer some questions. Run the slide 
show at least once (see “Running the slide show” on page 29) before answering them. You might 
want to add some questions of your own.

1) Are the slides in the correct order? If not, some of them will need to be moved.

2) Is the information well spaced and visible to members of an audience at the back of a large 
room? They may not be able to see information at the bottom of a slide, so you may need 
to design your presentation to fit the top three-quarters of the screen.
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3) Would an additional slide make a particular point clearer? If so, another slide needs to be 
created.

4) Do some of the slides seem unnecessary? Hide or delete them.

5) Would custom animations help some of the slides? (Advanced technique.)

6) Should some of the slides have a different slide transition than others? The transition of 
those slides should be changed.

Caution
If one or more slides seem to be unnecessary, hide the slide or slides, and view the 
slide show a few more times to make sure they are not needed. To hide a slide,  
right-click the slide in the Slides pane and select Hide Slide in the pop-up menu. 
Do not delete a slide until you have done this; otherwise you may have to create 
that slide again.

Once you have answered these and your own questions, make the necessary changes. This is 
done most easily in the Slide Sorter view (see page 21). Use the Slide Show menu to change the 
order of the slides, choose which ones are shown, automate moving from one slide to the next, 
and other settings. To change the slide transition, animate slides, and make other enhancements, 
use the various selections in the Task pane.

Custom animations
If you wish to add a custom animation to a slide, do it now. Custom animations are found in the 
Custom Animation section of the the Tasks pane. This is an advanced technique and is explained 
in Chapter 9, Slide shows.

Slide transitions
Your first slide show will probably have the same slide transition for all slides. Setting Advance 
slide to On mouse click is the default. If you want each slide to be shown for a specific amount of 
time, click Automatically after and enter the number of seconds. Click Apply to all slides.

Transition choices are found under Slide Transition on the Tasks pane. For more information about 
slide transitions, see Chapter 9, Slide Shows.

Tip
The Slide transition section has a very useful option: Automatic preview. With this 
option selected, when you make any changes in a slide transition, the new slide is  
previewed in the Slide Design area, including its transition effect.

Running the slide show

To run the slide show, do one of the following:

• Click Slide Show > Slide Show on the main menu bar.

• Click the Slide Show button on the Presentation toolbar or the Slide Sorter toolbar.

• Press F5 or F9. (F9 does not work on a Mac.) 

If the slide transition is Automatically after x seconds, let the slide show run by itself.

If the slide transition is On mouse click, do one of the following to move from one slide to the next.

• Click the mouse button to advance to the next slide.

• Use the arrow keys on the keyboard to go to the next slide or to go back to the previous 
one.

• Press the Spacebar on the keyboard to advance to the next slide.
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Right-click anywhere on the screen to open a menu from which you can navigate the slides and set 
other options.

When you advance past the last slide, the message Click to exit presentation... appears. Click the 
mouse or press any key to exit the presentation.

To exit the slide show at any time including at the end, press the Esc key.

Controlling a slide show using the Presenter Console

Most installations of LibreOffice Impress come with the Presenter Console extension built in. If it is 
not included, you can get the extension and install it as described in Chapter 11, Setting up and 
Customizing Impress.

The Presenter Console works only on operating systems that support two displays, and only when 
two displays are connected (one may be the laptop’s built-in screen).

The Presenter Console provides extra control over slide shows (presentations) through different 
views on the presenter’s computer screen and on the projection that the audience sees. The 
presenter’s view includes the current slide, the upcoming slide, the slide notes, and a presentation 
timer. See Chapter 9, Slide Shows for details.
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Designing a presentation

In addition to careful planning of the content (as discussed in Chapter 1), you need to plan the 
appearance of the presentation. It is best to do this after you have developed an outline, because 
the outline will determine some of the requirements for the appearance of the slides. For example:

• What color combinations (background and text) will look good and also be easy for your 
audience to read?

• Would a picture help your audience understand the contents better?

• Do you want particular text and a picture to appear on all the slides? (for example a 
company name and logo.) 

• Would the audience benefit from having the slides numbered so that they can quickly refer 
to one of them?

• Do you want a background graphic or gradient? If so, you need to pick something that does 
not interfere or clash with content such as the colors used in charts.

• Will you need one slide master or more than one? Will one slide design suit all of the 
content?

You can change the appearance of slides as you develop the presentation, but planning ahead will 
save you time in the long run.

What are slide masters?

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style 
in Writer: it controls the basic formatting of all slides based on it. A slide show can have more than 
one slide master.

Note
LibreOffice uses three terms for one concept: slide master, master slide, and master  
page. All refer to a slide which is used to create other slides. This book uses the term 
slide master, except when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or 
gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers 
and footers; placement and size of text frames; and the formatting of text.

All of the characteristics of slide masters are controlled by styles. The styles of any new slide you 
create are inherited from the slide master from which it was created. In other words, the styles of 
the slide master are available and applied to all slides created from that slide master. Changing a 
style in a slide master results in changes to all the slides based on that slide master. It is, however, 
possible to modify each individual slide without affecting the slide master.

Note
Although it is highly recommended to use the slide masters whenever possible, there 
are occasions where manual changes are needed for a particular slide, for example 
to enlarge the chart area when the text and chart layout is used. 

Slide masters have two types of styles associated with them: presentation styles and graphic  
styles. Both these style types can be modified. New graphic styles can be created but new 
presentation styles cannot..

Presentation styles are discussed in detail in Chapter 3, Working with Text. The use of graphic 
styles is covered in Chapter 6, Formatting Graphic Objects. See also “Working with styles in
Impress” on page 42.
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Working with slide masters

Impress comes with a collection of slide masters. These slide masters are shown in the Master 
Pages section of the Tasks pane (Figure 18). This section has three subsections: Used in This  
Presentation, Recently Used, and Available for Use. Click the expand marker (usually a downward-
pointing triangle or + sign) next to the name of a subsection to expand it and show thumbnails of 
the slides, or click the collapse marker (usually an upward-pointing triange or a – sign) to collapse 
the subsection to hide the thumbnails.

Figure 18: Available master pages (slide  
masters)

Each of the slide masters shown in the Available for Use list is from a template of the same name. 
If you have created your own templates, or added templates from other sources, slide masters 
from those templates will also appear in this list. See “Working with templates” on page 43 for more 
about templates.

Creating slide masters
You can create a new slide master in a similar way to modifying the default slide master.

To start, enable editing of slide masters by selecting View > Master > Slide Master and the 
Master View toolbar opens. You can also right-click on the slide master in the Master Pages 
section of the tasks pane and select Edit Master to open the Master View toolbar. On the Master 
View toolbar, click the New Master icon (highlighted in Figure 19).

Figure 19: Master View toolbar

A second slide master appears in the Slides pane. Modify this slide master to suit your 
requirements. It is recommended that you rename this new slide master. To do that, right-click on 
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the slide in the Slides pane and select Rename master from the pop-up menu. When you are 
done, close the Master View toolbar to return to normal slide editing mode.

Applying a slide master
In the Tasks Pane, be sure the Master Pages section is showing (Figure 18).

To apply one of the slide masters to all slides in your presentation, click on it in the list.

To apply a different slide master to one or more selected slides:

1) In the Slides Pane, select the slides you want to change.

2) In the Master Pages section of the Tasks Pane, right-click on the slide master you want to 
apply to the selected slides and click Apply to Selected Slides on the pop-up menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong 
to different templates (the use of templates is explained later in “Working with templates” on page 
43). For example, you may need a completely different layout for the first slide of the presentation, 
or you may want to add a slide from a different presentation to your current presentation (based on 
a template available on the hard disk).

The Slide Design dialog (Figure 20) makes this possible. Access this dialog either from the menu 
bar (Format > Slide design) or from the pop-up menu that appears when right-clicking on a slide 
in the Slides pane.

Figure 20: Slide Design

The main area in the dialog shows the slide masters already available for use. To add more:

1) Click the Load button.

2) Select in the Load Slide Design window (Figure 21) the template from which to load the 
slide master and click OK.

3) Click OK again to close the slide design dialog.

The slide masters in the template you selected are now shown in the Available for use subsection 
in the Master Pages section of the Tasks pane.
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Figure 21: Load Slide Design dialog for selecting templates

Note
The slide masters you have loaded will also be available the next time you load the 
presentation. If you want to delete the unused slide masters, click the corresponding 
checkbox in the Slide Design dialog.

Tip
To limit the size of the presentation file, you may want to minimize the number of 
slide masters used.

Modifying a slide master

The following items can be changed on a slide master:

• Background (color, gradient, hatching, or bitmap)

• Background objects (for example, adding a logo or decorative graphics)

• Text attributes for the main text area and notes

• Size, placement, and contents of header and footer elements to appear on every slide

• Size and placement of default frames for slide titles and content

Figure 22: Example of a slide with several modifications
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To select the slide master for modification:

1) Select View > Master > Slide Master from the menu bar. This unlocks the properties of the 
slide master so you can edit it.

2) Click Master Pages in the Tasks pane. This gives you access to the slide masters.

3) Click on the slide master you want to modify (Figure 18).

4) Make changes as described in this chapter, then click the Close Master View icon on the 
Master View toolbar. Save the file before continuing.

Caution
Any changes made to one slide when in Master View mode will appear on all slides 
using this slide master. Always make sure you close Master View and return to 
Normal view before working on any of the presentation slides. Select View > Normal 
from the menu bar, or clicking Close Master View in the Master View toolbar to 
return to the normal slide view.

The changes made to one of the slides in Normal view (for example, changes to the bullet point 
style, the color of the title area, and so on) will not be overridden by subsequent changes to the 
slide master. There are cases, however, where it is desirable to revert a manually modified element 
of the slide to the style defined in the slide master: to do that, select that element and choose 
Format > Default Formatting from the menu bar.

It is also possible to modify the default layout of the slide master, for example by moving the title to 
the side; however, you are restricted to modifications to the “Title, Text” layout (that is, the layout 
containing a title box and a text box).

Sometimes, depending on the contents of the slide, you may want to apply a different layout. The 
title and text boxes will inherit the properties of the slide master, but if you have changed the 
position of these text boxes in the slide master, the layout may appear corrupted and you may 
need to re-position some of the layout elements manually.

Choosing and applying the background
Backgrounds can be applied to a number of elements in Impress: the page, a default text area, a 
graphic object and so on. The procedures to apply a background are always the same.

The following procedure is used to apply a background to the page.

1) To begin, do one of the following:

• Select Format > Page from the menu bar. On the Page Setup dialog, choose the 
Background tab (Figure 24 on page 37).

OR

• Select Format > Styles and Formatting from 
the menu bar (or press F11) and make sure the 
Presentation Styles icon is selected (Figure 31), 
then right-click Background and select Modify 
from the pop-up menu. This opens the 
Background dialog, which has one tab (Area) 
that is the same as the Background tab in the 
Page Setup dialog.
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2) Select the type of fill you want for your background from the five choices in the drop-down 
menu (Figure 24): None, Color, Gradient, Hatching, or Bitmap.

Figure 24: Background choices on Page Setup dialog

3) A list of choices for the selected fill type then appears. Figure 25 shows an example of 
background colors.

Figure 25: Selecting a background color in the Page Setup dialog

4) Select one of the items on the Fill list and click OK. The fill you have chosen is added to the 
slide master, replacing any previously selected fill.

Tip
You can make custom additions to each type of background, with the obvious 
exception of None. After you create new fills, they are listed in the Background dialog 
along with the fills provided with LibreOffice (see Chapter 6 for more information).

Adding background objects
This section describes how to add background objects and graphic elements (such as a logo, 
decorative lines, and so on). LibreOffice supports a large number of graphic formats.

When you want the same graphic to appear on every slide of your presentation, the easiest and 
quickest solution is to use the slide master. It saves time while creating the presentation and when 
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you want to modify or reposition the graphic on the slide. If the graphic is added to each slide 
manually, these operations have to be performed on each individual slide in the presentation.

One of the most common actions in preparing a presentation is to add a picture to the slide master. 
To insert a picture already available on the computer, follow these steps:

1) Choose View > Master > Slide Master from the menu bar.

2) Select from the menu bar Insert > Picture > From File.

3) Navigate to the directory where your picture is located and select it. If you want to see a 
preview, select the corresponding checkbox in the file browser dialog.

Caution

LibreOffice offers the option to insert a picture as a link to the file rather than 
embedding it in the document. This can be useful when a presentation is not intended 
for distribution onto other computers, but where it will remain in the same computer 
and directory structure. For example, it could be created on a notebook computer, 
which is to be used to give the presentation, for example to a group of clients.

However, if the presentation file is to be distributed onto other computers, the picture 
must be embedded to avoid the “missing picture” syndrome when the presentation is 
given on a different computer.

Once the picture is inserted, you need to move it to the background. To do that, while the picture is 
still selected, right click on the picture and select Arrange > Send to Back from the context menu. 
You may also need to reposition it and modify its size. To do that see Chapter 4, Adding and 
Formatting Pictures.

Tip

If you want the image to blend with the background, you can set the background color  
of the picture as transparent. Select the picture, then chose Tools > Color Replacer 
from the menu bar. Select the first checkbox and then move the mouse cursor onto 
the picture and click on the color you want to make transparent. This color appears 
next to the checkbox. Make sure that Replace with... is set to Transparent and click 
Replace.

Tip
An easy way to make the picture lighter so that the text stands out better against its 
background, is to increase the transparency of the picture or change the gamma. Both 
these adjustments can be quickly made from the Picture toolbar.

In addition to pictures you can add a number of other background objects, for example decorative 
lines, text and shapes. Figure 22 is an example of a slide master with a custom background 
gradient, a background picture, another picture in the top right corner, some decorative lines and 
some customized presentation styles.

Slide master styles
Within the slide master you can define a complete set of styles for the default appearance of text 
and graphic objects inserted in slides based on that background. If for example your slide master 
has a dark background, you may want to set the font color of the title and text areas to be light. 
Rather than manually changing the font color for every new slide you create, a time-consuming 
operation prone to errors and omissions, simply modify the style in the slide master. Changes 
made to styles in the slide master only apply to the slides based on that particular slide master.

Styles in Impress are sub-divided into two main categories: Presentation styles and Graphics 
styles.
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Presentation styles
Presentation styles (Figure 31) affect three elements of a slide master: the background, 
background objects (such as icons, decorative lines, and text frames), and the text placed on the 
slide. Text styles are further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The 
outline styles are used for the different levels of the outline to which they belong. For example, 
Outline 2 is used for the sub-points of Outline 1, and Outline 3 is used for the sub-points of Outline 
2.

The presentation styles can be modified, but new presentation styles cannot be created.

Graphics styles
Graphics styles (Figure 26) apply to lines, shapes and text boxes created using the Impress 
drawing tools and define the formatting of such objects. You can create additional styles or modify 
the included styles.

Note

The presence of text and title styles both in the Presentation and Graphics styles may 
seem confusing. This apparent duplication is because Impress uses special text  
boxes when adding structured text to slides where Presentation styles apply 
(AutoLayout boxes). The title and other text styles in Graphics styles continue to apply 
to other text boxes you may want to add, or to text associated with shapes or lines.

To work on the slide master styles, start by opening the Styles and Formatting window shown in 
Figure 23 for Presentation styles and Figure 26 for Graphic styles. Either press F11 or select 
Format > Styles and Formatting from the main menu.

Figure 26: Graphic Styles and Formatting

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or other groups of styles, for example applied styles or (for  
Graphics styles only) custom styles.
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You can dock or undock the Styles and Formatting window by holding down the Control key while 
double-clicking on the icon toolbar. Press F11 to close the Styles and Formatting window when you 
do not need it. LibreOffice will remember its position the next time you re-open the Styles and 
Formatting window.

Modifying default text areas
When a slide master is opened for editing, it contains five areas, as shown in Figure 27.

• Title area for AutoLayouts

• Object area for AutoLayouts

• Date area

• Footer area

• Slide number area

Figure 27: Slide master showing five editable areas

Click with the left mouse button on any of these areas to display eight colored squares (handles) 
around the rectangle. Use these handles to modify the size and position of the area.

1) To change the position, move the mouse towards one of the edges, away from the 
handles, until the cursor changes shape1, then click the left mouse button and drag the 
area to the desired position.

2) To modify the shape and size of one of the rectangular areas, use one of the eight handles. 
The corner handles modify the height and width of the rectangle simultaneously while the 
side handles modify only one dimension at a time. The shape of the mouse cursor usually 
changes when over a handle, giving a clear visual indication of how it will affect the shape 
of the rectangular area.

1 The shape of the cursor to move and resize objects is operating system specific.
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Tip
To keep the shape of the rectangular area constant, move the mouse to one of the 
four corner handles and keep the Shift key pressed while dragging the handle with 
the mouse.

To accurately control the shape and size as well as the position of the default text area, it is better 
to use the Position and Size dialog than the mouse. First select the rectangular area by clicking on 
any point inside it, then press F4 or choose Format > Position and Size. The dialog shown in 
Figure 28 is displayed.

The functions of this dialog are explained in the Draw Guide, so only a short description of the 
most important fields is provided in this chapter.

Use the Position section to specify the X (horizontal) and Y (vertical) position of the rectangular 
area. The values represent the distance of the selected base point and the default position is the 
top left corner of the slide.

Figure 28: Position and Size dialog

Use the Size section to specify the width and height of the rectangular area. In the Base point 
section, select the part of the rectangular area that you do not want to move while resizing. The 
default setting of top left corner means that the position of the top left corner of the area will not 
change after resizing.

You can also use the Rotation tab of the dialog to rotate the default text area. For example, you 
can place the footer area on the side by rotating each text area by 90 degrees and obtain a more 
modern-looking layout. In general it is preferable to use only right angles for ease of editing, 
although the program does not impose restrictions on the values that can be used.

Further modifications to the default text areas
Besides the shape, size and position, it is also possible to modify other aspects of the editable 
areas on the slide master, such as the background, border, alignment relative to the slide, and 
position relative to other objects.
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While the background style and line style of an area can be accessed from the Format menu, to 
access the Alignment and Arrange menus you need either to open the Drawing toolbar or to use 
the context menu. To display the Drawing toolbar (Figure 29), select View > Toolbars > Drawing. 
To open the context menu, right-mouse click on the edge of the selected rectangular area. On the 
Drawing toolbar, click the arrow next to the Alignment or Arrange icon (highlighted in Figure 29) to 
display choices. See the Draw Guide for details.

Figure 29: Alignment and Arrange icons on the Drawing toolbar

The date area and slide number area do not automatically appear on every slide, even though you 
have defined them. To show them, you need to close the Master View and select the desired field 
from the menu bar: Insert > Page number or Insert > Date and time. This procedure is explained 
in detail in Chapter 8, Adding and Formatting Slides, Notes, and Handouts.

Adding text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text objects 
to the master page for your slides to act as a header or a footer.

1) Choose View > Master > Slide Master from the menu bar.

2) On the Drawing toolbar (Figure 29), select the Text icon or press F2.

3) Click once and drag in the master page to draw a text object, and then type or paste your 
text into the object or add fields as described below.

4) Choose View > Normal when you are finished.

To add a field, such as the date or page number (slide number), to a text object in the header or 
footer, select Insert > Fields. and select the required field from the submenu. If you want to edit a 
field in your slide, see Chapter 3, Adding and Formatting Text for more information.

The fields you can use in Impress are:

• Date (fixed)

• Date (variable): updates automatically when you reload the file

• Time (fixed)

• Time (variable): updates automatically when you reload the file

• Author: first and last names listed in the LibreOffice user data

• Page number (slide number)

• File name

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field, 
choose Format > Page and then select a format from the list in the Layout Settings 
area.

To change the author information, go to Tools > Options > LibreOffice > User Data.

Working with styles in Impress

If you are familiar with styles in Writer, you will find both similarities and differences in Impress. The 
presentation styles are comparable to paragraph styles in Writer and are used in a similar fashion. 
You cannot create new presentation styles but you can fully configure the existing ones. Note that, 
as with the Heading styles in Writer, the Outline styles are hierarchically linked, so that a change in 
the Outline 1 will cascade through all the other Outline levels.
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In Impress you will also find the graphics styles very useful. They define the characteristics of a 
graphic object (including a text object). If, for example, you need to create a organization chart 
diagram in one of the slides of your presentation, you will probably want all of the objects to have a 
consistent appearance, meaning the same line style, same font type, maybe the same shadow, 
and so on. The easiest way to achieve this result with the minimum effort is to create a graphics 
style for the objects and apply it to each object. The major benefit is that if you decide to change, 
say, the background color of objects, all you need to do is modify the style rather than each 
individual object.

Presentation styles are discussed in detail in Chapter 3, Working with Text. The use of graphics 
styles is covered in Chapter 6, Formatting Graphic Objects.

Working with templates

All documents in LibreOffice are based on templates. However, Impress is a little different from 
other LibreOffice components, in that it starts with the Presentation Wizard unless you have 
elected to turn off this wizard.

When you choose File > New > Presentation from the menu bar and if the wizard is active, it 
opens offering several choices for a new presentation, one of which is From template.

If you have turned off the Presentation Wizard, when you start a new presentation by choosing File 
> New > Presentation from the menu bar, LibreOffice uses the default presentation template. If 
you have not defined your own default template, LibreOffice uses the blank template supplied with 
Impress.

Using templates supplied with LibreOffice
Impress comes with a set of predefined templates. Two are in the Presentations folder and the 
others are in the Presentation backgrounds folder. The difference between them is that 
Presentation templates include a series of slides with sample titles and topics, while Presentation 
background templates have only backgrounds and background objects. Both types have 
predefined presentation and graphics styles.

You can create a new presentation from a previously saved presentation template by choosing File 
> New > Templates and Documents from the menu bar. This opens the Templates and 
Documents – Templates dialog. To open a new presentation based on a template, double-click the 
template’s name in the list.

Using templates from other sources
You can download templates for LibreOffice from many sources, including the official template 
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites 
you may find collections of templates that have been packaged into extension (.OXT) files. These 
are installed a bit differently (using the Extension Manager), as described below.

Some of these templates are free of charge; others are available for a fee. Check the descriptions 
to see what licenses and fees apply to the ones that interest you.

If you have created your own templates (see page 44), or installed templates from another source, 
they are probably stored in the My Templates folder. Templates installed using the Extension 
Manager may be installed in their own folders. Go to File > New > Templates and Documents to 
open the dialog where these folders are located.
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Installing individual templates
To install individual templates:

1) Download the template and save it anywhere on your computer.

2) Import the template into a template folder by following the instructions in “Importing a
template“ on page 47.

Tip

(For advanced users) If you know the location of LibreOffice template folders, you 
can manually copy new templates into them. The location varies with your 
computer’s operating system. To learn where the template folders are stored on 
your computer, go to Tools > Options > LibreOffice > Paths.

Installing template collections
The Extension Manager provides an easy way to install collections of templates that have been 
packaged into extension (.OXT) files. Follow these steps:

1) Download the extension and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension 
Manager dialog, click Add to open a file browser window.

3) Find and select the package of templates you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

4) When the package installation is complete, the templates are available for use through File 
> New > Templates and Documents and the extension is listed in the Extension Manager.

The slide masters created by the newly installed templates will now appear in the list of Available 
Master Pages in the Tasks Pane (Figure 18).

Tip

To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions here link. You do not need to download 
them separately as in step 1 above. It is advised that you use the Extension Manager 
to check for any new Impress updates.

Creating your own templates
To create a template from a presentation:

1) Open the presentation that you want to use for a template.

2) From the main menu, choose File > Templates > Save. The Templates dialog opens.

3) In the New template field, type a name for the new template.

4) In the Categories list, click the folder in which you want to store the template. This is 
usually the My Templates folder, unless you have created other folders.

To learn more about template folders, see “Organizing templates” on page 46.

5) Click OK. LibreOffice saves the new template and the Templates dialog closes.

Note
All the slide masters used in the template become available for use in other 
presentations.
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Figure 30. Saving a new template

Setting a default template
If you create a document by choosing File > New > Presentation from the main menu, LibreOffice 
creates the document from the default Impress template. However, you can set any presentation 
template to be the default template, even a custom template that you have created, so long as it is 
in one of the folders displayed in the Template Management dialog. You can reset back to the 
default Impress template later if you choose.

Setting a custom template as default
To set a custom template as default instead of using the Impress default template:

1) From the main menu, choose File > Templates > Organize. The Template Management 
dialog opens.

Figure 31. Template Management dialog

2) In the box on the left, double-click the folder containing the template that you want to set as 
the default, then select the template.

3) Click the Commands button.

4) From the drop-down menu, choose Set As Default Template. The next time that you 
create a new presentation by choosing File > New, the new presentation will be created 
from this template.
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Resetting default Impress template
To reset the default template for a new presentation to use the Impress default:

1) In the Template Management dialog, click any folder in the box on the left.

2) Click the Commands button and choose Reset Default Template from the drop-down 
menu. This command does not appear unless a custom template has previously been set 
as the default, as described above.

The next time that you create a new presentation by choosing File > New, the presentation will be 
created from the default Impress template.

Modifying a template
You can edit the styles and content of a template and then, if you wish, you can reapply the 
template styles to presentations that were created from that template.

Note You can only reapply styles. You cannot reapply content.

To edit a template:

1) From the main menu, choose File > Templates > Edit. A standard file browser window 
opens.

2) Find and select the template that you want to edit and then click Open. The selected 
template opens in Impress.

3) Edit the template just as you would any other presentation. To save your changes, choose 
File > Save from the main menu.

Updating a document from a changed template
The next time that you open a presentation that was created from the changed template, the 
following message appears.

Figure 32. Update styles message

Click Update Styles to update any styles in the template that have been changed in the document. 
Click Keep Old Styles if you do not want to update any styles in the template that have been 
changed in the document. Whichever option you choose, the message box closes and the 
presentation opens in Impress.

Organizing templates
LibreOffice can only use templates that are in LibreOffice template folders. You can create new 
LibreOffice template folders and use them to organize your templates. For example, you might 
have separate template folders for different purposes or projects. You can also import and export 
templates.

To begin, choose File > Templates > Organize from the main menu. The Template Management 
dialog (Figure 31) opens.
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Note
All the actions available from the Commands button in the Template Management 
dialog can also be carried out by right-clicking on the templates or the folders.

Tip
The location of LibreOffice template folders varies with your computer’s operating 
system. To learn where the template folders are stored on your computer, go to 
Tools > Options > LibreOffice > Paths.

Creating a template folder
To create a template folder:

1) In the Template Management dialog, click any folder.

2) Click the Commands button and choose New from the drop-down menu. A new folder 
called Untitled appears.

3) Type a name for the new folder, and then press Enter. LibreOffice saves the folder with the 
name that you entered.

Deleting a template folder
You cannot delete the template folders supplied with LibreOffice or installed using the Extension 
Manager. You can only delete folders that you have created.

To delete a template folder that you have created:

1) In the Template Management dialog, select the folder that you want to delete.

2) Click the Commands button and choose Delete from the drop-down menu. A message box 
appears and asks you to confirm the deletion. Click Yes.

Moving a template
To move a template from one template folder to another template folder:

1) In the Template Management dialog, double-click the folder that contains the template you 
want to move. A list of all the templates contained in that folder appears underneath the 
folder name.

2) Click the template that you want to move and drag it to the desired folder. If you do not 
have the authority to delete templates from the source folder, this action copies the 
template instead of moving it.

Deleting a template
You cannot delete the templates supplied with LibreOffice or installed using the Extension 
Manager. You can only delete templates that you have created or imported.

To delete a template:

1) In the Template Management dialog, open the folder that contains the template you want to 
delete by double-clicking on it. Then click the template that you want to delete.

2) Click the Commands button and choose Delete from the drop-down menu. A dialog 
appears and asks you to confirm the deletion. Click Yes.

Importing a template
Before you can use a template, you must import it into a LibreOffice template folder. To import a 
template into a template folder from another location on your computer:

1) In the Template Management dialog, click the folder into which you want to import the 
template.
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2) Click the Commands button and choose Import Template from the drop-down menu. A 
standard file browser window opens.

3) Find and select the template that you want to import and click Open. The file browser 
window closes and the template appears in the selected template folder.

4) If you want, type a new name for the template, and then press Enter.

Exporting a template
To export a template from a template folder to another location:

1) In the Template Management dialog, double-click the folder that contains the template you 
want to export. 

2) Click the template that you want to export.

3) Click the Commands button and choose Export Template. from the drop-down menu. The 
Save As window opens.

4) Find the folder into which you want to export the template and click Save.

Printing a list of styles defined in a template

To print a list of the styles defined in a template:

1) In the Template Management dialog, double-click the folder that contains the template.

2) Double-click the required template and Styles appears below the template name. Click 
Styles to select it.

3) Click the Commands button and choose Print from the drop-down menu and the Print 
dialog opens. From here you can print to a file or to a printer as usual.
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Introduction

Any text used in slides is contained in text boxes. This chapter describes how to create, modify, 
use, and delete text boxes. It also discusses the various types of text that can be inserted and 
explains how to format the text. Finally, it provides information on how to insert special forms of text 
such as numbered or bulleted lists, tables, fields, and hyperlinks.

Working with text boxes

There are two ways of adding text boxes to slides:

• Choose a predefined layout from the Layouts section of the Tasks pane, containing text 
elements as described in Chapter 1. These text boxes are called AutoLayout text boxes.

• Create a text box using the text tool  in the Drawing toolbar or the Text toolbar.

Using text boxes created from the Layout section
Make sure Normal view is selected:

1) Click in the text box that reads Click to add text.

2) Type or paste your text in the text box.

These text boxes are known as AutoLayout text boxes. See also “Creating bulleted and numbered
lists” on page 62.

Using text boxes created from the text tool
Make sure Normal View is selected:

1) Click on the Text icon  on the Drawing toolbar (Figure 33). The default position of the 
drawing toolbar is towards the bottom of the screen. If the Drawing toolbar with the text 
icon is not visible, choose View > Toolbars > Drawing.

Figure 33: Drawing Toolbar

2) Click and drag to draw a text box on the slide. This sets the width. Do not worry about the 
height because the text box will expand as you type.

3) To reposition the text box to a different part of the slide, see “Moving a text box” on page 
52; to change the width, see “Resizing a text box” on page 52.

4) Release the mouse button when finished. The cursor appears in the text box, which is now 
in edit mode (a hashed border; see Figure 34).

5) Type or paste your text in the text box.

6) Click outside the text box to deselect it.

Note

In addition to the normal text boxes where text is horizontally aligned, it is possible to  

insert text boxes where the text is aligned vertically. Click on the  icon in the 
drawing toolbar (Figure 33) to create a vertical text box. This choice is available only 
when Asian languages are enabled in Tools > Options > Language Settings > 
Languages.
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Figure 34: Using text boxes

Figure 35: Text toolbar

Using text boxes created from the Text toolbar
Make sure Normal view is selected:

1) Click on the Text icon  on the Text toolbar (Figure 35). If the Text toolbar with the text 
icon is not visible, choose View > Toolbars > Text.

2) Click and drag to draw a text box on the slide. This sets the width. Do not worry about the 
height because the text box will expand as you type.

3) To reposition the text box to a different part of the slide, see “Moving a text box” on page 
52; to change the width, see “Resizing a text box” on page 52.

4) Release the mouse button when finished. The cursor appears in the text box, which is now 
in edit mode (a hashed border; see Figure 36).

5) Type or paste your text into the text box.

6) Click outside the text box to deselect it.

Note
If you want to use vertical text text, click on the  icon in the text toolbar (Figure
35) to create a vertical text box. This choice is available only when Asian languages 
are enabled in Tools > Options > Language Settings > Languages.
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Figure 36: Moving a text box

Moving a text box
In Normal view, notice how the pointer changes from an arrow to an I-beam as you move it over 
the text in a text box.

1) Click when the pointer becomes an I-beam. The text box is now in edit mode. In this mode 
a hashed border is visible around the text box edges.

2) Move the I-beam (or pointer) over the hashed border. Notice how the I-beam changes 
shape, becoming the usual “move” symbol for your operating system (for example, a hand).

3) When the “move” symbol appears, click once and colored selection handles appear.

4) Click anywhere in the text box or on the hashed border (except for the colored handles) 
and drag to move the text box. A semi-transparent copy of the text box shows where your 
text box will be placed (Figure 36).

5) Release the mouse button when the text box is in the desired position. To return to edit 
mode, click outside the text box area and then repeat step 1) of this procedure.

Resizing a text box
In Normal view, enter edit mode by clicking on the text box, then move the mouse to the edge of 
the text box (Figure 37). When the cursor shape changes, click the left mouse button again. The 
text box now displays colored resizing handles. Move the pointer over any handle. Notice how the 
pointer changes shape, indicating in which direction the text box will be resized.

The corner handles change the two dimensions of the text area simultaneously, while the four 
handles at the center of each side modify only one dimension. When the two-headed arrow is 
displayed, click and drag to resize the text box.

Tip
To maintain the proportions of a text box while resizing, press and hold the Shift key, 
then click and drag. Make sure to release the mouse button before releasing the 
Shift key.

For more accurate control over the shape, size and position of the text box, instead of using the 
mouse, use the Position and Size dialog. Select the text box, then press F4 or select Format > 
Position and Size from the menu bar. The use of this dialog is explained in Chapter 2.
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Figure 37: Resizing a text box

Deleting a text box
1) Click the text once to display the hashed border.

2) Move the cursor to the edge of the text box and click the left mouse button. The hashed 
border now shows colored selection handles.

3) Press Delete.

Tip
Sometimes it is faster to to delete a text box by dragging a selection rectangle around 
the text box and then hitting the Delete key. Take care to avoid selecting and 
accidentally deleting other text boxes or shapes.

Inserting text

Pasting text
Text may be inserted into the text box by copying it from another document and pasting it into 
Impress. However, the pasted text will probably not match the formatting of the surrounding text or 
that of the other slides in the presentation. This may be what you want on some occasions; 
however in most cases you want to make sure that the presentation style is consistent. There are 
several ways to ensure consistency; these methods are explained below.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply the formatting later. To paste 
without formatting, either press Control+Shift+V and then select Unformatted text from the dialog 
that appears, or click on the small black triangle next to the paste symbol in the standard toolbar 

 and select Unformatted text. The unformatted text will be formatted with the outline style at 
the cursor position in an AutoLayout text box or with the default graphic style in a normal text box.

Figure 38: Text formatting toolbar
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Formatting pasted text
If pasting the text into an AutoLayout area, then to give the pasted text the same look and feel of 
the rest of the presentation apply the appropriate outline style to the text. To do so:

1) Paste the text in the desired position. Do not worry if it does not look right: it will in a 
minute.

2) Select the text you have just pasted (see “Selecting text” on page 56 for details on how to 
do that).

3) Select Format > Default formatting from the menu bar. This operation will assign one of 
the nine Presentation styles to the text (depending on where the insertion is made).

4) Use the four arrows on the Text Formatting toolbar (highlighted in Figure 38) to move the 
text to the appropriate position and give it the appropriate outline level. The left arrow 
promotes the list entry by one level (for example from Outline 3 to Outline 2), the right 
arrow demotes the list entry by one level, the up and down arrows move the list entry.

5) Apply manual formatting as required to sections of the text (to change font attributes, tabs, 
and so on).

If you are pasting text into a text box, you can still use styles to quickly format the text. Note that 
only one graphic style can be applied to the copied text. To do this:

1) Paste the text in the desired position.

2) Select the text you have just pasted (see “Selecting text” on page 56 for details).

3) Select the desired graphic style.

4) Apply manual formatting as required to sections of the text.

Tip Presentation styles are very different from Writer styles and are applied in quite a 
different way. Refer to ”Using styles to format text on page 56 for details.

Inserting special characters
To insert special characters, such as copyright, math, geometric, or monetary symbols, or 
characters from another language:

1) Click in the place in the text where you want to insert the character.

2) Choose Insert > Special Character. The Special Characters dialog appears (Figure 39). 
Alternatively if the text formatting toolbar has been customized and the special character 

icon  is visible, you can click this to bring up the Special Characters dialog.

Tip
To show toolbar buttons that are not visible, click on the small down-arrow on the 
right end of the tool bar, move the cursor over Visible Buttons and then click on the 
icon you wish to make visible.

3) Choose the font and character subset from the Font and Subset drop-down menus.

4) Click the character you want to insert. You may have to scroll to find the one you want.

5) Click OK.

Characters you select will be inserted in the order they were selected, even if you accidentally click 
on the wrong character. Clicking on another character will only add it to the ones being inserted. 
Click Delete and all the characters selected will be deleted, then click on the correct characters. 
Alternatively, you can also insert all the selected characters and delete any unwanted ones from 
the document because special characters behave like any other character.
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Figure 39: Special Characters dialog

Inserting non-breaking spaces and hyphens
Where it is not desirable for words that are separated by a space or a hyphen to span over two 
lines, or where an optional hyphen is desired, you can insert a special formatting mark. To access 
the Formatting marks options, select Insert > Formatting marks. Impress supports three 
formatting marks:

• Non-breaking space: a non-breaking space between two words prevents these two words 
being separated over two lines. The keyboard shortcut is Control+Shift+Spacebar to insert 
a non-breaking space.

• Non-breaking hyphen: a non-breaking hyphen keeps the two words separated by the 
hyphen on the same line.

• Optional hyphen: an optional hyphen is only activated (thus breaking the word) when the 
word is too long to fit on one line.

Introduction to formatting text

The appropriate use of text formatting can give a presentation a consistent look and a dynamic feel 
and it can even enhance the understanding of an audience by preventing any distracting elements 
in your message.

When you enter text, either in an AutoLayout text box or in a normal text box, it is formatted with a 
set of predefined attributes known as a style. The style used depends on the outline level of the 
point where the text was entered for AutoLayout text boxes. For example, if you are entering a 
level 2 item, Impress will format it either according to the Outline 2 presentation style or the Default 
Graphic style for text boxes.

Tip

Sometimes, as seen also in the “Pasting text” section on page 53, it is very useful to 
re-apply the baseline style to a selection of text eliminating any manual formatting 
applied to it, especially if you made a mistake and you do not know how to undo it. To 
the baseline style, select the manually formatted text and then select Format > 
Default formatting from the menu bar.

Formatting text may require some intervention in three areas:

• Character attributes (for example font color)

• Paragraph attributes (for example alignment)

• List attributes (for example type of bullet)
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In some cases it is quicker and more efficient to apply manual formatting; but in situations where 
you need to perform the same modifications to many different parts of the presentation, the use of 
styles is recommended. Both these techniques are described here.

Note

Unlike LibreOffice Writer, where it is recommended to use styles whenever possible,  
in Impress manual formatting has to be used more often. This is because 
presentation styles are fixed in Impress; therefore it is not possible, for example, to 
have two different level 1s or different types of bullet points for the same outline level.  
Also, the lack of support for character styles forces the use of manual formatting to 
modify sections of the text.

Selecting text
Text must be selected before it can be formatted.

• To format all the text in a text box, click once on the text, then click once on the border of 
the text box. The colored resizing handles are displayed. Now any formatting changes will 
apply to all the text in the text box.

• To format only part of the text, click once on the text, then select the text to be formatted by 
clicking and dragging over it (highlighting). You can also use keyboard combinations to 
select text: move the cursor where you want to begin your selection, press Shift and then 
use the arrow keys to extend your selection. Formatting changes will apply only to the 
selected text.

Tip

To select text word by word, instead of by character, press the Control key and Shift 
key together. To speed up the selection even further, you can combine the Shift key 
with the Home key or the End key to extend the selection up to the start or end of the 
line in which the cursor is positioned, respectively.

Using styles to format text

Impress has two categories of styles: presentation styles and graphics styles. Presentation styles 
are used on text inserted into an AutoLayout area, slide master backgrounds, and background 
objects. However, for text inserted in a text box or a graphic object, you need to apply a graphic 
style.

In this chapter we focus mostly on Presentation styles. For information on graphic styles, see 
Chapter 6, Formatting Graphic Objects.

Modifying a presentation style
To modify a presentation style, follow these steps:

1) Open the Styles and Formatting window (Figure 40) by pressing F11 or selecting Format > 
Styles and Formatting from the menu bar.

2) Make sure the Presentation Styles icon  is selected.

3) Right-click on the style to be modified and select Modify from the pop-up menu. The top 
portion of the dialog for modifying a presentation style is shown in Figure 41.
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Figure 40: Presentation Styles and Formatting

Figure 41: Dialog for modifying a presentation style

This modifying dialog consists of fifteen tabbed pages, which can be divided in two groups: pages 
that determine formatting of the text, and pages that determine the properties of slide master 
background and background objects.

There is no difference between attributes that determine a style and attributes used manually on 
portions of text. In fact the pages that open when manually applying formatting are the same that 
you use when configuring styles in the styles and formatting dialog. Therefore, once you master 
the formatting of text, you will know how to create and modify a style. In particular:

• For the Font and Font Effects style pages, refer to “Formatting characters” on page 58.

• For the Indents and Spacing, Alignment, and Tabs style pages, refer to “Formatting
paragraphs” on page 60.

• For the Bullet and numbering type, Graphics, Customize style pages, refer to “Creating
bulleted and numbered lists” on page 62.

Some of the pages in the modifying dialog relate to formatting presentation styles and some pages 
relate to formatting the background and background objects, which are described in detail in 
Chapter 6.

Updating a style from a selection
To update a style from a portion of text that you have just modified or would like to use:

1) Select an item in a text box that has the format you want to adopt as a style.

2) In the Styles and Formatting dialog (Figure 40), select the style you want to update and 

then click the Update Style icon .

Applying a presentation style
To apply a presentation style, move the paragraph to the appropriate outline level as described in 
“Changing the order or the outline level” on page 67.This is different from Writer, where you select 
the desired style from the Styles and Formatting window.
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Formatting characters

To view the character formatting options, select Format > Character or click the Character icon 

 on the Text Formatting toolbar (Figure 38) and the Character dialog opens (Figure 42). If Text 

Formatting toolbar is not visible, choose View > Toolbars > Text Formatting. Note that character 
styles do not exist in Impress.

Font page
Use the Font page to select the desired font type, its base attributes (Italic, Bold, etc.) as well as 
the size. A sample of the font is displayed in the lower part of the dialog. You can also specify the 
language of this style. This font page is also available when creating or modifying a presentation 
style or a graphics style.

Figure 42: Font page in Character dialog

Tip
When writing a presentation in multiple languages, you can use the language setting 
to create two styles that only differ in the language but are otherwise the same. This 
allows you to check the spelling of all of the contents without affecting appearance.

If Asian language support has been enabled (Tools > Options > Language Settings > 
Languages), the Font page changes to look like Figure 43. The page is divided into three parts. 
The top and bottom parts have the same functionality as the Character dialog in Figure 42, while in 
the middle part you can specify the Asian text font and its attributes.

Figure 43: Asian language enabled in Character dialog

58 LibreOffice 3.4 Impress Guide



Font Effects page
Use the Font Effects page (Figure 44) to apply special effects to the text, such as over lining and 
underlining, color, shadow and so on. As for the Font page, a sample of the text is displayed in the 
lower part of the dialog, providing a quick visual check of the effects applied. This page is also 
available when creating or modifying a presentation style or a graphics style.

Figure 44: Font Effects in Character dialog

Position page
The Position page (Figure 45) has advanced options to customize text. Use this page to set the 
text position relative to the baseline when you need to insert subscripts or superscripts. This page 
is not available when creating or modifying a presentation style or a graphics style.

Figure 45: Character Position in Character dialog
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To create a superscript or a subscript do the following:

1) Select Superscript or Subscript as applicable.

2) Specify the amount by which the text should be raised (superscripts) or lowered 
(subscripts).

3) Specify the dimensions of the character relative to the baseline character size (in 
percentage).

The amount by which the text is raised or lowered can be set to automatic by selecting Automatic.

Two more position attributes can be set on this page:

• The (width) scaling of the text, which specifies the percentage of the font width by which to 
compress or expand the individual characters of the selected text.

• The spacing between the characters of the font, which can be defined in number of points. 
Selecting Pair kerning causes LibreOffice to automatically adjust the spacing between 
certain pairs of characters to visually improve the appearance. For example, when writing a 
V followed by an A (VA) the spacing between the two letters is reduced (strong kerning) as 
can be easily seen when compared with, say, VS which is not a kerning pair.

Formatting paragraphs

To view the paragraph formatting options, select Format > Paragraph or click the Paragraph icon 

 on the Text Formatting toolbar (Figure 38) and the Paragraph dialog opens (Error: Reference
source not found). If this toolbar is not visible, choose View > Toolbars > Text Formatting. 
Normally the paragraph formatting dialog contains three pages: Indents and Spacing; Alignment 
and Tabs. However, if Asian language support has been enabled in Tools> Options > Language 
Settings > Languages, a page called Asian Typography is also displayed.

Indents and Spacing page
The Indents and Spacing page is shown when the Paragraph dialog opens and has four sections. 
This page is also available in Presentation Styles dialog and Graphics Styles dialog.

Figure 46: Indents and Spacing in Paragraph formatting dialog

• Indent: modifies the indentation of the text (before and after) as well as the indentation of 
the first line.

• Spacing: defines the space before and after each paragraph formatted with the style.
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• Line spacing: determines the spacing between two lines formatted with the style. Note that 
selecting Proportional spacing requires specifying the percentage of a line to be used as 
spacing; 100% corresponds to a single line, 200% to a double line, 50% to half a line. If 
Leading is selected, specify the amount of line spacing in your default unit of measurement.

• Preview area: provides a visual representation of the settings before you apply them.

Tip
Setting the line spacing to less than 100% is a good method to cram a lot of text into 
a text box, however care must be taken as too small a value will make the text hard 
to read.

Tip
You can change the default unit of measurement, for example from inches to 
centimeters, from Tools > Options > LibreOffice Impress > General.

Alignment page
Click on the Alignment tab to display the Alignment page (Figure 47). Use this page to determine 
the paragraph  alignment: Left, Right, Center, or Justified. A preview shows the effects of the 
changes. This page is also available in Presentation Styles dialog and Graphics Styles dialog. 

Note
If you have Complex Text Layout enabled in Tools > Options > Language Settings 
> Languages, an extra selection — Text Direction — appears at the bottom of the 
dialog; you can choose Left-to-right or Right-to-left.

The same alignment options can be accessed using the alignment icons  on the 
Text Formatting toolbar (Figure 38).

Figure 47: Alignment in Paragraph formatting dialog

Tabs page
Click on the Tabs tab to display the Tabs page (Figure 48). Use this page to determine the tab 
stops. This page is also available in Presentation Styles dialog and Graphics Styles dialog.

To delete an existing tab stop, select it in the list and click the Delete button. To delete all the tab 
stops, click the Delete All button.

To create a new tab stop:

1) Set the size of the tab stop in the edit box on the left.

Chapter 3  Adding and Formatting Text 61



2) Select the type. If you set the type to Decimal, specify in the box below the character to be 
regarded as the decimal point.

Figure 48: Tabs in Paragraph formatting dialog

3) Select a fill character which will be drawn from the tab insertion point up to the tab stop. 
You can choose any character to act as fill character.

4) Click the New button to apply the new tab stop.

Asian Typography page
Use the Asian Typography page (Figure 49) to set the following properties relative to line changes. 
This page is also available in Presentation Styles dialog and Graphics Styles dialog.

• Apply list of forbidden characters to the beginning and end of lines

• Allow hanging punctuation

• Apply spacing between Asian, Latin and Complex text

The use of these options is self-explanatory.

Figure 49: Asian Typography in Paragraph formatting dialog

Creating bulleted and numbered lists

The procedure to create a bulleted or numbered list varies depending on the type of text box used, 
although the tools to manage the list and customize the appearance are the same.

In text boxes created automatically by Impress (called AutoLayout), the outline styles available are 
by default bulleted lists. For normal text boxes an additional step is required to create a bulleted 
list.
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Creating lists in AutoLayout text boxes
Every text box included in the available layouts is already formatted as a bulleted list, therefore to 
create a bulleted list the only necessary steps are:

1) From the Layout pane, choose a slide design that contains a text box. Those are easily 
recognizable from the thumbnail.

2) Click in the text box that reads Click to add an outline.

3) Type the text, then press Enter to start a new bulleted line.

The default list type is a bulleted list. To customize the list appearance or to change from bulleted 
to numbered or numbered to bulleted, refer to “Changing the appearance of the list ” on page 63.

Tip

Press Shift+Enter to start a new line without creating a new bullet or number. The 
new line will have the same indentation as the previous line. Click the bullets icon  
on/off on the text formatting toolbar for a line without bullet. If the text formatting 
toolbar is not showing, enable it by selecting View > Toolbars > Text Formatting in 
the menu bar.

Creating lists in other text boxes
To create a list in a text box, follow these steps:

1) Place the cursor in the text box.

2) Click the Bullets On/Off button  in the text formatting toolbar (Figure 38).

3) Type the text and press Enter to start a new bulleted line.

The way to change the appearance of a list is explained on page 63.

Creating a new outline level
1) If necessary, press Enter to begin a new line.

2) Press Tab or click the indentation arrows  in the text formatting toolbar. Each time 
you press Tab or click the right arrow, the line indents to the next outline level. Pressing 
Enter creates a new line at the same level as the previous one. To return to the previous 
level, press Shift+Tab or click the left arrow.

In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a 
different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline 
3 style and so on. As a consequence, a change in the level also produces other changes (for 
example font size, bullet type, and so on).

Caution Do not try to change the outline level by selecting the text and then clicking the 
desired outline style as you would in Writer. Due to the way that presentation styles  
work in Impress it is not possible to apply them in this way.

Changing the appearance of the list 
You can fully customize the appearance of a list, changing the bullet type or numbering for the 
entire list or for single entry. All the changes can be made using the Bullets and Numbering dialog, 
which is accessed by selecting Format > Bullets and Numbering or by clicking on the Bullets 

and Numbering icon  on the text formatting toolbar.
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Selecting the entries
For the entire list:

1) Select the entire list or click on the gray border of the text box so that just the colored 
resizing handles are displayed.

2) Select Format > Bullets and Numbering or click on the Bullets and Numbering icon 

 on the text formatting toolbar.

3) The Bullets and Numbering dialog (Figure 50) contains five tabs: Bullets, Numbering type, 
Graphics, Position, and Customize.

• If a bulleted list is needed, select the desired bullet style from the six default styles 
available on the Bullets page.

• If a graphics style is needed, select one from those available on the Graphics page.

• If a numbered list is needed, select one of the 6 default numbering styles on the 
Numbering type page.

Figure 50: Bullets and Numbering dialog

Later in this section is an explanation on how to add further bullets and numbering styles to the 
existing ones.

For a single line in the list, click anywhere in the line to place the cursor in it and follow steps 2 and 
3 above.

If the list was created in an AutoLayout text box, then an alternative way to change the entire list is 
to modify the Outline styles. Changes made to the outline style will apply to all the slides using 
them, so be careful before using this command. The pages related to list management are 
described below.

Position page
Use the Position page (Figure 51) to adjust the indentation and spacing of the bullet point and its 
text. This page is particularly effective when used in combination with the Customize page.

To set up an outline level, first select it from the list on the left hand side of the page. Select level 
1 – 10 to modify all levels simultaneously. Then set the Indent, which is the spacing between the 
bullet or number and the text. If you select the Relative option, the indent value will be measured 
relative to the previous level and not from the margin.
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Figure 51: Bullets and Numbering – Position page

The numbering alignment is only useful when creating a numbered list; use it to specify the 
alignment of numbers. For example, you may want to align them to the right to line up one and 
two-digit numbers.

Tip
To fully appreciate how the Numbering alignment works, try to create a numbered list  
with more than ten elements and make sure that enough room has been made for a 
two (or more) digit number using the Width of numbering field.

The Position page is not available if you are modifying a presentation style or graphics style, 
however the same effects can be obtained by using the Indents and Spacing page of the 
Paragraph dialog (60) for creating or modifying a slide.

Customize page
Use the Customize page (Figure 52) to alter the style of all the outline levels.

The options available on this page depend on the type of marker selected for the list. Select first 
the level you want to modify on the left hand side of the box. To modify all levels at once, select 
1 – 10 as the level. With these levels being arranged in a hierarchical structure, changing, for 
example, the font attribute of one of the levels ripples through all the lower levels.

Depending on the bullet style selected (bullet, numbering; graphic), some of the following options 
may become available on the Customize page:

• Before: enter any text to appear before the number (for example, Step).

• After: enter any text to appear after the number (for example, a punctuation mark).

• Color: pick the color for the list marker (number or bullet character).

• Relative size: specify the size of the number relative to the size of the characters in the 
paragraph of the list.

• Start at: enter the first value of the list (for example, you might want the list to start at 4 
instead of 1).

• Character button: click this button to select the special character for the bullet.

• Graphics: opens a gallery of available graphics or allows the selection of a file on the hard 
disk to be used as a marker.
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Figure 52: Bullets and Numbering – Customize page

• Width and Height: specify the dimensions of the graphic marker.

• Keep ratio checkbox: if selected, the ratio between the width and the height of the graphic 
marker is fixed.

The right hand side of the screen shows a preview of the modifications made. To revert to the 
default values, click the Reset button in the bottom right corner.

Using the Customize page, you can create complex structured layouts, for example a nested list 
with numbering followed by bullets (Figure 53).

Figure 53: Nested list with mixture of numbers and bullets
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Changing the order or the outline level
Click once in a line of text to place the cursor in it, then click on the Outline tab (to the right of the 
Normal tab) in the Workspace and use the arrow icons in the Text Formatting toolbar (Figure 38) to 
move the text to the appropriate position and give it the appropriate outline level.

The arrow icon pointing left promotes the list entry by one level (for example from Outline 3 to 
Outline 2), the arrow icon pointing right demotes the list entry by one level, the up and down arrow 
icons move the list entry either up or down. Any numbering used adjusts automatically.

Tip
You can also use the Tab key and Shift + Tab keys to promote and demote the 
outline level of a line in a list.

Using tables

Tables are a powerful mechanism to convey structured information quickly, so they represent an 
important tool when creating a presentation. You can create tables directly in Impress eliminating 
the need to embed a Calc spreadsheet or a Writer text table in your presentation. However, in 
some circumstances, it makes sense to embed a Calc spreadsheet, especially when you require 
greater functionality in the table. The tables provided by Impress do have a limited functionality.

Many predefined table designs are available in the Table design section of the Tasks pane (Figure
54).

Figure 54: Table Design task pane
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Creating a table
When working with tables, it is useful to know the number of rows and columns needed as well as 
the appearance. The parameters can be adjusted later, but this is more laborious than setting the 
correct table dimensions from the beginning.

To insert a table, proceed as follows:

1) Select the slide which will contain the table and, if necessary, modify the slide layout to 
create space for the table.

2) Select Table Design (Figure 54) in the task pane. If the task pane is not visible, select View 
> Task pane.

3) Select one of the predefined styles, which only differ in the color scheme. You will be able 
to change the table colors later on. However, it is recommended that you select a color 
scheme similar to the one you want. Selecting a style opens the Insert Table dialog (Figure
55) where you can specify the number of rows and columns.

Figure 55: Insert Table dialog

The table is placed initially at the center of the slide, but you can move it by selecting it and then 
dragging it to the new position, or by using the method described in “Position and size” on page 72.

You can also create a table directly by selecting Insert > Table from the main menu or with the 

Insert Table icon  in the Standard toolbar. This opens the Insert Table dialog where you can 
specify the number of columns and rows.

Click on the small black triangle next to the Insert Table icon to open a graphic tool   for inserting a 
table (Figure 56). To use this tool, move the mouse to the right and down in the grid until you have 
the required number of columns and rows and then click the left mouse button to insert your table.

Figure 56: Insert Table Graphic Tool
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Note

Using either Insert > Table, the Insert Table icon, Insert Table graphic tool inserts a 
table with the default style and settings already applied. This table can be modified to  
your requirements.

A newly inserted table is given a set of default attributes such as color scheme, 
banded rows, header row and so on. Currently these defaults are hard coded in 
LibreOffice and cannot be changed.

Modifying a table
Once the table is added to the slide, you can control its appearance, size, position and so on using 
a combination of the Task Pane options, the Table toolbar and the Table properties dialog.

Task pane options
The following options are available in the Show section of the task pane:

• Header Row: selected by default, it adds a first row with a different background from the 
rest of the table.

• Total Row: the opposite of Header row; if selected, it changes the background of the last 
row to make it stand out from the other rows.

• Banded Rows: selected by default, this option colors alternate rows with different 
backgrounds making it easier to ready data presented in rows.

• First Column: highlights the first column of the table by allocating a darker background to it.

• Last Column: does the same to the last column.

• Banded Columns: when selected, alternate columns are colored differently.

Table toolbar
When a table is selected, eight colored selection handles appear around the edges and the Table 
toolbar (Figure 57) is displayed. If necessary, you can open the toolbar using View > Toolbars > 
Table. The Table toolbar contains the majority of the tools you need to manipulate a table and 
these are described below.

1 Table 7 Merge Cells 13 Insert Row

2 Line style 8 Split Cells 14 Insert Column

3 Line color (border) 9 Optimize 15 Delete Row

4 Borders 10 Text cell alignment - top 16 Delete Column

5 Area style/filling 11 Text cell alignment - center 17 Table Design

6 Color area style/fillings 12 Text cell alignment - bottom 18 Table Properties

Figure 57: The Table Toolbar
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Table
Use to create a new table in the selected slide. Opens the Insert Table dialog (Figure 55) where 
you can select the desired number of rows and columns. Alternatively, click on the small black 
triangle next to the icon to open an Insert Table graphic tool (Figure 56). To use this tool, move 
the mouse to the right and down in the grid until you have the columns and rows you require 
and click the left mouse button.

Line style
Use to change the style of the line of the selected cells. Opens a new dialog where you can 
choose from a range of predefined styles.

Line color (border)
Open a color selection dialog where you can choose the color of the lines around the selected 
cells.

Borders
Use to select among some predefined border configurations. The borders are applied to the 
selected cells. If the desired border pattern is not available, you will need to use the Table 
properties dialog.

Area style/filling
In the drop-down menu, first choose how the selected cells should be filled: Invisible, Color, 
Gradient, Hatching, or Bitmap. Depending on the selection, the Available Fillings drop-down 
menu is populated with the available schemes. Refer to Chapter 6 (Formatting Graphic 
Objects) for details on how to manage area filling styles.

Color area style/filling
Color selection of an area style/filling from a drop down menu.

Merge cells
Merges the selected cells into one cell. Note that the contents of the merged cells are also 
merged.

Split cells
The opposite operation of merge cells. Make sure that the cursor is positioned on the cell you 
want to split, then click to open the Split Cells dialog (Figure 58). Select the number of cells 
required from the split as well as whether the cell should be split horizontally or vertically. When 
splitting horizontally, you can select the “into equal proportions” option to get all cells of equal 
size. The contents of the split cell are kept in the original cell (the one on the left or top).

Figure 58: Split Cells dialog
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Optimize
Evenly distributes the selected cells either horizontally or vertically. If you want to optimize the 
whole table, you can evenly distribute rows or columns by right-clicking on the table edge and 
selecting  Row > Space Equally or Column > Space Equally from the pop-up menu.

Vertical text cell alignment
You can select the vertical alignment of text in a cell by selecting the required cells and 
choosing Top, Center or Bottom. The alignment commands can be applied to all the cells of the 
table by right-clicking on the edge of the table, choosing Cell from the pop-up menu and then 
choosing the required alignment.

Insert or delete rows and columns
Use the Table toolbar to insert or delete rows and columns of your table. Rows and columns 
are inserted/deleted below and to the right of the selected cell. You can insert rows and 
columns at the end of the table using the pop up menu that opens by right clicking on the edge 
of the table. The insert and delete commands are in the Row or Column menus.

Table design
The only purpose of this icon is to open the Table Design pane in the task pane.

Table properties
Click the Table Properties icon on the Table toolbar (Figure 57) to open the Format Cells dialog 
(Figure 59), which contains the following pages:

Figure 59: Format Cells dialog

• Font: use to select the desired font type, its base attributes (Italic, Bold, etc.) as well as the 
size. A sample of the font is displayed in the lower part of the dialog. You can also specify 
the language. See Font page on page 58 for more information on the available options.

• Font Effects: use to apply special effects to the text, such as over lining and underlining, 
color, shadow and so on. As for the Font page, a sample of the text is displayed in the 
lower part of the dialog, providing a quick visual check of the effects applied. See Font
Effects page on page 59 for more information on the available options.

• Borders: use to set advanced properties not available from the Table Toolbar, such as the 
spacing between the text and the border as well as setting the style of each individual 
border of the table separately. This page also provides the same options as the line style 
and line color buttons of the Table toolbar.

Note It is currently not possible to define diagonal borders for Impress tables.

Chapter 3  Adding and Formatting Text 71



• Background: changes the background of the selected cells and provides the same 
functions as the Area style/filling and Color area style/filling on the Table Toolbar.

Note
The Table Properties dialog can also be accessed from the pop-up menu that opens 
when right-clicking on the table.

Position and size
Impress treats tables just like any other graphic object. You can change table position and size on 
the slide by using the mouse or, for more accurate control, with the Position and Size dialog 
(Figure 60). When the table is selected right-click on the edge of table and select Position and 
Size from the pop-up menu or use Format > Position and Size on the main menu bar. Only the 
Position and Size page is available for tables. For more information on this dialog see Chapter 6 
Formatting Graphic Objects.

Note Unlike other graphic objects, tables cannot be rotated.

Figure 60: Position and Size dialog

Deleting a table
To delete a table use one of the following methods:

• Click in the slide and drag a box over the table to select it. Then press the delete key.

• Select all the rows in the table and use the Delete Row icon on the table toolbar (Figure
57).

Using fields

Fields allow the automatic insertion of text into the slide. You can think of a field as a kind of 
formula which is calculated when the document is loaded or printed and the result is written in the 
document. Fields are commonly used when creating templates and slide masters, as explained in 
Chapter 2.
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Inserting a field
To insert a field into a slide, move the cursor where the field will be and then select from the menu 
bar Insert > Fields followed by one of these choices:

• Date (fixed): inserts the date at the date of inserting the field.

• Date (variable): inserts a field that is updated with the date at the time of opening the file.

• Time (fixed): inserts a field displaying the time at the time of insertion.

• Time (variable): inserts a field which is updated with the time at the time of opening the 
file.

• Author: inserts the author of the presentation. This information is derived from the value 
recorded in the general options. To modify this information go to Tools > Options > 
LibreOffice > User Data.

• Page Number: inserts the page number of the slide.

• Page Count: inserts the total number of slides.

• File Name: inserts a field that contains the name of the file.

Customizing fields
The appearance of all the fields, excluding the page number field, can be customized from the 
corresponding field editor. To access the field editor (Figure 61):

1) Move the cursor to the field and select it.

2) Select Edit > Fields from the menu bar or right click on the field data.

3) Select the desired format in the dialog that appears.

4) Click OK.

Figure 61: Field Editor dialog

Tip
A similar list of format choices can be accessed by selecting the field and 
right-clicking.

Modifications to the page number fields can be done in two ways:

• Select the field and apply the formatting manually.
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• Switch to the slide master editing mode (View > Master > Slide Master), then modify the 
Background object style as desired. Once back in Normal view, insert page numbers from 
Insert > Page Number in the main menu. See Chapter 2 for more information about 
editing a slide master.

Using hyperlinks

When inserting text (such as a website address or URL) that can be used as a hyperlink, Impress 
formats it automatically, creating the hyperlink and applying color and underlining. If you do not 
want Impress to do that, select Edit > Undo Insert from the menu bar or press Control+Z 
immediately after the formatting has been applied.

You can also insert hyperlinks manually.

Tips

To prevent LibreOffice from automatically turning website addresses (URLs) into 
hyperlinks, go to Tools > AutoCorrect > Options and deselect the URL Recognition 
checkbox.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > 
Appearance, scroll to Unvisited links and/or Visited links, select the checkboxes, 
pick the new colors and click OK. Caution: this will change the color for all hyperlinks 
in all components of LibreOffice which may not be what you want.

To insert a hyperlink, or to customize the appearance of a hyperlink, select Insert > Hyperlinks 
from the menu bar. The Hyperlink dialog opens (Figure 62).

On the left hand side, select one of the four types of hyperlinks. The top right part of the dialog 
changes according to the choice made for the hyperlink type. A full description of all the choices, 
and their interactions, is beyond the scope of this chapter. A summary of the most common choices 
used in presentation are given below.

Figure 62: Dialog to edit hyperlinks

• Internet: choose whether the link is Web, FTP or Telnet. Enter the required web address 
(URL).

• Mail & News: choose whether the link is an E-mail or news link. Enter the receiver address 
and for email, also the subject.
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• Document: creates a hyperlink to another document or to another place, commonly 
referred to as a bookmark, in the presentation. Enter the document path, or click on the 
Open File icon to open a file browser; leave this blank if you want to link to a target in the 
same presentation. Optionally, you can specify a target i(for example a specific slide). Click 
on the Target icon to open the Navigator where you can select the target, or if you know 
the name of the target, you can type it into the box.

• New Document: creates a hyperlink to a new document. Choose whether to edit the newly 
created document immediately (Edit now) or just create it to edit later (Edit later). Choose 
the type of document to create (text, spreadsheet, etc.). For a presentation, Edit now is the 
more likely choice. The Select path button opens a file browser so that you can choose the 
directory for the new document.

Note 
For navigation within a presentation, it is generally better to use the object interaction 
menu that you can find either in the Drawing toolbar or in the pop-up menu that opens 
when right-clicking on an object.

The Further settings section on the Hyperlink dialog is common to all the hyperlink types, although 
some choices are more relevant to some types of links.

• Set the value of Frame to determine how the hyperlink will open. This applies to documents 
that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button. See “Working with
hyperlink buttons” for more information.

• Text specifies the text that will be visible to the user.

• Name is applicable to HTML documents. It specifies text that will be added as a NAME 
attribute in the HTML code behind the hyperlink.

Editing text hyperlinks
To edit a text hyperlink, select it (by dragging across the text, not clicking on it), then choose Edit > 
Hyperlink from the main menu bar. Make changes as needed and click Apply when done. If you 
need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of 
them. Be sure to click Apply after each one. When you are finished, click Close.

Working with hyperlink buttons
A hyperlink button is inserted in the center of the current slide. In most cases, that is not where you 
want it to appear. To edit the text or size of a hyperlink button, or to move it to another place on the 
slide, first display the Form Controls toolbar (View > Toolbars > Form Controls) (Figure 63). 
Select the Design Mode On/Off icon (highlighted).

Figure 63: Form Control toolbar

Now you can click on the hyperlink button and drag it to another position, or right-click to open a 
dialog where you can change the text on the button, the size of the button, and other properties.

When you have finished editing the button, click the Design Mode On/Off icon again to make the 
button inactive. For a detailed description of the properties and how to work with Form Controls, 
refer to the Writer Guide.
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Introduction

Pictures are often used in presentations as they can convey a large amount of information more 
quickly than the written word. You can also give a more professional look to your presentation by 
adding a company logo. Also, you may want to use Impress to create a presentation consisting 
only of pictures, such as a slideshow of holiday snapshots to share with friends.

This chapter describes how to insert and format pictures.

Inserting pictures

This section describes several ways to insert a picture from an external source into the 
presentation. Once the picture has been inserted, it can be formatted extensively as explained later 
in this chapter.

Inserting a picture from a file
Inserting a picture from a file is quick and easy. First choose a slide layout, as described in Chapter 
1, Introducing Impress. Most layouts include an set of icons for inserting objects, but you can insert 
a picture into any slide.

Whether you are using an AutoLayout for the placement of the picture, or you are just inserting a 
picture, follow these steps:

1) Go to Insert > Picture > From file on the menu bar or click on the Insert Picture icon 
(Figure 64) if you have inserted a slide and the Insert picture dialog opens (Figure 65).

2) Navigate to the directory containing the desired picture and select the file. LibreOffice 
recognizes a large number of image types. If the Preview option is selected, a thumbnail of 
the selected file will be displayed in the preview pane on the right.

3) Click Open to place the picture on the current (selected) slide. The picture is now displayed 
on the slide with colored resizing handles around it.

Figure 64: Slide showing the placeholder for inserting objects
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Figure 65: Insert picture dialog

Note
The Insert picture dialog has two options Link and Preview. The position of these 
options is determined by the operating system, but they are normally in the bottom-left  
part of the dialog.

Select the Link option to insert the picture as a link to the file rather than embedding the file itself. 
In general it is preferable to embed images so that the presentation can be copied for use on other 
computers. On some occasions, however, it makes sense to link the image rather than embed it. 
These include:

• When the image file is quite large and linking rather than embedding will dramatically 
reduce the size of the presentation file.

• When the same image file is used in many presentations. For example, when using the 
same background image for all the presentations created.

• When the linked file will be available when loading the presentation. For example, if the 
presentation is a slide show of holiday pictures.

Inserting a picture from a scanner
Inserting an image from a scanner is normally a simple process if one or more than one of the 
following are valid.

• The scanner software driver has been installed on the computer.

• Or the scanner is supported by the SANE system if the computer operating system is Linux 
or other UNIX-like) operating system

• Or the scanner is TWAIN compatible if the computer is operating Windows.

• Or the scanner is TWAIN compatible and if the computer is operating Mac OS.

• The scanner is configured on the computer with LibreOffice software installed.

To insert an image from the scanner:

1) Prepare the image for the scanner and make sure that the scanner is switched on.

2) If more than one scanning device is connected to the computer, select the source from 
Insert > Picture > Scan > Select Source.

3) Choose Insert > Picture > Scan > Request.
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4) The rest of the procedure depends on the scanner driver and interface that is being used. 
Normally, and after a preview scan, you will be required to specify the scan resolution, 
selected what to scan on the preview and other parameters for example color or greyscale. 
Consult the documentation for the scanner for more information.

5) When the image has been scanned, Impress places it into the selected slide. At this point it 
can be edited as any other image.

Inserting a picture from the Gallery
The Gallery contains a collection of images that you can use in a presentation. You can also add 
your own images to the Gallery, making it an essential tool for creating presentations quickly and 
with a consistent look. The Gallery is available in all components of LibreOffice. For an introduction 
to the Gallery, see Getting Started guide, Chapter 11, Graphics, the Gallery, and Fontwork.

Choose Tools > Gallery or click the Gallery icon  on the Drawing toolbar to open the Gallery 
dialog (Figure 66). The Gallery displays categories of themes with images stored under each 
category.

1) Select a theme category from the left pane and then scroll through the right pane to find a 
suitable image.

2) Click on the image and drag it onto the workspace.

3) Release the mouse button and the image will be placed in your slide. If necessary, resize 
the image as described in “Resizing a picture” on page 84.

Figure 66. Inserting an image from the Gallery
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Positioning the Gallery
To expand the Gallery, position the pointer over the line that divides it from the top of the 
workspace. When the pointer changes to parallel lines with arrows, click and drag downward. The 
workspace will resize in response.

By default, the Gallery is docked above the Impress workspace. To undock it , hold down the 
Control key and double-click on the upper part of the Gallery next to the View icons. Double-click in 
the same area to dock it again (restore it to its position over the workspace).

When the Gallery is docked, to hide it and view the full Impress workspace, click the Hide/Show 
button in the middle of the thin bar separating the Gallery from the workspace (highlighted in 
Figure 67). The Hide/Show button lets you keep the Gallery open for quick access while you 
create your slide show, yet out of the way when you need it to be.

Figure 67: Gallery with Hide/Show selector highlighted

Managing Gallery themes

Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and 3D Effects. The left 
pane of the gallery window lists the available themes. Click on a theme to see its images displayed 
in the right pane of the Gallery dialog.

The default themes are read only; no images or graphics can be added to or deleted from these 
themes. The default themes are easily recognizable by right-clicking on each category and the only 
available option in the pop-up menu is Properties.

In a default installation of LibreOffice, the My themes is the only category that is customizable and 
allows you add or delete your own images. You can also create new theme categories where you 
can add or delete your own images and this is explained on page 83.

Adding images to My themes
You can only add images to My themes or themes that you have created.

1) Right-click on My themes or the theme name that you created in the list of theme 
categories and choose Properties from the pop-up menu to open the Properties dialog 
(Figure 68).

2) Click on the Files tab.

3) Click on Find Files to open the Select Path dialog (Figure 69).

4) Browse to the folder that contains the images you want to use.

5) Click on OK to select the files contained in the folder and the Select Path dialog closes. 
The list of files contained in the folder now appear in the Theme Properties dialog.

6) Select the files you want to use in My themes and click on Add. The added files will 
disappear from the file list and the images will appear in the Gallery.
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Figure 68. Theme Properties dialog

Figure 69. Selecting path for new images in themes

7) If you want to add all the files in the list, then click on Add All. All the files will disappear 
from the list and the images will appear in the Gallery.

8) Click OK when finished and the Theme Properties dialog will close.

Deleting images from the Gallery
You can only delete images from My themes or themes that you have created.

1) Right-click on the image in the Gallery window.

2) Choose Delete from the pop-up menu.

3) A confirmation message appears, asking if you want to delete this object. Click Yes.
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Note
The image is a linked file and is deleted from the Gallery only. The original image file 
is not deleted.

All the images in a gallery are linked files. From time to time it is beneficial to update the gallery 
theme to make sure that all the files are still there. To do so, right-click on the theme where you 
added at least one file and then select Update from the pop-up menu.

Adding a new theme to the Gallery
You can add a new theme to the list of theme categories in the gallery as follows:

1) Click the New Theme button above the list of theme categories and the Properties dialog 
opens.

2) Click the General tab and type a name for the new theme in the text box (Figure 70).

3) Click the Files tab and follow Steps 3 through to 8 in Adding images to My themes on 
page 81.

4) The new theme will now be displayed in the list of theme categories in the Gallery.

Figure 70. Adding new theme to the Gallery

Note
If you wish, you can rename this new theme by manually by right-clicking the theme 
name and selecting Rename.

Formatting pictures

This section discusses the formatting of pictures inserted with one of the methods explained in 
Inserting pictures on page 78.

Moving a picture
1) Click on the picture to select it and colored selection handles are displayed.
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2) If necessary, move the mouse cursor over the picture until it changes shape. The cursor 
shape depends on the computer operating system, for example a four headed arrow or a 
hand.

3) Click and drag the picture to the desired position.

4) Release the mouse button.

For a more accurate placement of a picture, use the Position and Size dialog described in Chapter 
6, Formatting Graphic Objects.

Resizing a picture
1) Click the picture to show the colored selection handles.

2) Position the cursor over one of the colored selection handles. The cursor changes shape 
giving a graphical representation of the direction of the resizing.

3) Click and drag to resize the picture.

4) Release the mouse button when satisfied with the new size.

For more accurate resizing of a picture, use the Position and Size dialog described in Chapter 6, 
Formatting Graphic Objects.

Note
The corner handles resize both the width and the height of the graphic object 
simultaneously, while the other four handles only resize one dimension at a time.

Tip
To retain the original proportions of the graphic, Shift+click one of the corner handles, 
then drag. Make sure to release the mouse button before releasing the Shift key.

Caution
Be aware that re-sizing a bit-mapped (raster) image will adversely affect the 
resolution, causing some degree of blurring. It is better to use a specialized graphics 
manipulation program to correctly scale the picture to the desired size before inserting 
it into your presentation. We recommend you use a tool such as Gimp 
(http://www.gimp.org/).

Rotating a picture
As with the position of the image on the page, rotation of a picture can be done manually or using a 
dedicated dialog. The Rotation dialog is described in Chapter 6, Formatting Graphic Objects.

Rotate a picture manually as follows:

1) Select the picture to display the colored selection handles.

2) Click the Rotate icon  on the Drawing toolbar and the selection handles change color 
(Figure 71). The color change will depend on the computer operating system and how the 
computer has been setup.

Note

The icons representing the functions in the toolbars depend on the computer 
operating system used and how the computer has been setup, or whether LibreOffice 
has been customized or not. When in doubt, hover the mouse over the icons and 
wait for the tooltip to appear showing the name of the button.
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Figure 71: Rotating pictures

3) A circle or circle with crosshairs (depending on computer system) appears in the centre of 
the picture indicating the rotation point. The center of the picture is the normal rotation 
point, but this rotation point can be moved to change the rotation center to a corner or to a 
point outside the picture. To do this, click on the rotation point and drag it to the desired 
position before applying the rotation.

4) The selection handles in each corner are the rotation handles and the cursor shape will 
change when moved over one of them. Click the mouse and move in the direction in which 
you want to rotate the picture.

5) When satisfied, release the mouse button.

Tip
To restrict the rotation angles to multiples of 15 degrees, press the Shift key while 
rotating the graphic. This is very handy to rotate pictures of right angles, for example 
from portrait to landscape or from landscape to portrait.

Formatting using the Picture toolbar
When a picture is selected, the Picture toolbar becomes available. This toolbar provides a number 
of formatting options which are described in this section. If the picture toolbar does not appear 
when an image is selected, display it by selecting View > Toolbars > Picture from the menu bar 
(Figure 72).

Figure 72: Picture toolbar

Applying filters

Use the filter icon  on the Picture toolbar to apply various filters to the selected picture. The 
best way to judge if a filter works for your picture is to try it. To apply a filter:

1) Select the pictures so that the colored selection handles are displayed.
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2) Click on the filter icon  to show the different filters that are available. Table 2 describes 
briefly each of the available graphic filters and their effects. See the Draw Guide for more 
information and examples of the effects.

3) Select the filter you wish to apply. To show the name of the filter, hover the cursor over the 
icon and wait for the tooltip to appear.

4) If you are not satisfied with the effect obtained or you want to try a different one, before 
doing anything else click the Undo icon in main toolbar or select Edit > Undo: Bitmap 
Graphic Filter from the menu bar or press Control+Z.

Table 2: Graphic filters and their effects

Icon Name Effect

Invert
Inverts the color values of a color image, or the brightness values 
of a grayscale image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove noise Removes single pixels from an image.

Solarization
Mimics the effects of too much light in a picture. A further dialog 
opens to adjust the parameters.

Aging
Simulates the effects of time on a picture. Can be applied several 
times. A further dialog will open to adjust the aging level.

Posterize
Makes a picture appear like a painting by reducing the number of 
colors used.

Pop Art Modifies the picture dramatically.

Charcoal sketch Displays the image as a charcoal sketch.

Relief
A dialog is displayed to adjust the light source that in turn will 
create the shadow and hence the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Changing graphics mode

Use the graphics mode drop-down list  in the Picture toolbar (Figure 72) to change 
the mode of the image. Choose between the following:

• Default: no changes to the graphic object.

• Grayscale: the image is converted to scales of gray.

• Black/White: each pixel of the image is converted to black or white depending on the 
brightness value.

• Watermark: adjusts the brightness of the image making it suitable to be used as a 
watermark. For more information on inserting watermarks in the presentation, refer to 
Chapter 2, Slide Masters.
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Adjusting the color

Clicking on the color icon  in the Picture toolbar (Figure 72) opens the color adjustment dialog 
(Figure 73).

Figure 73: Color Adjustment dialog

Use this dialog to modify the individual color components of the image (red, green, blue) as well as 
the brightness, contrast, and gamma of the image. If the result is not satisfactory, press Control+Z 
to restore the default values.

Increasing the gamma value of a picture makes it more suitable to be used as a background or 
watermark as it will interfere less with a dark text.

Setting the object transparency

Modify the percentage value in the Transparency box  on the Picture toolbar (Figure
72) to make the image more transparent. Note that this is different from the transparency settings 
for a line or a shape (described in Chapter 5). As with the gamma value, increasing the 
transparency of a picture makes the picture blend more smoothly in the background making the 
overlay text easier to read.

Adjusting the line, area and shadow settings
These settings are not very commonly used for images, with the exception of the shadow setting, 
which applies a shadow to the image.

Cropping pictures
Impress provides two ways to crop a picture: interactively or using a dialog. The interactive method 
is easier to use, but the dialog provides more precise control. You can use both methods: first 
cropping interactively, then use the dialog to fine tune the result.

To crop a selected picture interactively, click the Crop icon  on the Picture toolbar (Figure 72). A 
set of crop marks appears around the picture (see Figure 74).

Figure 74: Interactive crop marks 

When you place the cursor over any of the crop marks, the cursor changes shape. Drag the mark 
to crop the picture. Click outside the picture to deactivate cropping mode.

Press the Shift button while working on the crop marks to produce the following effects:

• For a corner mark, the two sides of the picture forming the corner are cropped 
proportionally with the picture anchored to the opposite corner mark.
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• For a side mark, both dimensions are changed proportionally with the image anchored to 
the opposite side mark. 

The interactive crop mode operates in Keep Scale mode (see below).

To crop using the dialog, right-click a selected picture and choose Crop Picture or choose Format 
> Crop Picture from the menu bar. The Crop dialog (Figure 75) has the following options:

• Keep scale/Keep image size: when Keep scale is selected (default), cropping the image 
does not alter the scale of the picture. When Keep image size is selected, cropping 
produces enlargement (for positive cropping values), shrinking (for negative cropping 
values), or distortion of the image so that the image size remains constant.

• Left, Right, Top, and Bottom: the function of these boxes changes according to the choice 
made between Keep scale and Keep image size. In both cases, when a value is entered in 
one of these boxes, the image is cropped by that amount. For example, a value of 3cm in 
the Left box will cut 3cm from the left side of the picture.

When Keep scale is selected, the size of the image also changes, so in this example the 
width will be reduced by 3 cm. If Keep image size is selected instead, the remaining part of 
the image is enlarged (positive values for cropping) or shrunk (negative values for 
cropping) so that the width and height of the image remains unchanged.

Note that the Width and Height fields change as you enter the values when in this mode. 
Use the thumbnail next to these fields to determine the correct amount by which to crop.

Figure 75: Crop dialog options available when cropping a picture

• Scale Width and Height: specifies in percentages the scaling of the picture. The size of 
the image changes accordingly.

• Image size: specifies the size of the image in your preferred unit of measurement. The 
image enlarges or shrinks accordingly.

• Original size: when clicked, restores the original image size.

Deleting a picture
1) Click on the picture and the colored selection handles are displayed.

2) Press Delete.
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Creating an image map

An image map defines areas of the image (called hotspots) associated with a URL (a web address 
or a file on the computer). Hotspots are the graphic equivalent of text hyperlinks. Clicking on a 
hotspot causes Impress to open the linked page in the appropriate program (for example, default 
browser for an HTML page; LibreOffice Writer for a .ODT file; PDF viewer for a PDF file).

You can create hotspots of various shapes, such as hotspots: rectangles, ellipses, and polygons. 
You can also include several hotspots in the same image. When you click on a hotspot, the URL 
opens in a browser window or frame that you have specified. You can also specify the text that 
appears when your mouse cursor hovers over the hotspot.

To use the image map tool to create or edit a hotspot:

1) Select the picture on a slide where hotspots are going to be defined.

2) Go to Edit > ImageMap on the main menu bar and the ImageMap Editor dialog opens 
(Figure 76). The main part of the dialog shows the image on which the hotspots will be 
defined.

3) Active hotspots are indicated by a colored border, while inactive hotspots are indicated by a 
black or grayed out border.

Figure 76: Image Map Editor dialog for creating hotspots

4) Use the tools at the top of the dialog and the fields to define hotspots and their links.

5) Click the Apply icon  to apply the settings.

6) When done, click the Save icon  to save the image map to a file, then click the X in the 
upper right corner to close the dialog.

The top part of the dialog, from left to right, contains the following tools:

• Apply icon: click this icon to apply any changes made.

• Open, Save, and Select icons.
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• Rectangle, Ellipse, Polygon and FreeForm Polygon tools for drawing a hotspot shape. 
These tools work in exactly the same way as the corresponding tools in the Drawing 
toolbar (described in Chapter 5).

• Edit, Move, Insert, Delete Points are advanced editing tools to manipulate the shape of a 
polygon hotspot. Select Edit Points tool to activate the other tools.

• Active icon: toggles the status of the hotspot activating a   selected hotspot or deactivating 
it if active.

• Undo and Redo icons.

• Macro: associates a macro with the hotspot instead of a hyperlink.

• Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.

Below the toolbar are fields which specify the properties of a hotspot:

• Address: the URL address that points to a hyperlink. You can also point to an anchor in a 
document such as a specific slide number; to do this, write the address in this format: 
file:///<path>/document_name#anchor_name

• Text: enter the text that will be displayed when the mouse is moved over the hotspot.

• Frame: where the target of the hyperlink will open: _blank (opens in a new browser 
window), _self (default selection and opens in an active browser window), _top or _parent.

Tip
The value _self for the target frame will work on the vast majority of the occasions. It  
is not recommended to use the other values unless absolutely necessary.
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Introduction

This chapter describes how to manage graphic objects and in particular how to rotate, distort, 
arrange, and position them on the slide. Though this chapter focuses on the shapes that can be 
created with the available tools in Impress, some of the techniques described in this chapter are 
also applicable to images imported into slides.

Drawing toolbar

Default drawing tools
The Drawing toolbar (Figure 77) contains the majority of the tools normally used to create graphic 
objects. If this toolbar is not visible, select View > Toolbars > Drawing from the main menu bar. 
Table 3 describes the default set of tools that are available on the Drawing toolbar.

Figure 77: Drawing toolbar

Note

Your drawing toolbar may differ from the one shown in Figure 77 as this depends on 
how many drawing tools have been placed on the toolbar. If you click on the black 
triangle on the right of the drawing toolbar, then select Visible Buttons to display the 
available tools. From this dialog you can install and remove tools to and from the 
toolbar. Installed tools are indicated by a border around the icon.

Table 3: Default set of drawing tools on the Drawing Toolbar

Tool Name Purpose

Select Selects objects. To select a group of objects, click above the top left object  
and drag the mouse below the bottom right object of the intended selection 
while keeping the mouse button pressed. A “marching ants” rectangle 
identifying the selection area is displayed. You can also select several  
objects by pressing and holding the Shift key while selecting the individual 
objects.

Line Draws a straight line from the point where you click the mouse to the point 
where you drag the mouse pointer and release the mouse button. Press 
the Shift key to restrict the angle of the line to multiples of 45°. Press the 
Alt key to draw a line from its center. Press the Control key to detach the 
end point of the line from the grid (see “Snapping objects to grid or snap
guides“ on page 106).

Line Ends 
with Arrow

Draws a straight line ending with an arrowhead. The arrowhead is placed 
at the end of the line where you release the mouse button. The Shift, Alt 
and Control keys have the same effect as for the Line tool.

Rectangle Draws a rectangle when you drag the mouse from the top left to the bottom 
right corner. Press the Shift key to draw a square. Press the Alt key to draw 
a rectangle or square from its center.

Ellipse Draws an ellipse. Press the Shift key to draw a circle. Press the Alt key to 
draw an ellipse or circle from its center.

Text Creates a text box with text aligned horizontally.
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Tool Name Purpose

Vertical Text Creates a text box with text aligned vertically. This tool is available only  
when Asian language support has been enabled in Tools > Options > 
Language Settings > Languages.

Curve Draws a shape depending on the option that has been selected. Actual 
icon shown will depend on the option that has been selected. Click on the 
black triangle to show the available options Note that the title of this 
submenu when undocked from the drawing toolbar is Lines.

Connector Draws a connector line between two figures. Actual icon shown will depend 
on the option that has been selected. Click on the black triangle to show 
the available options. Each option is described in “Working with
connectors“ on page 109.

Lines and 
Arrows

Draws a line ending in an arrow. Actual icon shown will depend on the 
option that has been selected. Click on the black triangle to show the 
available options. Note that the title of this submenu when undocked from 
the drawing toolbar is Arrows.

Basic 
Shapes

Click the black triangle to open a toolbar showing the available options.  
Actual icon shown will depend on the option that has been selected. Select 
the desired basic shape, then draw it by placing your cursor on the slide 
and dragging your mouse to define an enclosing rectangle. Keep the Shift 
key pressed to obtain a basic shape where the height and width are equal.  
Press the Alt key to draw a basic shape from its center.

Chapter 5  Managing Graphic Objects 93



Tool Name Purpose

Symbol 
Shapes

Click the black triangle to open a toolbar showing the available options.  
Actual icon shown will depend on the option that has been selected. Select 
the desired symbol shape, then draw it by placing your cursor on the slide 
and dragging your mouse to define an enclosing rectangle. Keep the Shift 
key pressed to obtain a symbol shape where the height and width are 
equal. Press the Alt key to draw a symbol shape from its center.

Block 
Arrows

Click the black triangle to open a toolbar showing the available options.  
Actual icon shown will depend on the option that has been selected. Select 
the desired block arrow, then draw it by placing your cursor on the slide 
and dragging your mouse to define an enclosing rectangle. Keep the Shift 
key pressed to obtain a block arrow where the height and width are equal.  
Press the Alt key to draw a block arrow from its center.

Flowcharts Click the black triangle to open a toolbar showing the available options.  
Actual icon shown will depend on the option that has been selected. Select 
the desired flowchart shape, then draw it by placing your cursor on the 
slide and dragging your mouse to define an enclosing rectangle. Keep the 
Shift key pressed to obtain a flowchart where the height and width are 
equal. Press the Alt key to draw a flowchart shape from its center.
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Tool Name Purpose

Callouts Click the black triangle to open a toolbar showing the available options.  
Actual icon shown will depend on the option that has been selected. Select 
the desired callout, then draw it by placing your cursor on the slide and 
dragging your mouse to define an enclosing rectangle. Keep the Shift key 
pressed to obtain a callout where the height and width are equal. Press the 
Alt key to draw a callout from its center.

Stars Click the black triangle to open a toolbar showing the available options.  
Actual icon shown will depend on the option that has been selected. Select 
the desired star, then draw it by placing your cursor on the slide and 
dragging your mouse to define an enclosing rectangle. Keep the Shift key 
pressed to obtain a star where the height and width are equal. Press the 
Alt key to draw a star from its center. Note that the title of this submenu 
when undocked from the drawing toolbar is Starts and Banners.

Points Edits the individual points that form the shape or line. Select this tool and 
then select a shape or a line. You can also press the F8 key to select this 
tool.

Glue Points Edits the glue points of a graphic object. Glue points are the positions 
where connector lines terminate or start. See “Managing glue points” on 
page 109 for instructions.

Fontwork 
Gallery

Opens the Fontwork gallery. See “Using Fontwork” on page 114 for further 
information.

From File Equivalent to Insert > Picture > From file on the main menu. See Chapter 
4 for details.

Gallery Opens the gallery. Equivalent to Tools > Gallery on the main menu. See 
Chapter 4 for details.

Rotate Select this tool to rotate an object. As rotation is considered a formatting 
attribute and this is discussed in Chapter 6 of this guide.

Alignment See “Aligning shapes“ on page 106. Click the black triangle to open a 
toolbar showing the available options. Actual icon shown will depend on 
the option that has been selected.

Arrange See “Arranging objects“ on page 108. Click the black triangle to open a 
toolbar showing the available options. Actual icon shown will depend on 
the option that has been selected. Note that the title of this submenu when 
undocked from the drawing toolbar is Position.

Extrusion 
On/Off

Switches 3D effects on or off for the selected object. Clicking this button 
also opens the 3D settings toolbar. See “Working with 3D shapes” on page 
110 for details.

Interaction Opens a dialog where you can specify the interaction between the user 
and the object. See “Setting up interaction with an object” on page 113.
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Additional drawing tools
In addition to the default set of drawing tools available on the drawing toolbar (Figure 77), you can 
install additional tools. These additional tools are described in Table 4.

To install or remove additional tools onto or from the drawing toolbar:

1) Click on the black triangle on the right of the drawing toolbar.

2) Select Visible Buttons to display a list of the available tools.

3) To install a tool, click on it and the tool will appear in the drawing toolbar. The list of 
available tools will close automatically.

4) To remove a tool, click on it and the tool is removed from the drawing toolbar. Installed tools 
have a border around the tool icon. The list of available tools will close automatically.

Table 4: Additional drawing tools

Tool Name Purpose

3D Objects Click the black triangle to open a toolbar showing the available options.  
Actual icon shown will depend on the option that has been selected. Select 
the desired 3D shape, then draw it by placing your cursor on the slide and 
dragging your mouse to define an enclosing rectangle. Keep the Shift key 
pressed to obtain a 3D shape where the height and width are equal. Press 
the Alt key to draw a 3D shape from its center.

To Curve Converts the selected object to a Bézier curve.

To Polygon Converts the selected object to a polygon (a closed object bounded by 
straight lines). The appearance of the object does not change. If you want, 
you can right-click and choose Edit Points to view the changes.

To 3D Converts the selected 2D object to a 3D object.

To 3D 
Rotation 
Object

Converts the selected 2D object to a 3D rotation object.

Position 
and Size

Opens the Position and Size dialog. You can also press the F4 key to 
open this dialog.

Flip Flips the selected object horizontally, or vertically.

Insert Allows you to insert a slide, table, from file, movie and sound, formula, or 
chart into your presentation. Click the black triangle to open the Insert 
toolbar showing the available options. Actual icon shown will depend on 
the option that has been selected.

Controls Allows you to insert various form controls into your presentation. Click the 
black triangle to open the Form Controls toolbar showing the available 
options.
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Tool Name Purpose

Custom 
Animation

Adds a new animation effect to an object selected in the slide, or changes 
the animation of a selected element. Opens the Custom Animation 
section in the Tasks pane.

Animated 
Image

Adds animation to a selected object on a slide. Opens the Animation 
dialog.

3D Effects Specifies the properties of a 3D object or converts a 2D object to 3D. 
Opens the 3D Effects dialog.

Creating lines and shapes

To create regular shapes and lines:

1) Select the desired line or shape tool from the drawing toolbar.

2) Position your cursor on the slide, then click and drag to create the object.

Drawing a freehand polygon is when you create a shape segment by segment using one of the 
Curves tools on the drawing toolbar (see Table 3 and Figure 78).

Figure 78: Curve tool options

1) Click on the black triangle next to the Curve icon and select a tool.

2) Click once on the slide and move the cursor to draw the first segment.

3) Click once again and drawn the next segment of your freehand polygon.

4) To finish creating your freehand polygon, double-click when you have drawn the last 
segment. If a closed polygon was selected, Impress draws the line connecting the last point 
to the start point and fills the inside area with the default color.

5) Keep the Shift key pressed to restrict the angle between the segments to multiples of 45 
degrees.

When drawing certain regular shapes, one or more colored dots are displayed in a different color to 
the colored resizing handles. These dots perform a different function according to the shape they 
are applied to and are as follows.

Basic Shapes

• Rounded rectangles and squares: use the dot to change the radius of the curve that 
replaces the angled corners of a rectangle or square.

• Circle pie: use the yellow dots to change the size of the filled sector.

• Isosceles triangle: use the dot to modify the triangle type.

• Trapezoid, parallelogram, hexagon, or octagon: use the dot to change the angle between 
the sides.

• Cross: use the dot to change the thickness of the four arms of the cross.

• Ring: use the dot to change the internal diameter of the ring.

• Block arc: use the dot to change both internal diameter and size of the filled area.

• Cylinder and cube: use the dot to change the perspective.

• Folded corner: use the dot to change the size of the folded corner.

• Frame: use the dot to change the thickness of the frame.
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Symbol Shapes

• Smiley face: use the dot to change the smile on the face.

• Sun, moon, heart: use the dot to change the shape of the symbol.

• Prohibited symbol: use the do to change the thickness of the ring and the diagonal bar.

• Double bracket, left bracket, right bracket, double brace: use the dot to change the 
curvature of the bracket.

• Left brace, right brace: use the dots to change the curvature of the brace and the position 
of the point.

• Square bevel, octagon bevel, diamond bevel: use the dot to change the thickness of the 
bevel.

Block Arrows

• Arrows: use the dot to change the shape and thickness of the arrows.

• Pentagon, chevron: use the dot to change the angle between the sides.

• Arrow callouts: use the dots to change the shape and thickness of the callouts.

• Circular arrow: use the dots to change the thickness and area of the arrow.

Callouts

• Callouts: use the dots to change the length, position and angle of the pointer.

Stars

• 4-point star, 8 point star, 24 point star: use the dot to change the thickness and shape of 
the star points.

• Vertical scroll, horizontal scroll: use the dot to change the width and shape of the scroll.

• Doorplate: use the dot to change the inward curvature of the corners.

Grouping objects together

It is often convenient to group objects together so that they are treated as a single object by 
Impress. A group of objects can be formatted as if it was a single object, moved, rotated, deleted 
and so on.

To group objects together:

1) Select the objects to be grouped. To do this, use the selection tool on the drawing toolbar 
and draw a rectangle around the objects to be grouped, or click on each object to be added 
to the group while pressing the Shift key.

2) When the colored selection handles show, select Format > Group > Group or press 
Control+Shift+G on the keyboard or right-click within the group and select Group.

To edit or format a group of objects:

1) Once a group is defined, click on any of the objects in the group to select the group. Any 
editing or formatting is then carried out on all the objects within the group.

2) To edit only individual objects in the group, press F3 when the group is selected or select 
Format > Group > Enter Group from the menu bar or right-click and select Enter Group. 
You can then select individual objects within the group for editing or formatting.

3) To exit from individual editing and formatting, press Control+F3 or select Format > Group 
> Exit group from the menu bar or right-click and choose Exit Group. The whole group 
then becomes selected.

To ungroup objects:

1) Select the group of objects.

98 LibreOffice 3.4 Impress Guide



2) When the colored selection handles show, select Format > Group > Ungroup from the 
menu bar or press Control+Alt+Shift+G or right-click on the group and choose Ungroup.

For more about working with grouped objects, see the Draw Guide Chapter 5, Combining Multiple 
Objects.

Tip

If you use the group and ungroup commands often, why not add them to one of the 
toolbars shown by default so that the commands are readily available? To do so, you 
will need to customize the selected toolbar. See Chapter 11, Setting Up and 
Customizing Impress.

Moving graphic objects

To move a graphic object:

1) Click on a graphic object and the colored selection handles will show.

2) Move the pointer over the graphic object until the pointer changes shape. On most 
operating systems, the pointer associated with moving objects is a four-headed arrow, but it 
may also be a hand or some other symbol.

3) Click and drag the graphic object to the desired position (you can also use the arrow keys).

4) Release the mouse button.

Tip

By default Impress makes the objects snap to the grid. If you need to position the 
object between two points of the grid, hold down the Control key, then click on the 
object and move it to the desired position. Alternatively, you can turn off snap to grid 
or modify the grid resolution by going to Tools > Options > LibreOffice Impress > 
Grid.

For a more accurate placement of the graphic object, use the Position and Size dialog (Figure 79). 
With the graphic object selected and the colored selection handles displayed, either press F4 or 
select Format > Position and Size from the menu bar, or right click on the selected object and 
select Position and Size.

Figure 79: Adjustment of position and size of a graphic object

Chapter 5  Managing Graphic Objects 99



Use the Position section of the dialog to specify the X (horizontal) and Y (vertical) position of the 
graphic object. The values represent the distance of the base point (selected on the right hand side 
of the dialog) relative to the top left corner of the slide.

To prevent accidental modification of the position of the graphic object, select the Position option 
in the Protect section (bottom left) of the dialog.

The unit of measurement for this dialog and other dialogs is set in Tools > Options > LibreOffice 
Impress > General.

Resizing graphic objects

To resize a graphic object:

1) Click on a graphic object and the colored selection handles will show.

2) Position the pointer over one of the selection handles. The pointer changes shape giving a 
graphical representation of the direction of the resizing.

3) Click and drag to resize the graphic object.

4) Release the mouse button to complete resizing.

The corner handles resize both the width and the height of the graphic object simultaneously, while 
the other four handles resize only one dimension at a time.

Tip
To retain the original proportions of the graphic, Shift+click one of the corner handles, 
then drag. Be sure to release the mouse button before releasing the Shift key.

For more accurate resizing of the graphic object, use the Position and Size dialog (Figure 79).

1) Select the graphic object and open the Position and Size dialog.

2) Select as the base point the part of the graphic object that you would like to anchor to the 
page. The default setting (top left corner) means that when resizing, the position of the top 
left corner of the object will not change.

3) Now modify either the Width value or the Height value of the object.

4) To maintain the proportions between width and height, select the Keep ratio option before 
modifying any value. When Keep ratio is selected, changes to one of the dimension result 
in automatic changes to the other.

5) To prevent accidental modifications of the size, make sure that the Size option is selected 
in the Protect section in the bottom left part of the dialog.

Applying special effects

As well as the basic actions of moving and resizing an object, a number of special effects can also 
be applied to objects in Impress. Several of these effects are readily available in the Mode toolbar 
(Figure 80). If the Mode toolbar is not showing, select it from View > Toolbars > Mode.

This section describes how to rotate, flip, distort and two ways of setting an object in a circle. The 
transparency and gradient tools are more specific to formatting and are discussed in Chapter 6.

Rotating graphic objects
Rotation of an object can be carried out manually or using a dedicated dialog, just like changing 
object position and size. To rotate a graphic manually:

1) Click on a graphic object and the colored selection handles will show.
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Figure 80: Mode toolbar and available 
options

Figure 81: Object selected for rotation

2) Click the Rotate icon  in the Drawing or Mode toolbar.

3) The square selection handles change to a diamond shape and also change color (Figure
81).

4) Move the mouse over one of the corner handles and the mouse cursor shape will change. 
Click the mouse and move in the direction in which you want to rotate the graphic object. 
Only the corner selection handles are active for rotation.

5) When satisfied release the mouse button.

Note

The icons representing the functions in the toolbars maybe different depending on 
the operating system used and on whether LibreOffice has been customized. When 
in doubt, hover the mouse over an icon and wait for the tooltip to appear showing the 
name of the icon.

When the Rotate icon is clicked, a circle appears in the middle of the selected object to indicate the 
pivot point for rotation. Normally the center of an object will be just fine, but on some occasions you 
may wish to rotate around a corner or even around a point outside the picture. To move the rotation 
point, click on the circle and drag it to the desired position.
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Figure 82: Rotation page of the Position and Size dialog

To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while rotating 
the graphic. This is very handy for rotating pictures through a right angle, for example from portrait 
to landscape.

Instead of rotating a graphic object manually, you can use the Rotation dialog (Figure 82). To 
display this dialog, select the graphic object so that the selection handles are shown, then press 
F4 or select Format > Position and Size and select the Rotation page.

In the upper part of the dialog, select the position of the pivot point relative to the top left corner of 
the page. The default position of the pivot point is the center of the figure.

In the lower part of the dialog select the angle by which to rotate the graphic object. To the right of 
the Angle text box, eight default rotation values can be selected.

Flipping objects
The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Click on a graphic object and the colored selection handles will show.

2) Right click and select Flip > Horizontally or Flip > Vertically and the selected object will 
be flipped to face the other direction.

The Flip tool on the Drawing or Mode toolbar can also be used. Using this tool also allows you to 
change the position and angle that the object flips over (Figure 83).

1) Click on a graphic object and the colored selection handles will show.

2) Click on the Flip icon  and the axis of symmetry appears as a dashed line through the 
middle of the object. The object will be flipped about this axis of symmetry.

3) Move one or both ends of the axis of symmetry with your mouse cursor to set the 
orientation of the axis.

4) Place the mouse cursor over one of the object selection handles until it changes shape.

5) Click and hold, then move your cursor across the other side of the axis of symmetry. The 
new position of the figure is shown faintly until the mouse is released.
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Figure 83: Using the Flip tool

6) Release the mouse button and the object will appear flipped over. Angle and position of the 
flip will depend on the angle and position of the axis of symmetry.

Note
If you press the Shift key while moving the axis of symmetry and it will rotate in 45-
degree increments.

Mirror copies
At the moment there is no mirror command existing in Draw or Impress. However, mirroring an 
object can be emulated by using the Flip tool as follows:

1) Select the object you want to make a mirror copy of (Figure 84).

2) Copy the object to the clipboard.

3) Select the Flip tool on the Drawing or Mode toolbar.

4) Move the axis of symmetry to the desired location of the mirror axis.

5) Flip the object.

6) Click on an empty area of the page to deselect the object.

7) Paste from the clipboard to put a copy of the object in its original location and now you 
have a mirror copy.

Figure 84: Making a mirror copy of an object
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Distorting an image
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the 

image. The Distort tool  distorts an object in perspective, and Set to Circle (slant)  and 

Set in Circle (perspective)  tools both create a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. The results of using these tools are shown in the following figures.

Distort tool

Select an object and click on the Distort icon  on the Mode toolbar. After converting to a curve 
as requested, move the handles to stretch the object. The corner handles distort the corners, the 
vertical midpoint handles distort the figure horizontally and the horizontal ones distort it vertically 
(Figure 85).

Figure 85: Distorting an image
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Set in circle (perspective) tool

Select an object and click on the Set in Circle (perspective) icon  in the Mode toolbar. After 
converting to a curve , move the object handles to give a pseudo three-dimensional perspective) 
(Figure 86).

Figure 86: Setting an image to a circle with perspective

Set to circle (slant) tool

Select an object and click on the Set to Circle (slant) icon  in the mode toolbar. After 
converting to a curve, move the object handles to give a pseudo three-dimensional slant 
perspective (Figure 87).

Figure 87: Setting an image to a circle with slant

Note
Transforming an object into a curve is a safe operation, but it cannot be reversed 
other than by clicking the Undo button.
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Aligning shapes

Use the alignment tools to adjust the relative position of a graphic object compared to another 

object. Click on the black triangle next to the Alignment icon  in the Drawing toolbar or go to 
View > Toolbars > Align on the main menu bar to open the Align toolbar (Figure 88). These 
alignment options are also available when you right-click on a selected object.

Figure 88: Align toolbar and available options

The toolbar has six icons. The first three determine the horizontal alignment of the selected objects 
(Left, Center, Right); the other three determine the vertical alignment of the selected objects (Top, 
Middle, Bottom). Actual Alignment icon shown on the Drawing toolbar will depend on the option 
that has been selected.

If only one object is selected, it is aligned to the page. If several objects are selected together,  they 
are aligned to the object that selected first.

Snapping objects to grid or snap guides

Sometimes it is important to align objects to specific points of the page or to make sure that objects 
that appear on multiple slides are placed in exactly the same position. For this purpose Impress 
provides two mechanisms: Grid and Snap Guides (also called Snap Lines).

Using the grid
Options for the grid are available by right-clicking on an empty part of the page in Normal view and 
choosing Grid or by selecting View > Grid from the menu bar. In both cases a submenu with three 
options opens:

• Visible Grid (right click) or Display Grid (menu): displays the grid.

• Snap to Grid: the anchor points of an object will be placed on a grid when the object is 
moved or resized.

• Grid to Front: displays the grid in the foreground.

To set up the grid spacing and snapping options, go to Tools > Options > LibreOffice Impress > 
Grid on the menu bar.
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Using snap guides
Options for the guides are available by right clicking on an empty part of the page in Normal view 
and choosing Snap Lines or by selecting View > Guides from the menu bar. A submenu with 
three options opens:

• Snap Lines Visible (right click) or Display Guides (menu): the guides are shown on the 
slide.

• Snap to Snap Lines (right click) or Snap to Guides (menu): the anchor points of the 
objects snap to the guides when the object is moved or resized.

• Snap Lines to Front (right click) or Guides to Front (menu): displays the guides in the 
foreground.

Note The main menu uses the term Guides, but the pop-up menu refers to Snap Lines.

To create a new guide:

1) Right-click on an empty part of the work area and select Insert Snap Point/Line from the 
pop-up menu to open the New Snap Object dialog (Figure 89).

Figure 89: New Snap Object dialog

2) Specify the type of snap object. Depending on the choice made determines which field 
becomes active: Point both X and Y fields become active, Vertical only X field becomes 
active, Horizontal only Y field become active.

3) Enter the position of the guide.

4) Click OK to close the dialog.

Tip

When positioning the Snap Guides, it is useful to display the rulers. To do so, select  
View > Rulers.

Drag a Snap Guide directly onto the slide by clicking on the ruler and then dragging 
onto the slide.

To edit a guide:

1) Right-click next to or on the guide to be edited.

2) Select Edit Snap line from the pop-up menu.

3) Enter a new value in the X or Y field for the guide position and click OK. 
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To delete a guide:

1) Right-click next or on the guide to be deleted.

2) Choose Delete Snap line from the pop-up menu.

Arranging objects

Impress and Draw organize objects in a stack so that the objects on the top level of the stack cover 
the objects on lower levels if any overlapping occurs. The stack level of each object can be 
changed by arranging shapes on a slide or page.

To change the stack level of an object, select an object or objects and then click the small triangle 
on the side of the Arrange icon on the Drawing toolbar to open the Position toolbar (Figure 90). 
The arrange or position options are also available by right-clicking on a selected object.

Figure 90: Position toolbar for arranging objects

The first four tools determine the stack level of a selected object:

• Bring to front: the selected object is moved in front of all other objects.

• Bring forward: the selected object is moved one level up in the stack.

• Send backwards: the selected object is moved one level down in the stack.

• Send to back: the selected object is moved behind all other objects.

The other three tools determine the relative positions of the selected objects:

• In front of object: moves the first selected object in front of the second selected object.

• Behind object: moves the first selected object behind the second selected object.

• Reverse: swaps the stacking order of two selected objects.

To use the In front of object and Behind object tools:

1) Select the first object by clicking on it.

2) When the selection handles show, select the desired arrange action.

3) The mouse pointer changes to a pointing hand. Click on the second object.
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Working with connectors

Connectors are lines that can be anchored to particular places, called glue points, on the graphic 
object. The advantage of connectors is that when the graphic object to which the connector is 
attached is moved or resized, the connector automatically adjusts to the change. When creating a 
flowchart, organization chart, schematics or diagrams, it is highly recommended to use connectors 
instead of simple lines.

Impress offers a wide variety of predefined connectors, which differ in the termination shape (none, 
arrow, custom) and in the way the connector is drawn (straight, line, curved).

When a connector is drawn or selected Impress displays selection handles which are not shown 
for normal lines. The termination points of a connect are diamond shape and square handles are 
used to modify the routing of a connector where applicable.

Draw a connector in a similar way to drawing any object.

1) First open the Connector toolbar by clicking on the black triangle next to the Connector icon 

 (the connector shown depends on the connector option previously selected).

2) Move the mouse cursor over one of the objects to be connected and small crosses appear 
around the object edges which are the glue points to which a connector can be attached.

3) Click on the required glue point to attach one end of the connector, then hold the mouse 
button down and drag the connector to another object.

4) When the cursor is over the glue point of the target object release the mouse button and 
the connector is drawn.

5) If square handles appear on the connector, the path of the connector can be adjusted so 
that the connector does not cover another object in its path.

For more instructions on how to format a connector, refer to the corresponding section in Chapter 
6, Formatting Graphic Objects.

Managing glue points
A glue point is the attachment point for a connector on a shape or graphic object. Each shape has 
a number of predefined glue points, but it is possible to define new ones, as well as edit them, 

using the Gluepoints toolbar. Click on the Gluepoints icon  or go to View > Toolbars > 
Gluepoints to open the toolbar (Figure 91).

The first tool to insert a new glue point onto an object. The next four tools determine the exit 
direction of the connector terminating at the glue point.

To maintain the relative position of the glue point when resizing the object, make sure that the Glue 
point relative icon is selected. Deselecting the Glue point relative icon activates the remaining 
six icons on the toolbar. use these tools to fix the position of the glue point during the resizing of 
the object.

To delete a custom glue point, select it with the mouse and press the Delete key.

Setting custom glue points is useful where multiple connectors terminate on the same side of a 
shape or where the default glue point position is not satisfactory.

To move a predefined or newly inserted glue point:

1) Select the glue point tool from the drawing toolbar.

2) Click on the glue point you want to move. The glue point should now be highlighted.

3) Keep the mouse button pressed and drag the glue point to the desired position. Release 
the mouse button.
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Figure 91: Gluepoints toolbar and available options

Tip

Glue points are placed by default on the grid (see “Snapping objects to grid or snap
guides“ on page 106 for information). However it is sometimes necessary to fine tune 
the position of a glue point depending on the shape of the object. To do this, press 
the Control key to display guide lines and keep the Control key pressed while 
dragging the glue point to the new position.

Working with 3D shapes

3D graphic objects can be created in different ways in Impress:

• From the 3D-Objects toolbar. If the 3D-Objects tool  is not included on the Drawing 
toolbar, click on the small triangle at the end of the Drawing toolbar, select Visible Buttons, 
and then select 3D-Objects from the list. On the Drawing toolbar, click on the small triangle 
next to the 3D-Objects icon to display the 3D Objects toolbar (Figure 92).

Figure 92: 3D-Objects toolbar

• From the Convert sub-menu. Select a shape, right-click on it. In the Convert sub menu 
choose either To 3D to add thickness to the object or To 3D Rotation Object to create a 
3D shape resulting from the rotation of the object around an axis.

• From the Extrusion on/off icon  on the Drawing toolbar. Select the object to apply a 
3D effect, then click the Extrusion on/off icon on the Drawing toolbar to open the 3D-
Settings toolbar (Figure 93).
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Figure 93: 3D-Settings toolbar

Table 5: 3D-Settings tools and their purpose

Tool Name Purpose

Extrusion On/Off Adds thickness to an object and activates the 3D properties.

Tilt Down Tilts the object downwards around an horizontal axis.

Tilt Up Tilts the object up around an horizontal axis.

Tilt Left Tilts the object left around a vertical axis.

Tilt Right Tilts the object right around a vertical axis.

Depth Determines the thickness of the shape. An extended toolbar opens 
where some default values are given. If none of the values are 
satisfactory, select Custom and then enter the desired thickness.

Direction Opens an extended toolbar that lets you pick the direction of the 
perspective as well as the type (parallel or perspective).

Lighting Opens an extended toolbar that lets you specify the direction and 
intensity of light.

Surface Choose between Wire frame (useful when manipulating the object), 
Matt, Plastic or Metal.

3D Color Selects the color of the object thickness.

Although Impress offers advanced functions to manipulate 3D objects, this guide describes only 
the 3D settings applicable to an object with Extrusion enabled. For additional information on how to 
use advanced 3D effects such as geometry and shading, refer to the Draw Guide.

Caution
You cannot apply extrusion to rectangular and oval shapes created by using the 
rectangle or oval tools. Instead, select the desired shape from the basic shapes 
menu to create a rectangle or oval with 3D effects. Alternatively, right-click on the 
object, then select Convert > To 3D. Note that in this case the Extrusion on/off 
menu will not be enabled.

Select an object, then click on the Extrusion on/off icon  to activate the extrusion. The object 
shape changes and a default thickness is added to it. At the same time the 3D-Settings toolbar 
(Figure 93) opens. If this toolbar does not appear, select View > Toolbars > 3D-Settings. Use 
these tools to change the appearance of the 3D object and these are listed in Table 5. An example 
of an object converted to 3D is shown in Figure 94.

Most of the Fontwork shapes (see “Using Fontwork” on page 114) have 3D properties and can be 
manipulated with the 3D-Settings toolbar.

Chapter 5  Managing Graphic Objects 111



Note that when rotating a 3D object, in addition to the corner selection handles, four selection 
handles on the sides of the frame become available.

Figure 94: Example object converted to 3D

Converting an object to a different type

You can convert an object into a different type. Right-click on the object and select Convert to 
display a menu containing the following options:

• To Curve: converts the selected object to a Bézier curve. Click on the Points icon  on 
the Drawing toolbar to edit the points after conversion to a Bézier curve.

• To Polygon: converts the selected object to a polygon. Click on the Points icon to edit the 
object after conversion to a polygon. A polygon always consists of straight segments.

• To Contour: for basic shapes, this is equivalent to converting to polygon. For more 
complex shapes (or for text objects) this conversion creates a group of polygons that you 
can then manipulate by pressing F3 to enter the group.

• To 3D: converts the selected object to a 3D object.

• To 3D Rotation Object: creates a three-dimensional shape by rotating the selected object 
around its vertical axis.

• To Bitmap: converts the selected object to a bitmap.

• To Metafile: converts the selected object to Windows Metafile Format (WMF), containing 
both bitmap and vector graphic data.

Note
In most cases the conversion to a different type does not produce immediately visible 
results.

Tip
To Curve, To Polygon, To 3D and To 3D Rotation Object can be added to the 
Drawing toolbar as additional tools by clicking on the small triangle at the right of the 
toolbar and selecting Visible Buttons.
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Setting up interaction with an object

You can associate an object to an action that is performed when the user clicks on it. To create an 
interaction:

1) Select the object for which an interaction will be created.

2) Click on the Interaction icon  the Drawing toolbar or right-click on the object and select 
Interaction from the pop-up menu and the Interaction dialog opens (Figure 95).

Figure 95: Interaction dialog

3) Select the interaction type and the parameters (if applicable). Click OK to close the dialog. 
The interactions are explained in Table 6 and the Interaction dialog changes depending on 
the type of interaction selected.

4) To remove an interaction from a graphic object follow Steps 1 to 2 and then select No 
action as the interaction type at Step 3.

Table 6: Interaction types and their parameters

Interaction Parameters

Go to previous slide No parameters.

Go to next slide No parameters.

Go to first slide No parameters.

Go to last slide No parameters.

Go to page or object Specify the target from the list in the Target box. You can search for a 
specific target in the Slide/Object box at the bottom of the screen.

Go to document Select the document in the Document box. Use the Browse button to open 
a File Open dialog. If the document to be opened is in Open Document 
Presentation format, the target list will be populated allowing selection of 
the specific target.

Play sound Select the file containing the sound to be played. Use the Browse button to 
open a File Open dialog.

Run program Select the program to execute. Use the Browse button to open a File Open 
dialog.

Run macro Select a macro that will run during the presentation. Use the Browse button 
to open the Macro Selector dialog.

Exit presentation When the mouse is clicked over the object, the presentation will terminate.
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Using Fontwork

Use Fontwork to obtain special text effects. For more about this topic, see Chapter 11, Graphics, 
the Gallery, and Fontwork, in the Getting Started guide.

Figure 96: Fontwork Gallery

To start using Fontwork:

1) To open the Fontwork Gallery (Figure 96) click on the Fontwork Gallery icon  on the 
Drawing toolbar or on the Fontwork toolbar (Figure 97). If the Drawing toolbar is not 
showing, you can go directly to the Fontwork toolbar by selecting View > Toolbars > 
Fontwork from the main menu bar.

2) Select the preferred style from the Fontwork Gallery (Figure 96) and click OK. The text 
Fontwork in the selected style appears on the slide. You can modify its shape and 
properties after it has been placed on the slide.

3) Double-click the object to edit the Fontwork text. Type your own text to replace the word 
Fontwork that appears over the object.

4) Press the Esc key or click outside the area with the colored resizing handles to exit.

5) You can edit some of its attributes by using the Fontwork toolbar or tools that are used to 
change attributes of objects.

Using the Fontwork toolbar
Make sure that the Fontwork toolbar (Figure 97) is visible on the workspace. If not, select View > 
Toolbars > Fontwork from the main menu bar.

In addition to the Fontwork Gallery tool, this toolbar contains the following tools:

• Fontwork Shape : changes the shape of the selected object. Shapes are selected 
from the toolbar (Figure 98) that opens when this tool is selected.
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Figure 97: Fontwork toolbar

Figure 98: Fontwork shape toolbar

• Fontwork Same Letter Heights : changes the height of characters in the selected 
object. Toggles between normal height where characters have different heights to where all 
characters are the same height.

• Fontwork Alignment: : specifies the text alignment within the frame from the choices 
available.

• Fontwork Character Spacing : selects the desired spacing between characters and 
whether kerning pairs should be used. For custom spacing, input a percentage value: 
100% is normal spacing; less than 100% is tight spacing; more than 100% is expanded 
spacing.

Modifying Fontwork text as a shape
It is possible to treat Fontwork text as an object and therefore to apply to it all the formatting that 
has been described in this chapter. Assign line properties only to Fontwork which does not have a 
3D effect, otherwise the changes will not be visible.

Tip
You can change Fontwork color quickly using the Area fill color swatch on the Line 
and Filling toolbar.

You can modify some of the Fontwork shapes just as you modify the angles of trapezoid and 
parallelogram basic shapes by moving the dot that is displayed along with the colored resizing 
handles.

Animations

Animated slide transitions can be added between slides to give your presentation a more 
professional look when you change to the next slide (see Chapter 9 Slide Shows for more 
information on transitions). However, Impress also allows you to add animations onto the slides to 
create more interest in your presentation.

An animation consists of a sequence of images or objects called frames that are displayed in 
succession when the animation runs. Each frame may contain one or more objects. For example, 
make bullet points appear one by one; make pictures, shapes or other objects appear singly or as 
a group onto a slide. Animations can be controlled using the keyboard or mouse click or 
automatically in a timed sequence.

Chapter 5  Managing Graphic Objects 115



There are two ways to create an animation in Impress – Custom Animation (page 116) or Insert 
> Animated Image (page 119) and both are described below.

Tip
Animations can look great in a presentation, but overuse of animations can make a 
good presentation into a poor presentation. Always use discretion when adding 
animations to your presentation.

Figure 99: Custom Animation section on the Tasks pane

Custom Animation
Custom Animation (Figure 99) is located in the Tasks pane to the right of the Workspace in 
Impress. It is used to add an animation effect to a selected object on a slide, or change the 
animation effect of a selected object.

Note
Anything that can be placed onto a slide is an object. For example, an object can 
include a picture, clip art drawing or text and so on.

116 LibreOffice 3.4 Impress Guide



The Custom Animation section contains the following:

• Add - opens the Custom Animation dialog (Figure 100) to add an animation effect to a 
selected object on the slide.

• Change - opens the Custom Animation dialog to change the animation effect of a selected 
object.

• Remove - removes any animation effects from a selected object.

Figure 100: Custom Animation dialog

• Start - displays the start property of the selected animation effect. The following start 
properties are available:

• On click - the animation stops at this effect until the next mouse click.

• With previous - the animation runs immediately.

• After previous - the animation runs as soon as the previous animation ends.

• Property - selects additional properties of an animation. Click the … button to open the 
Effect Options dialog (Figure 101), where you can select, adjust and apply properties.

Note

The name of this option will change depending on the type of effect that has been 
selected, for example Property, Line Color, Direction, Font and so on. Also the 
options offered in the Effect Options dialog will also change depending on the type of  
effect and object that has been selected.

• Speed - specifies the speed or duration of the selected animation effect.
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• Change order - click one of the buttons to move the selected animation effect up or down 
in the order.

• Play - plays the selected animation effect in preview.

• Slide Show - starts the slide show from the current slide.

• Automatic preview - select to preview any new or edited effects on the slide while you 
assign them.

Figure 101: Effect Options dialog

The Custom Animation dialog (Figure 100) contains the following categories of effects in tabbed 
pages:

• Entrance – how an object appears on the slide.

• Emphasis – how an object is emphasized when it appears on the slide.

• Exit – how an object leaves the slide.

• Motion Paths – how an object moves on the slide during animation.

• Misc Effects – selects media effects from the miscellaneous effects.

• Speed - specifies the speed or duration of the selected animation effect.

• Automatic preview - previews any new or edited effects on the slide.

Creating an animation with Custom Animation
Create an animated object or objects using Custom Animation as follows:

1) To open the Custom Animation section (Figure 99), click on its name in the Tasks pane. 
The Custom Animation section can also be opened by going to Slide Show > Custom 
Animation or by using the Custom Animation tool on the Drawing toolbar.

Note
The Custom Animation tool  is an additional tool for the Drawing toolbar. It can 
be installed onto the Drawing toolbar by clicking on the small triangle on the right of  
the Drawing toolbar and clicking on Visible Buttons.

2) Select an object on a slide.
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3) Click on Add in Custom Animation to open the Custom Animation dialog (Figure 100).

4) Select an effect category and the type of effect you want to apply to the selected object.

5) Select the speed (if available) of the effect from the drop down menu and then click on the 
OK button.

6) Select the type of Property from the drop down menu.

7) If required, click on the … button to open the Effect Options dialog (Figure 101) to set the 
effect options, then click on the OK button.

Note

The name of this option will change depending on the type of effect that has been 
selected, for example Property, Line Color, Direction, Font and so on. Also the 
options offered in the Effect Options dialog will also change depending on the type of  
effect and object that has been selected.

8) If required, adjust the animation speed using the Speed drop down menu.

9) If required, change the appearance order of the objects in the animation using the Change 
order arrows.

10) If required, click on the Play button to check the animation effect.

11) When you are satisfied, click on the Slide Show button to check your presentation.

Insert animated images
You can create an animated image and then insert it into your presentation by going to Insert > 
Animated Image on the main menu bar to open the Animation dialog (Figure 102). The animation 
controls are explained in Table 7.

Figure 102: Animation dialog
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Table 7: Animation dialog controls

Control Control Name Purpose

First image Jumps to the first image in the animation sequence.

Backwards Plays the animation backwards.

Stop Stops playing the animation.

Play Plays the animation.

Last image Jumps to the last image in the animation sequence.

Image number Indicates the position of the current image in the animation 
sequence. If you want to view another image, enter its number 
or click the up and down arrows.

Duration Enter the number of seconds to display the current image. This 
option is only available if you select Bitmap object in 
Animation group.

Loop count Sets the number of times that animation will play. If you want 
the animation to play continuously, select Max.

Apply Object Adds selected object or objects as a single image.

Apply Objects 
Individually

Adds an image for each selected object. If you select a grouped 
object, an image is created for each object in the group.

You can also select an animation, such as an animated GIF, 
and click this icon to open it for editing. When you are finished 
editing the animation, click Create to insert a new animation 
into your slide.

Delete Current 
Image

Deletes the current image from the animation sequence.

Delete All 
Images

Deletes all images in the animation.

Number Total number of images in the animation.

Group object Assembles images into a single object so that they can be 
moved as a group. You can still edit individual objects by 
double-clicking the group in the slide.

Bitmap object Combines images into a single image.

Create Inserts the animation into the current slide.
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Creating an animation using Animated Image
Create an animation using Insert > Animated Image as follows:

1) Create the object you intend to animate using the drawing tools.

2) Open the Animation dialog (Figure 102 and Table 7) by going to Insert > Animated  Image 
on the main menu bar.

3) Select the object and click on Apply Object icon to add it as the first frame of the 
animation.

4) Apply a transformation or change to the object; for example, rotation, change color, add or 
remove a character(s) and so on.

5) When you are ready, create the second frame of the animation and click Apply Object 
again to add another frame to the animation.

6) Repeat steps 3, 4 and 5 until you have created all the desired frames of the animation.

7) Select Bitmap object in the Animation group section of the Animator dialog to customize 
the timing of each of the frames and the number of repetitions for the animation. Set the 
number of repetitions to Max to obtain a continuous loop for your animation.

8) Click Create and the animated image is placed on the slide.

Note
If the image to be copied in the Animator consists of several objects, you can choose 
to treat each object as a separate frame. In this case click on Apply objects 
individually icon. Remember that each object will be centered in the animation. 
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Formatting objects

This chapter describes how to format the graphic objects created with the available drawing tools.

The format of each graphic object, in addition to its size, rotation and position on the slide, is 
determined by a number of attributes that define the line, text and area fill of each object. These 
attributes (among others) also contribute to a graphics style. Although this chapter discusses 
mainly the manual formatting of objects, it concludes by showing how to create, apply, modify and 
delete graphics styles.

Formatting lines
In LibreOffice the term line indicates both a freestanding segment and the outer edge of a shape. 
In most cases the properties of the line you can modify are its style (solid, dashed, invisible, and so 
on), its width and its color. All these options can be applied with a few clicks of the mouse. Select 
the line you need to format and then use the controls on the Line and Filling toolbar to select your 
desired options.

Figure 103: Common line options (style, width, color) highlighted

If you need to fine tune the appearance of a line, choose Format > Line from the menu bar, or 
right-click on the line and select Line from the pop-up menu, or select the Line icon from the Line 
and Filling toolbar. All of these methods open the Line dialog shown in Figure 104, where you can 
set line properties. This dialog consists of four pages: Line, Shadow, Line Styles, and Arrow Styles.

Figure 104: Line properties dialog
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Line page
The Line page is where you can set the basic parameters of the line and is divided into four 
sections as follows.

Line properties section
The Line Properties section on the left side allows you to set the following parameters:

• Line style: several line styles are available from the drop-down list, but more line styles 
can be defined if necessary.

• Color: choose from the predefined colors in the drop down list or refer to “Creating custom
colors” on page 133 to create a new color.

• Width: specifies the thickness of the line.

• Transparency: sets the transparency of a line. Figure 105 illustrates the effects of different 
percentages of transparency to lines when placed over an object.

Figure 105: Line transparency effect (0%, 25%, 50%, 75% left to right)

Arrow styles section
The Arrow styles section of the Line dialog is only applicable to individual lines and is not used for 
lines that form the borders of a shape or polygon. To create a new arrow style, use Arrow styles on 
page 128.

• Style: sets the style of the two ends of a line. The left drop down menu is for where you 
start the line and the right drop down menu is for where you end the line.

• Width:  specifies the thickness of the arrow endings

• Center: moves the center of the arrow endings to the end point of the line. Figure 106 
shows the effects of selecting this option.

• Synchronize ends: makes the two line ends identical.

Figure 106: Default arrowheads (left) and centered arrowheads (right)
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Arrowheads

A quick way to set the arrowheads for a selected line is to click on the Arrow Style icon  in 
the Line and Filling toolbar (Figure 103). This opens the Arrowheads menu (Figure 107), where 
you can choose one of the many predefined arrowhead styles for the start and ending of the 
selected line.

Figure 107: Arrowheads menu

Corner style section
Corner styles determines how the connection between two segments looks. There are four 
available options in the drop down menu. To appreciate the difference between corner styles, 
choose a thick line style and observe how the preview changes.

Preview section
The bottom part of the Line page previews the applied style for a line and two different corners so 
that the corner style selection can be evaluated.

Shadow page
Use the Shadow page of the Line dialog to add and format the line shadow. The settings on this 
page are the same as those for shadows applied to other objects and are described in Formatting
shadows on page 140.

A quicker way to apply a shadow to a line is using the Shadow icon  on the Line and Filling 
toolbar (Figure 103). The main disadvantage of using the Shadow icon is that the shadow 
appearance will be constrained by the shadow settings of the default graphics style.
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Line styles page
Use the Line Styles page (Figure 108) of the Line dialog to create new line styles as well as to load 
previously saved line styles. It is normally better to create new styles when necessary than to 
modify the predefined styles.

Figure 108: Creating line styles

To create a new line style:

1) Choose Format > Line from the menu bar, or right-click on the line and select Line from 
the pop-up menu, or select the Line icon from the Line and Filling toolbar.

2) Click on the Line Styles tab.

3) Select from the Line style drop-down menu a style similar to the style you want to create.

4) Click Add. On the pop-up dialog, type a name for the new line style and click OK.

5) Now define the new style. Start by selecting the line type for the new style. To alternate two 
line types (for example, dashes and dots) within a single line, select different types in the 
two Type boxes.

6) Specify the Number and Length (not available for dot style) of each of the types of line 
selected.

7) Set the Spacing between the various elements

8) If necessary, select Fit to line width so that the new style fits the width of the selected line.

9) The new line style created is available only in the current document. If you want to use the 

line style in other presentations, click the Save Line Styles icon  and type a unique 
filename in the Save as dialog that opens. Saved styles have the file extension of .sod.

10) To use previously saved line styles, click the Load Line Styles icon  and select a style 
from the list of saved styles. Click Open to load the style into your presentation.

11) If necessary, click on the Modify button to change the name of the style.
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Arrow styles page
Use the Arrow Styles page (Figure 109) of the Line dialog to create new arrow styles, or modify 
existing arrow styles, or load previously saved arrow styles.

Figure 109: Creating arrow Styles

1) First draw a curve in the shape you want to use for the arrowhead or create a shape and 
convert to a curve. The top of the shape must face upward, as shown in Figure 110 
because this becomes the point of the arrow.

Note
The arrowhead created must be convertible to a curve. A curve is something you can 

draw without lifting a pencil. For example,  can be converted to a  curve but   
cannot.

Figure 110: Using shapes for arrow styles

2) Select the shape and, if necessary, right click and choose Convert > To Curve to convert 
the shape to a curve. If the shape is already a curve, To Curve will not be available.

3) With the selection handles showing, select Format > Line from the menu bar, or right-click 
and choose Line from the pop-up menu.

4) Go to the Arrow styles page (Figure 109), click the Add button, type a name for the new 
arrow style, and click OK. The new arrowhead style will be shown in the preview.

5) Now you can access the new style from the Arrow style list. When you select the name of 
the new style, it is shown at the bottom of the dialog.
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6) The new arrowhead style created is available only in the current document. If you want to 

use this arrowhead style in other presentations, click the Save Line Styles icon  and 
type a unique filename in the Save as dialog that opens. Saved styles have the file 
extension of .sod.

7) To use previously saved arrowhead styles, click the Load Line Styles icon  and select 
the style from the saved list of styles. Click Open to load the style into your presentation.

8) If necessary. click on the Modify button to change the name of the style.

Formatting the fill area

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching 
pattern, or bitmap (Figure 111). An area fill can be made partly or wholly transparent and can throw 
a shadow.

Figure 111: Different types of area fill

The Line and Filling toolbar has the majority of the tools normally used to format graphic objects. If 
this toolbar is not showing, choose View > Toolbars > Line and Filling from the menu bar. You 
can also use the Area dialog, described on page 131.

To format the area of an object, select it so that the selection handles show. A wide number of 
default fillings are readily available from the Line and Filling toolbar (Figure 112). Select from the 
Color pull-down menu the type of fill required (Figure 113). If you want no fill at all, select Invisible.

Once you have decided on a predefined or custom fill, you can further refine it by adding a shadow 
or transparency.

Figure 112: Common fill options highlighted

Figure 113: Area fill types
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Color area fill
To change the area fill of an object to a color (Figure 114):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Color from the drop down list.

3) Select a color from the drop-down list.

Figure 114: Color area fill

Gradient area fill
A gradient fill provides a smooth transition from one color to another. The transition pattern may 
vary from a simple linear transition to a more complex radial transition. To change the area fill of an 
object to a gradient (Figure 115):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Gradient from the drop down list.

3) Select a gradient from the drop-down list.

Figure 115: Gradient area fill

Hatching or line pattern area fill
When a hatching fill is applied it fills the complete area of the selected object.. To change the area 
fill of an object to a hatching (Figure 116):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Hatching from the drop down list.

3) Select a hatching fill from the drop-down list.
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Figure 116: Hatching area fill

Bitmap image area fill
You can fill an object only with a bitmap image but not a vector graphic image. To change the area 
fill of an object to a bitmap image (Figure 117):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, select Bitmap from the drop down list.

3) Select a bitmap fill from the drop-down list.

Figure 117: Bitmap image area fill

Using the Area dialog
In addition to using the Line and Filling toolbar, you can use the Area dialog to apply existing area 
fills or create your own area fill. To open it, choose Format > Area from the menu bar, or click on 

the Area icon  on the Line and Filling toolbar, or right-click on the object and select Area.

Use the Area tab to apply predefined fills, both those supplied with LibreOffice and those you 
create yourself.

Use the Colors, Gradients, Hatching, and Bitmaps tabs to define new fills, as described in 
“Creating new area fills” on page 133. The Transparency tab is discussed on page 141. To make 
the object cast a shadow, see page 140.

To apply an area fill, first select the required fill type in the top left drop-down list. The page 
changes to show, in the middle section, the list of predefined styles for that fill type.
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Note In the Area dialog, the choice for no fill is None rather than Invisible.

When using the Area tab of the Area dialog, some additional options may become available once 
you have selected the fill type and one of the available fill styles.

• For color fills, select Color from the drop down list and then select your required color from 
the list of available colors. Click on the OK button and the fill color will appear in the 
selected shape (Figure 118).

Figure 118: Area color dialog

• For gradient fills, select Gradient from the drop down list and then select your required 
gradient from the list of available gradients. Click on the OK button and the fill gradient will 
appear in the selected shape (Figure 119). You can override the number of steps 
(increments) that should be applied to the gradient transition. To do so, deselect the 
Automatic option under Increments and then enter the number of steps required in the box 
to the right.

Figure 119: Area gradient dialog

• For hatching fills, select Hatching from the drop down list and then select your required 
hatching from the list of available hatchings. Click on the OK button and the fill hatching will 
appear in the selected shape (Figure 120). You can apply a different background color by 
selecting the Background color option and choosing a color from the drop down list.

Figure 120: Area hatching dialog
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• For bitmap fills, select Bitmaps from the drop down list and then select your required 
bitmap from the list of available bitmaps. Click on the OK button and the fill bitmap will 
appear in the selected shape (Figure 121). You can customize a large number of 
parameters. Refer to “Working with bitmap fills” on page 137 for additional information.

Figure 121: Area bitmap dialog

Creating new area fills

The following sections describe how to create new fills and how to apply them.

Although you can change the characteristics of an existing fill and then click the Modify button, it is 
recommended that you create new fills or modify custom fills rather than  the predefined ones, as 
these may be reset when updating LibreOffice.

Creating custom colors
On the Colors page (Figure 122), you can modify existing colors or create your own. You can also 
specify a new color either as a combination of the three primary colors Red, Green, and Blue, 
(RGB notation) or by percentages of Cyan, Magenta, Yellow, and Black (CMYK notation).

To create a new color:

1) Enter the name for the color in the Name box.

2) Select whether to define the color in RGB or CMYK. For RGB Specify the red (R), green 
(G) and blue (B) component on a 0 to 255 scale. For CMYK specify the cyan (C), magenta 
(M), yellow (Y) and black (K) components from 0% to 100%.

3) Click the Add button. The color is now added to the Color drop down list.
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Figure 122: Creating a new color

To modify a color:

1) Select the color to modify from the list.

2) Enter the new values that define the color in RGB or CMYK.

3) Modify the name as required.

4) Click the Modify button.

Alternatively, you can edit a color:

1) Click on the Edit button to open the Color Picker dialog (Figure 123).

Figure 123: Editing a color
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2) Modify the color components as required using RGB, CMYK or HSB (Hue, Saturation, 
Brightness).

3) Click OK to exit the Color Picker dialog.

4) Click the Modify button on the Color dialog then click the OK button.

The new color created is available only in the current document. If you want to use this color in 

other presentations, click the Save Color List icon  and type a unique filename in the Save as 
dialog that opens. The saved colors list has the file extension of .soc.

To use a previously saved color list , click the Load Color List icon  and select from the file 
open dialog. Click Open to load the saved color list into Impress.

Tip
You can also add custom colors using Tools > Options > LibreOffice > Colors. This 
method makes the color available to all components of LibreOffice, whereas colors 
created using Format > Area > Colors are only available for Impress.

Creating custom gradients
To create a new gradient or to modify an existing one, select the Gradients tab from the Area dialog 
(Figure 125). Several types of gradients are predefined and in most cases changing the From and 
To colors will be sufficient to obtain the desired result.

It is highly recommended that you create a new gradient even if you just want to change the two 
colors, rather than modifying the predefined ones, which should be used only as starting points.

To create a new gradient:

1) First choose the From and To colors.

2) Then choose a type of gradient from the drop down list: Linear, Axial, Radial, Ellipsoid, 
Square or Rectangular.

Figure 124: Creating a new gradient
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3) A preview of the gradient type is shown under the available gradients list in the middle of 
the dialog.

4) Depending on the chosen type, some options will be grayed out. Set all the properties as 
desired (very often the default values will work well). The properties to set to create a 
gradient are summarized in Table 8.

5) Click the Add button to add the newly created gradient to the list.

The new gradient created is available only in the current document. If you want to use this gradient 

in other presentations, click the Save Gradients List icon  and type a unique filename in the 
Save as dialog that opens. The saved gradients list has the file extension of .sog.

To use a previously saved gradients list, click the Load Gradients List icon  and select from 
the file open dialog. Click Open to load the saved gradients list into Impress

Table 8: Gradient properties

Property Meaning

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the vertical offset of the gradient center.

Angle For all the gradient types, specifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
shape.

From
The start color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

To
The end color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

Creating custom hatching patterns
To create new hatching patterns or modify existing ones, select the Hatching tab of the Area dialog 
(Figure 125). As with gradients and colors, it is better to create a new hatching pattern rather than 
modify a predefined one. The properties that can be set for a hatching pattern are shown in Table
9.

To create a new hatching pattern:

1) Select as a starting point a pattern similar to the one that will be created.

2) Modify the properties of the lines forming the pattern. A preview is displayed in the window 
below the available patterns.

3) Click the Add button and choose a name for the newly created hatching.

The new hatching pattern created is available only in the current document. If you want to use this 

hatching pattern in other presentations, click the Save Hatches List icon  and type a unique 
filename in the Save as dialog that opens. The saved hatches list has the file extension of .soh.

To use a previously saved hatches list, click the Load Hatches List icon  and select from the 
file open dialog. Click Open to load the saved hatches list into Impress.
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Figure 125: Creating a new hatching pattern

Table 9: Properties of hatching patterns

Property Meaning

Spacing Determines the spacing between two lines of the pattern. As the value is 
changed the preview window is updated.

Angle Use the mini map below the numerical value to quickly set the angle formed 
by the line to multiples of 45 degrees. If the required angle is not a multiple of 
45 degrees, just enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the pattern.

Line color Use the list to select the color of the lines that will form the pattern.

Working with bitmap fills
On the Area tab, chose Bitmap from the drop-down list. Select from the list of bitmaps the one to 
be used to fill the area. Note that any imported bitmaps will become available in the list.

Set the size, position and offset parameters (as applicable) in the right hand side of the page, and 
then click OK to close the dialog.

As Figure 126 shows, there are quite a number of parameters to be configured when using a 
bitmap fill. These are described in Table 10.

Table 10: Bitmap fill properties

Property Meaning

Size – Original Select this box to retain the original size of the bitmap.

Size – Relative To rescale the object, deselect Original and select Relative. The Width 
and Height edit boxes are enabled.
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Property Meaning

Size – Width When Relative is selected 100% means that the bitmap original width will  
be resized to occupy the whole fill area width, 50% means that the width 
of the bitmap will be half that of the fill area.

Size – Height When Relative is selected 100% means that the bitmap original height 
will be resized to occupy the whole fill area height, 50% means that the 
height of the bitmap will be half that of the fill area.

Position – Anchor Map Select from the map the place within the area to which the bitmap should 
be anchored.

Position – Tile When this option is selected, the bitmap will be tiled to fill the area. The 
size of the bitmap used for the tiling is determined by the Size settings.

Position – X offset When Tile is enabled, enter in this box the offset for the width of the 
bitmap in percentage values. 50% offset means that Impress will place 
the middle part of the bitmap at the anchor point and start tiling from 
there.

Position – Y offset This will have a similar effect to the X offset, but will work on the height of 
the bitmap.

Position – Autofit Stretches the bitmap to fill the whole area. Selecting this option disables 
all the size settings.

Offset – Row If Tile is enabled, offsets the rows of tiled bitmaps by the percentage 
entered in the box so that two subsequent rows are not aligned.

Offset – Column If Tile is enabled, offsets the columns of tiled bitmaps by the percentage 
entered in the box so that two subsequent columns of bitmaps are not 
aligned.

Figure 126: Advanced formatting for bitmap fill
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The best way to acquire understanding of these parameters is to use them. Figure 127 shows 
some examples of bitmap fills and the parameters used.

Figure 127: Examples of bitmap fill

Creating and importing bitmaps
You can add (import) new bitmap fills or create your own pattern on a 8x8 grid using the Bitmaps 
tab of the Area dialog (Figure 128).

To create a bitmap fill:

1) Start with the Blank bitmap type on top of the list to activate the Pattern Editor.

2) Select the Foreground and Background colors.

3) Start creating the pattern by clicking with the left mouse button the squares (pixels) that you 
want in the foreground color. Use the right mouse button to apply the background color. 
Check the preview window to see if the desired effect is achieved.

4) When done, click Add to save the pattern.

To import a bitmap created in Draw or another program:

1) Click the Import button.

2) A file picker dialog is displayed and shows a list of compatible file types. Browse to the 
directory containing the bitmap file and select it, then click Open.

3) Type a name for the imported bitmap and click OK.

Note
Bitmaps generally have an extension .bmp or .png. To create a bitmap image with 
Draw, select File > Export, choose PNG from the pull-down list of file formats, give 
the file a name, and save it.
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The new bitmap created is available only in the current document. If you want to use this bitmap in 

other presentations, click the Save Bitmap List icon  and type a unique filename in the Save 
as dialog that opens. The saved bitmap list has the file extension of .sob.

Figure 128: Creating a new bitmap

To use a previously saved bitmap list, click the Load Bitmap List icon  and select from the file 
open dialog. Click Open to load the saved bitmap list into Impress.

Formatting shadows
Shadowing can be applied to lines, shapes and text.

To quickly apply a shadow to a line or shape only, first select the line or shape and then click on the 

Shadow icon  in the Line and Filling toolbar. The shadow applied using this method cannot be 
customized and is set to default settings.

For a more flexible way to apply a shadow to a line, shape or text, first select the object and then 
select Format > Area to open the Area dialog. Click on the Shadow tab to open the Shadow page 
(Figure 129). This will allow you to set the following properties for the shadow.

• Position: selects the point that determines the direction in which the shadow is cast.

• Distance: determines the distance between the object and the shadow.

• Color: sets the color of the shadow.

• Transparency: determines the amount of transparency for the shadow.

An alternative method for using shadows is to apply a style that uses a shadow See “Working with
graphics styles” on page 146 for additional information on using styles.
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Figure 129: Customizing a shadow

Transparency formatting
Transparency is applicable to objects as well as shadows. To apply transparency to lines, refer to 
“Formatting lines” on page 124; for shadows, refer to “Formatting shadows” on page 140.

To apply transparency to objects, select the object and then select Format > Area to open the Area 
dialog. Click on the Transparency tab to open the Transparency page shown (Figure 130).

Figure 130: Setting object transparency

Two types of transparency are available: uniform transparency and gradient transparency.

To create a uniform transparency, select Transparency and then select the percentage of 
transparency required.

To create a gradient transparency (so that the area becomes gradually transparent) select 
Gradient and then set the parameters of the gradient. Refer to Table 11 for a description of the 
properties.

More information on gradient transparency, including an example of combining color gradient with 
gradient transparency, can be found in “Advanced gradient controls” on page 142.
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Table 11: Gradient transparency properties

Property Meaning

Center X
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set 
the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Quadratic and Square gradients, modify these values to set 
the vertical offset of the gradient center.

Angle
For Linear, Axial, Ellipsoid, Quadratic and Square gradient, specifies the angle of 
the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
object.

Start value
Value for the starting transparency gradient. 0% is fully opaque, 100% means 
fully transparent.

End value
Value for the ending transparency gradient. 0% is fully opaque, 100% means fully 
transparent.

Advanced gradient controls
As discussed in “Creating custom gradients” on page 135, gradient properties can be configured 
using the properties given in the dialogs shown in Figure 125 and Table 8. Impress also provides a 
graphical interface for modifying the gradient parameters using only the mouse.

To use this tool, select an object with a gradient, then click on the Gradient icon  in the Mode 
toolbar (Figure 131). This displays a dashed line connecting to squares. The colors show the From 
and To colors that are used for the selected gradient (Figure 132).

Figure 131: Mode toolbar

Figure 132: From Red 4 to Yellow 1 gradient
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• For linear gradients: move the square corresponding to the From color to change where 
the gradient starts (border value). Move the square corresponding to the To color to change 
the orientation (angle value).

• For axial gradients: you can move only the To color to change both the angle and border 
properties of the gradient.

• For radial gradients: move the From color to modify the border property to set the width of 
the gradient circle. Move the To color to change the point where the gradient ends (Center 
X and Center Y values).

• For ellipsoid gradients: move the From color to modify the border property to set the size 
of the gradient ellipsoid. Move the To color to change the angle of the ellipsoid axis and the 
axis itself.

• For square and rectangular gradients: move the From color to modify the border to set 
the size of the gradient square or rectangle and the angle of the gradient shape. Move the 
To color to change the center of the gradient.

Note
Moving the squares will have different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.

Formatting text

Impress provides two dialogs related to text formatting: Format > Character for individual 
characters and Format > Text for whole words, sentences or paragraphs.

To modify formatting such as font and font effects, select the text in the shape and then go to 
Format > Character or Format > Text. This section covers the formatting of the overall shape of 
text which is added to an object. For more information on formatting text, see Chapter 3, Adding 
and Formatting Text.

Figure 133: Text dialog
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To add text to an object:

1) Select the object to which text will be added so that the selection handles are showing.

2) Double-click on the object and the cursor becomes an I-beam to indicate text mode.

3) Type your text.

4) When finished, click outside of the object or press Esc.

To format the text in an object:

1) Select the object to which text was added.

2) Select Format > Text or right-click on the shape and select Text from the pop-up menu. 
The Text dialog is displayed (Figure 133).

The Text section of the dialog offers several options in the form of checkboxes. Some of the 
options will be grayed out, depending on the object to which the text has been attached.

• Fit width to text: expands the width of the object if the text is too long for it.

• Word wrap text in shape: starts a new line automatically when the edge of the object is 
reached.

• Fit height to text: expands the object height whenever it is smaller than the text (set by 
default for lines).

• Resize shape to fit text expands a custom object when the text inserted in the object is 
too large.

• Fit to frame: expands the text so that it fills all the available space.

• Adjust to contour: makes the text follow a curved line.

In the Spacing to borders section, specify the amount of space to be left between the borders of 
the object and the text. This is similar to setting indentation and spacing for paragraphs.

The Text anchor section is used to anchor the text to a particular point within the object. The Full 
width option for anchoring centers the text within the object and will use the full width of the object 
before wrapping text.

Figure 134: Text animation dialog
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Text animation
The Text Animation dialog (Figure 134) adds animation effects to the text. Select one of four 
options from the drop down list. The animation direction of the effect, where applicable, is selected 
using one of the four arrow buttons to the right. The available effects are:

• No animation: default setting.

• Blink: the text will blink on the screen.

• Scroll through: the text will move into the object and then out following the selected 
direction.

• Scroll back and forth: the text will move first in the selected direction, but will bounce back 
at the object border.

• Scroll in: the text will scroll in towards the given direction starting from the edge of the 
object and stop in the center.

The other properties that can be set are:

• Start inside: when selected, the animation will start from inside the object.

• Text visible when editing: select this option to see the text while editing.

• Animation cycles: select either Continuous or a specific number of cycles for the 
animation.

• Increment: sets the amount the animation moves in either Pixels or a specific distance. 
Units of measurement depend on the settings in Tools > Options > LibreOffice Impress > 
General.

• Delay: sets the delay time either Automatically or a specific length of time before the 
animation starts.

To see some of the animations in action, it is necessary to start the presentation. Press F9 or 
select Slide Show > Slide Show from the main menu. To return to the edit mode, press Esc.

Formatting connectors

Connectors are lines that join two shapes and always start from or finish at a glue point on an 
object. Refer to Chapter 5, Managing Graphic Objects for a description of the use of connectors.

Figure 135: Connector properties dialog
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Connector properties can be accessed and modified in two ways:

• Right-click on the connector line and select Connector from the pop up menu.

• Select Format > Styles and Formatting or press the F11 key, then select Connector > 
Modify.

Both methods open the Connector dialog (Figure 135) where you can set the properties of the 
connectors.

• Type: sets the type of connector - Standard (default), Line, Straight, and Curved.

• Line skew: used where multiple connectors overlap to set the distance between the lines. 
You can customize the distance between four different lines.

• Line spacing: used to set the horizontal and vertical space between the connector and the 
object at each end of the connector.

Working with graphics styles

To achieve consistency in the style across the slides of a presentation, or a presentation portfolio, 
or to apply the same formatting to a large number of objects, the best approach is to use a 
graphics style.

Graphics styles are similar to paragraph styles for text. A graphics style groups all the formatting 
properties applicable to a graphical object and then associates this group of properties with a 
name. This makes a graphics style reusable for other graphical objects. If a graphics style is 
modified (for example, changing an area transparency), the changes are automatically applied to 
all objects using the same graphics style.

Figure 136: Graphics Styles and Formatting
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If you use Impress frequently, a library of well-defined graphics styles is an invaluable tool for 
speeding up the process of formatting your work according to your taste or any style guidelines you 
may need to follow (company colors, fonts and so on).

Click on the Graphics Styles icon  on the Styles and Formatting dialog (Figure 124) to access 
graphic styles. If the dialog is not open, press the F11 key, or click on the Styles and Formatting 

icon  on the formatting toolbar, or select Format > Styles and Formatting from the menu bar.

Linked graphics styles
Graphics styles support inheritance; that is, a style can be linked to another (parent) style so that it 
inherits all the formatting settings of the parent. You can use this property to create “families” of 
styles.

For example, if you need multiple boxes that differ in color but are otherwise identically formatted, 
the best way to proceed is to define a generic style for the box including borders, area fill, font, and 
so on and a number of hierarchically dependent styles which differ only in the fill color attribute. If 
later you need to change the font size or the thickness of the border, it is sufficient to change the 
parent style and all the other styles will change accordingly.

Creating graphics styles
You can create a new graphics style in two ways:

• Using the Style and Formatting dialog

• From a selection

Creating new graphics style using the Style and Formatting dialog

Click on the Graphics Styles icon  at the top of the Styles and Formatting window.

To link a new style with an existing style:

1) Select the style you want to use in the Styles and Formatting dialog (Figure 124).

2) Right click and select New to open the Graphics Styles dialog (Figure 137).

3) Give your new graphics style a memorable file name.

4) Use the various tabs and text boxes in the Graphics Styles dialog to format and categorize 
your new style.

5) Click on the OK button when finished to save your new graphics style.

Figure 137: Graphics Styles dialog
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The Graphics Styles dialog consists of several pages that may be grouped as follows:

• Organizer page contains a summary of the style and its hierarchical position.

• Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian typography pages set the 
properties of the text inserted in a text box or in a graphic object.

• Dimensioning page is used to set the style of dimension lines.

• Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency pages 
determine the formatting of a graphic object and are discussed elsewhere in this chapter.

Note
When styles are linked, changing the font for example will change the font in all linked 
styles. Sometimes this is exactly what you want; at other times you do not want the 
changes to apply to all linked styles. It pays to plan ahead.

Creating new graphics style from a selected object
You can create a new style from an object that has already been formatted. This can be text or 
graphics:

1) Select the object you want to use to create your new style.

2) Open the Styles and Formatting dialog and click the New Style from Selection icon 
(Figure 138).

3) In the Create Style dialog (Figure 139) type a name for the new style. The list shows 
existing custom styles of that are available.

4) Click OK to save the new style.

Figure 138: New style from selection

Figure 139: Naming a new style created from a selection

Modifying a graphics style
To modify an existing style, right-click on it in the Styles and Formatting dialog and choose Modify 
from the pop-up menu. The dialog for the modification of a graphics style is the same as the dialog 
for creating a new graphics style (Figure 137). Make the required changes to the style and then 
click OK to save them.
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Updating a graphics style from a selection
To update a style from a select object:

1) Select an object that uses the format you want to adopt as a style.

2) In the Styles and Formatting dialog, select the style you want to update, and then click the 
Update Style icon (Figure 140).

Figure 140. Updating a style from a selection

Tip

Any changes you make to a style are effective only in the document on which you are 
working and do not go into change the associated template. If you want the changes 
to apply to more than one document, you need to change the template (see Chapter  
2 Using Slide Masters, Styles, and Templates).

Applying graphics styles
You can apply a graphics style in two ways using the Styles and Formatting dialog. First make sure 
that the graphics styles are shown (Figure 124), then do one of the following:

• Select the object to which you want to apply a graphics style and double-click on the name 
of the style you want to apply.

• Click the Fill Format mode icon  and the mouse pointer changes to this icon. Position 
the icon on the graphic object to be styled and click the mouse button. This mode remains 
active until you turn it off, so you can apply the same style to several objects. To quit Fill 
Format mode, click the Fill Format mode icon again or press the Esc key.

• When Fill Format mode is active, a right-click anywhere in the document cancels the last 
Fill Format action. Be careful not to accidentally right-click and thus undo actions you want 
to keep.

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or groups of styles such as applied styles or (in the case of  
graphics styles) custom styles.

Deleting graphics styles
You cannot delete any of the predefined styles in Impress, even if you are not using them. You can 
only delete user-defined (custom) styles. However, before you delete a custom style, make sure 
the style is not in use. If an unwanted style is in use, replace it with a substitute style.
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To delete custom styles, right-click on them (one at a time) in the Styles and Formatting window 
and click Delete on the pop-up menu. Click Yes in the message box that pops up.

Assigning styles to shortcut keys
LibreOffice provides a set of predefined keyboard shortcuts which allow you to quickly apply styles 
while working with a document. You can redefine these shortcuts or define your own, as described 
in Appendix A, Keyboard Shortcuts.
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OLE objects

Object Linking and Embedding (OLE) is a software technology that allows embedding and linking 
of the following types of files or documents into an Impress presentation. The major benefit of 
using OLE objects is that it provides a quick and easy method of editing the object using tools from 
the software used to create the object.

• LibreOffice spreadsheets

• LibreOffice harts

• LibreOffice drawings

• LibreOffice formula

• LibreOffice text

These file types can all be created using the various modules included in LibreOffice software.

Two types of OLE objects can be created: new and from a file.

Inserting a new OLE object
When you insert a new OLE object into your presentation, it is only available in your presentation 
and can only be edited using Impress.

To add a new OLE object into your presentation:

1) Go to the slide where you want to insert the OLE object.

2) Select Insert > Object > OLE Object from the menu bar.

3) On the Insert OLE Object dialog box (Figure 141), select Create new.

Figure 141: Inserting a new OLE object

4) Select the type of OLE object you want to create and then click OK.

5) A new OLE object is inserted in the center of the slide in edit mode. The toolbars displayed 
in Impress will change providing the necessary tools for you to create the new OLE object.

Note

For computers operating Microsoft Windows there is an additional option of Further 
objects. Clicking on this option opens an Insert Object dialog allowing you to create 
an OLE object using other software that is compatible with OLE. This option is 
available for new OLE objects and OLE objects from a file.

Inserting a OLE object from a file
When you insert an existing file into your slide as an OLE object, by default any subsequent 
changes that are made to the original file do not affect the copy of the file inserted into your 
presentation. Similarly, changes to the file copy in your presentation do not change the original file. 
If you want any changes made to the file, either in the original or your presentation, to appear in 
both versions you have to link the original file with your presentation when it is inserted.
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Figure 142: Inserting an OLE object from a file

To insert a file into your presentation as an OLE object:

1) Go to the slide where you want to insert the spreadsheet.

2) Choose Insert > Object > OLE Object from the menu bar.

3) On the Insert OLE Object dialog box, select Create from file . The dialog box changes to 
show a File text box (Figure 142).

4) Click Search.and the Open dialog box is displayed.

5) Locate the file you want to insert and click on Open.

6)  Select the Link to file option if you wish to insert the file as a live link so that any changes 
made are synchronized in both the original file and your presentation.

7) Click on OK to insert the file as an OLE object.

Editing an OLE object
To edit an OLE object after it has been created or inserted from a file, double click on the OLE 
object to open edit mode (Figure 143). The toolbars displayed in Impress will change providing the 
necessary tools for you to edit the OLE object.

Figure 143: OLE object in edit mode

Spreadsheets

To include a spreadsheet in an Impress slide, you can either insert an existing spreadsheet file or 
insert a new spreadsheet as an OLE object. See OLE objects on page 152 for more information.

Embedding a spreadsheet into Impress includes most of the functionality of a Calc spreadsheet 
and is therefore capable of performing complex calculations and data analysis. However, if you 
plan to use complex data or formulas, it is better to perform complex operations in a separate Calc 
spreadsheet and use Impress only to display the embedded spreadsheet with the results.

You maybe tempted to use spreadsheets in Impress for creating complex tables or presenting data 
in a tabular format. However, the Table Design feature (described in Chapter 3 Adding and 
Formatting Text) is often more suitable and faster, depending on the complexity of your data.

The entire spreadsheet is inserted into your slide. If the spreadsheet contains more than one sheet 
and the one you want is not visible, double-click the spreadsheet and then select a different sheet 
from the row of sheet tabs at the bottom.

Chapter 7  Including Spreadsheets, Charts, and Other Objects 153



Editing a spreadsheet
When a spreadsheet is inserted in slide, it is in edit mode ready for inserting or modifying data or 
modifying the format (Figure 143). Note the active cell and the small resizing handles on the 
border. See Entering data on page 155 and Formatting spreadsheet cells on page 156 for more 
information.

When editing a spreadsheet, some of the toolbars change so that you can easily edit the 
spreadsheet (Figure 144). One of the most important changes is the presence of the Formula 
toolbar, just below the Formatting toolbar. The Formula toolbar contains (from left to right):

• The active cell reference or the name of the selected range

• The Formula Wizard button

• The Sum and Function buttons or the Cancel and Accept buttons (depending on the 
contents of the cell)

• A long edit box to enter or review the contents of a cell

If you are familiar with Calc, you will immediately recognize the tools and the menu items as they 
are similar.

Figure 144: Toolbars for spreadsheet editing mode

Resizing and moving a spreadsheet
When resizing or moving a spreadsheet, ignore the first row and the first column (easily 
recognizable because of their light background color) and the horizontal and vertical scroll bars. 
They are only used for editing purposes and will not be included in the visible area of the 
spreadsheet on the slide.

To resize the area occupied by the spreadsheet:

1) Double-click to enter edit mode, if it is not already active. Note the selection handles found 
in the border surrounding the spreadsheet (Figure 143).

2) Move the mouse over one of the handles. The cursor changes shape to give a visual 
representation of the effects applied to the area.

3) Click and hold the left mouse button and drag the handle. The corner handles move the two 
adjacent sides simultaneously, while the handles at the midpoint of the sides modify one 
dimension at a time.

You can move the spreadsheet (change its position within the slide) whether in edit mode or not. In 
both cases:

1) Move the mouse over the border until the cursor changes to a hand (actual cursor depends 
on your computer setup).

2) Click and hold the left mouse button and drag the spreadsheet to the desired position.

3) Release the mouse button.

When selected, the spreadsheet object is treated like any other object; therefore resizing it 
changes the scale rather than the spreadsheet area. This is not recommended, because it may 
distort the fonts and picture shapes.
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Navigating the spreadsheet

How a spreadsheet is organized
A spreadsheet consists of multiple tables called sheets, which in turn contain cells. However, in 
Impress only one of these sheets can be shown at any given time on a slide.

The default for a spreadsheet embedded in Impress is one single sheet called Sheet 1, unless the 
sheet has been renamed. The name of the sheet is shown at the bottom of the spreadsheet area 
(Figure 143).

If required, you can add other sheets by a right mouse click on the bottom area near the existing 
tab and selecting Insert > Sheet from the pop-up menu. Alternatively, click on the plus sign to the 
right of the tabs.

Just as in Calc, you can rename a sheet or move it to a different position using the same pop-up 
menu or the Insert menu on the main menu bar.

Note
Even if you have many sheets in your embedded spreadsheet, only one sheet – the 
one which is active when leaving the spreadsheet edit mode – is shown on the slide.

Each sheet is organized into cells. Cells are the elementary units of the spreadsheet. They are 
identified by a row number (shown on the left hand side) and a column letter (shown in the top 
row). For example, the top left cell is identified as A1, while the third cell in the second row is C2. 
All data elements, whether text, numbers or formulas, are entered into a cell.

Moving the cursor to a cell
To move around the spreadsheet and select an active cell, you can:

• Use the arrow keys.

• Left-click with the mouse on the desired cell.

• Use the combinations Enter and Shift+Enter to move one cell down or one cell up 
respectively; Tab key and Shift+Tab key to move one cell to the right or to the left 
respectively.

Other keyboard shortcuts are available to move quickly to certain cells of the spreadsheet. Refer to 
Chapter 5, Getting Started with Calc in the Getting Started guide for further information.

Entering data
Keyboard input into a cell can only be done when the cell is active. An active cell is identified by a 
thick border. The cell reference (or coordinates) is also shown on the left hand end of the formula 
toolbar.

To insert data, first select the cell to make it active, then start typing . Note that the input is also 
added to the main part of the formula toolbar where it may be easier to read.

Impress will try to automatically recognize the type of contents (text, number, date, time, and so on) 
entered into a cell and apply default formatting to it. Note how the formula toolbar icons change 

according to the type of input, displaying Accept ( ) and Reject ( ) icons whenever the input is 
not a formula. Use Accept to confirm an input made in a cell or simply select a different cell, or 
press the Enter key.
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Figure 145: Formatting cells in a spreadsheet

If Impress wrongly recognizes the type of input, select the cell then change format using Format > 
Cells in the main menu bar, or right-click on the cell and choose Format Cells from the pop-up 
menu to open the Format Cells dialog (Figure 145).

Tip

Sometimes it is useful to treat numbers as text (for example, telephone numbers) and 
to prevent Impress from removing the leading zeros or right align them in a cell. To 
force Impress to treat the input as text, type a single quotation mark (') before 
entering the number.

Formatting spreadsheet cells
Often, for the purposes of a presentation, it may be necessary to increase the size of the font 
considerably or to match it to the style used in the presentation.

The easiest way to format the embedded spreadsheet is to make use of styles. When working on 
an embedded spreadsheet, you can access the cell styles created in Calc and use them. However, 
a better approach is to create specific cell styles for presentation spreadsheets, as the Calc cell 
styles are likely to be unsuitable when working within Impress.

To apply a style to a cell or group of cells simultaneously (or manually format their cell attributes), 
first select a cell or a range of cells to which the changes will apply. A range of cells is indicated by 
a rectangular area with all its cells shaded. To select a multiple-cell range:

1) Click on the first cell belonging to the range (either the left top cell or the right bottom cell of 
the rectangular area).

2) Keep the left mouse button pressed and move the mouse to the opposite corner of the 
rectangular area which will form the selected range.

3) Release the mouse button.

To add further cells to the selection, hold down the Control key and repeat the steps 1 to 3 above.
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Tip
You can also click on the first cell in the range, hold down the Shift key, and click in 
the cell in the opposite corner. Refer to Chapter 5, Getting Started with Calc, in the 
Getting Started book for further information on selecting ranges of cells.

Some shortcuts are very useful to speed up selection and are listed below:

• To select the whole visible sheet, click on the blank cell between the row and column 
indexes, or press Control+A.

• To select a column, click on the column index at the top of the spreadsheet.

• To select a row, click on the row index on the left hand side of the spreadsheet.

Once a range is selected, you can modify the formatting, such as font size, alignment (including 
vertical alignment), font color, number formats, borders, background and so on. To access these 
settings, choose Format > Cells from the main menu bar or right-click and choose Format Cells 
from the pop-up menu to open the Format Cells dialog (Figure 145).

If the text does not fit the width of the cell, you can increase the width by hovering the mouse over 
the line separating two columns in the header row until the mouse cursor changes to a double-
headed arrow; then click the left button and drag the separating line to the new position. A similar 
procedure can be used to modify the height of a cell (or group of cells).

To insert rows and columns in a spreadsheet, use the Insert menu or right-click on the row and 
column headers and select the appropriate option from the pop-up menu. To merge multiple cells, 
select the cells to be merged and select Format > Merge cells from the main menu bar. To split a 
group of cells, select the group and deselect Format > Merge Cells (which will now have a 
checkmark next to it).

When you are satisfied with the formatting and the appearance of the table, exit edit mode by 
clicking outside the spreadsheet area. Note that Impress will display exactly the section of the 
spreadsheet that was on the screen before leaving edit mode. This allows you to hide additional 
data from view, but it may cause the apparent loss of rows and columns. Therefore, take care that 
the desired part of the spreadsheet is showing on the screen before leaving edit mode.

Tip To get back into edit mode, right click and select Edit.

Charts

The use of charts is described in detail in Chapter 3, Creating Charts and Graphs of the Calc 
Guide.

You can insert a chart to your presentation using the tools within Impress or as an OLE object. See 
OLE objects on page 152 for more information on inserting a chart as an OLE object.

To insert a chart using Impress tools, select the Insert Chart icon on the slide layout (Figure 146), 

or use Insert > Chart, or click the Insert Chart icon  on the Standard toolbar. A chart appears 
containing sample data (Figure 147). To enter your own data into the chart, see Entering chart data 
on page 160.
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Figure 146: Inserting objects into a slide

Figure 147: Chart with sample data

Selecting a chart type
Your data can be presented using a variety of different charts; choose a chart type that best suits 
the message you want to convey to your audience (see Chart types on page 159).

To choose a chart type:

1) Make sure that your chart is selected.

2) Click the Chart Type icon  or select Format > Chart Type, or right-click on the chart 
and choose Chart Type to open Chart Type dialog (Figure 148).

3) As you change selections in the left-hand list, the chart examples on the right change. If 
you move the Chart Type dialog box to one side, you can see the effect in your chart.

4) As you change chart types, other selections become available on the right-hand side. For 
example, some chart types have both three-dimensional and two-dimensional variants; 3D 
charts have further selections of shape for the columns or bars.
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Figure 148: Chart Type dialog showing two-dimensional charts

5) Choose the chart characteristics you want, and then click OK. The Chart Type dialog 
closes and you return to the edit window.

Now you can continue to format the chart, add data to the chart, or click outside the chart to return 
to normal view.

Chart types
The following summary of the chart types available will help you choose a type suitable for your 
data. For more detail, see Chapter 3, Creating Charts and Graphs in the Calc Guide. Column, bar, 
pie and area charts are available in 2D and 3D types.

Column charts
Column charts displays data that shows trends over time. They are best for charts that have a 
relatively small number of data points (for large time series, a line chart would be better.) This is 
the default chart type.

Bar charts
Bar charts give an immediate visual impact for data comparison where time is not important, 
such as comparing the popularity of products in a marketplace.

Pie charts
Pie charts give a comparison of proportions, for example, comparisons of departmental 
spending: what the department spent on different items or what different departments spent. 
They work best with a small range of values, for example six or less; more than this and the 
visual impact begins to fade.

Area charts
Area charts are versions of line or column charts. They are useful where you wish to 
emphasize volume of change. Area charts have a greater visual impact than a line chart, but 
the data you use will make a difference. You may need to use transparency values in an area 
chart.

Line charts
Line charts are time series with a progression. Ideal for raw data and useful for charts with data 
showing trends or changes over time where you want to emphasize continuity. On line charts, 
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the x-axis is ideal for representing time series data. 3D lines confuse the viewer, so just using a 
thicker line often works better.

Scatter or XY charts
Scatter charts are great for visualizing data that you have not had time to analyze and may be 
best for data where you have a constant value for comparison: for example weather data, 
reactions under different acidity levels, conditions at altitude, or any data which matches two 
numeric series. The x-axis usually plots the independent variable or control parameter (often a 
time series).

Bubble charts
Bubble charts are used to represent three variables: two identify the position of the center of a 
bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.

Net charts
Net charts are similar to polar or radar graphs and are useful for comparing data not in time 
series, but show different circumstances, such as variables in a scientific experiment. The 
poles of the net chart are the y-axes of other charts. Generally, between three and eight axes 
are best; any more and this type of chart becomes confusing.

Stock charts
Stock charts are specialized column graphs specifically for stocks and shares. You can choose 
traditional lines, candlestick, and two-column charts. The data required for these charts is 
specialized with series for opening price, closing price, and high and low prices. The x-axis 
represents a time series.

Column and line charts
Column and line charts are a combination of two other chart types. It is useful for combining 
two distinct, but related data series, for example sales over time (column) and the profit margin 
trends (line).

Entering chart data

Opening a chart data window
1) Make sure that your chart is selected and you have selected your chart type.

2) Click on the Chart Data icon , or select View > Chart Data Table, or right-click on the 
chart and choose Chart Data Table to open the Data Table dialog (Figure 149).

Tip
If you drag the Data Table dialog box so that your chart is visible, you can then 
immediately see the results of each change after clicking in a different cell.

Figure 149: Chart Data Table dialog
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Entering data
Type or paste information into the cells within the desired rows and columns to enter data into the 
Data Table dialog.

You can use the icons in the top left corner for large-scale editing:

• The three Insert icons insert rows, column (series) and text columns.

• The two Delete icons remove a selected row or column (series) with its data.

• The two Move icons move the contents of the selected column to the right, or the contents 
of the selected row down.

Adding or removing elements from a chart
The default chart includes only two elements: the chart wall and the legend (also known as the 
key). You can add other elements on your selected chart using the Insert menu (Figure 150). Each 
selection of a menu item opens a dialog where you can specify your requirements.

Figure 150: Chart insert menu

Formatting a chart
The format of your selected chart can be changed by clicking on Format in the main menu bar 
(Figure 151) where you can select several options to change the format of your chart.

The formatting options available will depend on which part of your chart has been selected  and 
are as follows:

• Format Selection opens a dialog where you can specify area fill, borders, transparency, 
characters, font effects, and position of the selected element of the chart.

• Position and Size opens the Position and Size dialog (see Resizing and moving a chart on 
page 163).

• Arrangement provides two choices: Bring Forward and Send Backward, only one may be 
active for specific items. Use these choices to arrange overlapping data series.

• Title formats the titles of the chart and its axes.

• Legend formats the location, borders, background, and type of the legend.

• Axis formats the lines that create the chart as well as the font of the text that appears on 
both the X and Y axes.

• Grid formats the lines that create a grid for the chart.
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Figure 151: Chart format menu

• Chart Wall, Chart Floor, and Chart Area are described in the following sections.

• Chart Type changes what kind of chart is displayed and whether it is 2D or 3D.

• 3D View formats the various viewing angles of 3D chart.

Note
Chart Floor and 3D View are available only for 3D charts. These options are 
unavailable (grayed out) if a 2D chart is selected.

A chart has two main areas: the chart wall and the chart area. These control different settings and 
attributes for the chart. Knowing the difference is helpful when formatting a chart.

• Chart wall contains the graphic of the chart displaying the data.

• Chart area is the area surrounding the chart graphic. The (optional) chart title and the 
legend (key) are in the chart area.

Figure 152: Chart wall and Chart area
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Note
Format > Chart Floor is only available for 3D charts and has the same formatting 
options as Chart Area and Chart Wall.

Resizing and moving a chart
You can resize or move all elements of a chart at the same time, interactively, or by using the 
Position and Size dialog. You may wish to use a combination of both methods.

To resize a chart interactively:

1) Click on the chart to select it and selection handles appear around the chart.

2) To increase or decrease the size of the chart, click and drag one of the corner handles. To 
maintain the correct aspect ratio, hold the Shift key down while you click and drag.

To move a chart interactively:

1) Click on the chart to select it and selection handles appear around the chart.

2) Hover the mouse pointer anywhere over the chart other than on a handle. When it changes 
shape, click and drag the chart to its new location.

3) Release the mouse button when the element is in the desired position.

To resize or move a chart using the Position and Size dialog box:

1) Double-click the chart so that it is in edit mode.

2) Select Format > Position and Size from the menu bar, or right-click and select Position 
and Size from the pop-up menu, or press F4 key to open the Position and Size dialog 
(Figure 153). For more about the use of this dialog, see Chapter 6, Formatting Graphic 
Objects.

Figure 153: Position and Size dialog
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Moving chart elements
You can move or resize individual elements of a chart independently of other chart elements. For 
example, moving the chart legend to a different position. Pie charts allow individual wedges of the 
pie to be moved as well as “exploding” the entire pie.

1) Double-click the chart so that it is in edit mode.

2) Click any of the elements – title, legend, or chart graphic – to select it and resizing handles 
appear.

3) Move the pointer over the selected element. When it changes shape, click and drag to 
move the element.

4) Release the mouse button when the element is in the desired position.

Note

If your chart is 3D, round selection handles appear which control the three-
dimensional angle of the chart. You cannot resize or reposition the chart while the 
round selection handles are showing. Shift + Click to get back to the square resizing 
handles. You can now resize and reposition your 3D chart.

Tip
You can resize the chart using its square resizing handles (Shift + Click, then drag a 
corner handle to maintain proportions). However, you cannot resize the title or key.

Changing chart area background
The chart area is the area surrounding the chart graphic and includes the (optional) main title and 
key.

1) Double-click the chart so that it is in edit mode.

2) Select Format > Format Selection and select the Area tab from the dialog that opens, or 
right click in the chart area and select Format Chart Area, or double click in the chart area 
to open the Chart Area dialog (Figure 154).

3) Select from the Fill drop down list the type of background fill you want to use.

Figure 154: Chart Area dialog
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Changing chart wall background
The chart wall is the area that contains the chart graphic.

1) Double-click the chart so that it is in edit mode.

2) Select Format > Format Selection and select the Area tab from the dialog that opens, or 
right click in the chart wall and select Format Wall, or double click in the chart wall to open 
the Chart Wall dialog. This dialog has  the same formatting options as described in 
Changing chart area background on page 164.

3) Choose your settings and click OK.

Changing chart elements
When the chart is selected and is in edit mode, individual elements within the chart graphic can be 
changed and reformatted. Right click on a chart element to open the appropriate formatting dialog. 
For more information on changing and formatting a chart, see the Calc Guide.

Movies and sound

To insert a movie clip or a sound file into your presentation:

1) Click the Insert Movie icon on the slide layout (Figure 146) or select Insert > Movie and 
Sound from the menu bar to open the Insert Movie and Sound dialog (Figure 155).

2) Select the media file to insert and click Open to place the object on the slide.

Figure 155: Insert Movie and Sound dialog

Tip
To see a list of audio and video file types supported by Impress, open the drop-down 
list of file types. This list defaults to All movie and sound files, enabling you to choose 
an unsupported type such as .MOV.

To insert media clips directly from the Gallery:

1) If the Gallery is not already open, choose Tools > Gallery from the menu bar.

2) Browse to a theme containing media files (for example Sounds).

3) Click on the movie or sound to be inserted and drag it into the slide area.
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Figure 156: Media playback toolbar

The Media Playback toolbar (Figure 156) is automatically opened when a media file is selected. 
The default position of the toolbar is at the bottom of the screen, just above the Drawing toolbar. 
However, this toolbar can be undocked from its fixed position and allowed to float on screen. If the 
toolbar does not open, select View > Toolbars > Media Playback.

The Media Playback toolbar contains the following tools from left to right:

• Movie and Sound: opens the Insert Movie and Sound dialog where you can select a 
media file to be inserted.

• Play, Pause, Stop: controls media playback.

• Repeat: if pressed, media will continuously repeat playing until this tool is de-selected.

• Playback slider: selects the position within the media file.

• Timer: displays current position of the media clip/length of media file.

• Mute: when selected, the sound will be suppressed.

• Volume slider: adjusts the volume of the media file.

• Scaling drop-down menu: (only available for movies) allows scaling of the movie clip.

The movie will start playing as soon as the slide is shown during the presentation.

Note that Impress will only link the media clip, not embed it. Therefore if the presentation is moved 
to a different computer, the link will be broken and the media clip will not play. To prevent this from 
happening:

1) Place the media file, which is to be included in the presentation, in the same folder where 
the presentation is stored.

2) Insert the media file in the presentation.

3) Send both the presentation and the media files to the computer, which is to be used for the 
presentation, and place both files in the same folder on that computer.

Impress has a media player to allow previewing of media files that are to be inserted into a 
presentation. To open it select Tools > Media Player and its toolbar is the same as that of the 
Media Playback toolbar (Figure 156).

Formulas

Use Insert > Object > Formula to create a Math object in a slide. A formula can also be included 
into a presentation as an OLE object; see OLE objects on page 152 for more information.

When editing a formula, the Math menu becomes available to allow you to create or edit a 
formula..

Care should be taken about the font sizes used to make them compatible with the font size used in 
the presentation. To change the font attributes of the Math object, select Format > Font Size from 
the main menu bar. To change the font type, select Format > Fonts from the main menu bar.

For additional information on how to create formulas, refer to Chapter 9, Getting Started with Math 
in the Getting Started guide, or to the Math Guide.

Note
Unlike formulas in Writer, a formula in Impress is treated as an object; therefore it  
will not be automatically aligned with the rest of the text. The formula can be 
however moved around (but not resized) like any other object.
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Drawings, text files, HTML files and other objects

You can insert into an Impress presentation such as drawings, text files and HTML files. Select 
Insert > File from the main menu to open a file selection dialog. Only file types acceptable by 
Impress will be inserted into a presentation.

Drawings, text files, HTML files and other objects can also be included in a presentation as OLE 
objects; see OLE objects on page 152 for more information.

For computers operating Microsoft Windows there is an additional option of Further objects. 
Clicking on this option opens an Insert Object dialog allowing you to create an OLE object using 
other software that is compatible with OLE.
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Introduction

This chapter describes how to add new slides to the presentation and how to format slides. It also 
explains how to format both the Notes and Handouts views. Notes are generally used as prompts 
for the person giving the presentation. Handouts are normally used for providing a printout of the 
slides to your audience.

Two pop-up menus are available and useful when performing the operations on slides. One slide 
pop-up menu is displayed by right-clicking on a slide in Normal view and then selecting Slide 
(Figure 157). The other slide pop-up menu is accessed by right-clicking on a slide thumbnail in the 
Slides pane (Figure 158).

Figure 157: Slide pop-up menu

Figure 158: Slide pane slide pop-up menu

Adding, renaming, and removing slides

Adding a new slide
You can add a new slide to a presentation in several ways:

• In Normal, Outline, or Slide Sorter view, select Insert > Slide on the main menu bar.

• In Normal, Outline, or Notes view, right-click on the Slides pane and select New Slide from 
the pop-up menu.

• In Slide Sorter view, right click in the main work area and select New Slide from the pop-up 
menu.

• In Normal view, right-click in the main work area and select Slide > New Slide.
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The new slide is inserted after the current slide or in the position where the mouse was clicked.

If multiple slide masters are used in the presentation, the new slide will apply the master of the 
previous slide in the sequence.

Inserting a slide from another presentation
You can insert slides from other presentations in three ways:

• Using Insert > File. With this method, you can optionally link the slides instead of copying. 
This embeds the file into your presentation using OLE. See Chapter 7 Including 
Spreadsheets, Charts, and Other Objects of this guide for more information on OLE.

• Copying and pasting.

• Dragging and dropping to copy or move slides.

Inserting from a file

Figure 159: Inserting slides from a file

1) In Normal view, select the slide after which you want to insert the new slide, then choose 
Insert > File from the menu bar.

2) In the file browser, locate the file containing the slide that you want to insert and click 
Insert.

3) In the Insert Slides/Objects dialog (Figure 159), click the small triangular icon next to the 
filename to list the slides.

4) Select the slides that you want to insert into your presentation.

5) If required, select the Link option to embed the slides as OLE objects.

6) Click OK. The slides are inserted after the selected slide in the presentation.

Tip
Figure 159 shows the importance of giving descriptive names to slides in a 
presentation. Refer to “Renaming a slide” on page 172 for more information.

Chapter 8  Adding and Formatting Slides, Notes, and Handouts 171



Copying and pasting between presentations
1) Open the presentations that you want to copy from and paste into.

2) In the presentation containing the slides that you want to copy from, select View > Slide 
Sorter.

3) Select the slides you require and then select Edit > Copy on the main menu, or click on the 

Copy icon  on the main toolbar, or press Control+C (Cmd+C in Mac OS).

4) Change to the presentation where you want to paste the slides and select View > Normal.

5) Select the slide where you want the copied slides to follow.

6) Select Edit > Paste on the main menu, or click the Paste icon  on the main toolbar, or 
press Control+V (Cmd+V in Mac OS).

Dragging and dropping between presentations
1) Open the presentations that you want to move slides between and arrange the windows so 

both presentations are visible.

2) Select View > Slide Sorter in each window.

3) In the presentation containing the slides that you want to move or copy, select the required 
slides.

4) To move the slides, click and hold down the left mouse button to drag and drop the 
selected slides into the target presentation.

5) To copy the slides, hold down the Control key (Cmd key in Mac OS) while dragging and 
dropping to copy the selected slides into the target presentation.

Duplicating a slide
Duplicating a slide is an easy way to add slides if you want a new slide to inherit formatting, layout 
and animations from a selected slide. To duplicate a slide:

1) Go to Normal view either by clicking on the Normal tab in the Workspace pane or selecting 
View > Normal from the main menu.

2) Make sure that the slide to be duplicated is on the Workspace pane.

3) Select Insert > Duplicate Slide from the main menu. The duplicated slide is inserted after 
the original slide and displayed in the Workspace pane.

Tip

Duplicating a slide is a good way of preventing slides being shown with too much 
information making it difficult for your audience to understand. If a slide becomes 
crowded with information, try duplicating a “busy” slide then split the information points 
over two or more slides. All the formatting, backgrounds, and so on will be preserved 
in each duplicated slide.

Renaming a slide
To rename a slide, do one of the following:

1) Right-click on the slide thumbnail in the Slides pane or in the Workspace pane and select 
Slide > Rename Slide from the pop-up menu.

2) In Slide Sorter view, right-click on the slide and select Rename Slide from the pop-up 
menu.

3) In the Rename Slide dialog (Figure 160), type a new name for the slide and click OK.
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Figure 160: Rename Slide dialog

Expanding a slide
Occasionally you may have a slide with too many points to fit in the space available. Instead of 
reducing the font size or using other methods to squeeze more text into the space, it is better to 
subdivide the contents of the slide into two or more slides.

As mentioned in “Duplicating a slide” on page 172, you can duplicate the slide and manually split 
the points. Alternatively the contents of a slide can be expanded as follows:

1) If necessary, duplicate the slide in case of error and you want to redo expansion of the 
slide.

2) Select Insert > Expand Slide from the main menu to create a new slide for each highest 
level of the outline. The outline text becomes the title of each new slide. Outline points 
below the top level on the original slide are moved up one level in the new slides.

3) If required, repeat steps 2 and 3 on any slide where level 2 entries of the outline exist, to 
expand those as well.

Figure 161 shows a slide with an outline that has been expanded using the Expand Slide 
command. Each expanded slide has been given the slide title of each of the second level points on 
the original slide.

Figure 161: Slide 1 expanded into Slides 2, 3 and 4

Caution For the Expand command to work, ensure that the slide layout contains only one text 
AutoLayout box. If the layout of the slide is not suitable for expansion, the menu item 
is grayed out.
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Creating a summary slide
It is also possible to reverse the Expand operation to create summaries. The Summary command 
is useful in creating an agenda for your presentation.

1) Select the slide that will be the first one to appear in the summary. Do this by clicking on it 
in the Slides Pane or Slide Sorter view.

2) Select Insert > Summary Slide to create a new slide (Figure 162) at the end of the 
presentation where all the titles of the previous slides are written as bullet points in the 
body of the slide.

3) If necessary, move this slide to wherever you want it to appear in your presentation.

Figure 162: Summary slide

Deleting a slide
To delete a slide, use any of the following methods:

• In Normal, Outline or Slide Sorter view, select a slide and then select Edit > Delete Slide in 
the main menu or press the Delete key.

• In the Slides Pane select a slide and then right-click on the slide. Select Delete Slide from 
the pop-up menu or press the Delete key.

• In Normal view, right-click on the slide in the Workspace pane and then select Slide > 
Delete Slide from the pop-up menu.

Tip
When working in the Slide sorter view (View > Slide sorter) it is possible to delete 
multiple slides simultaneously by selecting them with the mouse and pressing the 
Delete key.

Creating slides from an outline

When planning a presentation it may be useful to develop an outline using LibreOffice Writer. Once 
the outline is created, you can create one or more separate slides for each of the top level outline 
elements as follows:

• Send an outline from Writer to Impress to create a new presentation.

• Send an auto-abstract from Writer to Impress to create a new presentation.

• Copying and pasting the outline from Writer to Impress to add to an existing presentation or 
after creating a blank presentation.
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Using an outline from Writer
The text document in Writer must contain headings formatted with the default heading paragraph 
styles.

1) Select File > Send > Outline to Presentation in the Writer main menu to create a new 
presentation containing the headings as an outline.

2) The new presentation opens in the Impress Outline view (Figure 163).

3) Click on the Normal tab to populate the slides in the Slides pane.

Some outline levels may have too many points to fit on one slide. You can expand this slide, see 
“Expanding a slide” on page 173, or duplicate the slide and manually change the contents, see 
“Duplicating a slide” on page 172.

Figure 163: Outline created from a LibreOffice Writer document

Using AutoAbstract from Writer
To send an AutoAbstract from Writer to Impress, the text must contain headings formatted with the 
default heading paragraph styles. When using AutoAbstract to copy the headings and subsequent 
paragraphs to a new presentation, you can specify the number of outline levels as well as the 
number of paragraphs to be displayed.

1) Select File > Send > AutoAbstract to Presentation from the Writer main menu to open 
the Create AutoAbstract dialog (Figure 164).
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Figure 164: Choosing outline levels for AutoAbstract

2) Select the number of outline levels to be copied to the presentation in Included outline 
levels. For example, if you choose four levels, all paragraphs formatted with heading levels 
1 to 4 are included, along with the number of paragraphs specified in Paragraphs per 
level.

3) The new presentation opens in Impress Outline view. Click on the Normal tab to populate 
the slides in the Slides pane.

4) If an outline has too many points to fit on one slide, expand the slide 

Copying and pasting an outline
Copy and paste an outline into an existing presentation or a new presentation as follows:

1) In Writer, highlight the outline and select Edit > Copy, or right click on the outline and 
select Copy from the pop-up menu.

2) Create a new slide and choose the Title, Content layout (see “Choosing a slide layout” on 
page 178).

3) Paste the outline created with Writer into the text area of the slide. Do not worry if the text 
does not fit the space on the slide.

4) If some outline levels have too many points to fit on one slide, expand the slide, see 
“Expanding a slide” on page 173, or duplicate the slide and manually change the contents, 
see “Duplicating a slide” on page 172.

5) When pasting, the hierarchical structure of the outline may be lost. If necessary, use the 
Promote/Demote icons  on the Text Formatting toolbar to move the outline points 
to the correct hierarchical levels.

Tip
It may be useful to open the Style and Formatting window of the Presentation styles 
page to track the outline level of each item.

Modifying slides

Use slide masters to give your presentation a professional look and to avoid manually modifying 
the formatting of each individual slide. Multiple slide masters can be used in a single presentation 
to provide the same look for groups of slides and avoid modifying the formatting of each individual 
slide in a group of slides. See Chapter 2 Slide Masters, Styles, and Templates of this guide for 
details about using slide masters.

Formatting the slide or page area
The Page Setup dialog (Figure 165) can be used  to set up the page layout In Impress for the 
Normal, Notes or Handouts views.
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Figure 165: Page Setup dialog

Note

Any changes to the page format (size, margins, orientation, and so on) apply to all 
slides in the presentation. You can only define one page style in Impress, whereas in 
Writer or Calc you can define more than one page style. You can change the 
background of individual slides, see “Changing slide background” on page 178.

1) To start, click the Normal tab in the Workspace pane or select View > Normal in the main 
menu.

2) Select Format > Page from the main menu, or right-click on the slide and choose Slide > 
Page Setup to open the Page Setup dialog (Figure 165).

The Page tab has three sections: Paper format, Margins, and Layout settings. Changing these 
settings affects all slides in the presentation.

In Paper format, select the preferred format from the drop-down list. The dimensions change 
automatically when a standard format is selected. The drop-down list contains selections for 
displaying the slides as well as printing them on paper.

The default values for the screen settings are for a screen presentation with 4:3 ratio. If your 
computer uses a wide-screen monitor, you can manually adjust the width and height to fit a wide-
screen format.

In Margins, change the spacing between the edges of the page and the contents of the slide.

In Layout settings, select the page number format from the Format drop-down list. To allow 
resizing of slide objects and fonts to fit the selected paper format size, select the Fit object to 
paper format checkbox.

Printing slides
You can also select the orientation of the slide or paper (portrait or landscape) and the paper tray 
to be used. Note that in Impress you can only specify one printer tray for when printing pages 
(slides). However, you can specify different printer trays for printing all the slides, notes, and 
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handouts on different printing media by changing the setting in the Page Setup dialog before 
printing. This is useful if, for example, you want to print slides on transparencies and handouts on 
paper. For more about printing presentations, see Chapter 10 Printing, E-mailing, Exporting, and 
Saving Slide Shows of this guide.

Choosing a slide master
In the Task Pane, select the Master Pages tab. To apply one of the slide masters to all slides in 
your presentation, click on it in the list.

To apply a different slide master to one or more selected slides:

1) In the Slide Pane or the Slide Sorter view, select the slides you want to change.

2) In the Task Pane, right-click on the slide master you want to apply to the selected slides, 
and click Apply to Selected Slides on the pop-up menu.

Chapter 2 Slide Masters, Styles, and Templates of this guide discusses slide masters (also called 
master slides or master pages) in detail.

Changing slide background
This section describes how to modify the background of a single slide.

Tip
For easy maintenance it is recommended that slide masters are used to modify the 
slide backgrounds by creating additional slide masters as required.

Note
Applying a background to individual slides is no different from filling the area of a 
shape. See Chapter 6 Formatting Graphic Objects of this guide for more information.

To change the background for a slide:

1) Switch to Normal view by clicking the Normal tab in the Workspace pane or select View > 
Normal on the main menu.

2) Select the slide you want to change.

3) Select Format > Page from the main menu, or right-click and select Slide > Page Setup 
to open the Page Setup dialog (Figure 165). Choose the Background tab.

4) Follow the instructions in Formatting areas in Chapter 6 Formatting Graphic Objects of this 
guide.

5) Click OK to save the changes. A pop-up message asks if you want to change the 
background on all slides. To change only the selected slide, click No. If you press Yes, 
Impress will apply the new background to all the slides used in the presentation.

Choosing a slide layout
After creating a new slide, you can then decide on what layout is most suitable the slide contents 
and your presentation. Impress offers various types of predefined layouts that can be applied to a 
slide (Figure 166).

To apply a layout to a slide:

1) In the Tasks pane, select Layouts to display the various slide layouts available. If the Tasks 
pane is not visible, select View > Task Pane on the main menu.

2) Hover the mouse cursor over the layout thumbnail to get a tooltip with a summary of the 
type of layout.

3) Click on the selected layout to apply it to the slide.
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Figure 166: Available slide layouts

Note
If the layout is changed when the slide already contains contents, Impress will not  
delete the contents but reposition the contents according to the selected layout. This 
may result in some elements overlapping or being out of position.

If these layouts do not fit the presentation style, the elements can be rearranged on an individual 
slide and duplicated as often as needed by copying to another presentation or saving it as a 
template.

All the techniques in Chapter 3 Adding and Formatting Text of this guide for working with text 
boxes can be applied to the title and auto layout text elements of the slide. The placeholder for 
images can be moved and resized, see Chapter 4 Adding and Formatting Pictures of this guide. 
Chapter 7 Including Spreadsheets, Charts, and Other Objects of this guide describes how to 
include and modify spreadsheets, charts, and other objects.

Adding comments

When creating a presentation in a collaborative environment, it is often useful to add comments to 
the presentation for the benefit of the other people working on the presentation.

To add a comment, switch to Normal view and select the slide where you want the comment to 
appear. Select Insert > Comment from the main menu to display a comment box (Figure 167) in 
the top left corner of the slide. Once you are finished typing your comment you can close the 
comment box by clicking anywhere outside the comment box.
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Figure 167: Adding comments

Each comment is color coded and marked with the initials of the author as well as a sequential 
number and is shown in the top left corner of the slide in Normal view. Clicking on a comment box 
displays the full text of the comment. The size of the comments box is fixed and scroll bars appear 
when needed.

Editing, deleting and replying to comments
You can only edit the comments if you created them. You can reply to a comment created by 
another person. Select Reply from the comment drop down list (Figure 168). Click on the small 
triangle located in the bottom right of the comment to display the drop list or right click when the 
mouse cursor is over the comment.

Figure 168: Comments drop down list

A limited set of options available for formatting a comment can be accessed by right-clicking on the 
comment box. Use the pop-up menu to apply one or more font attributes (bold, italic, underline, 
strikethrough) or paste contents that have been copied to the clipboard.

Use the comment drop down list (Figure 168) to delete the current comment, delete all the 
comments from the author of the selected comment, or delete all the comments in the 
presentation. If the comment you opened was created by a different author the comment drop 
down list also displays the option to reply to the comment.

Adding and formatting notes

Notes view provides a convenient way to create reminders or add extra information to slides in a 
presentation. Notes are not displayed during a slide show. However, using a dual monitor, you can 
display any notes on the second monitor as a presentation cue. You can also print the notes and 
use them as handouts.
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Note

If you regularly give presentations in public using a projector, you may want to 
consider installing the Presenter Console, an extension that allows you to display on 
your screen the slide notes, the next slide, and other useful information while only the 
slide is shown through the projector. The extension may be installed with your copy 
of LibreOffice, or you can download it from http://extensions.libreoffice.org/.

Adding notes to a slide
To add notes to a slide:

1) In the Slides pane, select the slide to which you want to add notes.

2) Switch to Notes view (Figure 169) by clicking the tab in the Workspace pane or select View 
> Notes Page from the main menu.

3) Click in the text box showing Click to add notes and type or paste text or graphics as 
required.

4) To add notes to another slide, repeat steps 1 to 3.

5) When you have finished entering notes, return to Normal view.

Figure 169: Notes view

Formatting notes
It is highly recommended to use the Notes Master and the Notes Presentation style to format the 
appearance of notes, rather than formatting them for each slide individually.

All the formatting guidelines given in this section can be applied to either the Notes Master or to the 
Notes Presentation style.

To open the Notes Master, choose View > Master > Notes Master from the main menu (Figure
170).
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Figure 170: Notes Master layout

Formatting the Notes page
To format the Notes page:

1) Switch to Notes view by clicking the tab in the main work area or select View > Notes 
Page.

2) Select Format > Page from the menu bar, or right-click and choose Page Setup to open 
the Page Setup dialog (Figure 171).

3) Set the desired parameters. The Page Setup dialog for notes is the same as the page 
setup dialog for slides. Refer to “Formatting the slide or page area” on page 176 for a 
description of the page setup dialog. The only difference is that by default the Notes page 
orientation is set to portrait and the format is A4.

4) When finished setting up a notes page, click OK to close the dialog.
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Figure 171: Page Setup dialog for notes

Setting automatic layout options
In Notes view, Impress creates four areas input information about the presentation:

• Header area

• Date and Time area

• Footer area

• Slide or page number area

To customize these fields, proceed as follows:

1) Switch to Notes view from the corresponding tab in the work area or by selecting View > 
Notes Page from the main menu, or open the Notes Master by going to View > Master > 
Notes Master (Figure 170) on the main menu.

2) Choose Insert > Date and Time for the date and time. Choose between Fixed to enter the 
date and time that should be displayed or Variable to enter the date and time of the slide 
creation. Use the two drop-down menus to select the format of the date and the language.

3) Choose Insert > Page Number from the main menu to display the Header and Footer 
dialog. Select the Notes and Handouts tab (Figure 172).

4) Select the checkboxes to activate the corresponding areas. For the Header and Footer, 
type the text in the edit fields. If the Page number checkbox is activated, to format the type 
of numbering refer to “Formatting the Notes page” on page 182.

5) Click the Apply to All button to save these settings and close the dialog.
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Figure 172: Header and Footer dialog for notes

Text formatting
When text is inserted in the Notes text box, it is automatically formatted using the predefined Notes 
style that you can find in the Presentation styles. The best way to format the notes text is to modify 
this style to suit your needs. Refer to Chapter 2 Slide Masters, Styles, and Templates of this guide 
for more information.

If manual formatting is required, for example to highlight a particular section of the notes, refer to 
Chapter 3 Adding and Formatting Text of this guide for more information.

Advanced Notes formatting
You can make other changes to the Notes pages. For example, you can:

• Move the text box and the slide image around the page

• Resize the slide image and text box (only from the Slide Master view).

• Add other text boxes to the page.

Printing notes
1) Choose File > Print from the main menu.

2) On the Print dialog, in the Print section (Figure 173) of the General tab, select Notes from 
the Document list.

3) Make any other necessary changes and click OK to print.

For more information on printing slides, notes, and handouts, see Chapter 10 Printing, E-mailing,  
Exporting, and Saving Slide Shows of this guide.

Figure 173: Printing notes
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Exporting notes to PDF
1) Choose File > Export as PDF from the main menu.

2) In the PDF Options dialog, choose the General tab.

3) Under General, make sure that Export notes pages is checked, and then click OK.

4) In the Export dialog, enter a filename, select the folder in which to save it, and click Export.

Figure 174: Exporting Notes as PDF

Note

If your presentation has 10 slides, the PDF contains 20 pages: 10 pages of individual  
slides, followed by 10 pages with notes formatted for paper. If you want only the Notes 
pages, you will need to use some other program to remove the unwanted pages of 
slides from the PDF.

Creating handouts

A handout is a special view of the presentation suitable for printing and distribution to the audience. 
Each handout page contains from one to nine thumbnails of the slides in the presentation so that 
the audience can follow what is presented as well as use it as reference. This section explains how 
to customize the handout page.

Note that the Handout view consists of only one page regardless of the number of slides in the 
presentation or the number of pages of slides that will be printed.
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Changing the layout
When creating handouts, first decide how many slide thumbnails you want printed on each 
handout page.

1) Select the Handout view either by clicking on the tab in the Workspace pane or by selecting 
View > Handout Page from the main menu (Figure 175).

2) If the Task pane is not visible, select View > Task Pane from the menu bar.

Tip
As for any other toolbar, you can undock the Task pane by holding down the Control 
key and double-clicking on an empty part of the pane.

Figure 175: Example of a handout with six slide thumbnails

Figure 176: Layouts for handouts

3) In the Task pane select the Layouts tab (Figure 176).

4) Select the preferred layout and the main work area changes to reflect the selection.
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Formatting handouts
You can format several aspects of the handout, from the page style to the elements that appear on 
the page. You cannot format individual handout pages; any changes apply to all handouts in the 
presentation file.

Formatting the page
To format the handout pages:

1) Make sure you are in Handouts view. Click the Handouts tab in the Workspace pane or 
select View > Handout Page from the main menu.

2) Select Format > Page from the main menu, or right-click on the handout and select Slide > 
Page Setup from the pop-up menu.

3) On the Page Setup dialog (Figure 171), set the paper size, orientation (portrait or 
landscape), margins, and other parameters. Click OK.

Setting automatic layout options
In Handout view, as in Notes view, Impress creates four areas where you can put information about 
the presentation:

• Header area

• Date and Time area

• Footer area

• Slide or page number area

Note
The information in these areas does not show in Handout view, but it does appear 
correctly on the printed handouts.

The way to access and customize these areas is the same as for the Notes and uses the same 
dialog. Refer to “Setting automatic layout options” on page 183 for more information.

Moving thumbnails and adding graphics
You can move (but not resize) the slide thumbnails and add lines, boxes, and other graphic 
elements to the handouts. See Chapter 5 Managing Graphic Objects for instructions on using the 
graphics tools.

Tip

After designing a handout, you may wish to save it in a template so you can reuse it 
whenever you want. See “Working with templates” in Chapter 2 Slide Masters,  
Styles, and Templates for instructions on saving templates and starting a new 
presentation from a template.

Caution If you click on one of the other handout layouts and then return to the one you have 
reformatted, the slide thumbnails return to their original positions, although any lines 
or other graphics you have added remain where you put them. You will need to move 
the thumbnails back to where you want them.
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Printing handouts
1) Choose File > Print from the main menu.

Figure 177: Choose which slides to print

2) On the General page of the Print dialog, in the Print section, select Handouts from the 
Document list (Figure 174).

3) Specify the number of slides per page and the order in which to print multiple slides. To 
select which slides to include in the handouts, in the Range and copies section of the 
General page, select Slides and specify the slide numbers to be included.

For more information on printing slides, notes, and handouts, see Chapter 10 Printing, E-mailing,  
Exporting, and Saving Slide Shows of this guide.

Exporting handouts to PDF
At present there is no way to export handouts to PDF; if you try, you get the slides (one per page) 
instead. However, you can print to a PostScript file, if you have a postscript printer driver installed, 
and then use another program (such as Ghostscript or Adobe Distiller) to create a PDF from the 
PostScript file.
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Putting together a slide show

LibreOffice Impress gives you the tools to organize and display a slide show, including:

• Which slides to show and in what sequence

• Whether to run the show automatically or manually

• Transitions between slides

• Animations on individual slides

• Interactions: what happens when you click a button or link

Most tasks associated with putting together a slide show are best done in Slide Sorter view. 
Choose View > Slide Sorter from the main menu or click the Slide Sorter tab at the top of the 
Workspace pane. All of your slides appear in the workspace; you may need to scroll to see them 
all.

Basic settings for a slide show
Basic settings for a slide show include which slide to start from, the way you advance the slides, 
the type of presentation, and pointer options.

Select Slide Show > Slide Show Settings. From the main menu to open the Slide Show dialog 
(Figure 178).

Figure 178: Selecting slide show settings

In the Range section, select which slides to include in the slide show:

• All slides: includes all of the slides except for those marked Hidden (see “Hiding slides” on 
page 192). Slides are shown in the sequence they occur in the file. To change the 
sequence, either rearrange the slides in the slide sorter or choose a custom slide show 
(see below).

• From: starts the show at a slide other than the first. For example, you might have several 
slides at the beginning that describe you and your company, but when you present this 
show to your work colleagues, you want to skip that introduction.
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• Custom Slide Show: shows the slides in a different sequence that you have previously set 
up. This setting is not available until you have set up a custom slide show (see “Showing
slides in a different order” on page 192). You can set up as many different custom shows as 
you wish from one set of slides; they will appear in the drop-down list under this choice.

In the Type section, select how the slides will be displayed:

• Default: shows the slides full screen, without the LibreOffice program controls visible, and 
exits the show after the last slide.

• Window: runs the slide show in the LibreOffice program window and exits the show after 
the last slide.

• Auto: restarts the slide show after the last slide. A pause slide is displayed between the 
last slide and the start slide. Press the Esc key to stop the show. In the box, specify the 
length of time before the show restarts. If you enter zero, the show restarts immediately 
without showing a pause slide. The Show Logo option shows the LibreOffice logo on the 
pause slide.

In the Options section:

• Change slides manually: prevents slides from changing automatically even if an 
automatic transition has been set up.

• Mouse pointer visible: shows the mouse pointer during a slide show. If you do not have a 
laser pointer or other device to highlight items of interest during the show, this can be 
useful.

• Mouse pointer as pen: enables you to write or draw on slides during the presentation. 
Anything you write with the pen is not saved when you exit the slide show. The color of the 
pen cannot be changed.

• Navigator visible: displays the Navigator during the slide show. For more information on 
the Navigator, see Chapter 1 Introducing Impress of this guide.

• Animations allowed: displays all frames of animated GIF files during the slide show. If this 
option is not selected, only the first frame of an animated GIF file is displayed. This has 
nothing to do with the slide animations described in “Using slide animation effects” on page 
196.)

• Change slides by clicking on background: advances to the next slide when you click on 
the background of a slide. You can also press the spacebar on the keyboard to advance to 
the next slide.

• Presentation always on top: prevents any other program window from appearing on top 
of the presentation.

In the Multiple displays section:

• You can select which display to use for full screen slide show mode. Only available if the 
current desktop is displayed on more than one monitor. 

• If the current desktop is displayed on only one monitor, or if the multiple-display feature is 
not supported on the current system, you cannot select another display. 

• By default the primary display is used for slide show mode.

Note
This multiple displays setting is not a property saved in the document, but is instead 
saved as a local setting in the user configuration. This means that if you open the 
presentation on a different computer the local settings are applied.
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Hiding slides
You may not want to show all of the slides in a particular slide show. You can either hide some of 
the slides or set up a custom slide show; whichever method suits your requirements. For example, 
you may have draft slides that you do not want to show until they are finished, or you may have 
some slides that contain information for yourself, but not your audience.

To hide a slide:

1) In the Slides pane, or in Slide Sorter view, select the slides that you want to hide.

2) Click the Hide Slide icon  on the Slide View toolbar (Figure 179), right-click and select 
Hide Slide from the context menu, or select Slide Show > Hide Slide on the main menu. 
The slide is now displayed greyed out to indicate that it is hidden (Figure 180). The slide is 
not deleted and remains in the file.

Figure 179: Slide View toolbar

Figure 180: Slide 2 is hidden

To show a hidden slide:

1) In the Slides pane, or in Slide Sorter view, select the hidden slides that you want to show.

2) Click the Show Slide icon  on the Slide View toolbar (Figure 179), right-click and select 
Show Slide from the context menu, or select Slide Show > Show Slide on the main 
menu.

Showing slides in a different order
To show the slides in a different order, you can either rearrange them in the slide sorter, or set up a 
custom slide show. You can define as many custom slide shows as you require from one set of 
slides.

In a custom slide show, you can select which slides to include as well as the order in which they 
are shown. Any slides marked Hidden will not appear in a custom show.

Setting up a custom slide show
To set up a new custom slide show:

1) Choose Slide Show > Custom Slide Show from the main menu to open the Custom Slide 
Shows dialog (Figure 181).
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Figure 181: Custom Slide Shows dialog

Figure 182: Defining a custom slide show

2) Click on New and the  the Define Custom Slide Show dialog opens (Figure 182).

3) Type a name for the new custom show in the Name text box.

4) In the Existing slides list, select the slides to include in the show. Click the >> button to 
include the slides in the Selected slides list. In Figure 182, the first three slides have been 
selected.

5) You can select and include several slides at the same time. Hold down the Shift key and 
click the first and last slide in a group to select that group, or hold down the Control key and 
click on individual slides to select them.

Note

If you include several slides at the same time, they are added to the Selected slides 
list in the order they appear in your presentation regardless of the order in which you 
selected them. To put the selected slides in a different order, either select and include 
each slide individually or select a slide and drag it up or down in the selected slide 
list. You can also use the Slide Sorter view to rearrange the order of slides before 
making your selection.
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Tip

Slides are added to the Selected slides list after whichever slide is currently 
highlighted in the list. By default, the last slide added is highlighted unless you have 
selected a different one. For example, in Figure 182, to add the slide Final Slide 
Example after the Default Example and before Shapes, make sure that Default  
Example is highlighted before moving Final Slide Example into Selected slides.

6) When you have finished arranging the order of the slides, click OK to save this custom 
show and return to the Custom Slide Shows dialog box.

7) To activate a custom show, select it in the list in the Custom Slide Shows dialog box and 
then select the Use Custom Slide Show option at the bottom.

Editing, deleting, or copying a custom slide show
To edit a custom slide show (add, remove, or change the order of slides, or change the name of 
the show), select it in the Custom Slide Shows dialog (Figure 181) and click Edit.

To delete a custom slide show, select it in the Custom Slide Shows dialog and click Delete. 
Deletion is immediate; no confirmation message appears.

To create a copy of a slide show, select it in the Custom Slide Shows dialog and click Copy. You 
can now edit the copy by renaming and adding, removing, or changing the order of slides in it.

You can run or test your custom slide show from the Custom Slide Shows dialog, if the Use 
Custom Slide Show checkbox is selected. Select the slide show from the list and click on Start.

When you have finished working with custom slide shows, click Close to save all changes and 
close the Custom Slide Shows dialog.

Using slide transitions

Slide transitions are the effects that take place between slides when slides change in a 
presentation. Transitions add dynamic flair to a slide show, smoothing the change over between 
slides.

1) In the Tasks pane, choose Slide Transition (Figure 183).

2) In the Slides pane or Slide Sorter view, select the slides to which you want to apply the 
transition. If you want the transition to apply to all slides, do not select any slides.

3) In the Apply to selected slides list, select a transition.

4) Modify the selected transition by changing the speed or adding a sound, in the Modify 
transition section. If you decide to play a sound during transitions, select a sound from the 
Sound list. The Loop until next sound  option now becomes active. Select this option to 
play the sound repeatedly until another sound starts. If there are no subsequent sounds in 
your slide show, the selected sound will play continuously for the remainder of the show.

5) Select how to advance to the next slide: manually (on mouse click) or automatically. If you 
choose automatically, you can specify how long the slide remains visible before it 
automatically advances to the next slide.

6) If you want the transition to apply to all slides, click the Apply to All Slides button.

7) To start the slide show from the current slide so you can check your  transitions, click the 
Slide Show button.

8) If the Automatic preview checkbox is marked, the effect of a selected transition is 
immediately displayed in the work area. You can replay the effect at any time by pressing 
the Play button.
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Figure 183: Slide transitions

Tip

You can apply a single type of transition to all slides in the presentation or apply a 
different transition to any single slide, even having a different transition for every slide 
in the show. While using many different transitions may be fun to do, it may not give 
your slide show a professional appearance.

Tip
If you want most of the slides to have the same transition with a few different 
transitions, you may find it easier to apply one transition to all slides and then change 
only the ones you want to be different.

Setting the timing of automatic slide changes
You can set up a slide show to run automatically, either unattended or while you speak.

To set the default time for slides to be displayed before changing to the next slide:

1) Go to Slide Transition in the Tasks pane (Figure 183).

2) Leave the transition effect set to No Transition.
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3) Select Automatically after in the Advance slide section.

4) Set a time and click the Apply to All Slides button.

To vary the timing for some of the slides in your slide show:

1) Select Slide Show > Rehearse Timings from the main menu, or click the Rehearse 

Timings icon  on the Slide Show toolbar. The slide show begins in full-screen mode, 
and a timer appears in the lower left-hand corner of the screen.

2) When you want to advance to the next slide, click the timer. To keep the default setting for 
this slide, click the slide, not the timer.

3) Continue until you have set the timing for all slides in your presentation. Impress records 
the display time for each slide. When you next look at the time set under Automatically 
after, you will see that the times have changed to match what you set when rehearsing.

4) To exit from the rehearsal, press the Escape key or right click on the slide and select End 
Show.

If you want the whole presentation to auto-repeat, open the Slide Show dialog (Figure 178) by 
going to Slide Show > Slide Show Settings on the main menu. Click on Auto and then OK.

Playing a sound throughout a presentation
You can use the Slide Transition pane so that a sound or a song is played throughout the 
presentation.

1) Select the slide where you want the sound to start and go to the Slide Transition pane.

2) In the Modify transition section, select Other sound from the Sound drop-down list.

3) Select Loop until next sound checkbox if you want the sound to restart once it is finished.

Caution
Do not click the Apply to all button; otherwise your selected sound will restart at 
every slide.

Note

The sound file is linked to a presentation rather than embedded; therefore if you plan 
to display the presentation on a different computer, remember that you also have to 
make the sound file available on the computer where the presentation will be played,  
and re-establish the link to the local sound file before starting the slideshow.

Removing a transition effect
1) Select the desired slides.

2) Choose No Transition in the list on the Slide Transition page of the Tasks pane.

Using slide animation effects

Slide animations are similar to transitions, but they are applied to individual elements on a single 
slide: title, chart, shape, or individual bullet point. Animations can make a presentation more lively 
and memorable. Just as with transitions, heavy use of animations can be fun, but distracting and 
even annoying for an audience expecting a professional presentation.

Animation effects need to be applied from Normal view so that you can select individual objects on 
a single slide.
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Note

At present it is not possible to apply animation effects to the slide master elements.  
This means that if you want to display the items in a text box one by one, and use the 
same animation on more than one slide, you need to apply the effects to each slide,  
or alternatively copy the text box from one slide to another.

Applying an animation effect
In Normal view, display the desired slide and then select the text or object you want to animate. An 
object such as a graphic or an entire text box will have selection handles around it when selected. 
If you choose only a portion of the text in a text box, you may not see any selection handles.

Figure 184: Custom Animation on Task pane

1) In the Tasks pane, select Custom Animation (Figure 184).

2) Click Add to open the Custom Animation dialog (Figure 185).

3) Select an effect from one of the tabbed pages of this dialog, and choose the speed or 
duration of that effect.

4) Select an animation to be applied from the Entrance page when an object is placed on the 
screen.
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Figure 185: Custom Animation dialog

5) Use the Emphasis page to apply a basic effect to an object, for example changing font 
color, or adding special effects such as blinking text.

6) Use the Exit page to apply an effect when an object leaves the screen.

7) If you want the object to move along a line or curve, select an animation from the Motion 
Paths page. An example of this type of animation is provided in “Example: Setting up a
motion path” on page 200.

8) If required, change the speed of an effect from the Speed drop-down list before moving to 
another tabbed page.

9) Select Automatic preview if you want to see how the effect works with having to run the 
whole slide show.

10) Click OK to save the animation effects and return to the Custom Animation page on the 
Task pane. Here you can choose how to start the animation, change the overall speed, and 
apply some additional properties to the selected effect.

Starting an animation effect
You have three options from the Start drop-down list for starting an animation effect:

On click − the animation does not start until you click the mouse.

With previous − the animation runs at the same time as the previous animation.

After previous − the animation runs as soon as the previous animation ends.
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Choosing additional properties of an animation effect
Many animations have a set of properties that you can set or change. For example, for the Change 
Font Color effect on the Emphasis page, you can specify the font color. If you select Fly In on the 
Entrance page, you can specify the direction from which the object flies in.

The label on the Effect properties section changes depending on the effect selected. Also, the 
options available in this section change depending on the selected effect. For example, a Fly In 
effect has an option labelled Direction and a Change Font Color effect has an option labelled Font 
color.

Clicking on the … button opens the Effect Options dialog giving you additional options to customize 
the animation effect you have selected. An example of this dialog is shown in Figure 186.

Figure 186: Example of the Effect Options dialog

Example: Using multiple animation effects
To illustrate how you can set up multiple effects, we shall use a common animation: list items fly in 
one at a time from the bottom of the slide, and as each new item appears, the previous items 
change to a different color. Here is an example on how to create these effects:

Step 1. Apply the Fly in effect to all the items.

1) Display the Custom Animation page of the Task pane.

2) Create a slide with several items in a bullet list.

3) Select all items. Click Add on the Custom Animation in the Tasks pane.

Figure 187: Example of animated points
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4) On the Entrance page of the Custom Animation dialog select Fly In, change the Speed to 
Medium, and click OK.

5) The four animation effects set up are listed in the Custom Animation page (Figure 187).

Step 2. Apply the Change Font Color effect to some items.

Now the first three list items are going to change color when the following item appears on the 
slide. To do this:

1) Select the first three items on the slide (not in the animations list) and click Add in the 
Custom Animation pane.

2) Go to the Emphasis page of the Custom Animation dialog and select Change Font Color. 
Click OK to save this effect.

3) Notice that three new animations are listed at the bottom of the animations list, and the icon 
for type of effect is now is different from the icon for the first four effects (Figure 188). 

4) You could, if you wish, select any of the last three items and choose a different color from 
the Font color list on the Custom Animation pane.

5) Use the Change order: up-arrow button to move each of the last three items up the list so 
that they are under the other item with the same name.

Figure 188: Second animation added

Step 3. Change timing of some list items from With previous to On click.

All of the items on the animations list (except for the two “Point one” items) are set to start at the 
same time as the previous item. However, it is best that when you click to make the next point 
appear the previous point is dimmed. Therefore to set the color change of the previous point and 
the entrance of the new point to run on mouse click simultaneously.

1) Select the color change animations and choose On click from the Start list, then select the 
entrance animations (except the first) and choose With Previous from the Start list. 

2) Test this set of animations by clicking the Slide Show button.

Example: Setting up a motion path
The Motion path effect moves an object along a path consisting of a combination of straight and 
curved lines. Several pre-packaged paths are provided in LibreOffice, but it is not difficult to create 
your own custom path. Start by selecting the object you want to animate and selecting a pre-
packaged motion path animation that is similar to the effect you want to obtain. Alternatively use 
the Polygon or Curve animation to create a new path.

Select the object to show the animation path, which will be displayed as a thin gray line with a 
triangle showing the starting point and another indicating the end point. Click on any point on the 
line so that selection handles are displayed around it. When the selection handles are shown, you 
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can move or resize the path the same way you would perform these operations on a graphic 
object.

Note
When moving a path, remember to also move the object on that path; otherwise the 
animation will start with a jump. Currently it is not possible to rotate a path.

If instead you want to modify the individual points on the line, select the Points icon  from the 
Drawing toolbar while the path is selected. The Edit Points toolbar (Figure 189) is displayed; if not, 
select it from View > Toolbars > Edit Points. The number of icons available in the Edit Points 
toolbar will depend on the type of motion path and object selected.

Figure 189: Edit Points toolbar and icons

Once a point is selected, you can add an additional point, delete it, move it and so on. For a 
detailed explanation on how to manipulate the points on a curve, see the Draw Guide. Once you 
are satisfied with the shape of the curve and its speed, click anywhere on the screen to deselect 
the object and continue normal editing.

You can combine a motion path with other effects such as spinning or changing of size or colors to 
create dramatic effects.

Advanced animation effects
Click the Effect Options button [...] next to the Properties drop-down list to display the Effect 
Options dialog (Figure 186 on page 199).

What you see in the Effect Options dialog depends on the type of object selected. When a text 
object is selected, the dialog has three pages: Effect, timing, and Text Animation. When a graphical 
object is selected, the dialog has two pages: Effect and Timing.

The options available on the Effect page also vary depending on the type of object selected and 
the type of animation selected, such as Direction effect or a Font Color effect. For graphical 
objects, the Text animation box on the Effect page is unavailable.
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On the Effect page, you can select a sound to play, whether to dim or hide the object after 
animation, and (in the case of text objects) whether to animate the text all at once or word by word 
or letter by letter.

On the Text Animation page of the Effect Options dialog (Figure 190), you can group text as one 
object, all paragraphs at once, or by first-level paragraphs (that is, one list item together with its 
sub-items, if any).

Figure 190: Text Animation page of Effect Options dialog

On the Timing page of the Effect Options dialog (Figure 191) you to change the speed, delay, and 
other aspects of the timing of the effect.

Figure 191: Timing page of Effect Options dialog

Removing animation effects
1) On the Custom Animation page of the Task pane, select the desired object.

2) Click the Remove button.

Using interactions

Interactions are things that happen when you click on an object in a slide. They are typically used 
with buttons or images, but text objects can also have interactions.

To apply an interaction to an object (or change an interaction applied to an object), right-click on 
the object and choose Interaction from the pop-up menu to open the Interaction dialog (Figure
192). Select an interaction from the Action at mouse click drop-down list. With some interactions 
the Interaction dialog changes to offer more options.
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Figure 192: Dialog box before choosing an interaction

Tip
A sound interaction can be also applied using the Effect Options dialog (Figure 186 
on page 199).

Running a slide show

To run the slide show, do one of the following:

• Press F5.

• Click Slide Show > Slide Show on the main menu.

• Click the Slide Show icon on the Presentation toolbar or the Slide Sorter toolbar.

If the slide transition is Automatically after x seconds, let the slide show run by itself.

If the slide transition is On mouse click, do one of the following to advance from one slide to the 
next.

• Press the down arrow key, the right arrow key, or the Page Down key on the keyboard.

• Click the left mouse button.

• Press the Spacebar.

To go backwards through the show one slide at a time, press the up arrow key, the left arrow key, 
or the Page Up key. For more complex navigation, use the right-click menu (see “Navigating using
the right-click menu”).

Custom animations on a slide are run in the specified order when performing one of the above 
actions.

When you advance past the last slide, the message Click to exit presentation... appears. Click 
the left mouse button or press any key to exit the presentation.

To exit the slide show and return to the Impress workspace at any time, including at the end, press 
the Esc key.

Navigating using the right-click menu
If your presentation consists of more than one slide, right-clicking anywhere on the screen brings 
up a menu. The choices are:

• Next: moves to the next slide in the defined sequence.

• Previous: moves to the previous slide in the defined sequence.

• Go to Slide: displays a submenu allowing to quickly navigate through the presentation. 
Options on the submenu include First slide, Last Slide, or any slide in the show. This 
illustrates why giving the slides meaningful names, rather than leaving them at the default 
Slide 1, Slide 2, and so on, can be very helpful.
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• Screen: displays a submenu with two options. Each option blanks the screen, showing it 
as either all black or all white. This can be useful if you want to pause the show for awhile, 
perhaps during a break or to demonstrate something on another computer.

• End Show: ends the presentation and returns you to the Impress workspace. This is the 
same effect as pressing the Esc key.

Controlling a slide show using the Presenter Console

Most installations of LibreOffice Impress come with the Presenter Console extension built in. If it is 
not included, you can also get the extension and install it as described in Chapter 11, Setting up 
and Customizing Impress.

The Presenter Console provides extra control over slide shows (presentations) through different 
views on the computer screen the presenter is using and on the projection that the audience sees. 
The presenter’s view includes the current slide, the upcoming slide, the slide notes, and a 
presentation timer.

Note
The Presenter Console works only on operating systems that support two displays,  
and only when two displays are connected (one may be the laptop display).

The Presenter Console provides three easily changeable views:

• First view displays the current slide, including the effects, and the upcoming slide.

• Second view shows the notes for the speaker in large, scalable type, plus the current and 
upcoming slide.

• Third view is a slide sorter view with the slide thumbnails where you can select a thumbnail 
to jump to a slide out of sequence.

• Lastly, the presenter can display a set of help notes with navigational and other information.
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Introduction

This chapter provides information about printing, exporting, and e-mailing documents from 
LibreOffice Impress.

Quick printing

Click the Print File Directly icon  on the Standard toolbar to send the entire document to the 
default printer defined for your computer.

Note

You can change the action of the Print File Directly icon to send the document to 
the printer defined for the document instead of the default printer for the computer. 
Go to Tools > Options > Load/Save > General and select the Load printer 
settings with the document option.

Controlling printing

Impress provides many options for printing a presentation: with multiple slides on one page, with a 
single slide per page, with notes, as an outline, with date and time, with page name, and more.

For more control over printing a presentation, choose File > Print to display the Print dialog 
(Figure 193). The Print dialog has four tabs, from which you can choose a range of options, as 
described in the following sections.

Figure 193. Print dialog

Note

The options selected on the Print dialog apply to this printing of this document only.  
To specify default printing settings, go to Tools > Options > LibreOffice – Print and 
Tools > Options > LibreOffice Impress – Print. See “Selecting default print
options” on page 209 for more information.
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General printing options
On the General tab of the Print dialog (Figure 193), you can select:

• The printer from the printers available.

• Which slides to print, the number of copies to print, and whether to collate multiple copies 
using the Range and copies section.

• Whether to print slides, notes, handouts, or an outline of the presentation using the 
Document drop-down list in the Print section.

• For handouts, how many slides per printed page and in what order (see “Printing handouts,
notes, or outlines” on page 209 for details).

Click the Properties button to display a dialog (Figure 194) where you can choose portrait or 
landscape orientation, which paper tray to use, and the paper size to print on.

Figure 194: Properties dialog for General page in the Print dialog

The Options page of the Print dialog provides other options for printing your presentation, as 
shown in Figure 195.

Figure 195: Options page of Print dialog

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:

1) In the Print dialog, select the Page Layout tab (Figure 196).

2) In the Layout section, select from the drop-down list the number of pages to print per sheet. 
The preview panel on the left of the Print dialog shows how the printed document will look.

3) When printing more than two pages per sheet, you can select the order in which they are 
printed across and down the paper.

4) In the Page sides section, select whether to print all pages or only some pages.

5) Click the Print button.
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Figure 196: Page Layout page of Print dialog

Selecting slides to print
In addition to printing a full presentation, you can choose to print individual slides, ranges of slides, 
or a selection of slides, using the Ranges and copies section in the General page of the Print 
dialog (Figure 197). Make sure Slides is selected in the Document box in the Print section.

Figure 197: Ranges and copies section of Print dialog

To print an individual slide or several slides, do either of the following:

• Open the Print dialog, select the Slides option in the Ranges and copies section, type the 
slide number, and click Print. Multiple slides may be represented by a list (for example 
1,3,7,11) or as a range (for example 1-4).

• Select the slide in the Slides pane or the Slide Sorter view, then open the Print dialog and 
select Selection in the Ranges and copies section, then click Print.

Selecting other information to print
On the LibreOffice Impress page of the Print dialog (Figure 198), you can select:

• What to print in addition to the slides: Slide name, Date and time, and Hidden pages 
(slides).

• Whether to print in Original colors, Grayscale, or Black and white (on a color printer).

• What size to print slides.
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Figure 198: Selecting other information to print

Printing handouts, notes, or outlines
The Print section on the Print dialog (Figure 199) also gives you the option of printing Slides, 
Handouts, Notes, or an Outline.

• Handouts prints the slides in reduced size on the page, from one to nine slides per page. 
The slides can be printed horizontally (landscape orientation) or vertically (portrait 
orientation) on the page.

• Notes prints a single slide per page with any notes entered for that slide in Notes View.

• Outline prints the title and headings of each slide in outline format.

Figure 199: Printing handouts

To print handouts, notes, or outlines:

1) Choose File > Print from the main menu.

2) In the Print section of the Print dialog, select the required option from the Document drop-
down list.

3) For Handouts, you can then choose how many slides to print per page, and the order in 
which they are printed.

4) Click the Print button.

Selecting default print options
Selections in the Print dialog over-ride any default settings. To specify default settings for printing, 
use Tools > Options > LibreOffice Impress > Print.

Other printer settings are found in Tools > Options > LibreOffice > Print. Use these settings to 
specify quality settings for printing, and whether to have Impress warn you if the paper size or 
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orientation of your document does not match the printer settings. See Chapter 11, Setting Up and 
Customizing Impress for details.

Printing a brochure

You can print a presentation with two slides on each side of a sheet of paper, arranged so that 
when the printed pages are folded in half, the slides are in the correct order to form a booklet or 
brochure.

To print a brochure on a printer that can only print single sided pages:

1) Choose File > Print.

2) In the Print dialog, click Properties.

3) Check the printer is set to the same orientation (portrait or landscape) as specified in the 
page setup for your document. Usually the orientation does not matter, but it does for 
brochures. Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog (Figure 196 on page 208).

5) Select the Brochure option.

6) In the Page sides section, select Back sides / left pages option from the drop-down list.

7) Click the Print button.

8) Take the printed pages out of the printer, turn the pages over, and put them back into the 
printer in the correct orientation to print on the blank side. You may need to experiment a bit 
to find out what the correct arrangement is for your printer.

9) On the Print dialog, in the Page sides section, select Front sides / right pages option from 
the Include drop down box. Click the Print button.

To print a brochure on a printer that can print double sided pages:

1) Choose File > Print.

2) In the Print dialog, click Properties.

3) Check the printer is set to the same orientation (portrait or landscape) as specified in the 
page setup for your document. Usually the orientation does not matter, but it does for 
brochures. Click OK to return to the Print dialog.

4) Select the Page layout tab in the Print dialog (Figure 196 on page 208).

5) Select the Brochure option.

6) In the Page sides section, select All pages option from the drop-down list.

7) Click the Print button.

Exporting to PDF

Impress can export presentations to PDF (Portable Document Format). This industry-standard file 
format for file viewing is ideal for sending the file to someone else to view using Adobe Reader or 
other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  on the Standard toolbar to export the entire presentation 
using the default PDF settings. You are asked to enter the file name and location for the PDF file, 
but you do not get a chance to select a page range or the print quality.
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Controlling PDF content and quality
For more control over the content and quality of the PDF produced, use File > Export as PDF to 
open the PDF Options dialog (Figure 200). This dialog has five pages, described in this section. 
Make your selections, and then click Export. You are then asked to enter the location and file 
name of the PDF to be created. Click Save to export the file.

Figure 200: General page of PDF Options dialog

General page of PDF Options dialog
On the General page, you can select which pages (slides) to include in the PDF, the type of 
compression to use for images (this affects the quality of images in the PDF), and other options.

Range section
• All: exports the entire document.

• Pages: exports a range of slides. Use the format 3-6 for example to export a range of 
pages. Use the format 7;9;11 for example to export several individual slides. You can also 
export a combination of slide ranges and single slides by using a format like 3-6;8;10;12.

• Selection: exports whatever material is selected.

Images section
• Lossless compression: images are stored without any loss of quality. Tends to make 

large files when used with photographs and is not recommended for this type of graphic 
files.
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• JPEG compression: allows for varying degrees of quality. A setting of 90% tends to work 
well with photographs (small file size, little perceptible loss).

• Reduce image resolution: lower-DPI (dots per inch) images have lower quality. For 
viewing on a computer screen generally a resolution of 72DPI (Windows) or 96DPI 
(GNU/Linux/Mac OS) is sufficient. For printing it is generally preferable to use at least 
300DPI or 600DPI, depending on the capability of the printer. Higher DPI settings greatly 
increase the size of the exported file.

Note
EPS (Encapsulated PostScript) images with embedded previews are exported only 
as previews. EPS images without embedded previews are exported as empty 
placeholders.

General section
• PDF/A-1: this is an ISO standard for long-term preservation of documents. It embeds all 

the information necessary for faithful reproduction (such as fonts) while preventing other 
elements, for example forms, security, and encryption. PDF tags are written. If you select 
PDF/A-1, the elements not allowed are grayed-out (not available).

• Tagged PDF: a tagged PDF contains information about the structure of the document’s 
contents. This can help to display the document on devices with different screens and 
when using screen reader software. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form - Submit format: select the format of submitting forms from within the 
PDF file. This setting overrides the URL property control that you set in the document. 
There is only one common setting valid for the whole PDF document: PDF (sends the 
whole document), FDF (sends the control contents), HTML, and XML. Most often you will 
choose the PDF format.

• Export bookmarks: exports slide names as bookmarks (a table of contents list displayed 
by some PDF readers, including Adobe Reader).

• Export comments: exports comments as PDF notes.

• Export notes pages: exports a set of Notes as pages after the set of slides.

• Export automatically inserted blank pages: not used in Impress and is normally grayed 
out.

• Embed standard fonts: normally the 14 standard PostScript fonts are not embedded in a 
PDF file because PDF reader software already contains these fonts. However, you can 
choose to embed these fonts in all PDF documents created by LibreOffice to enhance 
display accuracy in PDF viewers. Font embedding may also be required by some printers.

• Create hybrid file: when the PDF Import Extension is installed, this option exports the 
document as a PDF file containing two file formats: PDF and ODP. The PDF format allows 
the file to be opened using PDF viewers. The ODF format allows the file to be easily edited 
using LibreOffice.

Initial View page of PDF Options dialog
On the Initial View page (Figure 201), you can select how the PDF file opens by default in a PDF 
viewer. The selections are self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings > 
Languages), an additional selection is available under Continuous facing: First page is left. 
Normally, the first page is on the right when using the Continuous facing option.
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Figure 201: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog
On the User Interface page (Figure 202), you can choose more settings to control how a PDF 
viewer displays the file. Some of these choices are particularly useful when you are creating a PDF 
for use in a presentation or kiosk-type display.

Figure 202: User Interface page of PDF Options dialog
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Window options section
• Resize window to initial page. makes the PDF viewer window resize to fit the first page of 

the PDF.

• Center window on screen. makes the PDF viewer window center on the computer screen.

• Open in full screen mode. makes the PDF viewer open full-screen instead of a window.

• Display document title. makes the PDF viewer display the document title in the title bar.

User interface options section
• Hide menubar. makes the PDF viewer hide the menu bar.

• Hide toolbar. makes the PDF viewer hide the toolbar.

• Hide window controls. makes the PDF viewer hide all other window controls.

Transitions section
• Use transition effects: includes Impress slide transition effects as PDF effects.

Bookmarks section
• All bookmark levels: displays all the bookmarks created in the presentation if Export 

bookmarks is selected on the General page.

• Visible bookmark levels: selects how many heading levels are displayed as bookmarks if 
Export bookmarks is selected on the General page.

Links page of PDF Options dialog
On the Links page (Figure 203), you can choose how links are exported to PDF.

Figure 203: Links page of PDF Options dialog

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this 
option exports them as “named destinations” allowing web pages and PDF documents to link.

Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as 
.ODT, .ODS, and .ODP), this option converts the files name extensions to .PDF in the exported 
PDF document.

Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files.
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Security page of PDF Options dialog
On the Security page (Figure 204), you can set PDF export options to encrypt a PDF file so that it 
can only be opened using a password and also apply digital rights management (DRM) features. 
Click on the Set passwords button to open the Set passwords dialog (Figure 205).

Figure 204: Security page of PDF Options dialog

Figure 205: Setting passwords to encrypt a PDF

Note Security settings are effective only if another PDF viewer respects the settings.

• Creating a Set open password (Figure 205), the PDF can only be opened with the 
password. Once opened, there are no restrictions on what the user can do with the 
document (for example, print, copy, or change it).

Chapter 10  Printing, E-mailing, Exporting, and Saving Slide Shows 215



• Creating a Set permission password (Figure 205), the PDF can be opened by anyone, 
but its permissions can be restricted using the options in Figure 204. These permissions 
only become available when this password is set. These selections are self-explanatory.

• With both of these passwords set, the PDF can only be opened with the correct password, 
and its permissions can be restricted.

Exporting as a Flash file

Macromedia Flash file format (.swf) was created to store animation for web pages. With most 
browsers able to play Flash movies these files can be viewed by the majority of users. If a browser 
cannot play Flash movies, then Adobe Flash Player is available as a free download from Adobe at 
http://www.adobe.com/products/flashplayer/.

Note Saving in Flash format does not retain animation and slide transitions.

Using LibreOffice, you can export your Impress slide show as a Flash file in .swf format as follows:

1) Choose File > Export.

2) Select the location where you want the file saved and type a name for the file.

3) Under File Format, choose Macromedia Flash (SWF) (.swf) and click Save.

Exporting as web pages (HTML files)

You can export presentations as a series of web pages that can be viewed in any browser.

Note Saving as web pages (HTML format) does not retain animation and slide transitions.

1) Select File > Export and choose HTML Document as the file type.

2) If necessary, create a folder for the files, then give a name for the resulting HTML file and 
click Save. The HTML Export wizard opens (Figure 206).

Figure 206: HTML Export wizard – selecting a design
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3) Select a design for all of the pages, either from an existing design or by creating a new 
one. If you have not previously saved a design, the Existing Design choice is not available.

4) Click Next to select the type of web pages to create (Figure 207). The available options will 
change depending on publication type selected.

• Standard HTML: one page for each slide with navigation links to move from slide to 
slide.

• Standard HTML with frames: one page with a navigation bar on the left-hand side; uses 
slide title as navigation links. Click on links to display pages in right-hand side.

• Automatic: one page for each slide, with each page set with the refresh meta tag so a 
browser automatically cycles from one page to the next.

• WebCast: generates an ASP or Perl application to display the slides. Unfortunately 
LibreOffice has no direct support for PHP yet.

Figure 207: HTML Export – selecting publication type

5) Click on Next to decide how the images will be saved (PNG, GIF or JPG) and what 
resolution to use (Figure 208). When choosing a resolution, consider what the majority of 
your viewers may have. For example, if you use a high resolution, then a viewer with a 
medium-resolution monitor will have to scroll sideways to see the entire slide.

6) If Create title page was selected in step 4, supply the information for it on the next page 
that appears after clicking on Next (Figure 209). The title page contains name of the author, 
e-mail address and home page, along with any additional information you want to include. 
This page of the Wizard does not display if Create title page was not selected.
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Figure 208: HTML Export – selecting graphics type

Figure 209: HTML Export – title page information

7) Click on Next to select the style of navigation buttons to use when moving from one page 
to another (Figure 210). If you do not choose a navigation style, LibreOffice will create a 
text navigator.

8) Click on Next to select the color scheme for the web pages (Figure 211). Available 
schemes include the existing scheme for the presentation, one based upon browser colors, 
and a user-defined scheme. You can save a new scheme so that it will appear on the first 
page of the HTML export wizard.
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Figure 210: HTML Export – selecting navigation style

Figure 211: HTML Export – selecting color scheme

9) Click Create to generate the HTML files. If this is a new design, a small dialog pops up 
(Figure 212). If you want to reuse this design, you can give it a name and save it. 
Otherwise, click Do Not Save.

Figure 212: Naming the design
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E-mailing a presentation

LibreOffice provides several ways to quickly and easily send a presentation as an e-mail 
attachment in one of three formats: .ODP (OpenDocument Presentation, LibreOffice default 
format), .PPT (Microsoft PowerPoint format), or as a PDF file.

To send the presentation in .ODP format:

1) Choose File > Send > Document as E-mail or File > Send > E-mail as OpenDocument 
Presentation. LibreOffice opens a new e-mail in your default e-mail program. The 
document is attached.

2) In your e-mail program, enter the recipient, subject and any text you want to add, then send 
the e-mail.

If you select E-mail as Microsoft PowerPoint Presentation, LibreOffice first creates a .PPT file 
and then opens your e-mail program with the .PPT file attached. This .PPT file is not saved on your 
computer.

Similarly, if you select E-mail as PDF, LibreOffice first creates a PDF using your default PDF 
settings (similar to using the Export Directly as PDF icon in the standard toolbar) and then opens 
your e-mail program with the .PDF file attached. This PDF file is not saved on your computer.

Tip
If you want to keep a copy of the .PPT or .PDF file as well as e-mailing it to someone, 
first save or export the presentation into the required format, then attach it to an e-mail 
in the usual way.

Digital signing of documents
To sign a document digitally, you need a personal key, also known as a certificate. A personal key 
is stored on your computer as a combination of a private key, which must be kept secret, and a 
public key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the 
document contents plus your personal key. The checksum and your public key are stored together 
with the document. 

When someone later opens the document on any computer with a recent version of LibreOffice, 
the program will compute the checksum again and compare it with the stored checksum. If both 
are the same, the program will signal that you see the original, unchanged document. In addition, 
the program can show you the public key information from the certificate. You can compare the 
public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features for validating a signature are used. On 
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For 
a more detailed description of how to get and manage a certificate, and signature validation, see 
“Using Digital Signatures” in the LibreOffice Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If you have not saved the document since the last change, a message appears. Click Yes 
to save the file.

3) After saving, you see the Digital Signatures dialog. Click Sign Document to add a public 
key to the document.

4) In the Select Certificate dialog, select your certificate and click OK.
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5) You see again the Digital Signatures dialog, where you can add more certificates if you 
want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon to view the 
certificate.

Removing personal data

You may wish to ensure that personal data, versions, notes, hidden information, or recorded 
changes are removed from files before you send them to other people or create PDF files from 
them.

In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn) 
you when files contain certain information and remove personal information automatically when 
saving the file or when creating a PDF.

To remove personal and some other data from a file, go to File > Properties. On the General tab, 
uncheck Apply user data and then click the Reset button. This removes any names in the created 
and modified fields, deletes the modification and printing dates, and resets the editing time to zero, 
the creation date to the current date and time, and the version number to 1. Make sure you click 
OK to save the changes.

Opening and saving a PowerPoint file

The file format of LibreOffice Impress is highly compatible with the format used by Microsoft 
PowerPoint. You can open a PowerPoint presentation in Impress, edit it, then save it in its original 
PowerPoint format or in OpenDocument Presentation format used by Impress. You can also create 
a new presentation in Impress and save it as a PowerPoint file.

Caution There are some differences between OpenDocument (.odp) and PowerPoint (.ppt, 
.pptx) files in text and graphics formatting, animations, transitions, and fields. For 
best results, avoid using features that are not fully supported in both formats.

Saving an Impress file as a PowerPoint file
1) Select File > Save As from the main menu.

2) Select the location where you want the PowerPoint file saved and type a name for the file.

3) Under File type, select a Microsoft PowerPoint format (.ppt or .pptx) from the available 
drop-down list.

4) Click Save. If you have the “Warn when not saving in ODF or default format” option set in 
Options > Load/Save > General, the message shown in Figure 213 appears. Click on the 
button showing the Microsoft PowerPoint format to confirm that you want to save the file in 
that format. You can deselect the Ask when not saving in ODF format checkbox to not show 
the message again unless you re-enable it in the Options.
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Figure 213: Warning message when saving in Microsoft PowerPoint format

Tip

Always save your work in Impress OpenDocument format (.odp) before saving in 
Microsoft format. Keep the Impress file as your working copy: if you need to change 
the presentation, change it in the Impress version and then save it again as 
PowerPoint. You are much less likely to have problems than if you open a file 
previously saved in PowerPoint format, edit it, and save it again.

Opening a PowerPoint file in Impress
If you receive a file from someone in PowerPoint format and need to edit it in Impress, here is how:

1) In LibreOffice, choose File > Open from the menu bar.

2) Under File type, choose All files (*.*) or Presentations or Microsoft PowerPoint from the 
drop-down list.

3) Navigate to the PowerPoint file, select it, and click Open.

The PowerPoint file can now be edited and saved as an Impress file or a PowerPoint file. To save 
the file as an Impress file, choose OpenDocument Presentation (.odp) as the File Type.
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Selecting options affecting LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice and are of 
interest to users of Impress. Other general options are discussed in Chapter 2, Setting Up 
LibreOffice in the Getting Started guide.

1) Click Tools > Options (LibreOffice > Preferences on a Mac). The list on the left-hand 
side of the Options – LibreOffice dialog (Figure 214) varies depending on which 
component of LibreOffice is open. The illustrations in this chapter show the list as it 
appears when Impress is open.

2) Click the expansion marker (+ or triangle) by LibreOffice on the left-hand side. A list of 
subsections drops down.

Figure 214: LibreOffice options

Note
The Revert button (not shown in the illustrations in this chapter) has the same effect 
on all pages of the Options dialog. It resets the options to the values that were in 
place when you opened LibreOffice.

User Data options
Impress uses the first and last name stored in the User Data to fill in the Created by and Modified 
by fields in document properties, the optional Author field used in the footer of a presentation, and 
the name associated with comments. If you want your name to appear, then do the following:

1) In the Options dialog, click LibreOffice > User Data (Figure 215).

2) Fill in the form on the LibreOffice – User Data page or delete any existing incorrect 
information.
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Figure 215: User Data

Print options
On the LibreOffice – Print page, set the print options to suit your default printer and your most 
common printing method.

You can change these settings at any time, either through the Options dialog or during the printing 
process (by clicking the Options button on the Print dialog). See Chapter 10, Printing, E-mailing,  
Exporting, and Saving Slide Shows for more information about the options available.

Color options
On the LibreOffice – Colors page (Figure 216), you can specify colors used in LibreOffice 
documents. You can select a color from a color table, edit an existing color, or define new colors. 
These colors are stored in your color selection palette and are then available in all components of 
LibreOffice.

You can also define colors within Impress by choosing Format > Area on the menu bar, or through 
the Line and Filling toolbar, but those colors will not be available to other components of 
LibreOffice.

Figure 216. Defining colors for use in LibreOffice
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Appearance options
On the LibreOffice – Appearance page (Figure 217), you can specify which items are visible and 
the colors used to display various elements of the user interface. The only option specific to 
Impress (and Draw) is the color of the grid points. Scroll down in the page until you find 
Drawing/Presentation.

To change the default color for grid points, click the down-arrow by the color and select a new color 
from the pop-up dialog.

If you wish to save your color changes as a color scheme, click Save, type a name in the Save 
scheme dialog, then click OK.

Figure 217. Changing the color of grid points in Impress and Draw

Choosing options for Impress

In the Options dialog, click the expansion marker to the left of LibreOffice Impress on the left-
hand side. A list of subsections for Impress drops down (Figure 218).

Figure 218: Options for Impress
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General options
In the Options dialog, click LibreOffice Impress > General (Figure 219).

Figure 219: Selecting general options for Impress

Text objects section

• Allow quick editing: sets Impress to immediately switch to text editing mode when you 
click on a text object. You can also activate the text editing mode through the Allow Quick 

Editing icon  on the Options toolbar (Figure 220). If the Options toolbar is not open, 
then go to View > Toolbars > Options on the main menu.

Figure 220: Options toolbar

• Only text area selectable: sets Impress to select a text frame when you click on text. In 
the area of the text frame that is not filled with text, an object behind the text frame can be 

selected. You can also activate this mode through the Select Text Area Only icon  on 
the Options toolbar.

New document section

• Start with Wizard: when selected Impress starts with the Presentation Wizard when 
creating a new presentation using File > New > Presentation or one of the other methods 
of creating a presentation.

Settings section

• Use background cache: sets Impress to use the cache for displaying objects on the 
master page. This setting speeds up the display. Uncheck this option if you want Impress to 
draw the background every time you display a slide.

• Copy when moving: automatically creates a copy when you move, rotate or resize an 
object while holding down the Ctrl key (⌘ key for Mac). The original object will remain in its 
current position and size.
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• Objects always movable: lets you move an object with the Rotate tool enabled. If this 
option is not selected, the Rotate tool can only be used to rotate an object.

• Unit of measurement: determines the unit of measurement used in presentations.

• Tab stops: defines the spacing between tab stops.

Start presentation section

• Always with current page: specifies that a presentation starts with the current slide. 
Uncheck this option to always start a presentation with the first page.

Compatibility section
The settings in this section are valid for the current presentation only.

• Use printer metrics for document formatting: applies printer metrics for printing and for 
formatting the display on the screen. Some formatting will depend on the printer selection 
or default printer on your computer and may vary if the presentation is moved to a different 
computer. If this option is not checked, a printer-independent layout is used for screen 
display and printing.

• Add spacing between paragraphs and tables (in current document): calculates the 
paragraph spacing in Impress exactly as Microsoft PowerPoint does. Microsoft PowerPoint 
adds the bottom spacing of a paragraph to the top spacing of the next paragraph to 
calculate the total spacing between both paragraphs. Impress normally uses only the larger 
of the two spacings.

View options
In the Options dialog, click on LibreOffice Impress > View (Figure 221).

Figure 221: Specifying view options for Impress

• Rulers visible: displays the rulers at the top and the left of the Workspace area.

• Guides when moving: displays dotted guides that extend beyond the box containing the 
selected object and which cover the entire work area, helping you position the object when 

moving it. You can also use the Helplines When Moving icon  on the Options toolbar 
(Figure 220 on page 227).

• All control points in Bézier editor: displays the control points of all Bézier points if you 
have previously selected a Bézier curve. If this option is not selected, only the control 
points of the selected Bézier points will be visible.

• Contour of each individual object: displays the contour line of each individual object 
when moving the object. This enables you to see if single objects conflict with other objects 
in the target position. If you do not select this option, Impress displays only a square 
contour that includes all selected objects.
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Grid options
The Grid page defines the grid settings for Impress. Using a grid helps you determine the exact 
position of your objects. You can also set this grid in line with the snap grid.

In the Options dialog, click LibreOffice Impress > Grid (Figure 222).

Figure 222: Specifying grid options for Impress

Grid section

• Snap to grid: activates the snap function. If this option is selected, but you want to move or 
create individual objects without snapping to the grid, press the Ctrl key to deactivate Snap 

to grid whilst moving the individual object. You can also use the Snap to Grid icon  on 
the Options toolbar.

• Visible grid: displays grid points on the screen. These points will not display or print as 
part of a presentation.

Resolution and Subdivision sections
This section allows you to set the unit of distance for the spacing between horizontal and vertical 
grid points and subdivisions (intermediate points) of the grid.

• Synchronize axes: applies any changes to the Resolution or Subdivision settings to both 
axes of object movement.

Snap section

• To snap lines: snaps the edge of an object to the nearest snap line when you release the 

mouse button. You can also use the Snap to Snap Lines icon  on the Options toolbar.

• To the page margins: aligns the contour of the graphic object to the nearest page margin. 
The cursor or a contour line of the graphic object must be within snap range. You can also 

use the Snap to Page Margins icon  on the Options toolbar.

• To object frame: aligns the contour of the graphic object to the border of the nearest 
graphic object. The cursor or a contour line of the graphic object must be within snap 

range. You can also use the Snap to Object Border icon  on the Options toolbar.
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• To object points: aligns the contour of the graphic object to the points of the nearest 
graphic object. The cursor or a contour line of the graphic object must be within snap 

range. You can also use the Snap to Object Points icon  on the Options toolbar.

• Snap range: defines the snap distance between the mouse pointer and the object contour. 
Impress snaps to a snap point if the mouse pointer is nearer than the distance selected in 
the Snap range box.

Snap position section

• When creating or moving objects: restricts graphic objects vertically, horizontally or 
diagonally (45°) when creating or moving them. You can temporarily deactivate this setting 
by pressing the Shift key.

• Extend edges: controls how a square or circle is drawn with the drawing tool.  When this 
option is selected, when the Shift key is pressed before before pressing the mouse button a 
square is drawn equal to the longer side of a rectangle. This also applies to the ellipse tool: 
when the Shift key is pressed before you press the mouse button a circle will be drawn 
based on the longest diameter of the ellipse. When the Extend edges option is not 
selected, a square or a circle will be created based on the shorter side or diameter.

• When rotating: restricts the rotation of graphic objects within the rotation angle that you 
select. If you want to rotate an object outside of the defined angle, press the Ctrl key (Shift 
key on Mac) when rotating. Release the key when the desired rotation angle is reached.

• Point reduction: defines the angle for point reduction. When working with polygons, you 
might find it useful to reduce their editing points.

Print options
In the Options dialog, click on LibreOffice Impress > Print (Figure 223). See Chapter 10, Printing,  
E-mailing, Exporting, and Saving Slide Shows for more information about the options available.

Figure 223: Specifying print options for Impress
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Customizing the user interface

Customizing menu font
If you want to change the menu font from that supplied by LibreOffice to the system font for your 
operating system, do this:

1) Choose Tools > Options > LibreOffice > View.

2) Check Use system font for user interface and click OK.

Customizing menu content
You can customize the menus in Impress by adding and rearrange items on the menu bar, adding 
items to menus, and other changes.

1) Choose Tools > Customize to open the Customize dialog (Figure 224).

Figure 224. Menus page of the Customize dialog

2) Make sure the Menus page is open.

3) In the Save In drop-down list, select whether to save this customized menu in LibreOffice 
Impress or for a presentation.

4) In the section LibreOffice Impress Menus, select from the Menu drop-down list the menu 
that you want to customize.

5) To customize the selected menu, click on the Menu or Modify buttons. You can also add 
commands to a menu by clicking on the Add button. These actions are described in the 
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following sections. Use the up and down arrows next to the Entries list to move the 
selected menu item to a different position.

6) When you have finished making all your changes, click OK to save them.

Creating a new menu
To create a new menu:

1) In the Menus page of the Customize dialog box, click New to open the New Menu dialog 
(Figure 225).

2) Type a name for your new menu in the Menu name box.

Figure 225: Adding a new menu

3) Use the up and down arrow buttons to move the new menu into the required position on 
the menu bar.

4) Click OK to save. The new menu now appears on the list of menus in the Customize 
dialog. It will appear on the menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 233.

Modifying existing menus
To modify an existing menu:

1) Select it in the Menu list and click the Menu button to open a list of modifications: Move, 
Rename, Delete. Only Move is available in the list. Rename and Delete are not available 
for the menus supplied by LibreOffice.

2) To move a menu (such as File), select Menu > Move to open the dialog (Figure 226). Use 
the up and down arrow buttons to move the menu into the required position.

3) To move submenus (such as File | Send), select the main menu (File) in the Menu list and 
then, in the Menu Content section of the Customize dialog (Figure 224), select the 
submenu Send in the Entries list and use the arrow keys to move it up or down in the 
sequence.
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Figure 226: Moving a menu

In addition to renaming a menu, you can specify a keyboard shortcut that allows you to select a 
menu command when you press Alt key plus an underlined letter in a menu command.

1) Select a menu or menu entry.

2) Click the Modify button in the Customize dialog (Figure 224) and select Rename.

3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to 
select the Save All command by pressing Alt+V, enter Sa~ve All.

Caution Be careful when creating new shortcuts. In the example above, if the File menu is 
not already open, then pressing Alt+V opens the View menu. If another menu is 
open, Alt+V might activate some other command.

Adding a command to a menu
You can add commands to menus and to menus you have created.

1) In the Customize dialog (Figure 224), select the menu in the Menu list and click the Add 
button.

2) In the Add Commands dialog (Figure 227), select a category and then the command, and 
click Add. The dialog remains open, so you can select additional commands.

Figure 227: Adding a command to a menu
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3) When you have finished adding commands, click Close.

4) In the Customize dialog, you can use the up and down arrow buttons to arrange the 
commands in your preferred sequence.

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

1) Select the menu or submenu in the Menu list near the top of the Customize dialog (Figure
224 on page 231).

2) Select the entry in the Entries list under Menu Content.

3) Click the Modify button and choose the required action from the drop-down list of actions. 
Most of the actions are self-explanatory. Begin a group adds a separator line after the 
highlighted entry.

Figure 228. Toolbars page of the Customize dialog

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible, and 
locking the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice of the 
Getting Started guide. This section describes how to create new toolbars and add other icons 
(commands) to the list of those available on a toolbar.
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To open the customization dialog (Figure 228), do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize > Toolbars tab from the menu bar.

To customize toolbars:

1) Make sure the Toolbars page is open.

2) In the Save In drop-down list, select whether to save this customized toolbar for Impress or 
for a selected presentation.

3) In the LibreOffice Impress Toolbars section, select from the Toolbar drop-down list the 
toolbar that you want to customize.

4) Click the Toolbar button on the right to display a drop-down list of options for customizing 
the toolbar.

5) To display or hide commands, select or deselect the checkboxes in the Toolbar Content – 
Commands section.

6) To change the position of commands on a toolbar, select a command and click the up and 
down arrows to the right of the lists.

7) When you have finished customizing a toolbar, click OK to save your changes.

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the main menu to open the Customize dialog 
(Figure 228).

2) Make sure the Toolbars page is open.

3) Click on New to open the Name dialog (Figure 229).

4) Type a name for the new toolbar and select from the Save In drop-down list where to save 
this new menu: for Impress or for a selected document.

Figure 229: New toolbar dialog

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new 
toolbar, you need to add some commands to it, as described below.

Adding commands to a toolbar
To add commands to a new toolbar or to customize an existing toolbar as follows:

1) On the Toolbars page of the Customize dialog (Figure 228), select the toolbar from the 
Toolbar drop down list and click the Add button. The Add Commands dialog (Figure 227 
on page 233) opens and is the same dialog used for adding commands to menus.

2) Select a Category and then the Command from the relevant list.

3) Click on Add. The dialog remains open, so you can select additional commands.
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4) When you have finished adding commands, click Close. If you insert an item which does 
not have an associated icon, the toolbar will display the full name of the item; the next 
section describes how to choose an icon for a toolbar command.

5) On the Customize dialog, you can use the up and down arrow buttons to arrange the 
commands in your preferred sequence.

6) When you have finished making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons.

To choose an icon for a command:

1) Select the command and click on Modify > Change icon to open the Change Icon dialog 
(Figure 230).

2) Scroll through the available icons and select the one you want to use.

3) Click OK to assign it to the command.

Figure 230: Change Icon dialog

To use a custom icon, create it in a graphics program and then import it into LibreOffice by clicking 
the Import button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in 
size and cannot contain more than 256 colors.

Customizing keyboard shortcuts 
The Appendix to this guide lists the default keyboard shortcuts supplied with Impress. You can 
change these defaults or add new shortcuts. You can assign shortcuts to standard Impress 
functions or your own macros and save them for use with Impress only or with the LibreOffice 
suite.

Caution

Be careful when reassigning predefined shortcut keys used in your operating system 
or LibreOffice. Many key assignments are universally understood shortcuts, such as 
F1 for Help, and are always expected to provide certain results. Although you can 
easily reset the shortcut key assignments to LibreOffice defaults, changing some 
common shortcut keys can cause confusion, frustration and possible data loss or  
corruption, especially if other users share your computer.
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For example, suppose you wish to assign a shortcut key to easily insert a duplicate slide in your 
presentation. You could assign the Insert key as a logical shortcut for this purpose, as described 
below.

1) Choose Tools > Customize.

Figure 231: Customizing keyboard shortcuts

2) On the Customize dialog, open the Keyboard page (Figure 231).

3) As the shortcut key assignment is only relevant with Impress and not LibreOffice, select 
Impress at the upper right corner of the Keyboard page.

4) Select Insert in the Functions - Category list and Duplicate Slide in the Function list.

5) Select the shortcut key Insert in the Shortcut keys list and click the Modify button at the 
upper right.

6) Click OK to accept the change. Now the Insert key will insert a duplicate slide immediately 
after the currently selected slide.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys 
selection box. Since there was no currently assigned shortcut for the Insert > 
Duplicate Slide function the Keys list was empty. If it had not been, and you wished 
to reassign a shortcut key combination that was already in use, you would first have 
to Delete the existing Key.

Shortcut keys not available for reassignment are greyed out in the listing on the 
Customize dialog, such as F1 and F10.
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Saving changes to a file
Changes to the shortcut key assignments (and other configurations) can be saved in a keyboard 
configuration file for use at a later time. This allows you to create and apply different configurations 
as the need arises.

To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button on the Customize 
dialog.

2) In the Save Keyboard Configuration dialog box, select All files from the Save as Type list.

3) Enter a name for the keyboard configuration file in the File name box, or select an existing 
file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog will appear if you are about to overwrite an existing file; 
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button on the Customize dialog, and then select the configuration file from the Load Keyboard 
Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button on the 
Customize dialog. Use this feature with care as no confirmation dialog will be displayed and the 
defaults will be set without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly 
user-defined; none are built in. For information on macros, see Chapter 13, Getting started with 
macros in the Getting Started guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality.

Although individual extensions can be found in different places, the official LibreOffice extension 
repository is at http://extensions.libreoffice.org/. Some extensions are free of charge; others are 
available for a fee. Check the descriptions to see what licenses and fees apply to the ones that 
interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager from the main menu.

3) In the Extension Manager dialog (Figure 232), click Add.

4) A file browser window opens. Find and select the extension you want to install and click 
Open. The extension begins installing. You may be asked to accept a license agreement.

5) When the installation is complete, the extension is listed in the Extension Manager dialog.
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Tip
To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions online link.

Note
To install a shared extension, you need write access to the LibreOffice installation 
directory. 

Figure 232: Extension Manager dialog

Using extensions
This section describes some of the more important and popular extensions to Impress. In each 
case, you need to first install the extension as described in the previous section.

Presenter Console
This is bundled with most installations of LibreOffice and provides extra control over slide shows 
(presentations). For example, the presenter has the ability to see the upcoming slide, the slide 
notes, and a presentation timer, while the audience only sees the current slide. The Presenter 
Console displays the elements in three easily changeable views:

• The first view displays the current slide, including the effects, and the upcoming slide.

• The second view shows notes for the speaker in large, clear, and scalable type, plus the 
current and upcoming slide.

• The third view is a slide sorter view with the slide thumbnails.

The Presenter Console is only available for use if you have a second display connected to your 
computer. See Chapter 9, Slide Shows for more information about using the Presenter Console.

Note
The Presenter Console works only on an operating system that supports multiple 
displays and only when two displays are connected (one may be the laptop’s built-in  
screen).
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Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. Available in several languages. 
After you have installed this extension, you will find the templates under File > New > Templates 
and Documents.

Presentation Minimizer
Reduces the file size of the current presentation. Images are compressed and data that is no 
longer needed is removed. Can also optimize the image quality size. Presentations designed for 
screen or projector do not require the same high quality as presentations designed for print.

Template Changer
Adds two new items to the File > Templates menu that allow you to assign a new template to a 
folder of presentations. All styles and formatting will be loaded from that template and the 
document will behave as if it were created using that template.
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Introduction

You can use LibreOffice without requiring a pointing device, such as a mouse or trackball, by using 
its built-in keyboard shortcuts. Tasks as varied and complex as docking and un-docking toolbars 
and windows, or changing the size or position of objects can all be accomplished with only a 
keyboard. Although LibreOffice has its own extensive set of keyboard shortcuts, each component 
provides others which are specific to its work.

For help with keyboard shortcuts in LibreOffice, or using LibreOffice with a keyboard only, search 
the LibreOffice Help using the “shortcut” or “accessibility” keywords.

In addition to using the built-in keyboard shortcuts (listed in this Appendix), you can also define 
your own. You can assign shortcuts to standard Impress functions or your own macros and save 
them for use with Impress only, or with the entire LibreOffice suite.

To adapt shortcut keys to your needs, use the Customize dialog as described in this section and in 
“Customizing keyboard shortcuts” in Chapter 11, Setting Up and Customizing Impress.

Tip for Macintosh users
Some keystrokes are different on a Mac from those used in Windows and Linux. The following 
table gives some common substitutions for the instructions in this book. For a more detailed list, 
see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu 
selection

LibreOffice > Preferences Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open Styles and Formatting window
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Function keys for Impress

Shortcut Keys Effect

F2 Select text tool

F3 Enter group

Ctrl+F3 Exit group

Shift+F3 Duplicate graphic object

F4 Open Position and Size dialog box

F5 View slide show

Ctrl+Shift+F5 Open Navigator

F7 Start spelling checker

Ctrl+F7 Open thesaurus

F8 Edit points

Ctrl+Shift+F8 Fit text to frame

F11 Open the Styles and Formatting window
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Other shortcut keys for Impress

Shortcut Keys Effect

Arrow key Move the selected object or the page view in the direction of the 
arrow.

Ctrl+Arrow key Move the slide in the normal view.

Shift+drag Constrain the movement of the selected object horizontally or 
vertically.

Ctrl+drag 
(with Copy when moving 
option active)

Hold down Ctrl and drag an object to create a copy of the object.

Alt key Hold down Alt to draw or resize objects by dragging from the centre of 
the object outward.

Alt+click Select the object behind the currently selected object.

Alt+Shift+click Select the object in front of the currently selected object.

Shift+click Select adjacent items or a text passage. Click at the start of a 
selection, move to the end of the selection, and then hold down Shift  
while you click.

Shift+drag 
(when resizing)

Hold down Shift while dragging to resize an object to maintain the 
proportions of the object.

Tab Select objects in the order in which they were created.

Shift+Tab Select objects in the reverse order in which they were created.

Escape Exit current mode.

Enter Activate a place-holder object in a new presentation (only if the frame 
is selected).

Ctrl+Enter Move to the next text object on the slide.

If there are no text objects on the slide, or if you reached the last text 
object, a new slide is inserted after the current slide. The new slide 
uses the same layout as the current slide.

Navigating in the Slide Sorter

Shortcut Keys Effect

Escape Moves the focus to the first slide.

Arrow key Moves the focus to the next slide.

Spacebar Makes the slide with the focus the current slide.
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Shortcut keys in the Normal view

Shortcut Keys Effect

Plus(+) key Zoom in.

Minus(-) key Zoom out.

Times(×) key 
(number pad)

Fit page in window.

Divide(÷) key 
(number pad)

Zoom in on current selection.

Shift+Ctrl+G Group selected objects.

Shift+Ctrl+Alt+A Ungroup selected group.

Ctrl+click Enter a group, so that you can edit the individual objects of the 
group. Click outside the group to return to the normal view.

Shift+Ctrl+K Combine selected objects.

Shift+Ctrl+K Split selected object. This combination only works on an object that 
was created by combining two or more objects.

Ctrl+Plus key Bring to front.

Shift+Ctrl+Plus key Bring forward.

Ctrl+Minus key Send backward.

Shift+Ctrl+Minus key Send to back.

Shortcut keys in slide shows

Shortcut Keys Effect 

Esc End presentation.

Spacebar or Right arrow or 
Down arrow or Page Down or 
Enter or Return or N 

Play next effect (if any, else go to next slide).

Alt+Page Down Go to next slide without playing effects.

[number] + Enter Type the number of a slide and press Enter to go to the slide.

Left arrow or Up arrow or 
Page Up or Backspace or P

Play previous effect again. If no previous effect exists on this 
slide, show previous slide.

Alt+Page Up Go to the previous slide without playing effects.

Home Jump to first slide in the slide show.

End Jump to the last slide in the slide show.

Ctrl+Page Up Go to the previous slide.

Ctrl+Page Down Go to the next slide.

B or . Show black screen until next key or mouse wheel event.

W or , Show white screen until next key or mouse wheel event.
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Index

A  
accessibility  242
alignment of text  61
alignment tools  106
animation effects  

multiple  199
properties  199

area fills  
hatching  130

Arrow styles page  128
Asian language support  93
auto-abstract  174
AutoAbstract  175
AutoLayout  50

B  
background  

adding objects and graphics  37
choosing  36

Bézier curve  228
bitmap image  131
Bitmap image area fill  131
blink  145
brochure printing  210
bulleted list  62
Bullets and Numbering dialog  64

C  
cache  227
certificate  220
chart  

entering data  160
color  87
content boxes (Impress)  26
Create AutoAbstract dialog  175
Create Style dialog  148
crop  87
curve  128
Custom Animation dialog  198
custom slide show  192

D  
default formatting  54
default settings  209
Define Custom Slide Show dialog   193
Documentation  9
Drawing toolbar  92

E  
e-mail attachment  220
Effect Options  201

F  
FDF  212
Fill Format mode  149

filters  85
Fontwork  114
Fontwork toolbar  114
formatting   

text  143
Formatting marks options  55

G  
Gallery  

Hide/Show button  81
themes  81

glue points  
custom  109

graphic filters  86
graphic styles  39

creating  147
graphics  

3D tools  110
interaction  113
rotating  100

grid  106
grid points, color  226
guides  228

H  
handles  40
Handout view  20, 185
handouts  

automatic layout options  187
creating  185
layout  185
template  187
thumbnails  185, 187

hatching patterns, creating  130
Help system  8
Hide/Show button  81
HTML Export wizard  216
hyperlink  

inserting  74

I  
image map  89
Impress  

content boxes  26
slide elements, modifying  27
starting  14

Insert picture dialog  78
interaction  113
International Support  9

K  
keyboard configuration  238
keyboard shortcuts  242
keyboard shortcuts, customizing  236
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L  
licensing of LibreOffice  11
lines  

formatting  124

M  
macros  238
main Impress window  15
Master Pages  33
master slides  28
Media Playback toolbar  166
Media Player  166

N  
Navigator  18
non-breaking hyphens  55
non-breaking spaces  55
Normal view  19
notes  

automatic layout options  183
fields  183
formatting  181, 184

Notes Master  181
Notes view  19, 181
numbered list  62

O  
objects  

converting  112
Open Source Initiative (OSI)  11
outline from Writer  174
outline level  63, 64, 65, 67
Outline view  19, 175

P  
Page Setup dialog  176, 183
page style  177
PDF  

form  212
PDF/A-1  212
personal key  220
Picture toolbar  85
pictures  

AutoLayout  78
color  87
crop  87
filters  85
formatting  83
resizing  84
rotating  84
transparency  87

polygon  97
Position and Size dialog  99, 102
Position and Size dialog than the mouse  41
position of text  59
PowerPoint format  

save as  221
presentation  

backgrounds  23
formatting  25
modifying  28
title slide  26
transitions  24

presentation styles  
AutoLayout area  56

Presentation Wizard  227
Print dialog   206
printing  

brochure  210
handouts  209

R  
range selection (spreadsheet)  156
Rehearse Timings  196
resizing pictures  84
rotating pictures  84
rulers  228

S  
screen settings  177
shapes  

3D  110
aligning  106
convert  112

shared extension  239
shortcut keys  244
Slide Design dialog  34
slide elements, modifying  27
slide master  28

apply  34
author information  42
create  33
description  32

slide show  
custom  192
organizing  190
Rehearse Timings  196
running  29
settings  190
timing of automatic slide changes  195
transitions  29

Slide Sorter view  21
slide transition effects  214
slides  

animations  196
hide  29
layouts  26
master  28, 32
modifying  28
move  22
select  22
summary slide  174
transitions  194

Slides pane  15
snap guides  107
special characters  54
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spreadsheet  
cells  155
moving  154
range  156

Style and Formatting dialog  147
styles  

description  32
Fill Format mode  149
graphic styles  39
graphics styles  147
Styles and Formatting window  40

Styles and Formatting dialog  147
Styles and Formatting window  40
summary slide  174
support  8
symbols, inserting  54
system font  231

T  
Tasks pane  16
Template Management   45
templates  

create a template folder  47
delete a template folder  47
from other sources  43
organizing  46
supplied with LibreOffice  43
using  43

text  
alignment  61
animation  145
bulleted or numbered list  62
character formatting  58
default formatting  54

formatting  55, 143
outline level  63
paragraph formatting  60
pasting  53
position  59
selecting  56

text areas  
handles  40
position and size  41
rotation  41

text box  
AutoLayout  50, 63
moving  52
resizing  52

Text Formatting toolbar  54, 58
text tool  50
themes  81
three-dimensional objects  110
timing of automatic slide changes  195
title slide  26
toolbar  129
toolbars  17
tooltips  26
transparency  87, 141

U  
unit of measurement  228
User guides  9
user interface, parts of  10

W  
Windows Metafile Format (WMF)  112
Workspace  17
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