Part V. Building the system

Table of Contents

30. Obtaining the sources
30.1. Preparing directories
30.2. Terminology
30.3. Downloading tarballs
30.3.1. Downloading sources for a NetBSD release
30.3.2. Downloading sources for a NetBSD stable branch
30.3.3. Downloading sources for a NetBSD security/critical branch
30.3.4. Downloading sources for a NetBSD-current development branch
30.4. Fetching by CVS
30.4.1. Fetching a NetBSD release
30.4.2. Fetching a NetBSD stable branch
30.4.3. Fetching a NetBSD security/critical branch
30.4.4. Fetching the NetBSD-current development branch
30.4.5. Saving some cvs(1) options
31. Crosscompiling NetBSD with build.sh
31.1. Building the crosscompiler
31.2. Configuring the kernel manually
31.3. Crosscompiling the kernel manually
31.4. Crosscompiling the kernel with build.sh
31.5. Crosscompiling the userland
31.6. Crosscompiling the X Window System
31.7. Changing build behaviour
31.7.1. Changing the Destination Directory
31.7.2. Static Builds
31.7.3. Using build.sh options
31.7.4. make(1) variables used during build
32. Compiling the kernel
32.1. Requirements and procedure
32.2. Installing the kernel sources
32.3. Creating the kernel configuration file
32.4. Building the kernel manually
32.4.1. Configuring the kernel manually
32.4.2. Generating dependencies and recompiling manually
32.5. Building the kernel using build.sh
32.6. Installing the new kernel
32.7. If something went wrong
33. Updating an existing system from sources
33.1. Manual build and update procedure
33.1.1. Building a new userland
33.1.2. Building a new kernel
33.1.3. Installing the kernel and userland
33.1.4. Updating the system configuration files
33.1.5. Summary
33.2. Using sysinst
33.3. Using sysbuild and sysupgrade
33.3.1. Tweak: Building as non-root
33.3.2. Tweak: Setting up nightly builds
33.4. More details about the updating of configuration and startup files
33.4.1. Using etcupdate with source files
33.4.2. Using etcupdate with binary distribution sets
33.4.3. Using etcmanage instead of etcupdate
34. Building NetBSD installation media
34.1. Creating custom install or boot floppies for your architecture e.g. i386
34.2. Creating a custom install or boot CD with build.sh