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Topics
• What is Open ESB?
• What is JBI?
• JBI and GlassFish
• Usage Scenario
• Open ESB Development & Deployment Environment
• SE's and BC's (available right now)
• NetBeans support of Open ESB
• Java EE SE, IEP SE, Aspect SE, etc
• IEP (Intelligent Event Processing) SE Demo
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Open ESB
• Open Source Enterprise Service Bus runtime implemented 

atop the Java Business Integration (JBI) foundation
> http://open-esb.org/

• Runs within Glassfish/
Sun App Server

• Many services

http://open-esb.org/
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Why JBI?
• Point-to-point integration (adaptor) model is not 

scalable and is hard to maintain
• The traditional EAI model has its own problems

> Proprietary integration server – vendor lock-in
> High barrier for entry for small vendors to provide best of 

breed solutions
• Need of an open standard that allows containers to 

inter-operate
> JBI provides open standard for integrating applications  

in the same way Java EE standard provides standard for 
building and deploying enterprise applications
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What Is JBI?
• Standard “meta-container” 

for integrating services
> Service can be anything

> Business logic
> Integration/System services

> Service can be located locally 
or remotely

• Plug-in architecture
> Service Engines (SE) – Local 

service or consumer
> Binding Components – Remote 

service or consumer



8

JBI
Core

Services
Normalized Message Router

J2EE Platform

Sy
ste

m
Ma

na
ge

me
nt

Orchestration
(BPEL)

Transformation
(XSLT) J2EE Platform

AS2 JMSWS-I Basic
SOAP

Service Provider Self-Description

WSDL WSDL WSDL

WSDLWSDLWSDL

Components register the
services they provide



9

Service Engines vs. Binding 
Components
• From the JBI perspective, there is very little difference: 

both function as service providers and consumers. 
• The main difference is location: where are the services 

being consumed or provided. 
> A service engine does these things locally, while a binding 

component acts as a proxy for a remote service providers and 
consumers. 
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Normalized Message Router

• Key to interoperation between components
• Mediated Message Exchange
• Normalized Message

> Abstract Message (payload) +
> Message Properties (metadata)

• Message Exchange Pattern
> Support for simple communications primitives
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Administration

• Component Life Cycle (containers)
> Installation

• Packaging and Deployment to Components
> Service Units
> Service Assemblies
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JBI and ESBs
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JBI v2
• Submitted: 2007-03-13  (JSR 312)
• Public Review: mid-2007

> Looking more end-users on the EG
• Focus

> Administration of clustered / distributed enviros
> Better alignment with Java EE
> Interceptors
> Policy/capabilities
> Greater coverage of JBI enablement of Composite Apps
> Choreography
> SCA alignment
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JBI Support in GlassFish
• A JBI runtime has been integrated with GlassFish V2
• GlassFish admin console now supports JBI
• Java EE Service Engine (SE) act as the bridge 

between Java EE applications and JBI
• A Java EE application archive (ear/war/jar) can be 

packaged in a JBI composite application
• JBI runtime has been enhanced to adhere to the 

appserver clustering architecture
> Each instance in the appserver cluster will also have a JBI 

runtime in it
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JBI in Admin Console
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Usage Scenario: Loan Processing
• Loan Requestor Service:

> LoanRequestProcess
> WS-I BP
> BPEL Orchestration

> LoanProcessor
> Java EE 

> TransformReport
> XSLT

> LoanReportStore
> Business Partner thru FTP

> LoanReportMailer
> Legacy thru JMS
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Open ESB Environment
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OpenESB Architecture
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JBI Components (SE's and BC's)
• Service Engines

> BPEL SE
> XSLT SE
> JavaEE SE
> IEP SE
> ETL SE
> SQL SE
> Workflow SE

• Binding Comps
> MQSeries BC
> HL7 BC
> SAP BC
> SMTP BC
> HTTP BC
> JMS BC
> File BC
> CICS BC
> DCOM BC
> CORBA BC
> ...

• Other
> Clustering
> CASA
> JBI Mock
> WSIT Tech

• In Progress
> CAM
> Aspect SE
> Encoding SE
> Rules SE
> Scripting SE
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open-esb.dev.java.net/Components.html
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Open ESB Package Ships Many SE's/BC's
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Types of SOA “NetBeans” Projects
• When creating a composite application, you typically 

use the following types of SOA “NetBeans” projects:
> BPEL Module project (NetBeans 6.0)
> XSLT Module project (NetBeans 6.0)
> SQL Module project (NetBeans 6.0)
> Composite Application project (NetBeans 6.0)
> IEP Module project (OpenESB package)
> Worklist Module project (OpenESB package)
> ETL (Extract, Transform, and Load) (OpenESB package)
> EDM (Enterprise Data Mashup) (OpenESB package)
> And more
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Types of SOA “NetBeans” Projects
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BPEL Module Project
• BPEL Module project is a group of source files 

which includes 
> XML Schema (*.xsd) files
> WSDL files
> BPEL files

• Within a BPEL Module project, you can author a 
business process compliant with the WS-BPEL 2.0 
language specification.

• Will be added to a Composite application as a JBI 
module
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Composite Application Project
• Composite Application project is a project whose 

primary purpose is to assemble a deployment unit 
for the Java Business Integration (JBI) server 
> BPEL Module projects must be added to a Composite 

Application project in order to be deployed to the BPEL 
runtime. 

• The Composite Application Project can also be 
used to create and execute test cases that can then 
be run, in JUnit fashion, against the deployed BPEL 
processes.
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Composite Application Project
• With a Composite Application project, you can:

> Assemble an application that uses multiple project types 
(BPEL, XSLT, IEP,  SQL, etc.)

> Configure external/edge access protocols (SOAP, JMS, 
SMTP, and others)

> Build JBI deployment packages
> Deploy the application image to the target JBI server
> Monitor the status of JBI server components and 

applications
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Lots of Step by Step Tutorials
• http://www.netbeans.org/kb/60/ep-index.html
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BPEL SE

• Standards
> BPEL 2.0 (subset)
> WSDL1.1

• BPEL SE Configuration
> num threads
> persistence
> failover

• BPEL Editor
> BPMN
> Debugger



  
Java EE SEJava EE SE
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JavaEE SE
• Ideal place to execute complex business logic
• Bridge between JavaEE container and JBI container
• Provides support for

> Transactions
> Resource Pooling
> Security

• Code re-use – Invoke your EJBs/web applications 
from OpenESB components (BPEL SE)

• Ability to expose your EJB/Web applications to 
multiple transports (using BCs) – just add bindings 
to your WSDL
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Scenario 1: Remote throughHTTP BC
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➔ JAXWS
➔ Unmarshal <xml>
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➔ WS.helloWorld(name)

• BPEL
➔ NMR
➔ HTTP BC
➔ Marshall DOM to <xml>
➔ SOAP/HTTP
➔ Network layer
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Scenario 2: Local through NMR
• BPEL
➔ NMR
➔ HTTP BC
➔ Marshall DOM to <xml>
➔ SOAP/HTTP
➔ Network layer
➔ SOAP/HTTP
➔ JAXWS
➔ Unmarshal <xml>
➔ Create DOM
➔ JAXB
➔ WS.helloWorld(name)
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Advantages:
> Performance
> Transaction propagation
> Security context propagation
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Scenario: Portal + EE + BPEL

• Portlet gets name, invokes WAR which calls BPEL 
to orchestrate process

• BPEL activity requires complex business logic 
> executes faster in EJB right
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Intelligent Event Processing (IEP) SE 
• Handles real time events and process them to 

higher level events which then can be used for 
further analysis or monitoring.
> Aggregation
> Filtering
> Correlation
> Partition

• Provides real time event notifications and triggers
> Update database in realtime
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IEP SE
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Usage Scenario 
• Many modern applications require long-running, or 

continuous, queries over continuous unbounded 
streams of data.

• The need exists to detect business-critical issues as 
they happen, and to route, filter and pre-process 
data continuously over an indeterminate period of 
time.

• Event processing involves the continuous 
processing and analysis of high volume, high-speed 
data streams from inside and outside an 
organization. 
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IEP Operators
• Input

> Stream-Input
> Table-Input

• Output
> Stream-Output
> Relation-Output
> Table-Output

• Correlation and Filtering
> Stream-Project-and-Filter
> Tuple-Serial-Correlation
> Relation-Map

• Aggregator
> Time-Based-Aggregator
> Tuple-Based-Aggregator
> Relation-Aggregator.

• Stream Converter
> Tuple-Based-Window
> Time-Based-Window
> Attribute-Based-Window
> Partitioned-Window

• Relation Converter
> Insert-Stream
> Delete-Stream
> Relation-Stream
> Table

• Relation Operator
> Distinct
> Union
> Union-All
> Minus
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       IEP Support in NetBeans



  
Intelligent Event Intelligent Event 
Processing (IEP) SEProcessing (IEP) SE
DemoDemo

You can try this demo yourself! You can try this demo yourself! 
http://www.javapassion.com/handhttp://www.javapassion.com/hand
sonlabs/openesbiep/sonlabs/openesbiep/
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Demo Scenario
• External program keep sending stock quote data 

stream events to the IEP (through JBI)
> The IEP receives the stock quote stream as real time 

events 
• The IEP send notifications to the database and the 

database gets updated continuously



53

Steps to follow
1.Create IEP module project

➢ Create quotes.iep
➢ Generate quotes.wsdl

2.Create a Composite application
➢ Add IEP module to the Composite application

3.Run the test application that sends stock quote 
stream to the composite application
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Aspect SE

• Aspects help to encapsulate cross-cutting 
expressions in one place. 

• By applying an Advice, at various points in an 
application called Join-Points, Aspects can alter the 
behavior of the non-aspect parts of a software 
application.

• There are two types of aspect patterns that are 
addressed:
> Gateway Pattern
> Aspect-Weaving Pattern 



  
CASACASA



57

CompApp Service Assembly Editor
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CompApp Manager
● collect statistics for 

endpoints, SUs / 
SAs

● monitor and 
configure runtime 
parameters for a 
managed 
component

● control managed 
components (e.g. 
start/stop/shutdow
n/etc)
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OpenESB: Projects 
• Glassfish JBI Integration

> Place where JBI runtime will be implemented
> will become the OpenJBI project

• Open JBI Components
> Component Development
> “Independant” of OpenESB. E.g., could be used in other JBI 

based environment. E.g., JBossESB
• Open ESB

> Umbrella Project, includes runtime and components
• Open B2B

> B2B specific components: HIPAA, RFID, EDI, ebXML
• Netbeans Enterprise Pack
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Open ESB Distribution

• Open ESB
> JBI Runtime
> Full collection of 

OpenESB components
> NetBeans based tooling 

(see Tooling section of 
presentation)

> Latest builds

• Java Application 
Platform SDK
> Glassfish
> JBI Runtime
> Milestone of OpenESB 

components
> Includes other open 

source projects
>Portal, OpenSSO, etc 

http://open-esb.dev.java.net
http://java.sun.com/developer/technicalArticles/J2EE/sdk_overview/ 
http://enterprise.netbeans.org/ 

http://open-esb.dev.java.net/
http://java.sun.com/developer/technicalArticles/J2EE/sdk_overview/
http://enterprise.netbeans.org/
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Open ESB and JavaCAPS

• Open ESB
> JBI Runtime
> Glassfish v2 AppServer
> Full collection of 

OpenESB components
> NetBeans v6 based 

tooling 
> Combination of Sun and 

3rd party components
> Constantly evolving
> Community Support

• JavaCAPS 5.2 ++
> JBI Runtime + 

JavaCAPS 5.1 Runtime
> Glassfish v2 AppServer
> Selection of OpenESB 

components
> NetBeans v6 based 

tooling (incl Enterprise 
Designer components)

> Combination of Sun and 
3rd party components

> Sun Support
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More Info
• JBI

> http://www.jcp.org/en/jsr/detail?id=208 
> http://java.sun.com/integration/ 

• Open ESB Project
> http://open-esb.dev.java.net/ 
> https://open-jbi-components.dev.java.net/ 
> http://www.glassfishwiki.org/jbiwiki/Wiki.jsp?page=Jbicomps 

• Free online course on Web services, Open ESB
> http://www.javapassion.com/webservices

• Examples and Demos:
> http://enterprise.netbeans.org/ 

http://java.sun.com/integration/
http://open-esb.dev.java.net/
https://open-jbi-components.dev.java.net/
http://www.glassfishwiki.org/jbiwiki/Wiki.jsp?page=Jbicomps
http://enterprise.netbeans.org/
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