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Introduction

In this section, you do the minimum configuration tasks for the server, design tool, and utilities, so you can get started
creating ETL solutions.

Prerequisites

Before you begin, you must have installed Pentaho Data Integration software. If you chose to install the Pentaho
Business Analytics software you must go through a different configuration process.

Expertise

The topics in this section are written for IT administrators who know where data is stored, how to connect to it, details
about the computing environment, and how to use the command line to issue commands for Microsoft Windows, Linux,
or Microsoft OS.

Tools

We provide a design tool, Spoon, that you use to perform most configuration tasks.

Login Credentials

All of the configuration tasks that use Spoon require that you login to Spoon using a Pentaho administrator user name
and password.
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Configure the DI Server

Before you can use Pentaho Data Integration (PDI) to extract data, transform it into a useful format, and load it for
analysis, you need to perform configuration tasks. Just follow the guideposts to make sure that you complete the entire
process. It should take you approximately one hour or less.

Start and Stop the Data Integration Server

To work with Pentaho Data Integration you must have the DI server running. There may be times when you need to
manage Pentaho Data Integration components, stopping the DI server to perform system maintenance and restarting
it after you are done. As part of the Installation Wizard and Archive Installation, Pentaho provides different ways to
help you start and stop the components depending on the operating system you use and the method you used for
installation.

For Microsoft Windows, these are your options for starting and stopping the components.

• Windows Pentaho Installation Wizard
• Windows Pentaho Archive Installation

For Linux and Macintosh OS, these are your options for starting and stopping the components.

• Linux Pentaho Installation Wizard
• Linux Pentaho Archive Installation
• Linux Pentaho Wizard or Archive Installation—Starting on Boot

When you are done, please go to the next stop on the guidepost.

Windows Pentaho Installation Wizard

When you ran the Installation Wizard on Windows, the BA Server installed in a Tomcat Application server. You can
manage the Tomcat and DI servers by clicking Start > Pentaho Enterprise Edition > Server Management and then
selecting from these menu items.

• Start the DI Server
• Stop the DI Server

The wizard also registered the DI Server and the PostgreSQL solution repository as services. These services are set
to run automatically, enabling them to start and stop when the computer running them boots or shuts down. You can
use the Windows Services applet found in the Control Panel to start and stop the Pentaho servers and the solution
repository.

1. Click Start > Control Panel > Administrative Tools > Services.

2. In the Services window, right-click one of these services in the list and choose Start or Stop from the menu that
appears.

• Data Integration
• Pentaho Solution Repository
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Windows Pentaho Archive Installation

If you used the Archive Installation, we provide individual control scripts to start and stop the DI server, and DI
repository. Here is where you can find the individual control scripts.

DI Repository

• The Archive Installation enables you to install PostgreSQL, MySQL, or Oracle as the solution repository. Consult the
third-party documentation for the RDBMS to find more information about starting and stopping.

The solution repository must be started before the DI Server.

DI Server

• /pentaho/server/data-integration-server

Linux and Macintosh OS Pentaho Installation Wizard

When you ran the Installation Wizard on Linux, the DI Server was deployed in an included Apache Tomcat application
server. You can control the Tomcat server using the start and stop scripts that come with the Pentaho installation. This
script is also used as an easy way to start and stop the DI Server and the PostgreSQL repository. You can find this
script at /pentaho/ctlscript.sh.

Here is a list of the script arguments you can use with the data-integration-server service.

Arguments

• start
• stop
• restart
• status
• help

./ctlscript.sh start data-integration-server

./ctlscript.sh status data-integration-server

./ctlscript.sh help

Linux and Macintosh OS Pentaho Archive Installation

If you used the Archive Installation, Pentaho provides individual control scripts to start and stop the Pentaho Tomcat
application server, the DI Server, and the PostgreSQL server. Here is where you can find the individual control scripts.

DI Repository

• The Archive Installation enables you to install either PostgreSQL, MySQL, or Oracle as the solution repository.
Consult the documentation for the RDBMS you selected for information about starting and stopping.

The solution repository must be started before the DI Server.

DI Server

• pentaho/server/data-integration-server/start-pentaho.sh and stop-pentaho.sh

Linux and Macintosh OS Pentaho Wizard or Archive Installation—Starting on Boot

Because the Installation Wizard and the Archive Installation do not provide a way to start the DI repository and DI
Server automatically on boot or shut-down, here are examples of how you might approach creating a script to do this.

This procedure assumes that you are running the DI Server under the pentaho local user account. If you are using a
different account to start these services, substitute it in the script in step 2. This script also assumes you are using the
PostgreSQL solution repository. Where postgrtesql appears in this script, change it to reflect the RDBMS you are
using as a solution repository, either MySQL or Oracle. This script was tested on Red Hat Enterprise Linux. You may



 | Configure the DI Server | 7

have to modify the details of the script if you use a different distribution of Linux or other Unix-like operating system,
different shells, or different init systems.

1. With root permissions, create a file in /etc/init.d/ named pdi.

2. Using a text editor, copy the following content into the new pentaho script, changing postgresql to the name of
the init script for your database, if it is running on the remote machine, or remove postgresql entirely if you are
using a remote database. You may also have to adjust the paths to the DI Server scripts to match your situation.

#!/bin/sh
### BEGIN INIT INFO
# Provides: start-data-integration-server stop-data-integration-server
# Required-Start: networking postgresql
# Required-Stop: postgresql
# Default-Start: 2 3 4 5
# Default-Stop: 0 1 6
# Description: Pentaho DI Server
### END INIT INFO

case "$1" in
"start")
su - pentaho -c "/home/pentaho/pentaho/server/data-integration-server/start-
pentaho.sh"
;;
"stop")
su - pentaho -c "/home/pentaho/pentaho/server/data-integration-server/stop-
pentaho.sh"
;;
*)
echo "Usage: $0 { start | stop }"
;;
esac
exit 0

3. Save the file and close the text editor.

4. Open /home/pentaho/pentaho/server/data-integration-server/start-pentaho.sh with a text
editor.

5. Change the last if statement to match the this example.

if [ "$?" = 0 ]; then
  cd "$DIR/tomcat/bin"
  export CATALINA_OPTS="-Xms2048m -Xmx2048m -XX:MaxPermSize=2048m -
Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000"
  env JAVA_HOME=$_PENTAHO_JAVA_HOME sh ./startup.sh
fi

6. Save the file and close the text editor.

7. Make the init script executable.

chmod +x /etc/init.d/pentaho

8. Add the pentaho init script to the standard run levels by using the update-rc.d command, so that it runs when
the system starts, and stops when the system is shut down or rebooted.

This command may not exist on your computer if it is not Debian-based. If that is the case, consult your distribution
documentation or contact your distribution's support department to determine how to add init scripts to the default
run levels.

update-rc.d pentaho defaults
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Access Spoon

Spoon is a desktop application that you will use primarily as a graphical interface and editor for transformations and
jobs. With Spoon you can author, edit, run, and debug transformations and jobs. You can also use Spoon to enter
license keys, add data connections, and define security.

• Start Spoon
• Enter Licenses
• Connect to the DI Repository
• Tour Spoon
• Change Administrator Password

When you are done, please go on to the next stop on the Guide Post graphic.

Start Spoon

There are a few different ways to start Spoon. The method that you should use depends on the way you installed
Pentaho Data Integration (PDI).

Start Spoon for Windows Pentaho Graphical Installation

1. Start the DI server.

2. From the Windows Start menu, select All Programs > Pentaho Enterprise Edition > Design Tools > Data
Integration.
The PDI Design Tool, Spoon, appears.

Start Spoon for Archive or Manual Installation

1. Start the DI server.

2. Navigate to the folder where you have installed PDI. For example ...\pentaho\design-tools\data-
integration.

3. Launch Spoon in the best way for your operating system.

a) For Windows: double-click Spoon.bat.
b) For Linux: double-click spoon.sh
c) For Macintosh: go to .../pdi-ee/data-integration and double click on the Data Integration 32-bit or

Data Integration 64-bit icon depending on your system.

The Pentaho License Manager dialog appears. You must enter licenses.
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Tour Spoon

Component Name Name Function

Toolbar Single-click access to common
actions such as create a new file,
opening existing documents, save
and save as.

Perspectives Toolbar Switch between the different
perspectives.

• Data Integration — Create ETL
transformations and jobs

• Instaview — Use pre-made
templates to create visualizations
from PDI transformations

• Visualize — Test reporting and
OLAP metadata models created
in the Model perspective using
the Report Design Wizard and
Analyzer clients

• Model Editor — Design reporting
and OLAP metadata models which
can be tested right from within
the Visualization perspective or
published to the Pentaho BA
Server

• Schedule — Manage scheduled
ETL activities on the Data
Integration Server

Sub-toolbar Provides buttons for quick access
to common actions specific to the
transformation or job such as Run,
Preview, and Debug.

Design and View Tabs The Design tab of the Explore
pane provides an organized list of
transformation steps or job entries
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Component Name Name Function

used to build transformations and
jobs. Transformations are created by
simply dragging transformation steps
from the Design tab onto the canvas
and connecting them with hops to
describe the flow of data.

The View tab of the Explore pane
shows information for each job
or transformation. This includes
information such as available
database connections and which
steps and hops are used.

In the image, the Design tab is
selected.

Canvas Main design area for building
transformations and jobs describing
the ETL activities you want to perform

Table 1: Spoon Icon Descriptions

Icon Description

Create a new job or transformation

Open transformation/job from file if you are not connected
to a repository or from the repository if you are connected
to one

Explore the repository

Save the transformation/job to a file or to the repository

Save the transformation/job under a different name or file
name (Save as)

Run transformation/job; runs the current transformation
from XML file or repository

Pause transformation

Stop transformation

Preview transformation: runs the current transformation
from memory. You can preview the rows that are
produced by selected steps.

Run the transformation in debug mode; allows you to
troubleshoot execution errors

Replay the processing of a transformation

Verify transformation

Run an impact analysis on the database

Generate the SQL that is needed to run the loaded
transformation.
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Icon Description

Launch the database explorer allowing you to preview
data, run SQL queries, generate DDL and more

Hide execution results pane

Lock transformation

Enter Licenses

You must start Spoon before adding licenses.

1. Copy your license files to a convenient location.

2. Log into Spoon.
The Pentaho License Manager dialog appears.

3. From within the Pentaho License Manager, click on the Add button.

4. Double-click on the license key to open it.
A green check appears in the Status column to show that the license key installed correctly.

5. Click Close to close the dialog box.

6. Close any windows that appear and restart Spoon so that the license key will take effect.

Alternatively, you can install licenses using the command line interface.

Connect to the DI Repository

If current license keys are installed when you start Spoon, the Repository Connection dialog box appears. The DI
Repository provides you a place to centrally store ETL jobs and transformations. You may choose to set up common
connections for your users now or you can close the dialog box and allow your users to connect to the DI Repository
themselves.

1. In the Repository Connection dialog box, click the add button.

2. Select DI Repository: DI Repository and click OK.
The Repository Configuration dialog box appears.

3. Keep the default URL, which is http://localhost:9080/pentaho-di.

4. Click Test to ensure your connection is properly configured. If you get an error, make sure you have started the DI
Server.

5. Click OK to exit the Success dialog box.

6. Enter an ID and Name for your repository.

7. Click OK to exit the Repository Configuration dialog box.
Your new connection appears in the list of available repositories.

8. Log on to the repository by entering the following credentials: user name = admin, password = password.

Change the Administrator Password

After you have logged into Spoon for the first time, it is a best practice to change the default administrator password.

Define Security for the DI Server

Using security is a best practice, but is not required. If you want to get started quickly or do not have information about
your user community, skip this for now and go on to the next stop on the Guide Post graphic. You can always come
back to it later.
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We support two different security options: Pentaho Security or advanced security providers, such as LDAP, Single Sign-
On, or Microsoft Active Directory. This table can help you choose the option that is best for you. If you are using an
advanced security provider, see Implementing Advanced Security for the DI Server before continuing the configuration
process.

Table 2: Security Decision Table

Choose OptionsExplore Considerations

Pentaho Security Advanced Security Providers
—LDAP, Single Sign-On, or
Microsoft Active Directory

Summary Pentaho Security is the easiest way
to configure security quickly. Spoon
enables you to define and manage
users and roles. The DI Server
controls which users and roles can
access resources in the DI repository.

Pentaho Security works well if you do
not have a security provider or if you
have a user community with less than
100 users.

If you are already using a security
provider, such as LDAP, Single Sign-
On, or Microsoft Active Directory,
you can use the users and roles you
have already defined with Pentaho.
Your security provider controls which
users and roles can access the DI
repository.

Advanced security scales well for
production and enterprise user
communities.

Expertise Knowledge of your user community
and which users should have
which roles in the Pentaho system.
Knowledge about security in general
is not required.

Knowledge of your user community
and which users should have
which roles in the Pentaho system.
Knowledge about your particular
security provider and its options is
required.

Time It takes approximately 5 minutes per
user and role to configure Pentaho
Security.

It takes approximately 1 hour to
configure the DI Server to use your
existing security provider.

Recommendation Recommended for the Pentaho
Trial Download, evaluating, and
rapid development.

Recommended for production.

Use Pentaho Security on the DI Server

You must log into Spoon as an administrator to manage users and roles for Pentaho Security. This section provides an
overview of the out-of-box users and roles, along with the permissions that are included with each role. Permissions can
be further refined on the file- or folder-level from the Browser view of the User Console.

Here is how you can manage users.

• Add Users
• Change Passwords Using Spoon
• Delete Users
• Assign Users to Roles
• Edit User Information

Here is how you can manage roles.

• Add Roles
• Edit Roles
• Delete Roles
• Make Changes to the Admin Role
• Assign Permissions in the Repository Using Spoon
• Enable System Role Permissions

Before changing security settings, play it safe and back up these relevant files.
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• If you installed using the Installation Wizard or the Archive Installation, back up all Data Integration directories.
• If you installed manually, back up the Pentaho  .war and solutions.

Control users and roles in the DI Repository with a point-and-click user interface. The users and roles radio buttons
allow you to switch between user and role settings. You can add, delete, and edit users and roles from this page.

Default Users and Roles

Viewing default users and roles gives you an idea of how you can define your specific users and roles. To view the
default users and roles, log into Spoon, click Tools > Repository > Explore and select the Security tab. Highlighting
a user in the users list shows which roles are available for that user, as well as which role is currently defined for that
user.

Out-of-Box Role Out-of-Box User Permissions

Administrator admin • Administer Security
• Read Content
• Publish Content
• Create content
• Schedule Content

Power User suzy • Schedule Content

Report Author tiffany • Publish Content
• Schedule Content

Business Analyst pat • Publish Content

Add Users

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

Note:  The Users radio button is selected by default.

3. Next to Available, click the round green plus button, Add.
The Add User dialog box appears.

4. Type the User Name and Password associated with your new user account in the appropriate fields.

Note:  An entry in the Description field is optional.

5. If you have available roles that can be assigned to the new user, under Member, select a role and click OK.

The role you assigned to the user appears in the right pane under Assigned.

6. Click OK to save your new user account and exit the Add Users dialog box.

The name of the user you added appears in the list of Available users.
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Change Passwords Using Spoon

1. Launch Spoon as described in Start Spoon.

2. Click on Tools > Repository > Explore.

3. Click on Security.

4. Select Users, Roles, or System Roles from the option button.

5. Select the role for which you want to change the password and click the Edit icon.

6. In the Password field, type the new password. Click OK.

Delete Users

You must be logged into the DI Repository as an administrative user.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

3. Select the user you want to delete from the list of available users.

4. Next to Users, click Remove.
A confirmation message appears.

5. Click Yes to delete the user.

If a user or role is deleted in the DI Repository, content that refers to the deleted user, either by way of owning the
content or having an ACL that mentions the user or role, is left unchanged. This makes it possible to create a new user
or role using an identical name. In this scenario, content ownership and access control entries referring to the deleted
user or role now apply to the new user or role.

To avoid this problem, we recommend that you disable a user or role instead of deleting it. This prevents a user or role
with an identical name from ever being created again. Use these alternatives rather than deleting the user or role.

IF THEN

You are dealing with a role Unassign all current members associated with the role

You are dealing with a user Reset the password to a password that is so cryptic that it
is impossible to guess and is unknown to any users

Assign Users to Roles

You must be logged into the DI Repository as an administrative user.

You can assign users to roles and roles to users when you add a new user or role. You can also assign users to roles
as a separate task.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

3. Click the Roles radio button.
The list of available roles appear.

4. Select the role to which you want to assign one or more users.

Note:  If the role has users currently assigned to it, the names of the users appear in the table on the right
under Members. You can assign or unassign any users to a role. You can select a single item or multiple
items from the list of members. Click Remove to remove the user assignment.

5. Next to Members, click Add.
The Add User to Role dialog box appears.

6. Select the users you want assigned to the role and click Add.
The users assigned to the role appear in the right pane.

7. Click OK to save your entries and to exit the Add User to Role dialog box.

The specified users are assigned to the specified role.
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Edit User Information

You must be logged into the DI Repository as an administrative user.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

Note:  The Users radio button is selected by default.

3. Select the user whose details you want to edit from the list of available users.

4. Click Edit.
The Edit User dialog box appears.

5. Make the appropriate changes to the user information.

6. Click OK to save changes and exit the Edit User dialog box.

Add Roles

You must be logged into the DI Repository as an administrative user.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

3. Click the Roles radio button.
The list of available roles appear.

4. Click Add.
The Add Role dialog box appears.

5. Enter the Role Name in the appropriate field.

Note:  An entry in the Description field is optional.

6. If you have users to assign to the new role, select them (using the <SHIFT> or <CTRL> keys) from the list of
available users and click the yellow arrow to move it from the left pane to the right pane.
The user(s) assigned to your new role appear in the right pane.

7. Click OK to save your entries and exit the Add Role dialog box.

The specified role is created and is ready to be assigned to user accounts.

Edit Roles

You must be logged into the DI Repository as an administrative user.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

3. Click the Roles radio button.
The list of available roles appear.

4. Select the role you want to edit and click Edit.
The Edit Role dialog box appears.

5. Make the appropriate changes.

6. Click OK to save your changes and exit the Edit Role dialog box.

Delete Roles

You must be logged into the DI Repository as an administrative user.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

3. Select the role you want to delete from the list of available roles.
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4. Click Remove.
A confirmation message appears.

5. Click Yes to delete the role.

The specified role is deleted.

Make Changes to the Admin Role

The assigning of action-based permissions, (read, create, and administrate), associated with the administrator role
in the DI Repository cannot be edited in the user interface. The administrator role is the only role that is assigned the
Administrate permission; the Administrate permission controls user access to the Security tab.

Deleting the administrator role prevents all users from accessing the Security tab, unless another role is assigned the
administrator permission.

These are the scenarios that require a configuration change not available through Spoon:

• You want to delete the administrator role
• You want to unassign the administrator permission from the administrator role
• You want to configure LDAP

Follow these instructions to change the administrator role:

1. Shut down the DI Server.

2. Open the repository.spring.xml file located at \pentaho\server\data-integration-server\pentaho-
solutions\system\.

3. Locate the element with an ID of immutableRoleBindingMap.

4. Replace the entire node with the XML shown below. Make sure you change yourAdminRole to the role that will
have Administrate permission.

<util:map id="immutableRoleBindingMap">
    <entry key="yourAdminRole">
      <util:list>
        <value>org.pentaho.di.reader</value>
        <value>org.pentaho.di.creator</value>
        <value>org.pentaho.di.securityAdministrator</value>
      </util:list>
    </entry>
</util:map>

5. Restart the DI Server.

The administrator role changes according to your requirements.

Assign User Permissions in the Repository using Spoon

You must be logged into the repository as an administrative user.

You can restrict what users see by assigning roles to users. For example, you can create administrative groups who are
allowed to administer security and create new content.

To assign permissions in the repository, follow these instructions.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens.

2. Click the Security tab.

3. Click the Roles radio button.
The list of available roles appear.

4. Select the role to which you want to assign permissions.

5. Enable the appropriate permissions and click Apply.

The permissions you enabled for the role take effect the next time the specified users log in.

Enable System Role Permissions

When users log into the DI Repository, they are automatically assigned the Authenticated system role in addition to the
role you assigned them. Pentaho requires the Authenticated system role for users to log into the DI Repository. This
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includes administrative users. By default, the Authenticated system role provides Read Content and Create Content
permissions to all users who are logged in. You can change these permissions as needed.

Note:  Important! The Anonymous system role is not being used at this time.

Follow the steps below to change permissions for the Authenticated system role.

1. In Spoon, go to Tools > Repository > Explore.
The Repository Explorer opens

2. Click the Security tab.

3. Click the System Roles radio button.
The list of available system roles appear.

Note:  The Anonymous role is not functional.

4. Select the Authenticated role from the list of available roles.

5. Under Permissions, enable the appropriate permissions for this role.

6. Click Apply to save your changes.

The specified permissions are enabled for the Authenticated system role.

Next Steps

After you have performed these tasks, configure the PDI tool and utilities.
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Configure the PDI Design Tools and Utilities

Before you can use the Pentaho Data Integration tools, you need to perform configuration tasks for each workstation
that runs the tools and utilities. Just follow the Guide Post graphics to ensure you complete the entire process. It should
take you less than 1 hour for each workstation running the design tools.

If you used the Pentaho Trial Download and the Installation Wizard, the DI Server and its tools and utilities reside on
the same workstation. If you used any of the other installation techniques, the DI Server and its tools and utilities may
reside on separate workstations.

Here is the list of the Pentaho Data Integration tools and utilities and what they do.

Tool or Utility What It Does

Carte • Enables remote execution of jobs and transformations
continuously in the background

• Enables distribution and coordinated job execution
across a collection of computers, a process known as
clustering

Kitchen • Provides a command-line method to run jobs
immediately

• Typically used after the ETL development phase for
production environments

Pan • Provides a command-line method to run
transformations immediately

• Typically used after the ETL development phase for
production environments

Spoon Allows users to design and manage complex ETL
workloads with a graphical user interface

Start and Stop PDI Design Tools and Utilities

Each of the DI tools has a specific function, so you start and stop each one individually. As part of the Installation
Wizard and Archive Installation, we provide different ways to help you start each tool and utility, depending on the
operating system you use. This table shows you options. After you have decided how you want to start and stop the tool
and utilities, please go on to the next stop on the Guide Post graphic.
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Operating
System

Installation Method Start the Tools and Utilities

Microsoft
Windows

Pentaho Installation
Wizard

Spoon

• Click Start > Programs > Pentaho Enterprise Edition > Design
Tools and double-click on Data Integration the item to launch
Spoon.

For these tools and utilities, you must navigate to a directory to
launch the .bat file.

Carte

• \pentaho\design-tools\data-integration\carte.bat

Kitchen

• \pentaho\design-tools\data-integration\kitchen.bat

Pan

• \pentaho\design-tools\data-integration\pan.bat

Microsoft
Windows

Pentaho Archive or
Manual Installation

Create shortcuts to the .bat file or each design tool and add them to
the Start menu. Or, navigate to the one of these directories and run the
design tool's .bat file to launch it.

Carte

• \pentaho\design-tools\data-integration\carte.bat

Kitchen

• \pentaho\design-tools\data-integration\kitchen.bat

Pan

• \pentaho\design-tools\data-integration\pan.bat

Spoon

• \pentaho\design-tools\data-integration\spoon.bat

Linux Pentaho Wizard, Archive,
or Manual Installation

Navigate to one of these directories and run the design tool .sh file to
launch it.

Carte

• pentaho/design-tools/data-integration/carte.sh

Kitchen

• pentaho/design-tools/data-integration\kitchen.sh

Pan

• /pentaho/design-tools/data-integration/pan.sh

Spoon

• /pentaho/design-tools/data-integration/spoon.sh

Mac OS Pentaho Wizard, Archive,
or Manual Installation

Navigate to one of these directories and run the design tool .app file to
launch it.

Carte

• pentaho/design-tools/data-integration/carte.app

Kitchen

• pentaho/design-tools/data-integration\kitchen.app

Pan

http://windows.microsoft.com/en-us/windows7/customize-the-start-menu
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Operating
System

Installation Method Start the Tools and Utilities

• /pentaho/design-tools/data-integration/pan.app

Spoon

• /pentaho/design-tools/data-integration/spoon.app

Enter Licenses and Connect to the DI Repository

You must also use Spoon to set up each workstation.

• Start Spoon
• Enter Licenses
• Make a Connection to the DI Repository

When you are done, please go on to the next stop on the Guide Post graphic.

Start Spoon

1. Start the DI server.

2. Navigate to the folder where you have installed Pentaho Data Integration; for example ...\pentaho\design-
tools\data-integration.

3. Launch Spoon in the best way for your operating system.

a) For Windows: double-click Spoon.bat.
b) For Linux: double-click spoon.sh
c) For Macintosh: go to .../pdi-ee/data-integration and double click on the Data Integration 64-bit icon

depending on your system.

The Pentaho License Manager dialog appears. You must enter licenses.

Enter Licenses

You must start Spoon before adding licenses.

1. Copy your license files to a convenient location.

2. Log into Spoon.
The Pentaho License Manager dialog appears.

3. From within the Pentaho License Manager, click on the Add button.

4. Double-click on the license key to open it.
A green check appears in the Status column to show that the license key installed correctly.

5. Click Close to close the dialog box.

6. Close any windows that appear and restart Spoon so that the license key will take effect.

Connect to the DI Repository

If current license keys are installed when you start Spoon, the Repository Connection dialog box appears. The DI
Repository provides you a place to centrally store ETL jobs and transformations. You may choose to set up common
connections for your users now or you can close the dialog box and allow your users to connect to the DI Repository
themselves.

1. In the Repository Connection dialog box, click the add button.

2. Select DI Repository: DI Repository and click OK.
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The Repository Configuration dialog box appears.

3. Keep the default URL, which is http://localhost:9080/pentaho-di.

4. Click Test to ensure your connection is properly configured. If you get an error, make sure you have started the DI
Server.

5. Click OK to exit the Success dialog box.

6. Enter an ID and Name for your repository.

7. Click OK to exit the Repository Configuration dialog box.
Your new connection appears in the list of available repositories.

8. Log on to the DI Repository by entering the following credentials: user name = admin, password = password. If you
have changed the credentials, then those are the credentials you must use.

Next Steps

After you have performed these tasks, you can choose your next steps.

• If you want to create jobs and transformations with your data, you must connect to your data and then connect to the
DI Repository so you have somewhere to save your jobs and transformations.
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