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Thank you for considering Pentaho as your Business Intelligence solutions provider. If you are reading this
guide, you have chosen to download, install, and evaluate Pentaho Report Designer, version 3.8 GA. The
purpose of this document is to provide you with instructions for creating a simple Report Designer report.

Pentaho Reporting provides unmatched deployment flexibility. Whether you're looking for a standalone
desktop reporting tool, Web-based reporting, or comprehensive business intelligence (Bl) including
reporting, analysis, and dashboards, Pentaho Reporting allows you to “start small” and scale up if your
reporting needs grow in the future.

The Pentaho Report Designer provides you with the following features:

« Drag-and-drop graphical designer that gives users full control of data access, layout, grouping,
calculations, charting and formatting for pixel-perfect reports

* Integrated, step-by-step wizard that guides report designers through the design process

* Report templates that accelerate report creation and provide consistent look-and-feel
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Report Designer allows you to create a report by following a four step wizard; however, to show you a
larger range of features, the exercises in this document walk you through the manual procedures for
creating a simple report. Keep in mind that is basic tutorial and will not provide details about advanced
Report Designer features.

Important: The scope of this document is limited to the topics described in the paragraph above.
i you need further information deploying the Pentaho Bl Suite or have custom configuration
requirements, contact your Pentaho Sales Representative or send an email to Support.
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Follow the instructions below to begin creating your report:

1. Start the Report Designer. Go to Start -> Programs -> Pentaho Enterprise Edition -> Design Tools
-> Report Designer.
The Report Designer home page appears.

2. Click New Report in the Welcome dialog box.
The design workspace appears.


mailto:supportadmin@pentaho.com

- Note: If you'd like to change the size of the layout bands to give yourself more area to work in
[i_f without changing the dimensions of the published report, you can click and drag the percentage
number in the upper left corner of the workspace. By default it says 100%, but if you click and
drag it diagonally toward the upper left or lower right corners, the view will zoom in or out. If you
want to reset the view to 100%, double-click the upper left corner where the percentage shows.

3. In the right pane, click the Data tab.

4. For the purpose of this exercise, right-click Data Sets and choose JDBC. Alternatively, you can click
the yellow database icon to display the JDBC dialog box.
The JDBC Data Source dialog box appears.

5. Under Connections, select SampleData (Memory).

Next to Available Queries click @ (Add).

Query 1 appears under Available Queries. Notice that the edit icon -!5"'? is enabled.

'~ JDBC Data Source

Connections: . (@ B3 [Available Queries (] ]
|sampleData (Hypersonic) |Query 1
SampleData (Local)
sampieData (MySQL)

Query Name
Query 1

Query

N b a dden R A SOV ey

Click & (Edit).

The SQL Query Designer window opens. The SQL Query Designer provides you with a graphical
environment that allows you to work with the data even if you don't understand SQL, the standard
programming language for retrieving content from databases.

8. Double-click ORDERFACT so that the table appears in the workspace as shown in the image above.
9. In the SQL Query Designer workspace, right-click "ORDERFACT" and choose deselect all.

select all
l

open all foreign tables
open all primary tables
[¥] STATUS
] COMMENTS
[l CUSTOMERNUMBER
[ TIME_ID
¥l aTR_ID
[l MONTH_ID
[¥] YEAR_ID

10.Now, select the following fields in the ORDERFACT table: ORDERNUMBER, QUANTITYORDERED,
PRICEEACH, and ORDERDATE.
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/| "ORDERFACT™
[¥] ORDERNUMBER -
(| PRODUCTCODE
[¥] QUANTITYORDE
[¥] PRICEEACH
| jonnsnuumuuaﬁ
L | TOTALFRICE
¥] ORDERDATE
[[] REQUIREDDATE
(] SHIPFEDDATE
ClsTaTUS
-

11.Double-click PRODUCTS so that the table appears in the workspace.
Notice that there is a line that joins the ORDERFACT and PRODUCTS tables together.
12.Deselect all PRODUCTS table fields, except for PRODUCTNAME and PRODUCTLINE.

e K

e

| "ORDERFACT™ | "PRODUCTS"
[v] ORDERNUMBER [_] PRODUCTCODE
[]PRODUCTCODE [¥¥] PRODUCTNAME
[¥] QUANTITYORDERED [¥¥] PRODUCTLINE
[¥] PRICEEACH [ PRODUCTSCALE
[[] ORDERLINENUMEBER [ PRODUCTVENDOR
[JTOTALPRICE [ PRODUCTDESCRIPTION
[¥] ORDERDATE [ QUANTITYINSTOCK
[ REQUIREDDATE [ BUYPRICE
] SHIPPEDDATE [CImsrP !
CIsTATUS [
L] COMMENTS e
[[] CUSTOMERNUMBER \
CImMe_ID
[JaTR_iD

IMONTH_ID

PEEL A amath. -

13.For the purpose of this exercise, click the Syntax tab in the lower left portion of the SQL Query
Designer workspace to display a simple SQL statement associated with the tables. Notice that
PRODUCTCODE is the common field between the ORDERFACT and PRODUCTS tables.

2 4
a
SELECT b
~ORDERFACT™ . "ORDERNTMEER" , >
“CRDEREACT . “QUANTITYORDERED", 1
"ORDERFACT" . "FRICEEACH", }
"ORDERFACT" . "ORDERTATE", i
~PRODUCTS™ . ~PRODUCTHAME™, £
“BRODUCTS" . “PRODUCTLINE™ 5
FROM ‘}
"PRODUCTS™ INMER JOIN "CRDERFACT™ ON "PRODUCTS"."PRODUCTCODE™ = "CRDERFACT™."PRODUCTCODE" r

peandr e astamn et fp. adfin g Supie. . aemaes.get

14.Click OK in the syntax window to return to the JDBC Data Source dialog box. Notice that the SQL
statement appears on the right under Query.

15.1n the JDBC Data Source dialog box, click OK to return to the Design page.
Notice that the fields associated with your tables are listed under Query 1. You are now ready to start
Designing Your Report on page 7.
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v (& Queny1
__| ORDERNUMBER (Integar) rlj

[ QUANTITYORDERED (Integer) -,

“| PRICEEACH (BigDecimal) 3
|| ORDERDATE (Timestamp} f
[ PRODUCTNAME [String) LY
[ PRODUCTLINE (String)

“| ORDERNUMEER (::column:-0) %
L QUANTITYORDERED t"r.olumrr}
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Designing Your Report

This exercise walks you through the process of designing the look-and-feel of your report.

1. Under the View item in the Report Designer menubar, click Element Alignment Hints and Snap to
Elements to enable them. These options help you to align the elements of your report.

2. Inthe Design page, under Query 1, click and drag the ORDERNUMBER field into the Details band.
Make sure that the top line of the field name and the top line of the Details band match up.

3. Place the ORDERDATE, PRODUCTNAME, QUANTITYORDERED, and PRICEEACH fields into the
Details Band. Take care not to overlap the fields or your report will not display correctly.

4. Use the resizing handles to make the PRODUCTNAME field larger and the QUANTITYORDERED field
smaller as shown in the example below:

[_f:;: Tip: You can also click *! (Preview) on the left side of your workspace or select it from the

View menu option to preview a report. Clickﬁ (Edit) to return to the workspace view.

ORDERNUMBER ORDERDATE

E OUAN
o

Resizing Handle

10,107
10,121
10,134
10,145
10,159
10,168
10,180
10,188
10,21
10,211
10,223
10,237
10,251
10,263
10,275
10,285
10,299
10,309
10,318
10,329
10,341
10,354
10,351
10,375
10,388
10,399
10,403
10,417
10,103

Feb 24, 2003
May 7, 2003
Jul1, 2003
Aug 25, 2003
et 10, 2003
Oct 28, 2003
Mov 11, 2003
Mow 18, 2003
Dac 1, 2003
Jam 15, 2004
Feb 20, 2004
Apr 3, 2004
May 18, 2004
Jun 28, 2004
Jull 23, 2004
Aug 27, 2004
Sep 30, 004
Oct 15, 2004
Mow 2, 2004
Mov 15, 2004
Mow 24, 2004
Dec 4, 2004
Dec 17, 2004
Fab 3, 2005
War 3, 2005
Apri1, 2005
Aprg, 2005
May 13, 2005
Jan 28, 2003

Refining Your Report

1969 Harley Davidson Ulimate Cho ..

1969 Harley Davidson Uttimate Cho
1869 Harley Davidson Ultimate Cho

1969 Harley Davidson Ulimate Cho ..
19639 Harley Davidson URimata Cho ..

1969 Harley Davidson Ultimate Cho
19649 Harley Davidson Ultimate Cho

1968 Harley Davidson Ulimate Cho .
1969 Harley Davidson Ulimate Cho ..

1969 Harley Davidson Uttimate Cho
1869 Harley Davidson Ultimate Cho

1969 Harley Davidson Ulimate Cho.. 2
19639 Harley Davidson URimata Cho ..

1969 Harley Davidson Ultimate Cho
19649 Harley Davidson Ultimate Cho

1968 Harley Davidson Ulimate Cho .
1969 Harley Davidson Ulimate Cho ..

1969 Harley Davidson Uttimate Cho
1869 Harley Davidson Ultimate Cho

1969 Harley Davidson Ulimate Cho ..
19639 Harley Davidson URimata Cho ..

1969 Harley Davidson Ultimate Cho
19649 Harley Davidson Ultimate Cho

1968 Harley Davidson Ulimate Cho .
1969 Harley Davidson Ulimate Cho ..

1969 Harley Davidson Uttimate Cho
1869 Harley Davidson Ultimate Cho

1969 Harley Davidson Ulimata Cho .

1952 Alping Ranaul 1300

100
100
1DD

WJJM;?@“W

But, wait... There's a problem. Without headers, report users will have a hard time understanding its

content. You must continue refining your report, see Refining Your Report on page 7.

You have created your first report. Click | (Preview) to examine your report. Clickﬁ (Edit) to return
to the workspace view.

You've created a report in the previous exercise but now you need to make the report more descriptive so

that users can understand the content in the report. Follow the instructions below to refine your report.

1.
Click -‘;? (Edit) to return to the Design page.
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2. Click and drag a * (Label) from the tools palette into the middle of the Page Header band. Notice how
Report Designer keeps track of the report structure (shown below).

| order_report.prpt (] | marinas._test_report X |

@ [sent »jo |~ B I U [ETEEN-]|
100% (05 10 15 20 .25 30 35 40 45 50 55 60
a1 a
Page Header |° o @ o

=

| (T &
= Master Report
[ -

¢ B Groups
1 Group Header
o= { = Details Body
= Group Footer
& L Report Footer
& | Page Footer
Watermark

3. Click inside the Label item and type Order Report

4. Double-click inside the Order Report label to select the text, then in the toolbar, select a larger font size
(18 point) and apply boldface.

® U - |

18-20-22 24 -26-28-30-32 .34 -36-38.40.42 -4

brder Report -

The changes are applied to the text; however, now that the text is bigger you may not see all of it, so
use your resizing handles and enlarge the label until you can see all of the text. Alternatively, you can
stretch the resizing handles all the way to each edge of the workspace and click the align center icon in
the toolbar so that the text is automatically placed in the center of the report page.

5. With the Order Report label still selected, click down arrow of the font color icon in the toolbar. Select a
color for your label.
The font color changes. This page header will appear on every page of your report.

6. Now, you must create column headers. On the right side of your workspace, click Structure -> Details
Header.

7. In the lower right section of your workspace, click Attributes.

8. Under common, change the Value of the hide-on-canvas option to False.
Notice that the Details Header pane appears in your workspace.

In the toolbar, click | ¥ (Select Objects).

Notice that the icon changes to a cross hair as you move into the workspace.

10.Move your mouse to the far right of the Details pane. Now, drag your mouse to the far left over all your
column objects to select them. You may have to move the mouse under the headings to make them
easier to select.

Drag your mouse from right to left.

it DERNUMBER SORDERDATE 5 FRODUETNAME manTHvoRDARCEERTH ]
] r] -] o o o o @ Q o a

Detalls
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11.Click <CTRL+C> to copy your objects and <CTRL+V> to paste them into the Details Header pane.

; Note: Alternatively, you can choose Copy from the right-click menu.

12.Under Format in the Report Designer menubar, select Morph.
The column objects are changed to labels.

13.Type the correct heading names for each of your columns: Order No., Order Date, Product Name,

14.

Quan., and Price Each.
Your headers will align correctly over your columns.

Click _*| (Preview) to display your report.

Order No. Order Date

10,107 Fab 24, 2003
10121 May 7, 2003
10,134 Jul 1, 2003
10,145 Aug 25, X003
10,159 Oct 10, 2003
10,168 Oct 28, 2003
10,180 Mov 11, 2003
10,188 Mov 18, 2003
10,201 Dec 1, 2003
10,21 Jan 15, 2004
10,223 Fab 20, 2004
10,237 Apr S, 2004
10,251 May 18, 2004
10,263 Jun 28, 2004
10,275 Jul 23, 2004
10,285 Aug 27, 2004
10,289 Sep 30, 1004
10,309 Oct 15, 2004
10,318 Mov 2, 2004
10,328 Mov 15, 7004
10,341 Mov 24, 7004
10,354 D 4, 2004

Produc HName Quan.
1964 Harley Davidson Ultimate Chopper 30
1565 Harley Davidson Lltimate Chopper 34
1969 Harley Davidson Ultimate Choppar 41
1969 Harley Davidson Ultimate Chopper 45
15965 Harley Davidson Ultimate Chopper 49
1868 Harley Davidson Ultimate Chopper 36
196% Harley Davidson Llitimate Choppar 29
1969 Harley Davidson Ultimate Chopper 48
1968 Harley Davidson Ultimate Chopper 22
15965 Harley Davidson Lltimats Choppar 41
1969 Harley Davidson Ultimate Chopper 37
1964 Harley Davidson Ultimate Chopper 23
1565 Harley Davidson Ultimate Chopper 28
1965 Harley Davidson Ultimate Choppar 34
1969 Harley Davidson Ultimate Chopper 45
1965 Harley Davidson Ultimate Chopper 38
1868 Harley Davidson Ultimate Chopper 23
196% Harley Davidson Litimate Choppar 41
1965 Harley Davidson Ultimate Chopper 48
1958 Harley Davidson Ultimate Chopper 42
1965 Harlay Davidson Ltimats Choppar 41
1969 Harley Davidson Ultimate Chopper

218,361 De-: w& Harley Davidson Ulugaﬁnpper ’

The report looks good but you may want to make it even easier to read by applying some banding.

Order Report

15.In the toolbar, go to Format -> Row Banding.
16.In the Row Banding dialog box, choose Yellow from the drop-down list next to Visible Color and click

OK.

17'CIick *| (Preview) to display your report.

Abrder Moo
i, 147
(LR
b, 134
10, 148
I, 145
1, 168

[EONE]

W A

Ohrder Dwie

Mo Fb 24
D00 DO EST
Wiad May 07
D000 EDT ..
T Jul G
00000 YT
Mlon Awg 25
o000 EDT .
Fri ket 19
D00 00 EDFT
T Cice 26
D000 EST ..
T N 1|
000000 L5 T

Order Report

Froduc Nume uan
1% Marbey Davidson Llzimate Chopper 30
196 Maley Davidsos Ultimate Choppar 34
|9 Blawrbery Dhavidscs Lleimune Chopper 4l
1966 Harley Davidson Ultimuie Chopper 4%
198 lwley Davideon Ultimste Chopper 40
196 Maley Davidson Lltimate Chopper 36
|9 Blarbery Dhavidscs Llimne Chopper P

L‘&?:)ll:! | 965 Harley Davidson Llsimuic O 4%
W“”—"h“w

18.In the menubar, go to File -> Save to save your report in the ...\report-designer\samples folder. Type

Orders in the File Name text box.

[y ’ .

Price Each
"
8138
LR
LR

100

6

a5.13

| Welcome | 9



10| | Welcome

- Note: See More about Row Banding, Data Formatting, and Alignment on page 10 for
[:::' additional information about refining your report.

More about Row Banding, Data Formatting, and Alignment

Row Banding

By creating a row band element, you can select the specific fields in your report that will display a row
band. For example, you may want to emphasize specific fields and not others on a line. You can give your
row band element any name you choose. In the example below, the row band element is called row-band-
element.

Visible Color
Invisible Color |
Element
State on new Group
State on new Page

|row-band-edemant

Inrvisible
Same as initial state

After you create your element, go back to the report and select the columns (fields) whose data will always
be displayed with a row band. You must also type row-band-element in the name field under Attributes. is
In the example below, the data associated with each of the columns in the report will display a row band.
Notice the banding in the report preview.

| Structure | Data

B I U TN -

-Jlo [=
20 <25 - 30 - 35 - &D - 45 - 50 - 55 . EQ

05 10 1% B Mxater Rupont
& = Page Header
Ab bl Dideis
= Rapon Hesder
¢ {H Groups
Grug Heade
¢ = Dutaity Body
§ ™= Deiads Header
Ab Labal OTer Mumbead
Ab labet Order Dl
Ab I3bet Papdudt Mame
Al labet: Quanity Deders
Ab bl B -
Gt

Orders

Data Formatting

Report Designer uses default formats for dates and numbers. You can change how dates and numbers
display by selecting the object (field) and selecting the appropriate value for the format from the drop-down
list next to format (under Attributes). In the example below, the dates associated with the Order Date
field will display as MM-dd-yy.



| e Nuammibr Ovder Duge Prodect Name Caamtity Ovdors | = Det.a;l-sm T

number-field: PRICEEACH
number-field: QUANTITYORDEF

i fn = E
DUANTITY OR [MRED FRICEEACH Sokeflok:
i n : MEER

o= = Mo Data

o= [ Details Foater

i e[ Group Fooler
i ql____"L'_.'—] I

Name |  Value |  Formula

L ]
ORDERDATE

When you preview the report, notice that it displays in a cleaner format:

2 Print Preview ;(I
Report Export View Help
[a) « < >[w[a]
-
Orders
Ovdx Numbsy Oy Dhaby Prodect Name Quannty (ders Price Each
1, 10T 02-24-03 1908 Habey Duvidson Ultimase 30 4.7
Chopper
o, 121 oS0T.E 1969 Habey Davidion Utinate 34 LEES
o, 154 070000 1969 Harbey Davidion Uhimane 41 W
L boppa
o, 145 08-25-03 1565 Harbey Dovisdson Uliimaie 4% Li8.
[T o 10-03 1964 Harboy Davidion Ulimabs 49 L]
Chiopper )
10, 16t 10-28:00 1969 Habey Danidion Ultisute 36 ke
1o, | B0 H=10-a0 |M|l‘l€}lhh-}uﬁl.llli|hh.' ol 813
 hoppor
o, |85 [IEER 1969 Harbey Duvisdson Ubtinuite 48 (0]
020 120003 194 Harbey Dovidson Ultimase 12 857
Choppear N
w2l Bl 1964 Harbey Dovidion Uhtimare 41 (L]
223 00-20-8 1969 Harbey Daviskon Uliimaie 37 10
gt
10,237 00 1969 Harbey Davidson Ullinabe 23 e
10,251 Ol R 1964 Harbey Davidion Ultimate 28 [
 hoppar ) | -
10,263 [ES-ER 1965 Habey Davidion UTtimate 34 (]
10,275 072304 196 Harbey Duvidson Uhtimate 48 LEEN]
Choppser
[Ty s 55 as e T ] S Y [

Note: You can type a value for your own format if you know the correct JavaScript string
nomenclature.

Alignment
To align multiple objects press <SHIFT+ CLICK> to select each object. Then, choose an alignment option

from the Format menu. Alternatively, you can click I '*| (Select Objects) and drag your mouse over the
objects you want to select and then choose an alignment option.

In the example below, the selected objects will be aligned in the middle of the band.

| Welcome | 11



= Pentaho Report Designer - orders - C:\Documents and Settings\mbaker \Desktop\All Des

Hypariinks...
Conditional Hide . . 30 3 5 d ] -I 5 .

Orders

BEOOOCerE sEEEEEST

Adding a Chart to Your Report

12| | Welcome

So far you've seen a small subset of features associated with Report Designer. In this exercise, you will
add a chart to your report.

1. Click File -> Open and find the report you just saved. Click OK.
2. Inthe palette, click and drag a [€] Chart into the Report Footer band.
3. Use the resizing handles to center and stretch the chart. You can also adjust the width of the band.

Bar Charl

| i Iu

Cat..

4. Double-click the sample chart.
5. The type of chart most appropriate for your report is a pie chart. In the top portion of the Edit Chart
dialog box, select the pie chart icon.

Note: Notice that the pie chart properties that define its look-and-feel are listed in the left pane
ﬂf of the Edit Chart dialog box. Properties associated with the data in the chart are listed in the right
pane.
6. Go to the Title properties; net to the chart-title property, type Product Pie Chart.

7. Under Common, click the down arrow next to value-column click the ellipsis [...] to open the Edit
Array dialog box.

The value-column specifies the actual values (measures) you want to chart. In this instance, you want
to chart the quantity ordered.



I Secondary Data Source

Click here

V aluwe

IANTITYORLER

sanes-by-iiald [PRODUCTLMNE]

auta-generabe-series
8 Grous < Selepti el 3 —

e iy 4 emv:solubonRoot (avaJang. String) s
— emviusername (javalang. Siring)

report.date (Rvautil.Date)

] ORDERMUMEBER (java lang.nieger)

QUANTITYORDERED (javalang nteger)

£ PRICEEACH (avamath.BigDecimal)

£ ORDERDATE (java.sql. Timestamip)

D) PRODUCTHAME (javaang. String)

£l PRODUCTLIME [javalang. String) =

| ok || cancel

8. Click in the blank field to expose the drop-down arrow.
9. Select QUANTITYORDERED from the list and click OK.
10.Click OK to exit the Edit Chart dialog box.

11.Under Series click the ellipsis [...] next to series-by-field to open the Edit Array dialog box.

The series-by-field specifies the field you are charting. In this instance you are charting by product line.

Series are usually placed in the chart legend.
12.
Click ﬁ(Add).

13.Click in the blank field to expose the drop-down arrow.
14.Select PRODUCTLINE from the list and click OK.
15.Click OK to exit the Edit Chart dialog box.

16'Click “* (Preview) to display your report.

17.When the report displays, click the double arrows to go to the last page.

Product Bar Chart
:

Series [z2w}—+

B Motoreycies i Classic Cars () Trucks and Busas Vinlage Cars ) Planes Ships ) Trains

The chart you created appears on the last page of the report. If you want to display a bar or line chart
instead, use the chart settings below. You have to add the series-by-value setting manually in the Edit

Array dialog box. Click @ (Add) and type SALES; click @ (Add) and type COST. Run the report to

display the bar chart.

| Welcome | 13



PRODUCTLINE
[QUANTITYORDERED, PRICEEACH]

calegony-column
valug-CHumns

senes-Dyvalue [SALES, COST]
senes-by-iield 1
Auto-generate-senes

Product Bar Chart

Values

——
78,000
E— =]
SO0 1
o I I I I I
| I I —

Moty . " Tfuaha Wirrla, F'Lar-aa 5hp¢. Trairn
I
Series Categories

18.Save your report. You are now ready to Adding Parameters to Your Report on page 14.

Adding Parameters to Your Report

When you set parameters, users are prompted for a value or values when they run the report. The ability to
provide parameters is an important part of creating a report.

1. In the Report Designer, click File - > Open to select the report you created.

2. In the menubar go to Data -> Add Parameter. Alternatively, you can click == (Master Report
Parameter) under the Data Tab in the Report Designer workspace.

The Add Parameter dialog box appears.

In the Add Parameter dialog box, type enter_prodline in the Name text field.

Type Select Line in the Label text field.

Next to Display Type, select Drop Down so users can select a product line.

o 0w

Click -ﬁ (Edit) to add a query that supplies the values, (motorcycles, cars, ships, and so on), from
which users of the report must choose.

-
-

The JDBC Data Sources dialog box appears.
Under Connections, select SampleData (Memory).

Note: Click on JDBC (SampleData - Memory) under Data Sources if the Edit icon is disabled.

~

Next to Available Queries click @ (Add).

A new query placeholder is added to the list (Query 2).

9. In the Query Name text field, type prodlineList.

10.Enter your SQL query in the Query box.

You can copy and paste the required lines, (shown below) directly into the SQL statement or you can
use the alternate steps in the table below.

. Important: Make sure to use curly brackets, (not parentheses), before and after
[-:f {enter_prodline} or the report will not display correctly.

SELECT DI STI NCT " PRODUCTS". " PRODUCTLI NE"
FROM " PRODUCTS"
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Query Hame
prodiineList

Query
SELECT DISTIHCT

TERODUCTS™. "FRODUCTLINE™

e <

By entering these lines, report users see a prompt when they open the report in the Pentaho User
Console that allows them to enter a product line. That way, they can examine orders by product line. If
you do not add the lines, the report displays orders for all product lines.

Alternatively, you can use the SQL Query Designer to build your query:

Step Description

1 In the JDBC Data Source dialog box,

click & (the Edit icon on the right).

2 In the SQL Query Designer, select the
PRODUCTS table on the left.
3 On the right, click PRODUCTS and

choose Deselect All.

4 Right-click SELECT on the left and
choose Distinct.

5 On the right, select PRODUCTLINE
and click Preview. The product line list
appears. Click Close.

6 Click OK to exit the SQL Query Designer
and go to Step 11.

11.Click OK to exit Data Source dialog box.

12.In the Add Parameter dialog box, under Data Sources, double-click JDBC SampleData (Memory) and
select prodlineList.

13.Next to Value Type, select String.
14.Type a default value, for example, "Motorcycles," in the Default Value text box. (Optional)
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e

DataSources @
[ JDEC (SampleData (Memory))|  Mame lentes_prodline
[ produnet ist Laabed Salac Ling
[ cwers 1 Value Type [String
Data Format |
Defauit Value Matarcycles
Default Value Formula |
Post.Processing Formula
[] Mandatory
[] Hididen
Display Type |Drop Dawn J
Query prodiineL ist
Value |P'HﬂDLN:IIJPE 1
Display Name |P'EDDLN:IIJIE

15.Click OK to exit the Add Parameter dialog box.

16.Now that you've created a product line parameter, you must map it back to your query (Query 1). Under
Data, double-click Query 1.

# [5] JOBC (SampileDiats (Hypersomcl)
D) romnetist
¥ ) Ouery 1
DWWMR L4

D QUSNTITYORDERED (QUANTITYORDY
D) PRICEEACH (PRICEEACH, BigDecims
) ORDERDATE (ORDERDATE, Timastar

17.Right-click PRODUCTLINE and select add where condition.
The condition.edit dialog box appears.

18.Type ${ ent er _pr odl i ne} in the edit area and click OK.

< condition.edit '\.ﬂ

[ ]

PRODUCTS " PRODUCTLIMNE™

= w |[[] SUBQUERY

Is{enter_prodiine} ﬁ Use {curly brackets} not
{parentheses) around your
text!

Lok || cose

19.Click OK to exit the /SQL Query Designer.
20.Click OK to exit the Data Source dialog box.

2L Click = (Preview),
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You should see your product line drop-down list.
22.You are now ready to Publishing Your Report on page 17.

Publishing Your Report

You have created and formatted a simple report, added a chart, and now you are ready to share the report
with your users.

1. In the Report Designer, click File -> Open to open the report you just created.

2. Click File -> Publish. Alternatively, click @
If you haven't saved the report, a warning message reminds you to save it. The Login dialog box
appears, pre-populated with credentials valid for the evaluation.

Important: Make sure that the Server URL is setto htt p: / /1 ocal host : 8080/ pent aho/ .

=

Server
URL:
T —
[hitp=iocakhos 1808 pentahol [l "
Pentaho Credentials
User:

-|c|e
Password:

EEREERE

_OK Canc

w

Click OK.
The Publish to Server dialog box appears.

In the Publish to Server dialog box, type in a report name and description into the appropriate fields.
Under Location, save the reportinthe . . . / st eel - wheel s/ report s folder.
Select html as the Output Type.

In the Publish Password text field, type the publish password, password, and click OK.
A success message appears.

8. Click Yes to go directly to the Pentaho User Console to view the report you just published.

If you want to access the report later, log into the Bl Server by going to http:// localhost:8080 in your
Web browser, then navigate to the Reporting Examples directory in the Solution Browser. You
should see your published report in the list. If not, click Tools -> Refresh Repository.

9. Log in as Joe. Joe's password is password.
10.Your report displays in the Pentaho User Console.

N o ok
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You now have a report that users can view at any time.

¥ Report Parameters

Product Line
Classic Cars = I

Output
HTML -

View Flapen |F Auto-Submit
WI4] Page[ & of 310w

b
Order Report
Order Xo. Order Date Product Name Quan. Price Each
L
-«

10,253 Jun-01-2004 1970 Plymouth Hemi Cuda 25 9017
10,266 Jual-06-2004 1970 Plyeouth Hema Cuda 3z T6.61
10,276 Aug-02-2004 1970 Plymouth Hemi Cuda k1. 8iTe
10,287 Aug-30-2004 1970 Plymsouth Hemi Cuda 41 69.43
10,300 Oct-04-2003 1970 Plymouth Hemi Cuda 2] T6.61
10,310 Oct-16-2004 1970 Plymouth Hemi Cuda 49 814
10320 MWow-03-2004 1970 Plvmouth Hemi Cuda 38 7342
10,3 Now-13-2004 1570 Plymouth Hemi Cuda
_w" - 24-3 " Pt nahinoder, - ' V‘-J

11.In the Pentaho User Console select your product line parameter from the drop-down list. Accept the
default under Output Type.

From Evaluation to Implementation

This document was designed to quickly demonstrate basic Pentaho Report Designer features. To find out
more about the benefits of Pentaho Reporting and Pentaho Enterprise Edition product offerings, contact
Pentaho Sales.
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