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Welcome

Thank you for considering Pentaho as your Business Intelligence solutions provider. If you are reading this
guide, you have chosen to download, install, and evaluate Pentaho BI Suite Enterprise Edition, version
3.8.0 GA. The purpose of this document is to provide you with instructions for using the graphical installer,
a wizard that walks you, step-by-step, through a typical installation of Pentaho BI Suite Enterprise Edition,
3.8.0 GA on Windows devices.

This guide also provides you with basic instructions for verifying your installation of Pentaho BI Suite
Enterprise Edition (from now on referred to as the Pentaho BI Suite). Post installation exercises walk
you through designing a simple report, Pentaho Analyzer report, and dashboard. Once you complete the
installation and related tasks, you will be able to start taking advantage of many of the features that are
included in this release of the Pentaho BI Suite.

Note:  The scope of this document is limited to the topics described in the paragraph above. If you
need further information deploying the Pentaho BI Suite or have custom configuration requirements,
contact your Pentaho Sales Representative or send an email to Support.

Below is a brief description of each section in this document:

Section Description

Before You Begin on page 8 Provides a quick description of each
component included in this release of
Pentaho BI Suite Enterprise Edition;
also included are hardware and software
requirements

Installing the Pentaho BI Suite on page
11

Walks you through installation of the product

mailto:supportadmin@pentaho.com
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Section Description

Creating an Ad Hoc Report  on page 16 Provides you with instructions for creating
a simple ad hoc report in the Pentaho User
Console

Creating a New Analyzer Report on page
19

Provides you with instructions for working with
interactive and dynamic reports

Working with Dashboards on page 22 Provides instructions for creating a simple
dashboard using sample data

Creating a Report Using Report Designer
on page 45

Provides instructions for creating a report
using basic Report Designer features

Defining a Database Connection on page
60

Provides instructions for adding your own
data source connection

From Evaluation to Implementation on
page 76

Provides you with instructions for contacting
Pentaho Sales

Pentaho BI Suite Enterprise Edition Features

Pentaho BI Suite Enterprise Edition allows you to deploy the BI suite components with confidence,
security, and far lower total cost of ownership than proprietary alternatives. Pentaho BI Suite Enterprise
Edition provides additional capabilities including a comprehensive professional technical support program,
access to an extensive product-related knowledge base, software maintenance, enhanced software
functionality, certified software, product expertise, and the best software assurance program in the industry
that provides intellectual property indemnification and warranty for services.

Software and Services Community Edition Enterprise Edition

Reporting Open Source Certified

Analysis Open Source Certified

Dashboards Open Source Certified

Data Integration / ETL Open Source Certified

Business Intelligence
Platform

Open Source Certified

Data Mining Open Source Certified (Add On)

Community Forums
Interaction

Yes Yes

Community Web
Documentation (Wiki)

Yes Yes

Professional Support No Yes

Software Maintenance By In-House Staff By Pentaho Engineers

Enhanced Functionality No Yes

Certified Software No Yes

Product Expertise No Yes

Software Assurance No Yes
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Finding More Resources

We, at Pentaho, understand that business intelligence implementations can be complex. For this reason,
we provide you with tools that support you through your evaluation period and beyond. Your trial evaluation
entitles you with access to the Pentaho Knowledge Base where you can find articles, manuals, and tech
tips that cover basic and advanced topics associated with implementing the Pentaho BI Suite. In addition,
the Pre-Sales portal provides you with access to recorded Webcasts that give you basic understanding of
the features and functionality offered by the Pentaho BI Suite.

Note:  Refer to your Welcome email for details about how to access the Knowledge Base and Pre-
Sales portal.

Successful implementations start with training and support. Pentaho trainers are experts in the industry
and offer a wide range of affordable classroom, online, and on-site training services to meet your
knowledge requirements. Our support team will help you become productive quickly.
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Before You Begin

The sections that follow provide you with knowledge requirements, Pentaho components included in this
release, and system requirements.

Knowledge Requirements

To install the Pentaho BI Suite, you must be familiar with system administration and operations associated
with network services, such as modifying your firewall to open specific ports and adding services to the
system startup and shutdown scripts. In most installation scenarios, this means you must be comfortable
using your operating system's command line interface. You must have the ability to install software,
open firewall ports, and start and stop system services on the device on which you are performing
the installation. If you need to access a remote database, make sure you have the level of permission
necessary to do so from your test machine. If you don't have the required access or permissions, contact
your system or database administrator.

Components Included in this Release

This release includes the complete Pentaho BI Suite, the BI server, and all client tools as described in the
list below:

Component Name Description

Pentaho BI Server The BI Server is an enterprise-class Business
Intelligence (BI) platform that supports
Pentaho's end-user reporting, analysis,
and dashboard capabilities with back-end
security, integration, scheduling, and workflow
capabilities.

Pentaho Enterprise Console The Pentaho Enterprise Console is a
standalone utility distributed with the BI
Platform that provides administrators with a
thin-client interface for administering users,
roles, data sources, scheduling and more.

Pentaho Design Studio  (client tool) The Pentaho Design Studio is a collection
of editors and viewers integrated into a
single application that provides a graphical
environment for building and testing action
sequence documents.

Pentaho Metadata Editor (client tool) The Metadata Editor (PME) is a tool that
builds Pentaho metadata domains and
models. A Pentaho metadata model maps
the physical structure of your database into a
logical business model.

Report Designer (client tool) The Report Designer is the primary tool for
creating and publishing Pentaho Reports.
It provides a graphical interface allowing
users to connect to their data, design and
preview reports, and publish the reports to the
Pentaho BI Platform.
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Component Name Description

Pentaho Schema Workbench (client tool) The Schema Workbench is the primary tool
for designing, editing, and publishing Pentaho
Analysis(Mondrian) OLAP schemas.

Pentaho Aggregation Designer  (client tool) Pentaho Aggregation Designer is a graphical
environment used to increase query
performance of a Mondrian OLAP schema
through the creation of aggregate tables.

Pentaho Data Integration  (client tool) Pentaho Data Integration is a graphical, drag-
and-drop design environment for delivering
Extraction, Transformation and Loading
(ETL) capabilities using a metadata-driven
approach. The extensible standards based
architecture avoids the adoption of proprietary
methodologies into your ETL solution.

Pentaho Analyzer  (client tool) Pentaho Analyzer is an interactive analysis
tool, (an OLAP viewer), that allows
non-technical business users to create
meaningful, attractive, and interactive Web-
based reports and charts quickly and easily.
Pentaho Analyzer puts intuitive, analytical
capabilities in to the hands of knowledge
workers without the usual complexities of
traditional Business Intelligence applications
and with little to no training.

System Requirements

Below are the system requirements for each Pentaho component included in this release:

Hardware Requirements

The Pentaho BI Suite software does not have strict limits on computer or network hardware. As long as
you meet the minimum software requirements (note that your operating system will have its own minimum
hardware requirements), Pentaho is hardware agnostic. There is, however, a recommended set of system
specifications:

RAM At least 2GB

Hard drive space At least 1GB

Processor Dual-core AMD64 or EM64T

It's possible to use a less capable system, but in most realistic scenarios, the too-limited system resources
will result in an undesirable level of performance.

Your environment does not have to be 64-bit, even if your processor architecture supports it; while all
modern desktop, workstation, and server machines have 64-bit processors, they typically ship by default
with 32-bit operating systems. If you want to run the Pentaho BI Suite in a pure 64-bit environment,
you will have to install a 64-bit operating system, ensure that your solution database and Java Runtime
Environment are 64-bit, and install the BI Suite via the archive-based or manual deployment methods.
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Software Requirements

Note:  The system requirements listed below apply to the BI Suite. The BI Suite graphical
installation utility, however, will only work on Windows or Linux.

In terms of operating systems, Windows XP with Service Pack 2, modern Linux distributions (SUSE Linux
Enterprise Desktop and Server 10 and Red Hat Enterprise Linux 5 are officially supported, but most others
should work), Solaris 10, and Mac OS X 10.4 are all officially supported.

No matter which operating system you use, you must have the Sun Java Runtime Environment (JRE)
version 1.6 (sometimes referenced as version 6.0) installed.

Note:  The GNU Compiler for Java, or GCJ for short, interferes with the way many native Java
programs work on Linux, including some of the components of the Pentaho BI Suite. If you are
using a Linux distribution that installs GCJ by default (which includes all of the most popular distros),
then before you begin installation you must remove, disable, or circumvent GCJ. If you cannot
remove it, you can simply ensure that your JAVA_HOME variable is properly set, and add the Java
Runtime Environment's /bin/ directory to the beginning of your PATH variable in ~/.bashrc or /etc/
environment, then relog before continuing.

Workstations will need to have reasonably modern Web browsers to access Pentaho's Web interface.
Internet Explorer 6 or higher; Firefox 3.0 or higher (or the Mozilla or Netscape equivalent); and Safari 2.0.3
or higher will all work.

Your environment can be either 32-bit or 64-bit as long as it meets the above requirements.

The aforementioned configurations are officially supported by Pentaho. Other operating systems such as
Windows Vista, FreeBSD, and OpenBSD; other Java virtual machines like Blackdown; other application
servers such as Liferay and Websphere; and other Web browsers like Opera may work without any
problems. However, the Pentaho support team may not be able to help you if you have trouble installing or
using the BI Suite under these conditions.

Note:  Some Pentaho client tools, such as Metadata Editor, Aggregation Designer, Pentaho Data
Integration, and Design Studio, require that the Eclipse SWT JAR be in your Java classpath. This
can be an issue in scenarios where standalone client tools are installed onto a machine that does
not also have the BI Platform installed, particularly on platforms other than Windows and Linux.

Note:  The Pentaho Reporting engine requires a graphical environment in order to create charts.
If you are installing the BI Platform onto a headless Linux, BSD, or Solaris server and do not have
X11R6 on it, you should install the Xvfb package on your server to satisfy the charting dependency.
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Installing the Pentaho BI Suite

It is assumed that you will follow the default installation instructions and that you are installing to a local
device (localhost). If you have have custom configuration requirements, such as installing the Pentaho BI
Suite on a remote server, contact your Pentaho Sales Representative or send an email to Support.

Follow the instructions below as you go through each step in the installation wizard. See Troubleshooting
Your Installation on page 75 in the unlikely event you run into port conflict issues.

Note:  You must disable any anti-spyware software before installing the Pentaho BI Suite. Some
types of software firewalls and anti-virus scanners may also block the BI Server or prevent it from
operating normally.

1. Read and accept the License Agreement.
2. Click Default to accept the default installation.
3. Specify the location in which to install the Pentaho BI Suite or accept the default.
4. Type and retype password to set the master password for required users, the repository "root" user,

the BI server publish password, and the admin user for the Pentaho Enterprise console.
5. Click Next to start installing the Pentaho components.
6. Once the installation is complete, you can choose to view the installation summary and launch the

Pentaho User Console. Accept the default choices.
This document and Pentaho User Console home page appears. Some installations may prevent the
browser from opening. In these instances, you must open the console manually. See instructions for
starting the Pentaho User and Pentaho Enterprise consoles under Verifying Your Installation on page
11. Keep your consoles open and available as you step through the exercises in this document.

Verifying Your Installation

Now that you have successfully installed the Pentaho BI Suite, this section steps you through verifying your
installation.

Note:  As you start and stop the consoles and other Pentaho components, you may see black
command prompt windows open or close. These windows display the scripts that run the BI Suite
components. You can minimize the command prompt windows so they do not clutter your desktop

Making sure the BI Server and MySQL have started

If you selected to launch the User Console or Enterprise Console, the installer automatically starts the BI
Server, Solution Repository, and Enterprise Console. You can check to see if the Pentaho BI Server and

mailto:supportadmin@pentaho.com
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the MySQL database that contains the Pentaho Solution Repository have started by launching “Services”
from the Control Panel.

Go to Start -> Control Panel -> Administrative Tools -> Services. Alternatively, you can type
services.msc in the Run command on the Start menu. Under local Services scroll down to Pentaho BI
Server. In the image below, the Pentaho BI Server is started on Tomcat. The Pentaho Solution Repository
(MySQL) is also started.

Note:  Right-click on the BI Server or Solution Repository in the Services window to start or stop
them. Alternatively, you can start the BI Server by navigating to Start -> Programs -> Pentaho
Enterprise Edition  -> Server Management -> Start BI Server. The MySQL database starts
automatically when you log on to your device.

Logging into the Pentaho User Console

To log into the Pentaho User Console...

1. Go to Start -> Programs -> Pentaho Enterprise Edition -> Server Management -> Start BI Server.
2. If required, open a browser and navigate to http://localhost:8080/ or http:yourhostname:8080.
3. Enter the credentials (joe/password) to open the Pentaho User Console home page. Joe is a sample

user with administrative privileges to the Pentaho User Console.

Note:  Alternatively, (after you started the BI Server), go to Start -> Programs -> Pentaho
Enterprise Edition  ->  User Console Login.
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Logging into the Pentaho Enterprise Console

To log into the Pentaho Enterprise Console...

1. Go to Start -> Programs (or All Programs) -> Pentaho Enterprise Edition  ->  Enterprise Console
Login.

2. If required, open a browser and navigate to http://localhost:8088/ or http:yourhostname:8088.
3. Enter your credentials (admin/password) to open the Pentaho Enterprise Console home page.

Introduction to the Pentaho User and Enterprise Consoles

The Pentaho User Console (shown below) provides centralized access to reports, analysis, and
dashboards. You and your users can interact with, share, or create new BI content with the Pentaho User
Console. To look at sample reports, dashboards, Analyzer reports, and more, open the Steel Wheels
folder. To learn more about the Pentaho User Console, go to Help -> Documentation. Click the Toggle
Browser button (shown below) to display the samples directory.

The Pentaho Enterprise Console (shown below) provides you with a central location from which to
administer your Pentaho deployments. The console simplifies many common administrative tasks such
as setting up user authentication, monitoring performance, managing connections, testing configuration,
configuring LDAP, and much more. Click  (Help) -> Documentation to learn more about the Pentaho
Enterprise Console.
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The Data Integration Server

The Pentaho BI Suite installation provides you with a complete set of Business Intelligence tools, including
the Data Integration server, a dedicated ETL server.

Among other things, the Data Integration server...

• Executes ETL jobs and transformations using the Pentaho Data Integration engine
• Allows you to manage users and roles (default security) or integrate security to your existing security

provider such as LDAP or Active Directory
• Includes content management providing the ability to centrally store and manage your ETL jobs and

transformations which encompasses full revision history on content and features such as sharing and
locking for collaborative development environments

• Allows you to schedule activities and monitor scheduled activities on the Data Integration server from
within designer environment

Configuring the Enterprise Console

The Data Integration Server is an independent, separate server from the Pentaho BI Server. The Pentaho
Enterprise Console can be used to manage the BI Server, the Data Integration server, or both. If you are
setting up a dedicated server for ETL, follow the instructions below to configure the Pentaho Enterprise
Console to display administrative functions associated with Pentaho Data Integration exclusively.

1. Click  (Setup) in the upper-right corner of the Pentaho Enterprise Console home page.
The Pentaho Enterprise Setup page appears.

2. Enable Running Data Integration Server Only.
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3. Click OK to exit the setup page.

The Pentaho Enterprise Console displays a page that contains information associated with Pentaho Data
Integration. For more information, see Getting Started with Pentaho Data Integration available in the
Pentaho Knowledge Base.
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Creating an Ad Hoc Report

Ad Hoc Reporting allows you and your users to create a basic data-driven report quickly and efficiently.
With Ad Hoc Reporting, users do not need to know the structure of the database, nor do they need to know
any SQL. A metadata model created with the Pentaho Metadata Editor, (a graphical user interface for
creating user friendly metadata models), acts as a buffer between users and the complexities of relational
data sources. The Pentaho BI Suite comes with three pre-built business models (datasets).

Note:  What is metadata? Quite simply, metadata is "data about data." For example, a library
catalog is considered "metadata" because it contains information about books and other
publications. A metadata model, is a collection of related categories of data.

You can quickly access data in your own relational database or CSV flat file for evaluation or testing
purposes. To find out more, see Using the Data Sources Feature in the Pentaho User Console on page
64 .

Ad Hoc Reporting Interface provides...

• Easy-to-create connections to your relational or CSV (flat file) data sources for evaluation and testing
purposes

• Interactive ”drag and drop” Web interface for business user self-service report creation
• Wizard-driven authoring supporting report templates, metadata-based query creation, sorting, and

filtering
• Interoperability with Pentaho Report Designer allowing ad hoc reports to be “promoted” for fine-tuning

by IT professionals
• Single reporting engine for ad hoc and pixel-perfect reports for lowest possible total cost of ownership

To create an ad hoc report, you must logged onto the Pentaho User Console.

1. In the Pentaho User Console click Create New Report.
The ad hoc query wizard starts.

2. In the first step of the wizard, select Orders from the list under Select a Data Source.
As you become more familiar with Ad Hoc Reports features, you can add your own relational or flat
file (CSV) data sources to ad hoc reports. See Using the Data Sources Feature in the Pentaho User
Console on page 64 for more information.
The tables associated with the Orders data source are listed in the Details pane.

3. In the Apply a Template field, select a predefined report template.
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A thumbnail preview of the template appears in the Template Details field. A template specifies a
variety of properties in the report that affect its appearance, like font size and background colors for
various report elements.

4. Click Next.

5. In the Available Items list, click the Territory business column and drag it to the upper right into the
Level 1 box.

This determines how the data is grouped.

6. Drag and drop the Amount and Buy Price into the Details box on the right.

This determines which fields to display for the given groups.

7. Click Go to preview how these new items have affected the report, then close the preview tab when
you're done.

8. Click Next.

9. Click the Territory item in the Groups list.

A list of general options appear on the right.

10.Click Center.

This centers the territory name above each table, making it easier to read.

11.Click Amount, then click Add in the Sort Detail Columns area on the right.

This sorts the sales amounts from lowest to highest.

12.Click Go to test the new change, or Next to continue to the next part of the wizard.

13.To set the header, footer, description, paper type, and page orientation, change the on-screen values
for these elements accordingly.

PDF is the only output type that has a concept of a page, so the Page portion of the Header and
Footer sections only applies to PDFs.

14.Click the blue Save button in the top toolbar to save your report. In the ensuing file dialog, navigate to
the location you want to save the report to, and type in a filename for the report.

You can continue to modify your report after it's been saved; just click Save to update the report file
after you've made changes.

You now have a report that shows how much revenue is coming from each sales territory, and the itemized
price of each purchased product. As you can see, ad hoc reporting provides business users with a quick
and simple solution for building basic reports. For report designers who need access to more advanced
features like pixel perfect layout, conditional formatting, or parameterization, Pentaho provides the full-
client Report Designer.
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Analyzing Data with Pentaho Analyzer

Pentaho Analyzer is the front-end interface of the Pentaho Analysis product line. Using Pentaho Analyzer,
you can query the data in a database without having to understand how the database is structured.
Pentaho Analyzer allows you to explore your data dynamically. You can drill down into the data to discover
hidden details that may help you make important business decisions. Pentaho Analyzer also presents data
multi-dimensionally and lets you select what dimensions and measures you want to explore.

Pentaho Analyzer is an interactive analysis tool; it provides you with a rich drag-and-drop user interface
that allows you to create reports quickly based on your exploration of your data. You can also display
Pentaho Analyzer reports in a dashboard.
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Creating a New Analyzer Report

In this exercise of the Pentaho Analyzer you will be creating a report that displays the actual versus
budgeted expenses by region for each department in the fictitious Steel Wheels company (SampleData).

Follow the instructions below to start creating an Analyzer report.

1. In the Pentaho User Console menubar, go to File -> New and select Analyzer Report.
Pentaho Analyzer opens.

2. Select your Schema and Cube from the corresponding lists. For the purposes of this exercise, select
SampleData and Quadrant Analysis, respectively.

Note:  The list of available schemas and cubes are provided by your administrator. A schema
is the structure of the relational database and includes tables, fields, views, and more. A cube is
a data structure that allows information in a database to be analyzed quickly and from multiple
perspectives.

3. Click OK.
A blank report appears.

4. In the list of fields (on the right), click and drag Department to the Analyzer workspace in the left pane.
The Department column appears in the workspace.

5. Click and drag the Budget and Actual fields to the workspace.
The columns appear in the workspace in the order in which they were placed.

6. Right-click the Budget column to display the Edit Column dialog box. Select Column Name and
Format -> Currency ($) from the Format list so that your values display as dollar amounts. Repeat this
step for the Actual column.

Note:  If you need help to understand the options in any Pentaho Analyzer dialog box, click
Help.

7. Click and drag the Region column to the report. (Read the note below.)

Note:  Notice that the Region column appears in the workspace; however, you want this column
to be the first column in the report.
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8. In the workspace, click and drag the Region column to the left of the Department column.

Pentaho Analyzer is designed to provide you with great flexibility when designing the visual structure of
your report.

9. At this point you have a functioning report and you can view your data in chart form. Click  (Switch to
Chart Format) to examine your report data in a chart format. The default display is a bar chart but if you
click  (Choose Another Chart Type) you can select a different chart type to display your data.

10.Save your report before continuing the exercise. In the Pentaho User Console, click  (Save As).
When the Save As dialog box appears, save your report as Regional Expense Report under /Steel
Wheels/Analysis and click OK.

Enhancing the Pentaho Analyzer Report

You have created a working Analyzer report; however you can make the data in the report more useful if
you can show the difference, in dollar amounts, between the actual and budgeted expenses.

Follow the instructions below to enhance your report.

1. In the Pentaho User Console menubar, go to File -> Open.
2. Browse to /Steel Wheels/Analysis and select Regional Expense Report.
3. Click  (Switch to Table Format) if you are in chart mode when the report appears.
4. Right-click the Actual column and select User Defined Number -> Calculated Number.

The New Calculated Number dialog box appears.
5. In the Name field, type Difference.

This step creates a new column in the report.
6. Select Currency ($) from the Format list so that the data in your report displays as dollar amounts.
7. In the right pane of the dialog box, click  so that a minus sign appears next to [Actual]-.
8. Click Budget in the left pane and click  to move it to the right pane so that you create a formula that

subtracts the budgeted expenses from the actual expenses, [Actual]-[Budget]. Click OK.
The Difference column appears in the report.

9. Right-click the Region column and select Show Subtotals.
The subtotals for each region is displayed in the report.

10.Save the report.

Adding Filters to an Analyzer Report

Filters are used to restrict or limit the data that is presented in a report. For example, a report shows sales
by product line. A filter on Quarter restricts the data so that sales for the fourth quarter in 2006 only are
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shown. If you were to add a regional filter of Europe, the report displays data pertaining to European sales
in the fourth quarter of 2006, exclusively. If you were to add a filter on the Product Line field to exclude
Surfing, the report displays data pertaining to European sales in the fourth quarter of 2006 that are not in
the surfing product line, exclusively.

Follow the steps below to add a filter to your sample report:

1. Open the Regional Expense Report.

2. Under the report name click Show/Hide Filters next to No Filter in Use.
A workspace for filters appears at the top of the report.

3. Click and drag the Region field/column into the filter workspace.
The Filter on Region dialog box appears. Notice that the values, (Central, Eastern, Southern, and
Western), associated with the Region field are listed in the dialog box. You can choose one of these
values or you can enable Match a specific string to filter the report on a specific string of data.

4. Select Eastern from the list of values and click  (Add Selected) to move it into the right pane.
Eastern appears with a green checkmark next to it in the right pane.

5. Select Western from the list of values and click  (Add Selected) to move it into the right pane.
Western appears with a green checkmark next to it in the right pane.

6. Click OK to exit the dialog box.
Your sample report displays data for the Eastern and Western regions only.

Note:  You can click Undo or Reset to return to the previous version of the report.

7. Click OK and save your report.

Exporting the Analyzer Report

Pentaho Analyzer allows you to export your report as a PDF, a Microsoft Excel spreadsheet, or a CSV file.

Follow the instructions below to export your report:

1. In the Pentaho Analyzer toolbar, click More and select Export Report.
The export options list appears.

2. Select Export to PDF.
A PDF of the report appears.

3. Examine your report.

Notice that Pentaho Analyzer appends metadata about the report itself in the PDF. Information about
the report author, the location of the source file, fields used, filter summary, are included.
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Working with Dashboards

A dashboard is a management tool that helps you measure your company's "vital signs" quickly and
efficiently. Instead of relying on outdated paper reports to make important business decisions, a dashboard
delivers current and relevant information to employees through the use of a combination of graphs,
scorecards, and report components. Because dashboards tend to be highly visual, they are easy to read
and interpret providing employees quick access to information that helps them answer critical questions
about the performance of their specific departments. With just a few mouse clicks, employees will know if
a plan they are implementing is effective, how it compares to the competition, and any other metrics you
define. Best of all, they can access this type of information easily — from any location around the world
over the Web.

Dashboard Designer empowers business users to create rich, interactive dashboards with little or no
training. Creating a dashboard is as simple as selecting your layout, theme, and the content you want to
display. This content can include reports, charts, or even interactive Pentaho Analyzer reports. Dashboard
Designer also provides you with the ability to add dynamic filter controls making it easy for dashboard
consumers to filter the entire contents of their dashboard using a simple pick list.

You can quickly access data in your own relational database or CSV flat file for evaluation or testing
dashboard capabilities. To find out more, see Using the Data Sources Feature in the Pentaho User
Console on page 64 .

The Dashboard Designer allows you to display the following content types in your dashboard:

• Chart — When selected, opens the Chart Designer that allows you to create bar, line, area, pie, and
dial charts for display in your dashboard.

• Data Table — When selected, allows you to display database-related content in tabular format.
• File — When selected, opens a browser window that allows you to locate a file (.xaction or .prpt) that

contains the content, usually a report or chart, you want to display in your dashboard.
• URL — When selected, opens a dialog box that allows you to enter the URL of the Web site you want

to display in your dashboard.

Defining Your Dashboard Look-and-Feel

You must be logged on to the Pentaho User Console. Follow the instructions below to create a new
dashboard:

1. In the Pentaho User Console quick launch bar, click New Dashboard. Alternatively, you can click File >

New > Dashboard or click  (New Dashboard) in the tool bar. The New Dashboard page appears.

2. In the edit pane (lower portion of the page), click Properties, and type My Dashboard in the Page Title
text box. This is the title for your dashboard page.
The name you entered appears on the top left corner of the dashboard. This name helps you identify
the page if you want to edit, copy, or delete it later.

3. Click Templates to select a dashboard layout. Select the 2 by 2 template.

A blank dashboard with the layout you selected appears.

4. Click Theme to select a theme for your dashboard. Select the Cool Blue theme.
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The theme you selected is applied to your dashboard.

Working with the Chart Designer

The Chart Designer allows you to create bar, pie, line, dial, and area charts that can be added to a
dashboard. Below are the general steps associated with creating a chart:

1. Selecting a data source and building a query
2. Setting the data definitions: values, series, category
3. Selecting a chart type and theme
4. Entering labels for the chart title, and x,y axes
5. Adjusting scaling and label rotation (if applicable)
6. Placing your chart in the dashboard.
7. Saving your dashboard

Adding Data to Your Chart

Before you create a chart you must select a data source that contains the data you want to use. You must
then define the data that will be displayed in the chart.

Follow the instructions below to add data to your chart:

1. In the Dashboard, choose a dashboard panel and click  (Insert) and select Chart.
The Select a Data Source dialog box appears.

2. Select the Orders data source. This data source contains the content you want to display in your chart.
The Query Editor appears.

3. The Query Editor allows you to retrieve dynamic data from a database for display in a chart. Defining
your query is the first step in ensuring that the correct data is selected. In the Query Editor, click (+) next
to a category name to display its associated table columns.

4. Click the small yellow arrow to place the column name, Customernumber, under Selected Columns.
In the example below, the Customernumber column has been selected and moved under Selected
Columns. Expand the Orders category, select and place the Status and Total columns under Selected
Columns.



24 |  | Working with Dashboards

5. Now add the Conditions; these are your constraints that filter what you are selecting. Although you can
designate multiple conditions, for this exercise, the search is limited to customer numbers 144 and 145.

Under Combine, select the OR constraint from the drop-down list. Under Comparisons, click the drop-
down list to display options for comparisons, =, <, >, and so on; (for example, where the customer
number is equal to 144 or 145). In this exercise, you are not selecting an aggregate type. See the
Pentaho User Console Guide for information about aggregation.

Note:  For information about adding parameters in the Query Editor, see Assigning Parameters
in the Query Editor.

Note:  Click Preview at any time to view the data associated with your query.

6. Click OK.
The Chart Designer appears.

7. Under Data, click the drop-down arrow to display and select the table columns as shown in the example
below:
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Data Definition Description

Series Series show up as the individual columns
on a bar chart and as individual lines in
a line chart. Area charts display each
series as a point.

Category Categories are displayed as bars or
groups of bars on the y-axis (vertical
axis). In line charts, categories are
usually associated with time periods.
In area charts, the x-axis displays the
category labels.

Note:  If you don't want to display
categories, select None.

Values The value is always numeric. The value
determines the height of columns in a
bar chart and the height of lines in a line
chart. In area charts, the y-axis values
determine the heights of the points.

A preview of the chart appears in a box in the upper-right corner of the Chart Designer as you select
your options. The bar chart is the default chart type for displaying your data.

8. Under Chart Type, click on a chart type to select to examine your data displayed in an area, dial, or pie
chart. Refer to the Pentaho User Console Guide for more information about chart types.

9. Under Theme, select the Primaries theme from the list.
The theme is applied to your chart.

10.Enter the labels for the Chart Title, X Axis Title (horizontal axis), and Y Axis Title (vertical axis). Type
Customers 144 and 145 for your Chart Title, Status for your X Axis Title, and Total Orders for your Y
Axis Title.

11.Click Apply to see the chart preview.
Your entries are displayed in the chart preview as shown in the example below.
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Note:  To edit your chart, see Editing a Chart.

12.Click OK display your chart in the dashboard panel.

Correcting Scaling Issues

Use the scaling feature in instances where numeric values in a chart are so long that they affect the
display.

1. Preview your chart in the Chart Designer.
2. Under Scale, click to display the drop-down list of scaling options. In the example below, the scaling

option used is "1000." Notice the change in the display of numeric values when scaling is applied.
Users of the chart can see actual values when they hover over the bars in the chart.

3. Click Apply to display the chart in the dashboard.

Note:  The scaling feature is available for all chart types except pie.

Rotating Chart Axis Labels

If your chart axis labels become unreadable because they are too long, Label Rotation may correct the
problem.

1. In the Chart Designer, display your chart.
2. Under Label Rotation, select Diagonal or Vertical and click Apply.

The labels display with the rotation you set.
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3. Click OK to display the chart in the dashboard panel.

Editing a Chart

Follow the instructions below to edit a chart.
1. In the Dashboard Designer, select the panel that is displaying the chart you want to edit.
2.

In the upper right corner of the panel click (Edit)
The Chart Designer appears.

3. Click Edit Query.
The Query Editor opens.

4. Edit the query as needed and click OK.
The Chart Designer appears.

5. Select the appropriate data definitions to build the chart.
6. If applicable, change the chart type and theme and click Apply to see a preview of the edited chart.
7. Click OK to display the chart in the dashboard.

Note:  See also, Editing Your Dashboard on page 44

Adding a Data Table to a Dashboard

The Data Table feature allows you to display a tabular representation of a database query in a dashboard.
It also allows you and consumers of the dashboard to manipulate the data in the data table, while in the
dashboard. For example, users can resize, sort, and change the order of columns. Follow the instructions
below to add a data table to your dashboard.
1. Select Panel 2 in the Dashboard Designer.
2. Click  (Insert) and select Data Table.

The Select a Data Source dialog box appears.
3. Select a data source from the list of available data sources and click OK.

Note:  The data sources in the list are defined by an administrator.

The Query Editor opens.
4. Begin building your query. Click (+) next to the category name to display its associated table columns.

When the column names appear, click to select the column that contains the data you want displayed in
your data table.

5. Click the small yellow arrow to place the column name under Selected Columns.
6. Now add the Conditions; these are your constraints that filter what you are selecting. You can add

multiple conditions.
Under Combine, you can select your constraint (and, or, and not, or not) from the drop-down list. Under
Comparisons you can click the drop-down list to display options for comparisons, =, <, >, and so on;
(for example, where the customer number is equal to 144 or 145). You can also select an aggregation
type from the drop-down list for table columns that contain numeric data. The table below contains a
definition for each aggregate type:

Aggregate Type Description

SUM Sums a column's values

COUNT Counts a column's values

AVG Averages a column's values

MIN Selects the minimum column value

MAX Selects the maximum column value
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Note:  Click Preview at any time to view the data associated with your query.

7. Add the columns that you want to Order By. The ordering of the selected data is accomplished by one
or more columns in a table. For example, you can sort the data by customer name and address.

8. Click OK in the Query Editor when you are done.
The Data Table appears in the dashboard panel.

Updating the Data Table Display

You can edit the data table display directly in the dashboard panel.

Sorting Column Data

To change the sort order data under a column, click the drop-down arrow in the header and choose Sort
Ascending or Sort Descending. You can also hide one or more columns by disabling the appropriate
check boxes next to the column names.

Adjusting Column Width

You can adjust the width of a column by clicking the right border of the column header and dragging it to
the right or left. Release the mouse button when you are done.

Moving Columns

To move the placement of a column, click and drag the column it to the appropriate location in the Data
Table as shown in the example below:
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Paginating

The pagination feature allows you to page through a large number of records.

Displaying a Report Designer (.prpt) File in the Dashboard

Follow the instructions below to display a report created in Report Designer and in a dashboard.

1. Select a panel in the Dashboard Designer.

2. Click  (Insert) and select File.
A browser window opens.

3. Locate the appropriate report file. Report Designer files have a .prpt extension.

4. Click Select to place the report inside the dashboard panel.

Pagination control arrows at the top of a report allows you to scroll through long reports. Notice that the
report file name, NewReport.prpt, appears under Content: in the dashboard edit pane in the sample
below. This sample report contains parameters, (Additional Title-Text, Output Type), that do not have
default values. You can enter values manually and link them to a dashboard filter in the text boxes
under Source. When the report renders again, the parameter value(s) you entered are included in the
report.
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Important:  If you select a Report Designer file to place in a dashboard, but do not supply values
for required parameters, the report will show up blank.

Displaying an Analyzer Report in a Dashboard

Follow the instructions below to display an Analyzer report in a dashboard.

1. Select a panel in the Dashboard Designer.
2. Click  (Insert) and select File.

A browser window opens.
3. Locate the appropriate Analyzer report and click Select.

The Analyzer Report appears inside the dashboard panel.
4. Save your dashboard. See Saving Your Dashboard.

Displaying an .xaction File in the Dashboard

Follow the instructions below to display the contents of an .xaction file in a dashboard.

Note:  Generally, .xaction files are provided to you by an administrator. A file may contain a report, a
chart, or other type of content.

1. Select a panel in the Dashboard Designer.
2. Click  (Insert) and select File.

A browser window opens.
3. Locate the appropriate .xaction file.
4. Click Select to place the contents of the file inside the dashboard panel.

Notice that the file name, Sales Year Over Year, appears under Content: in the dashboard edit pane
of the sample below. This sample chart contains parameters, (screen_res, Region), and default values
(large, NA).
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Displaying a Web site in a Dashboard

Follow the instructions below to display contents of a Web site in a dashboard panel.

1. Select a panel in the Dashboard Designer.

2. Click  (Insert) and select URL.
The Enter Web site dialog box appears.

3. Enter the Web site URL in the text box and click OK.

In the example below, a search parameter has been added to the URL.

When the parameter displays in the edit pane of the dashboard, you can enter a value for the
parameter in the text box next to the parameter name.
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4.
If applicable, click (Edit) to make changes.

5. Save your dashboard when you are done.

Working with Filters

Filters allow you to display a subset of data based on the dashboard user's point of view. For example, the
dashboard user's point of view of Region may be "East;" his or her point of view of Time may be, "Fourth
Quarter." Pentaho Dashboards allows you to designate a point of view based on the filters in your source
data.

Dynamic filters make it easy for dashboard users to customize the information that they want to see;
static filters display specific information by default. The Dashboard Designer also allows an administrator
or design engineer to use a SQL-based query that dynamically retrieves a list of display names and
corresponding values directly from a relational database as shown in the example below. In this example,
users of the dashboard are able to view data associated with customer ID numbers below 130:

Follow the steps below to create a simple static filter:

1. Go to the File menu, then select Dashboard from the New sub-menu.
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A New Dashboard page appears with the default 2 by 2 template selected.
2. Click the Properties tab near the bottom of the page to change to the Properties pane.

The only property you can set is the page title.
3. Type in Territory Sales Performance in the Page Title field and click General Settings.

The new title appears in the upper left corner of the dashboard as soon as you click outside of the
Properties pane.

4. Click back to the Templates tab and then select the two-column dashboard template from the
horizontal list.
The dashboard template changes from four panes to two.

5. Click the Theme tab to switch to the Theme pane.
6. Select the Cool Blue theme.
7. In Objects list on the left, click the Untitled 1 item.
8. In the upper right corner of the Untitled 1 panel click the Insert Content down arrow and choose File.

In the browser, navigate to /steel-wheels/Dashboards/Widget Library/KPIs/Sales Year/Year and
click Select.

9. In the Title field on the right, type Yearly Sales Trend.
10.Click Apply to show the content in the left pane.
11.Click Untitled 2 in the Objects list to switch to the right panel.
12.In the upper right corner of the Untitled 2 panel click the Insert Content down arrow and choose File.

In the browser, navigate to /steel-wheels/Dashboards/Widget Library/KPIs/Productline Mix - Total
Sales (flash) and click Select.

13.In the Title field on the right, type Product Share.
14.Click Apply to show the content in the left pane.
15.Click Filters in the Objects list.

The Filter Editor appears on the right.
16.Click the Show Filter Toolbar checkbox.

This toolbar enables user-interactive controls at the top of the dashboard.
17.

Click  in the upper right corner of the Filter Editor.
The Filter Properties dialog box appears.

18.In the Name field, type Territory.
This is display name for the filter control label.

19.Enable Display Name as Control Label if you want users to see the display name in the filter toolbar.

Note:  Notice that there are several filter controls from which to choose; however, you will be
using the default selection, Drop Down. Also, keep the default Data Type, Static List.

20.
In the Filter Properties dialog box, click .
The List Value dialog box appears.

21.Type North America into the Label field, and NA in the Value field, then click Add.
22.Add two more list values for Europe/EMEA and Asia Pacific/APAC, then click Close.
23.Click OK in the Filter Properties dialog box to finish creating the filter list.

A drop-down box will appear in the filter toolbar at the top.
24.In the Objects list, click Yearly Sales Trend.
25.Under the Parameters tab, next to Region, click the down-arrow and select Territory.
26.Repeat the previous step for Product Share.

You now have a functional dashboard that shows bar and pie chart data filtered by sales region. To switch
to a different region, select it from the Territory drop-down box in the upper left corner of the dashboard.
You can now save your dashboard and share it normally through the Pentaho User Console. Go on to the
next exercise to create a cascading filter.
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Creating a Cascading Filter

A cascading filter changes based on a value a user selects. When the value in the drop down list (Country)
changes, the filter is automatically applied to the second filter, (the City checkboxes) thus changing its
values.

The example above was created using a Metadata List for the drop down filter control and a SQL List for
the checkbox filter control.

Follow the instructions below to link the drop-down filter to the checkbox filter.

1. In the dashboard page, under General Settings, select Filters.
The Filter Editor appears on the right.

2. To display a filter toolbar to users of the dashboard, enable Show Filter Toolbar.
A placeholder for the filter toolbar appears at the top of the dashboard.

3.
Click  (Add) to add a filter.
The Filter Properties dialog box appears.

4. In the Filter Properties dialog box, type Country as the Name for your filter.

5.

Click on the Drop Down filter control icon ( ) to display your list of countries.
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Note:  The drop down control is the default selection.

6. Under Type, select Metadata List.
7. Click Select to choose Orders as the data source that contains the content you need for setting options

from the drop-down list. Click OK.
The Query Editor opens.

8. In the Query Editor, build a query. Expand the Customer node under Categories/Columns and select
Country. Click  (arrow) to place the column name, Country, under Selected Columns as shown in
the example below.

9. Click Preview to ensure that the query produces the correct results, then click OK to exit the Query
Editor.
Your options appear under Selected Items in the Filter Properties dialog box.

10.Under Control Properties, type USA in the Initially Selected field. Select Country as your default
Label/Value for the initially selected  option in your filter control.

11.Click OK to exit the Filtered Properties dialog box.
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The Country filter appears at the top of the dashboard.

12.To create your City filter, select Filters under General Settings.

13.
Click  (Add) to add a filter.

14.In the Filter Properties dialog box, type City as the Name for your filter.

15.

Click to select the checkbox filter control.

16.Under Type , select SQL List.

17.Under Connection, keep the default, SampleData.

18.
Click  (Edit) to open the Query dialog box. Type the following query and click OK.

select distinct city from customers where country = ${selected_country}

The dollar sign and brackets around the country value, ${selected_country}, parameterizes the query
allowing the City filter to be driven by Country filter you created previously.

Click Test to validate query results.

The parameter, selected_country appears in the lower portion of the Query dialog box.

19.Under Default Value, type USA. Click Test to see results.

20.Click OK to exit the Query dialog box.

21.Under Control Properties, type NYC in the Initially Selected textbox.

22.Click the Parameters button in the Filter Properties dialog box .

23.Under Source, click the down arrow and select Country as the new value for the selected_country
parameter; click OK.
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24.Under Display, choose Horizontal, so that the City checkbox filter control displays the cities
horizontally.

25.Click OK to exit the Filter Properties dialog box.

The City filter control appears at the top of the dashboard. Now, you can add a chart, data table, or report
to the dashboard and use the cascading filter to drive the content in your dashboard.

Linking Your Filter Control to Dashboard Content

In the previous exercise, you created a cascading filter. Now, you must add some content to your
dashboard that can be driven by your filter.

1. In the Dashboard, choose a dashboard panel and click  (Insert) and select Chart.
The Select a Data Source dialog box appears.

2. Select the Orders data source. This data source contains the content you want to display in your chart.
The Query Editor appears. You will be creating a query that will give you total sales per city.

3. Under Categories/Columns, expand the Orders node and select ,Total.
4. Click  (arrow) to move the Total column under Selected Columns on the right.
5. Under Categories/Columns, expand the Customers node and select, City.
6. Click  (arrow) to move the City column under Selected Columns on the right.
7. Click  (arrow) to move the City column under Conditions on the right.
8. Under Value, type {city}; for the Default, type NYC|Las Vegas.

This parameterized condition ties the content in your dashboard panel to the cascading filter you
created. Your completed query should look like the example below.

9. Click OK to exit the Query Editor.
The Chart Designer opens.
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10.Under Type, select Pie Chart. Set the Series Column to City. and the Values Column to Total. Type,
Sales Percentage by City, as your Chart Title.

11.Click OK to exit the Chart Designer and return to the dashboard.
The dashboard displays the pie chart. Notice that the default values to entered in the Query Editor are
reflected in the chart, which displays sales percentages for NYC and Las Vegas.

12.If not already selected, click the dashboard panel that contains the chart. It should be labeled, Untitled
1. Now, you are going to change the source value for the {city} parameter from NYC/Las Vegas to
City.

13.Click Apply.
In the dashboard, you can now click the checkboxes next to mutltiple cities and watch the chart update.
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14.Save your dashboard. See Saving Your Dashboard on page 43 for instructions.

Working with Parameters

If you are placing a file, such as an .xaction or .prpt, inside a dashboard panel, it is possible that the author
of the file, defined meaningful parameters for the content. If previously defined, the parameters and their
associated default values, appear under Parameters in the edit pane of the dashboard. In the example
below, when the chart initially rendered, it displayed a parameter called, "chart_type" with a default value
called, "bar." A user can change the value of the parameter to see the content rendered as a pie, line, or
area chart.



40 |  | Working with Dashboards

Parameter names are "hard-coded," in the file; that means they cannot be changed. Neither can you
change the number of parameters associated with a file. When you create a chart using the Chart
Designer, embed a URL into a dashboard, or create a data table, you can change both the name and value
of a parameter.

Adding Parameters to a Chart or Data Table Using the Query Editor

When you place a chart in a dashboard panel, you use the Query Editor to retrieve data from a database
for display on your chart or data table. If applicable, you can add Conditions or constraints that filter the
data so that the chart or data table displays the information you want dashboard consumers to see.

Using parameters is critical if you plan on using dashboard filters or linking content in one dashboard panel
to content on another dashboard panel. For example, suppose you create a pie chart and you want to filter
details associated with an exploded pie slice in the adjoining data table as shown in the example below. In
this instance, you must use a parameter that allows the data table to update when a dashboard consumer
clicks on a pie slice. Optionally, you can parameterize the query condition so that the content is updated
based on a user interaction, such as changing a filter value.
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To create a parameter, in the Value field, type the name of the parameter inside curly braces, as in
{Parameter Name}. In the example below, the designer created a parameter called, {TERRITORY};
the default value, or source, for the parameter is, "NA" (North America). When a chart or data table
renders, it displays data associated with North America. Remember that this a default value. When you
enclose a parameter name with curly braces, you are creating a parameter query. That means, that users
can change the query dynamically by replacing the default, "NA," with a different territory acronym, (for
example, EMEA), when the query runs.

You can define two defaults by adding a pipe (|) between the values, as in NA|EMEA.

Suppose a dashboard designer chooses to limit the data to North America (NA) exclusively? In this
instance, he or she would not include the curly braces around "NA," (as shown in the example below), and
Default (value) is disabled. This is an example of a static query.

Using Content Linking to Create Interactive Dashboards

Depending on your needs, you can create a "static" dashboard, which contains content in each panel
that is separate but related. For example, you may provide users with a bar chart that contains total sales
figures by region. Additionally, you may provide a data table that displays sales details for each state in a
specific region. You may also want to provide sales data associated with each salesperson in a specific
region. The content in your dashboard is useful to dashboard consumers, but to make it more "interactive,"
you may want to consider using content linking.

The content linking features in dashboards allow you to associate (link) content in one dashboard panel
to content on another dashboard panel as long as query parameters have been defined. These features
are particularly helpful for drilling down or for dynamic filtering; for example, when dashboard consumers
explode a single slice in a pie chart to launch content in a data table associated with that pie slice. In this
instance, dashboard consumers are moving from a summary view to a detailed view interactively.
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You can use content linking if your dashboard panel contains a data table, chart, .xaction, .prpt, and
Analyzer report.

Content Linking and Query Parameters

Query parameters are required for content inside a dashboard panel to receive values used to filter data
from a filter control. They are also required when receiving values from content in other dashboard panels
that are broadcasting values associated with Content Linking. The way in which query parameters are
defined is different depending on the type of content you are placing inside your dashboard panels:

Linking a Chart to a Data Table

In previous exercises, you created a cascading filter and you added a pie chart to a dashboard panel that
could be driven by your filter. Now, you will add a data table to your dashboard. When you click on a pie
slice, the data table with update with associated information.

1. Use the Pentaho User Console browser on the left to find your dashboard. It should be under Steel
Wheels -> Dashboards -> Product Sales .

Note:  If you don't see the browser, click  (Toggle) in the console toolbar.

The dashboard opens. Click  (Edit) from the console toolbar to go into Edit mode.

2. Select the dashboard panel that contains the pie chart and click the Content Linking tab.

3. Click the check box next to the field name, City and click Apply.

This step enables content linking on the chart series; in this example, the chart series is City. When you
enable content linking on a chart series, you make the series value available as a source of parameters
for content in other dashboard panels.

4. Select a dashboard panel and insert a Data Table.

5. Select the Orders data source and click OK.

6. In the Query Editor, create a query as shown in the sample below. Select the Customer Name, City,
and Total columns. Add a parameterized condition, {city} with a default of NYC.

7. Click OK to exit the Query Editor and return to the dashboard.
The data table displays in the dashboard.

8. Click the Parameters tab and select Untitled 1 - City as the new Source for the city parameter.
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9. Save your dashboard.

When you click a pie slice , the data table displays content associated with that specific pie slice.

Saving Your Dashboard

Follow the instructions below to save your dashboard:

1. In the toolbar, click  (Save) to open the Save dialog box.

2. In the File Name text box, type Product Sales.

3. Save your file in the .../steel-wheels/dashboards directory. You can do this by double clicking
the Steel Wheels folder the Dashboards folder.
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4. Click Save.

Editing Your Dashboard

Follow the instructions below to edit an existing dashboard:

1. In the lower left corner of the Pentaho User Console, (under Files), select an existing dashboard file.
The dashboard panels and their related content appear.

2.
Click  (Edit) from the console toolbar to go into Edit mode.

3.
Click  (Edit) in the upper-right corner of the dashboard panel you want to edit.

Note:  Some content such as action sequence files (.xaction) and Report Designer files (.prpt)

cannot be edited directly in the dashboard. In such instances,  (Edit) is disabled.

4. Make your changes as needed.

5. In the toolbar, click (Save As) to open the Save As dialog box.

6. In the File Name text box, type a file name for your dashboard. Alternatively, use the up/down arrows or
click Browse to locate the solution (content files) directory in which you will save your dashboard.

7. Click Save.
The name of your dashboard file appears in the list under Files in the lower left portion of the Pentaho
User Console.

Displaying Your Dashboard

After you save your dashboard go to the Tools menu and click Refresh Repository Cache. Your
dashboard appears in the User Console under Dashboards.



 | Creating a Report Using Report Designer | 45

Creating a Report Using Report Designer

Pentaho Reporting provides unmatched deployment flexibility. Whether you’re looking for a standalone
desktop reporting tool, Web-based reporting, or comprehensive business intelligence (BI) including
reporting, analysis, and dashboards, Pentaho Reporting allows you to “start small” and scale up if your
reporting needs grow in the future.

The Pentaho Report Designer provides you with the following features:

• Drag-and-drop graphical designer that gives users full control of data access, layout, grouping,
calculations, charting and formatting for pixel-perfect reports

• Integrated, step-by-step wizard that guides report designers through the design process
• Report templates that accelerate report creation and provide consistent look-and-feel

The Report Designer allows you to create a report by following a four step wizard; however, to show you
a larger range of features, the exercises that follow walk you through the manual procedures for creating
a simple report. Keep in mind that is basic tutorial and will not provide details about advanced Report
Designer features.

1. Start the Report Designer. Go to Start -> Programs -> Pentaho Enterprise Edition  -> Design Tools
-> Report Designer.
The Report Designer home page appears.

2. Click New Report in the Welcome dialog box.
The design workspace appears.

3. In the right pane, click the Data tab.
4. For the purpose of this exercise, right-click Data Sets and choose JDBC. Alternatively, you can click

the yellow database icon to display the JDBC dialog box.
The JDBC Data Source dialog box appears.

5. Under Connections, select SampleData (Memory).
6.

Next to Available Queries click  (Add).
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Query 1 appears under Available Queries. Notice that the edit icon  is enabled.

7.
Click  (Edit).
The Query Designer window appears. The Query Designer provides you with a graphical environment
that allows you to work with the data even if you don't understand SQL, the standard programming
language for retrieving content from databases.

8. Double-click ORDERFACT so that the table appears in the workspace as shown in the image above.

9. In the Query Designer workspace, right-click "ORDERFACT" and choose deselect all.
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10.Now, select the following fields in the ORDERFACT table: ORDERNUMBER, QUANTITYORDERED,
PRICEEACH, and ORDERDATE.

11.Double-click PRODUCTS so that the table appears in the workspace.

Notice that there is a line that joins the ORDERFACT and PRODUCTS tables together.

12.Deselect all PRODUCTS table fields, except for PRODUCTNAME and PRODUCTLINE.

13.For the purpose of this exercise, click the Syntax tab in the lower left portion of the Query Designer
workspace to display a simple SQL statement associated with the tables. Notice that PRODUCTCODE
is the common field between the ORDERFACT and PRODUCTS tables.
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14.Click OK in the syntax window to return to the JDBC Data Source dialog box. Notice that the SQL
statement appears on the right under Query.

15.In the JDBC Data Source dialog box, click OK to go to the Design page.

Notice that the fields associated with your tables are listed under Query 1. You are now ready to start
Designing Your Report on page 48.

Designing Your Report

This exercise walks you through the process of designing the look-and-feel of your report.

1. Under the View item in the Report Designer menubar, click Element Alignment Hints and Snap to
Elements to enable them. These options help you to align the elements of your report.

2. In the Design page, under Query 1, double-click and drag the ORDERNUMBER field into the Details
band. Make sure that the top line of the field name and the top line of the Details band match up.

3. Place the ORDERDATE, PRODUCTNAME, QUANTITYORDERED, and PRICEEACH fields into the
Details Band. Take care not to overlap the fields or your report will not display correctly.

4. Use the resizing handles to make the PRODUCTNAME field larger and the QUANTITYORDERED field
smaller as shown in the example below:

5.
You have created your first report. Click  (Preview) to examine your report. Click  (Edit) to return
to the workspace view.

Tip:  You can also click  (Preview) on the left side of your workspace or select it from the

View menu option to preview a report. Click  (Edit) to return to the workspace view.
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But, wait... There's a problem. Without headers, report users will have a hard time understanding its
content. You need to continue Refining Your Report on page 49.

Refining Your Report

You've created a report in the previous exercise but now you need to make the report more descriptive so
that users can understand the content in the report. Follow the instructions below to refine your report.

1.
Click  (Edit) to return to the Design page.

2. Click and drag a  (Label) from the tools palette into the middle of the Page Header band. Notice how
Report Designer keeps track of the report structure (shown below).

3. Click inside the Label item and type Order Report
4. Double-click inside the Order Report label to select the text, then in the toolbar, select a larger font size

(18 point) and apply boldface.
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The changes are applied to the text; however, now that the text is bigger you may not see all of it, so
use your resizing handles and enlarge the label until you can see all of the text. Alternatively, you can
stretch the resizing handles all the way to each edge of the workspace and click the align center icon in
the toolbar so that the text is automatically placed in the center of the report page.

5. With the Order Report label still selected, click down arrow of the font color icon in the toolbar. Select a
color for your label.
The font color changes. This page header will appear on every page of your report.

6. Now, you must create column headers. On the right side of your workspace, click Structure -> Details
Header.

7. In the lower right section of your workspace, click Attributes.

8. Under common, change the Value of the hide-on-canvas option to False.
Notice that the Details Header pane appears in your workspace.

9. In the toolbar, click  (Select Objects).
Notice that the icon changes to a cross hair as you move into the workspace.

10.Move your mouse to the far right of the Details pane. Now, drag your mouse to the far left over all your
column objects to select them. You may have to move the mouse under the headings to make them
easier to select.

11.Click <CTRL+C> to copy your objects and <CTRL+V> to paste them into the Details Header pane.

Note:  Alternatively, you can choose Copy from the right-click menu.

12.Under Format in the Report Designer menubar, select Morph.
The column objects are changed to labels.

13.Type the correct heading names for each of your columns: Order No., Order Date, Product Name,
Quan., and Price Each.
Your headers will align correctly over your columns.

14.
Click  (Preview) to display your report.
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The report looks good but you may want to make it even easier to read by applying some banding.
15.In the toolbar, go to Format -> Row Banding.
16.In the Row Banding dialog box, choose Yellow from the drop-down list next to Visible Color and click

OK.
17.

Click  (Preview) to display your report.

18.In the menubar, go to File -> Save to save your report in the ...\report-designer\samples folder. Type
Orders in the File Name text box.

Note:  See More about Row Banding, Data Formatting, and Alignment on page 51 for
additional information about refining your report.

More about Row Banding, Data Formatting, and Alignment

Row Banding

By creating a row band element, you can select the specific fields in your report that will display a row
band. For example, you may want to emphasize specific fields and not others on a line. You can give your
row band element any name you choose. In the example below, the row band element is called row-band-
element.
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After you create your element, go back to the report and select the columns (fields) whose data will always
be displayed with a row band. You must also type row-band-element in the name field under Attributes. is
In the example below, the data associated with each of the columns in the report will display a row band.
Notice the banding in the report preview.

Data Formatting

Report Designer uses default formats for dates and numbers. You can change how dates and numbers
display by selecting the object (field) and selecting the appropriate value for the format from the drop-down
list next to format (under Attributes). In the example below, the dates associated with the Order Date
field will display as MM-dd-yy.
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When you preview the report, notice that it displays in a cleaner format:

Note:  You can type a value for your own format if you know the correct JavaScript string
nomenclature.

Alignment

To align multiple objects press <SHIFT+ CLICK> to select each object. Then, choose an alignment option

from the Format menu. Alternatively, you can click  (Select Objects) and drag your mouse over the
objects you want to select and then choose an alignment option.

In the example below, the selected objects will be aligned in the middle of the band.

>

Adding a Chart to Your Report

So far you've seen a small subset of features associated with Report Designer. In this exercise, you will
add a chart to your report.
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1. Click File -> Open and find the report you just saved. Click OK.
2. In the palette, click and drag a  Chart into the Report Footer band.
3. Use the resizing handles to center and stretch the chart. You can also adjust the width of the band.

4. Double-click the sample chart.
5. The type of chart most appropriate for your report is a pie chart. In the top portion of the Edit Chart

dialog box, select the pie chart icon.

Note:  Notice that the pie chart properties that define its look-and-feel are listed in the left pane
of the Edit Chart dialog box. Properties associated with the data in the chart are listed in the right
pane.

6. Go to the Title properties; net to the chart-title property, type Product Pie Chart.
7. Under Common, click the down arrow next to value-column click the ellipsis [...] to open the Edit

Array dialog box.

The value-column specifies the actual values (measures) you want to chart. In this instance, you want
to chart the quantity ordered.

8. Click in the blank field to expose the drop-down arrow.
9. Select QUANTITYORDERED from the list and click OK.
10.Click OK to exit the Edit Chart dialog box.
11.Under Series click the ellipsis [...] next to series-by-field to open the Edit Array dialog box.

The series-by-field specifies the field you are charting. In this instance you are charting by product line.
Series are usually placed in the chart legend.

12.
Click (Add).

13.Click in the blank field to expose the drop-down arrow.
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14.Select PRODUCTLINE from the list and click OK.
15.Click OK to exit the Edit Chart dialog box.
16.

Click  (Preview) to display your report.
17.When the report displays, click the double arrows to go to the last page.

The chart you created appears on the last page of the report. If you want to display a bar or line chart
instead, use the chart settings below. You have to add the series-by-value setting manually in the Edit

Array dialog box. Click  (Add) and type SALES; click  (Add) and type COST. Run the report to
display the bar chart.

18.Save your report. You are now ready to Adding Parameters to Your Report on page 55.

Adding Parameters to Your Report

When you set parameters, users are prompted for a value or values when they run the report. The ability to
provide parameters is an important part of creating a report.

1. In the Report Designer, click File - > Open to select the report you created.
2. In the menubar go to Data -> Add Parameter. Alternatively, you can click  (Master Report

Parameter) under the Data Tab in the Report Designer workspace.
The Add Parameter dialog box appears.

3. In the Add Parameter dialog box, type enter_prodline in the Name text field.
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4. Type Select Line in the Label text field.
5. Next to Display Type, select Drop Down so users can select a product line.
6.

Click  (Edit) to add a query that supplies the values, (motorcycles, cars, ships, and so on), from
which users of the report must choose.

Note:  Click on JDBC (SampleData - Memory) under Data Sources if the Edit icon is disabled.

The JDBC Data Sources dialog box appears.
7. Under Connections, select SampleData (Memory).
8.

Next to Available Queries click  (Add).
A new query placeholder is added to the list (Query 2).

9. In the Query Name text field, type prodlineList.
10.Enter your SQL query in the Query box.

You can copy and paste the required lines, (shown below) directly into the SQL statement or you can
use the alternate steps in the table below.

Important:  Make sure to use curly brackets, (not parentheses), before and after
{enter_prodline} or the report will not display correctly.

SELECT DISTINCT "PRODUCTS"."PRODUCTLINE"
                        FROM "PRODUCTS"

By entering these lines, report users see a prompt when they open the report in the Pentaho User
Console that allows them to enter a product line. That way, they can examine orders by product line. If
you do not add the lines, the report displays orders for all product lines.

Alternatively, you can use the Query Designer to build your query:

Step Description

1 In the JDBC Data Source dialog box,

click  (the Edit icon on the right).

2 Under Choose Schema, select Public,
and click OK to open the Query
Designer.

3 In the Query Designer, select the
PRODUCTS table on the left.

4 On the right, click PRODUCTS and
choose Deselect All.

5 Right-click SELECT on the left and
choose Distinct.

6 On the right, select PRODUCTLINE
and click Preview. The product line list
appears. Click Close.
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Step Description

7 Click OK to exit the Query Designer and
go to Step 11.

11.Click OK to exit Data Source dialog box.

12.In the Add Parameter dialog box, under Data Sources, double-click JDBC SampleData (Memory) and
select prodlineList.

13.Next to Value Type, select String.

14.Type a default value, for example, "Motorcycles," in the Default Value text box. (Optional)

15.Click OK to exit the Add Parameter dialog box.

16.Now that you've created a product line parameter, you must map it back to your query (Query 1). Under
Data, double-click Query 1.

17.Right-click PRODUCTLINE and select add where condition.
The condition.edit dialog box appears.

18.Type ${enter_prodline} in the edit area and click OK.
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19.Click OK to exit the Query Designer.

20.Click OK to exit the Data Source dialog box.

21.
Click (Preview).

You should see your product line drop-down list.

22.You are now ready to Publishing Your Report on page 58.

Publishing Your Report

You have created and formatted a simple report, added a chart, and now you are ready to share the report
with your users.

1. In the Report Designer, click File -> Open to open the report you just created.

2. Click File -> Publish. Alternatively, click .
If you haven't saved the report, a warning message reminds you to save it. The Login dialog box
appears, pre-populated with credentials valid for the evaluation.

Important:  Make sure that the Server URL is set to http://localhost:8080/pentaho/.
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3. Click OK.
The Publish to Server dialog box appears.

4. In the Publish to Server dialog box, type in a report name and description into the appropriate fields.

5. Under Location, save the report in the .../steel-wheels/reports folder.

6. Select html as the Output Type.

7. In the Publish Password text field, type the publish password, password, and click OK.
A success message appears.

8. Click Yes to go directly to the Pentaho User Console to view the report you just published.

If you want to access the report later, log into the BI Server by going to http:// localhost:8080 in your
Web browser, then navigate to the Reporting Examples directory in the Solution Browser. You
should see your published report in the list. If not, click Tools -> Refresh Repository.

9. Log in as Joe. Joe's password is password.

10.Your report displays in the Pentaho User Console.
You now have a report that users can view at any time.

11.In the Pentaho User Console select your product line parameter from the drop-down list. Accept the
default under Output Type.
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Defining a Database Connection

The BI Server includes sample data and reports; however, if you are evaluating Pentaho client tools, like
Report Designer, you may want to use your own data. You manage database connections in the Pentaho
Enterprise Console.

To define database connection you must have a JDBC class name for the database driver, a URL (server
name, port number, database name), and the user ID and password. Contact your database administrator
to get the specific details about your database. To find driver information, see A List of JDBC Drivers.

You must be logged on to the Pentaho Enterprise Console to follow the instructions below. Go to Start ->
Programs -> Pentaho Enterprise Edition -> Enterprise Console Login.
1. In the Pentaho Enterprise Console go to Administration > Database Connections.
2. Click the General icon to display basic configuration options.
3. Click the plus sign (+) (add) if you cannot find your data source in the default list.
4. The Add Database Connection dialog box appears.
5. Type an easy to remember connection name This is the name you give the connection (sometimes

referred to as a Pentaho Database Connection or named connection. It is also the name you use when
creating a connection on a client tool, like Report Designer.

6. Type or select the Driver Class from the list. The database driver name you select depends on the type
of database you are accessing. For example, org.hsqldb.jdbcDriver is a sample driver name for a
HSQLDB (previously Hypersonic SQL or hsql) database.
If your JDBC driver is not available, see Adding a JDBC Driver.

7. Type the User Name and Password required to access your database.
8. Type or select the URL from the list. This is the URL of your database; for example,

jdbc:hsqldb:hsql://localhost/sampledata. JDBC establishes a connection to a SQL-based
database and sends and processes SQL statements.

9. Click Test.
A success message appears if the connection is established.

10.Click OK to save your entries

Adding a JDBC Driver

http://www.devx.com/tips/Tip/28818


 | Defining a Database Connection | 61

Before you can connect to a data source in any Pentaho server or client tool, you must first install the
appropriate database driver. Your database administrator, CIO, or IT manager should be able to provide
you with the proper driver JAR. If not, you can download a JDBC driver JAR file from your database vendor
or driver developer's Web site. Once you have the JAR, follow the instructions below to copy it to the driver
directories for all of the BI Suite components that need to connect to this data source.

Note:  Microsoft SQL Server users frequently use an alternative, non-vendor-supported driver called
JTDS. If you are adding an MSSQL data source, ensure that you are installing the correct driver.

Backing up old drivers

You must also ensure that there are no other versions of the same vendor's JDBC driver installed in these
directories. If there are, you may have to back them up and remove them to avoid confusion and potential
class loading problems. This is of particular concern when you are installing a driver JAR for a data source
that is the same database type as your Pentaho solution repository. If you have any doubts as to how to
proceed, contact your Pentaho support representative for guidance.

Installing JDBC drivers

Copy the driver JAR file to the following directories, depending on which servers and client tools you are
using (Dashboard Designer, ad hoc reporting, and Analyzer are all part of the BI Server):

• BI Server: /pentaho/server/biserver-ee/tomcat/lib/
• Enterprise Console: /pentaho/server/enterprise-console/jdbc/
• Data Integration Server: /pentaho/server/data-integration-server/tomcat/lib/
• Data Integration client: /pentaho/design-tools/data-integration/libext/JDBC/
• Report Designer: /pentaho/design-tools/report-designer/lib/jdbc/
• Schema Workbench: /pentaho/design-tools/schema-workbench/drivers/
• Aggregation Designer: /pentaho/design-tools/agg-designer/drivers/
• Metadata Editor: /pentaho/design-tools/metadata-editor/libext/JDBC/

Note:  To establish a data source in the Pentaho Enterprise Console, you must install the driver in
both the Enterprise Console and the BI Server or Data Integration Server. If you are just adding a
data source through the Pentaho User Console, you do not need to install the driver to Enterprise
Console.

Restarting

Once the driver JAR is in place, you must restart the server or client tool that you added it to.

Connecting to a Microsoft SQL Server using Integrated or Windows Authentication

The JDBC driver supports Type 2 integrated authentication on Windows operating systems through
the integratedSecurity connection string property. To use integrated authentication, copy the
sqljdbc_auth.dll file to all the directories to which you copied the JDBC files.

The sqljdbc_auth.dll files are installed in the following location:

<installation directory>\sqljdbc_<version>\<language>\auth\

Note:  If you are running a 32-bit Java Virtual Machine (JVM), use the sqljdbc_auth.dll file in the
x86 folder, even if the operating system is the x64 version. If you are running a 64-bit JVM on a
x64 processor, use the sqljdbc_auth.dll file in the x64 folder. If you are running a 64-bit JVM on a
Itanium processor, use the sqljdbc_auth.dll file in the IA64 folder.

1

Defining a Database Connection in Report Designer

1 MSDN, "Building the Connection URL," (accessed February 22, 2011)
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You've created a report, refined, and published it. If you are ready to start creating reports using your own
data, you may need to contact your database administrator to get details (JDBC driver, connection string,
user name and password) for configuring your database. This is the same information you used to add a
database connection in the Pentaho Enterprise Console.

• An OLAP (Mondrian) Data Source is accessed through JDBC and require a valid Mondrian Schema file
(.mondrian.xml). MDX is used to query this data source.

• Pentaho metadata data sources are accessed through JDBC and require a valid metadata model
(.xmi.) The Pentaho MQL is used to query this data source.

• XML Data Sources are accessed through XQuery and require that your data is in one xml file. XQuery
is used to query this data source.

Report Designer comes with a group of common drivers for Hypersonic (HSQLDB), MySQL, Postgres,
Derby, DB2, H2, Oracle, and more.

You must follow the instructions below if the database driver you require is not available.

1. Contact your database vendor for more information if you have questions about which driver to use.

2. Drop the associated .jar driver file in the following location: ...\client\report-designer\lib
\jdbc.

3. In the Report Designer, go to Data -> Add a Data Source -> JDBC.
The JDBC Data Source dialog box appears.

4.
On the left, next to Connections, click  (Add).
The Database Connection dialog box appears.

5. Select the appropriate connection type from the list.

6. Enter the appropriate information for connecting to your data source. The example below demonstrates
entries for the Hypersonic database that holds the Pentaho sample data.

Options Description

Connection Name An easy-to-remember name that
identifies the data you are accessing; this
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Options Description

is the same name you used when adding
a data source in the Pentaho Enterprise
Console.

Host Name The name of the device on which the
database is hosted.

Database Name The name of the database that contains
the data you want to display; in the
example above the database is called,
sampledata.

Port Number The port number associated with the
database; the default port number is
displayed.

User Name Database user name to be passed to the
JDBC driver

Password Database password to be passed to the
JDBC driver

7. Click Test to test your connection.
A success message appears if your configuration is correct.

8. Click OK to save your entries.
The new data source (connection) appears in the list on the left under Connections.
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Using the Data Sources Feature in the Pentaho User
Console

The Data Sources feature makes it easy for you to access your own data when you are evaluating the
capabilities of the Pentaho User Console. In addition, as part of the Agile BI initiative, the data sources
feature allows you to quickly create ad hoc reports and Analyzer reports using data that is critical to your
own business environment.

If you are running a test environment, you can quickly add, edit, and delete a relational or CSV (flat file)
data source in the Pentaho User Console. An exercise using sample CSV file as a data source is provided
in the sections that follow, but it is important that you repeat the exercise using your own data.

You can restrict access to a data source by individual user or user role; by default, authenticated users are
limited to view-only permissions. (See Assigning Data Source View Permissions on page 74 for more
information.) This means that they are limited to selecting a data source from a list of available options.

Note:  Non-administrative users of the Pentaho User Console do not see icons or buttons
associated with adding, editing, or deleting a data source.

When selecting a relational data source, users can query against the data source within the scope of data
defined in query you set up. If users choose a CSV-based data source, they can query the flat file data to
create a chart or data table.

The Data Source Wizard, which allows you to set up access to a relational data source or CSV data
source in the Pentaho User Console, is available in the following instances:

• When you click the New Data Source button on the Pentaho User Console Quick Launch page
• When you select File -> New -> Data Sources in the Pentaho User Console menu bar
• When you select File -> Manage -> Data Sources from the Pentaho User Console menu bar and click

 (Add)
• When you click Add in the Select a Data Source step in Ad Hoc Reports
• When you click Create Data in charts in the Dashboard
•

When you click  (Add) as a first step of the create Data Table process
• When you click Create New Data Source when creating a new Analyzer report

Creating a CSV Data Source in the Pentaho User Console

The New Data Source dialog box allows you to import a CSV (flat file) and stage the content in the BI
Server for use as a data source. Once you create a CSV file as a data source, end-users can create
reports, charts, and data tables based on data loaded from the CSV file. When you complete the exercise,
repeat it using your own data. See Using Your Own Data Source on page 72 for more information.

Follow the instructions below to create a CSV-based data source:

1. In the Quick Launch page, click New Data Source.

2. In the Data Source Wizard, type Sales Data Sample in the Data Source Name text field.
3. Under Source Type select CSV from the list to define a CSV file as your data source and click Next.
4. Click Import to open the Import File dialog box.
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5. Click Browse to search for, sales_data_sample.csv (...\biserver-ee\data\csv
\sales_data_sample.csv);click Import when you locate the file.
The Import File dialog box closes and the CSV file is uploaded to the BI Server.

Note:  Notice that a preview of the contents of your file appears in the lower portion of the wizard
page. When items do not align, it is because the delimiter and enclosure types were not specified
correctly. The file you uploaded does not have delimiter and enclosure-related issues. Also
notice that the First row is header option is automatically enabled. When enabled, the first row
of your CSV file is specified as the heading for the columns in the file.

6. Click Next configure how the columns will be created in the staging table for this data source.

Default staging settings will be auto-detected based on a sample of the first 500 rows in the CSV file.
These defaults can be overridden.

Note:  Notice that all columns are enabled in this step. Click Deselect All to disable all columns.
You can then select the columns that require formatting individually. Click Select All to enable all
columns again, if necessary.

7. Use the scrollbar to locate the PHONE, ADDRESSLINE1, and ADDRESSLINE2 columns, then disable
them as shown in the example below:
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8. Notice that you can change the  Name and Type values. Use the drop-down list to display format
options for dates and numeric values. Formats are auto-detected based on the contents of your
data source; however, if you see a format option that is not correct, you can enter it manually in the
appropriate Source Format text box.

Note:  The format option you select must match the date format in the CSV file.

Length indicates the maximum number of characters allowed in a field. Precision is the number of
digits after a decimal point. Drop-down lists are not enabled for certain data types such as the String
data type.
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Important:  Boolean values are rendered as "true" or "false."

9. Click Show File Contents to see a sample of the data in your source file. Click OK to return to staging.
This step allows you to make formatting changes, if necessary.

10.Click Finish.
A success message appears indicating the number of rows being loaded into the staging database and
that a default metadata model was created. You have a choice to accept the default metadata model
or to customize the metadata model. If you are not familiar with the concepts behind modeling, the next
exercise will help you understand how it works.

11.Click Customize model now to open the Data Source Modeler and customize your metadata model.

Customizing the Metadata Model

As soon as you complete the Data Source Wizard steps, the content in "sales_data.csv" is uploaded and
staged in a relational database on the BI server. In addition, a default metadata model is created. The data
source is immediately available and users can use it to build an ad hoc or Analyzer report, a dashboard, or
data chart; however, for the data associated with your new data source to be more useful, you may want to
edit the metadata model.

The modeler is a metadata modeling tool that makes it possible for you to edit the model without having
to understand the underlying database structure or having to understand SQL and MDX. If you are not
familiar with metadata modeling, think of it this way — metadata is simply "data about data." For example,
a database contains fields, such as customer name, address, city, and state. Metadata provides the
naming conventions for the fields, describes their size, and specifies what is allowed in the field, such
as numeric values only. If you were to hand a database file to a user, without providing the associated
metadata, the file would appear as a long string of characters. Metadata defines how data is extracted into
fields and records.
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Below is an example of the default metadata model based on the exercise you just completed. Notice that
all the columns (fields) from the original CSV file are listed on the left under Available Fields. Measures
and Dimensions are listed in the middle, under Model. When you click on a measure or dimension, it's
associated properties appear on the right, under Properties. The toolbar items, contain toot tips that define
their function, such as editing the source data, auto populating the model, and more.

Notice that all numeric values are listed under both Measures and Dimensions. Measures are numeric
attributes that usually relate to business performance (KPIs) such as sales price, sales results, cost, and
profit. In the example, items associated with dates, MONTH ID, QTR ID, and YEAR ID, do not belong on
the list. ORDERLINENUMBER and ORDERNUMBER are IDs and also do not belong on the list. In the
exercise that follows, you will edit the metadata model.

1.
In the modeler, select MONTH ID and click  (Delete). Repeat this step to remove,
ORDERLINENUMBER, ORDERNUMBER, QTR ID, and YEAR ID.
The remaining items are true measures. They include, MSRP, PRICEEACH, QUANTITYORDERED,
and SALES. In the next step, you must remove these measures from the Dimensions list.

2.
Under Dimensions, select MSRP and click  (Delete). Repeat this step to remove PRICEEACH,
QUANTITYORDERED, and SALES.

Next, you will group the date-related dimensions under a single hierarchy. Hierarchies contain levels
that organize data into a logical structure.

3. Click (+) to expand the YEAR ID and QTR ID dimensions.
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4. Click on the QTR ID level ( ) and drag it under the YEAR ID level.

Note:  Notice the yellow caution symbol ( ) next to the QTR ID dimension. The dimension no
longer contains hierarchies and levels, so you must select and delete it.

5. Click and drag the MONTH ID dimension closer to the YEAR ID dimension.

6. Click (+) to expand the MONTH ID dimension and move the MONTH ID level under the QTR ID level.

Important:  Make sure you delete the MONTH ID dimension when you are done.

7. Click on the YEAR ID dimension. Under Properties, change the Dimension Name to TIME. Change the
YEAR ID hierarchy name to SALES YEAR.
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8. Click OK to save your updated metadata model. Next, you will create an analyzer report using your new
data source.

Creating an Analyzer Report based on the Metadata Model

You created a new data source and edited its associated metadata model. You can now use the data
source to create analyzer reports.

Note:  You can use the new data source to create ad hoc reports, dashboards, and data charts as
well.

Follow the instructions below to create an analyzer report.

1.
In the Pentaho User console, go to File -> New -> Analyzer Report. Alternatively, click  (New
Analyzer Report) on the console toolbar.

2. In the Select Data Source dialog box, choose Sales Data Sample.
A blank Analyzer report opens.

3. On the right, under Available Fields, click View and select Number - Text - Time.

This selection allows you to examine the data in a view that is similar to the view in the metadata model.
The fields/categories are listed in alphabetical order.

4. You want to see yearly sales by product line so under Available Fields, select YEAR ID and drag it to
the workspace.
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5. Select the SALES measure and drag it to the workspace. Place it next to YEAR ID. Move YEAR ID
above SALES so that it forms columns.

6. Click and drag PRODUCTLINE to the workspace as shown in the example below to complete your
report.

7. Go to File -> Save As and save your report in the .../steel-wheels/analysis directory.
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Using Your Own Data Source

Before create your own data source, choose an interesting metric, (related to cost, revenue, customer
satisfaction, for example), that you or others are interested in exploring, then follow the guidelines below:

• Select a single file with de-normalized transactional data, such as a summarized spreadsheet with
orders by store or by product SKU, for example.

Note:  Do not worry about summarization; the BI Server handles summarization automatically.

• Select a file that contains fewer than one million rows for quick and productive prototyping.
• Select a file that contains facts which are relevant to Key Performance Indicators (KPIs).
• Select a file that contains time fields, for example, yyyy-MM-dd.
• Select a file that contains “interesting dimensional attributes; for example, “I want to look at sales

by state, by sales rep, by customer demographic, over time, etc.” In other words, add your own “by
clause,” for slicing and dicing.

• Select a file that contains descriptive row headers.

Creating a Relational Data Source in the Pentaho User Console

Follow the instructions below to create a relational data source. In addition to allowing you to connect to
your database (using JDBC), you must also enter a SQL statement that defines the "scope, "(similar to a
database view), of your data source.

Note:  In the context of the Pentaho User console, a relational "data source" is a combination of a
connection plus a query. Pentaho recommends that you use the Pentaho Metadata Editor to create
relational data sources for a production environment.

You can customize how columns are presented to users who are building queries against the new data
source; for example, you can define "friendly" column names and more.

Once you create the data source, it is available to users of the Dashboard Designer, Analyzer, Chart
Designer, and Ad Hoc Report.

You must be logged on to the Pentaho User Console as an administrator to follow the instructions below.
Additionally, your database must be up and running in order for you to complete the steps required in the
Data Source Wizard. In this exercise, you will be using sample data. After you complete the exercise, try
repeating it using your own data.

1. In the Data Source Wizard, type Customers in the Name field.

Note:  The name of the data source is important because it becomes the name of the data
source displayed in Analyzer, Ad Hoc Report and Chart Designer.

2. Under Source, select Database as your data source type.
3.

If not already configured, click  (Add) to add a connection to the database that contains the content
you want to access. The Database Connection dialog box appears.
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Note:  If this is the first time you are using the wizard, you will not see a list of connections under
Available Connections. When you have added your connection, the connection name will appear
in the list.

4. In the Connection Name text box, type Sample Data.

5. Under Connection Type, select Hypersonic from the list.

6. Enter the appropriate connection information for this database.

Option Description

Host Name localhost

Database Name sampledata

Port Number 9001

User Name pentaho_user

Password password

7. In the Connection dialog box, click Test to test your connection and click OK.
A success message appears if your settings are correct. The connection name appears in the list.

8. Under SQL Query, type: select * from CUSTOMERS. Click Data Preview to ensure that your query
returns data.
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9. Click Close to exit the Preview window.

10.Click Finish.
A success message appears. In the background, after you click Finish, a default metadata model is
generated based on the query for use in Analyzer, Ad Hoc Reporting, Report Designer, and Chart
Designer. You can keep the default model or edit the model so it can be customized for your specific
needs. See Editing a Data Source Connection for instructions about changing connection details.

Assigning Data Source View Permissions

By default, authenticated users have view-only permissions to data sources in the Pentaho User Console.
Users with administrative permissions can create, delete, and view data sources. If you want to fine tune
permissions associated with data sources, you must edit the appropriate settings.xml file. Follow the
instructions below to edit the file.

1. Go to ...\biserver-ee\pentaho-solutions\system\data-access-plugin and open
settings.xml.

2. Edit the settings.xml file as needed. The default values are shown in the sample below. You can assign
permissions by individual user or by user role. If you are using LDAP, you can define the correct ACLs
value for view permissions; the default value is "31."

3. Save your changes to the settings.xml file.

4. Refresh the Admin Console.
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Troubleshooting Your Installation

As stated previously, you must be able to assign ports, if necessary, during installation. It is recommended
that you contact your system or database administrator for help when you encounter port-related conflicts.

Below is the default port information:

MySQL Server Startup Port: 3306

Tomcat BI Server Startup Port: 8080

Tomcat Data Integration Server Startup Port: 9080

Enterprise Console Startup Port: 8088
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From Evaluation to Implementation

This document was designed to quickly demonstrate basic Pentaho BI Suite Enterprise Edition features
and functions. To find out more about the benefits of the Pentaho Enterprise Edition product offerings,
contact Pentaho Sales.

http://www.pentaho.com/contact/
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