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Welcome

Thank you for considering Pentaho as your Business Intelligence solutions provider. If you are reading this guide,
you have chosen to download, install, and evaluate Pentaho Report Designer, version 3.8 GA. The purpose of this
document is to provide you with instructions for creating a simple Report Designer report.

Pentaho Reporting provides unmatched deployment flexibility. Whether you’re looking for a standalone desktop
reporting tool, Web-based reporting, or comprehensive business intelligence (BI) including reporting, analysis, and
dashboards, Pentaho Reporting allows you to “start small” and scale up if your reporting needs grow in the future.

The Pentaho Report Designer provides you with the following features:

• Drag-and-drop graphical designer that gives users full control of data access, layout, grouping, calculations, charting
and formatting for pixel-perfect reports

• Integrated, step-by-step wizard that guides report designers through the design process
• Report templates that accelerate report creation and provide consistent look-and-feel

Report Designer allows you to create a report by following a four step wizard; however, to show you a larger range of
features, the exercises in this document walk you through the manual procedures for creating a simple report. This is a
basic tutorial and will not provide details about advanced Report Designer features.

Important:  The scope of this document is limited to the topics described in the paragraph above. If you need
further information deploying the Pentaho BI Suite or have custom configuration requirements, contact your
Pentaho Sales Representative or send an email to Support.

Creating a Report Using Report Designer
Follow the instructions below to begin creating your report:

1. Start the Report Designer. Go to Start -> Programs -> Pentaho Enterprise Edition  -> Design Tools -> Report
Designer.
The Report Designer home page appears.

2. Click New Report in the Welcome dialog box.
The design workspace appears.

Note:  If you'd like to change the size of the layout bands to give yourself more area to work in without
changing the dimensions of the published report, you can click and drag the percentage number in the upper
left corner of the workspace. By default it says 100%, but if you click and drag it diagonally toward the upper
left or lower right corners, the view will zoom in or out. If you want to reset the view to 100%, double-click the
upper left corner where the percentage shows.

mailto:supportadmin@pentaho.com
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3. In the right pane, click the Data tab.

4. For the purpose of this exercise, right-click Data Sets and choose JDBC. Alternatively, you can click the yellow
database icon to display the JDBC dialog box.
The JDBC Data Source dialog box appears.

5. Under Connections, select SampleData (Memory).

6.
Next to Available Queries click  (Add).

Query 1 appears under Available Queries. Notice that the edit icon  is enabled.

7.
Click  (Edit).
The SQL Query Designer window opens. The SQL Query Designer provides you with a graphical environment
that allows you to work with the data even if you don't understand SQL, the standard programming language for
retrieving content from databases.

8. Double-click ORDERFACT so that the table appears in the workspace as shown in the image above.

9. In the SQL Query Designer workspace, right-click "ORDERFACT" and choose deselect all.

10.Now, select the following fields in the ORDERFACT table: ORDERNUMBER, QUANTITYORDERED, PRICEEACH,
and ORDERDATE.

11.Double-click PRODUCTS so that the table appears in the workspace.

Notice that there is a line that joins the ORDERFACT and PRODUCTS tables together.

12.Deselect all PRODUCTS table fields, except for PRODUCTNAME and PRODUCTLINE.
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13.For the purpose of this exercise, click the Syntax tab in the lower left portion of the SQL Query Designer workspace
to display a simple SQL statement associated with the tables. Notice that PRODUCTCODE is the common field
between the ORDERFACT and PRODUCTS tables.

14.Click OK in the syntax window to return to the JDBC Data Source dialog box. Notice that the SQL statement
appears on the right under Query.

15.In the JDBC Data Source dialog box, click OK to return to the Design page.

Notice that the fields associated with your tables are listed under Query 1. You are now ready to start designing your
report.

Designing Your Report

This exercise walks you through the process of designing the look-and-feel of your report.

1. Under the View item in the Report Designer menubar, click Element Alignment Hints and Snap to Elements to
enable them. These options help you to align the elements of your report.

2. In the Design page, under Query 1, click and drag the ORDERNUMBER field into the Details band. Make sure that
the top line of the field name and the top line of the Details band match up.

3. Place the ORDERDATE, PRODUCTNAME, QUANTITYORDERED, and PRICEEACH fields into the Details Band.
Take care not to overlap the fields or your report will not display correctly.

4. Use the resizing handles to make the PRODUCTNAME field larger and the QUANTITYORDERED field smaller as
shown in the example below:
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5.
You have created your first report. Click  (Preview) to examine your report. Click  (Edit) to return to the
workspace view.

Tip:  You can also click  (Preview) on the left side of your workspace or select it from the View menu

option to preview a report. Click  (Edit) to return to the workspace view.

But, wait... There's a problem. Without headers, report users will have a hard time understanding its content. You
must continue refining your report, see refining your report.

Refining Your Report

You've created a report in the previous exercise but now you need to make the report more descriptive so that users
can understand the content in the report. Follow the instructions below to refine your report.

1.
Click  (Edit) to return to the Design page.

2. Click and drag a  (Label) from the tools palette into the middle of the Page Header band. Notice how Report
Designer keeps track of the report structure (shown below).



8 | Pentaho BI Suite Official Documentation | Welcome

3. Click inside the Label item and type Order Report

4. Double-click inside the Order Report label to select the text, then in the toolbar, select a larger font size (18 point)
and apply boldface.

The changes are applied to the text; however, now that the text is bigger you may not see all of it, so use your
resizing handles and enlarge the label until you can see all of the text. Alternatively, you can stretch the resizing
handles all the way to each edge of the workspace and click the align center icon in the toolbar so that the text is
automatically placed in the center of the report page.

5. With the Order Report label still selected, click down arrow of the font color icon in the toolbar. Select a color for
your label.
The font color changes. This page header will appear on every page of your report.

6. Now, you must create column headers. On the right side of your workspace, click Structure -> Details Header.

7. In the lower right section of your workspace, click Attributes.

8. Under common, change the Value of the hide-on-canvas option to False.
Notice that the Details Header pane appears in your workspace.

9. In the toolbar, click  (Select Objects).
Notice that the icon changes to a cross hair as you move into the workspace.

10.Move your mouse to the far right of the Details pane. Now, drag your mouse to the far left over all your column
objects to select them. You may have to move the mouse under the headings to make them easier to select.

11.Click <CTRL+C> to copy your objects and <CTRL+V> to paste them into the Details Header pane.

Note:  Alternatively, you can choose Copy from the right-click menu.

12.Under Format in the Report Designer menubar, select Morph.
The column objects are changed to labels.
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13.Type the correct heading names for each of your columns: Order No., Order Date, Product Name, Quan., and
Price Each.
Your headers will align correctly over your columns.

14.
Click  (Preview) to display your report.

The report looks good but you may want to make it even easier to read by applying some banding.

15.In the toolbar, go to Format -> Row Banding.

16.In the Row Banding dialog box, choose Yellow from the drop-down list next to Visible Color and click OK.

17.
Click  (Preview) to display your report.

18.In the menubar, go to File -> Save to save your report in the ...\report-designer\samples folder. Type Orders in the
File Name text box.

Note:  See More about Row Banding, Data Formatting, and Alignment for additional information about
refining your report.

More about Row Banding, Data Formatting, and Alignment

Row Banding

By creating a row band element, you can select the specific fields in your report that will display a row band. For
example, you may want to emphasize specific fields and not others on a line. You can give your row band element any
name you choose. In the example below, the row band element is called row-band-element.
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After you create your element, go back to the report and select the columns (fields) whose data will always be displayed
with a row band. You must also type row-band-element in the name field under Attributes. is In the example below, the
data associated with each of the columns in the report will display a row band. Notice the banding in the report preview.

Data Formatting

Report Designer uses default formats for dates and numbers. You can change how dates and numbers display by
selecting the object (field) and selecting the appropriate value for the format from the drop-down list next to format
(under Attributes). In the example below, the dates associated with the Order Date field will display as MM-dd-yy.

When you preview the report, notice that it displays in a cleaner format:
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Note:  You can type a value for your own format if you know the correct JavaScript string nomenclature.

Alignment

To align multiple objects press <SHIFT+ CLICK> to select each object. Then, choose an alignment option from the

Format menu. Alternatively, you can click  (Select Objects) and drag your mouse over the objects you want to select
and then choose an alignment option.

In the example below, the selected objects will be aligned in the middle of the band.

>

Adding a Chart to Your Report

So far you've seen a small subset of features associated with Report Designer. In this exercise, you will add a chart to
your report.

1. Click File -> Open and find the report you just saved. Click OK.

2. In the palette, click and drag a  Chart into the Report Footer band.

3. Use the resizing handles to center and stretch the chart. You can also adjust the width of the band.
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4. Double-click the sample chart.

5. The type of chart most appropriate for your report is a pie chart. In the top portion of the Edit Chart dialog box, select
the pie chart icon.

Note:  Notice that the pie chart properties that define its look-and-feel are listed in the left pane of the Edit
Chart dialog box. Properties associated with the data in the chart are listed in the right pane.

6. Go to the Title properties; net to the chart-title property, type Product Pie Chart.

7. Under Common, click the down arrow next to value-column click the ellipsis [...] to open the Edit Array dialog box.

The value-column specifies the actual values (measures) you want to chart. In this instance, you want to chart the
quantity ordered.

8. Click in the blank field to expose the drop-down arrow.

9. Select QUANTITYORDERED from the list and click OK.

10.Click OK to exit the Edit Chart dialog box.

11.Under Series click the ellipsis [...] next to series-by-field to open the Edit Array dialog box.

The series-by-field specifies the field you are charting. In this instance you are charting by product line. Series are
usually placed in the chart legend.

12.
Click (Add).

13.Click in the blank field to expose the drop-down arrow.

14.Select PRODUCTLINE from the list and click OK.

15.Click OK to exit the Edit Chart dialog box.

16.
Click  (Preview) to display your report.

17.When the report displays, click the double arrows to go to the last page.
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The chart you created appears on the last page of the report. If you want to display a bar or line chart instead, use
the chart settings below. You have to add the series-by-value setting manually in the Edit Array dialog box. Click

 (Add) and type SALES; click  (Add) and type COST. Run the report to display the bar chart.

18.Save your report. You are now ready to add a parameter to your report.

Adding Parameters to Your Report

When you set parameters, users are prompted for a value or values when they run the report. The ability to provide
parameters is an important part of creating a report.

1. In the Report Designer, click File - > Open to select the report you created.

2. In the menubar go to Data -> Add Parameter. Alternatively, you can click  (Master Report Parameter) under the
Data Tab in the Report Designer workspace.
The Add Parameter dialog box appears.

3. In the Add Parameter dialog box, type enter_prodline in the Name text field.

4. Type Select Line in the Label text field.

5. Next to Display Type, select Drop Down so users can select a product line.

6.
Click  (Edit) to add a query that supplies the values, (motorcycles, cars, ships, and so on), from which users of
the report must choose.

Note:  Click on JDBC (SampleData - Memory) under Data Sources if the Edit icon is disabled.

The JDBC Data Sources dialog box appears.
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7. Under Connections, select SampleData (Memory).

8.
Next to Available Queries click  (Add).
A new query placeholder is added to the list (Query 2).

9. In the Query Name text field, type prodlineList.

10.Enter your SQL query in the Query box.

You can copy and paste the required lines, (shown below) directly into the SQL statement or you can use the
alternate steps in the table below.

Important:  Make sure to use curly brackets, (not parentheses), before and after {enter_prodline} or the
report will not display correctly.

SELECT DISTINCT "PRODUCTS"."PRODUCTLINE"
                        FROM "PRODUCTS"

By entering these lines, report users see a prompt when they open the report in the Pentaho User Console that
allows them to enter a product line. That way, they can examine orders by product line. If you do not add the lines,
the report displays orders for all product lines.

Alternatively, you can use the SQL Query Designer to build your query:

Step Description
1

In the JDBC Data Source dialog box, click  (the Edit
icon on the right).

2 In the SQL Query Designer, select the PRODUCTS table
on the left.

3 On the right, click PRODUCTS and choose Deselect All.
4 Right-click SELECT on the left and choose Distinct.
5 On the right, select PRODUCTLINE and click Preview.

The product line list appears. Click Close.
6 Click OK to exit the SQL Query Designer and go to Step

11.

11.Click OK to exit Data Source dialog box.

12.In the Add Parameter dialog box, under Data Sources, double-click JDBC SampleData (Memory) and select
prodlineList.

13.Next to Value Type, select String.

14.Type a default value, for example, "Motorcycles," in the Default Value text box. (Optional)
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15.Click OK to exit the Add Parameter dialog box.

16.Now that you've created a product line parameter, you must map it back to your query (Query 1). Under Data,
double-click Query 1.

17.Right-click PRODUCTLINE and select add where condition.
The condition.edit dialog box appears.

18.Type ${enter_prodline} in the edit area and click OK.

19.Click OK to exit the /SQL Query Designer.

20.Click OK to exit the Data Source dialog box.

21.
Click  (Preview).



16 | Pentaho BI Suite Official Documentation | Welcome

You should see your product line drop-down list.

22.You are now ready to publish your report.

Publishing Your Report

You have created and formatted a simple report, added a chart, and now you are ready to share the report with your
users.

1. In the Report Designer, click File -> Open to open the report you just created.

2. Click File -> Publish. Alternatively, click .
If you haven't saved the report, a warning message reminds you to save it. The Login dialog box appears, pre-
populated with credentials valid for the evaluation.

Important:  Make sure that the Server URL is set to http://localhost:8080/pentaho/.

3. Click OK.
The Publish to Server dialog box appears.

4. In the Publish to Server dialog box, type in a report name and description into the appropriate fields.

5. Under Location, save the report in the .../steel-wheels/reports folder.

6. Select html as the Output Type.

7. In the Publish Password text field, type the publish password, password, and click OK.
A success message appears.

8. Click Yes to go directly to the Pentaho User Console to view the report you just published.

If you want to access the report later, log into the BI Server by going to http:// localhost:8080 in your Web browser,
then navigate to the Reporting Examples directory in the Solution Browser. You should see your published report
in the list. If not, click Tools -> Refresh Repository.

9. Log in as Joe. Joe's password is password.

10.Your report displays in the Pentaho User Console.
You now have a report that users can view at any time.
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11.In the Pentaho User Console select your product line parameter from the drop-down list. Accept the default under
Output Type.

From Evaluation to Implementation
This document was designed to quickly demonstrate basic Pentaho Report Designer features. To find out more about
the benefits of Pentaho Reporting and Pentaho Enterprise Edition product offerings, contact Pentaho Sales.

http://www.pentaho.com/contact/
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