How to Unmirror a File System
Use this procedure to unmirror a file system that can be unmounted while
the system is running. To unmirror root (/
), /var
, /usr
, or swap
, or any other file system that
cannot be unmounted while the system is running, see How to Unmirror a File System That Cannot Be Unmounted.
Read Creating and Maintaining RAID-1 Volumes.
Make sure that you have root privilege and that you have a current backup of all data.
Verify that at least one submirror is in the Okay state.
# metastat mirror
Unmount the file system.
# umount /file-system
Detach the submirror that will continue to be used for the file system.
# metadetach mirror
submirror
For more information, see the metadetach ( 1M ) man page.
Clear the mirror and remaining subcomponents.
# metaclear -r mirror
For more information, see the metaclear ( 1M ) man page.
Edit the /etc/vfstab
file
to use the component detached in Step 4, if necessary.
Remount the file system.
# mount /file-system
Example 11.21. Unmirroring the /opt
File System
#metastat d4
d4: Mirror Submirror 0: d2 State: Okay Submirror 1: d3 State: Okay Pass: 1 Read option: roundrobin (default) Write option: parallel (default) Size: 2100735 blocks (1.0 GB) d2: Submirror of d4 State: Okay Size: 2100735 blocks (1.0 GB) Stripe 0: Device Start Block Dbase State Reloc Hot Spare c0t0d0s0 0 No Okay Yes d3: Submirror of d4 State: Okay Size: 2100735 blocks (1.0 GB) Stripe 0: Device Start Block Dbase State Reloc Hot Spare c1t0d0s0 0 No Okay Yes ... #umount /opt
#metadetach d4 d2
d4: submirror d2 is detached #metaclear -r d4
d4: Mirror is cleared d3: Concat/Stripe is cleared (Edit the /etc/vfstab file so that the entry for /opt is changed from d4 to the underlying slice or volume) #mount /opt
In this example, the /opt
file system is composed
of a two-way mirror, d4
. The submirrors of the mirror
are d2
and d3
. The submirrors are
composed of slices /dev/dsk/c0t0d0s0
and /dev/dsk/c1t0d0s0
. The metastat command verifies that at least
one submirror is in the “Okay” state. (A mirror with no submirrors
in the “Okay” state must be repaired first.) The file system is
unmounted. Then, submirror d2
is detached. The metaclear
r
command deletes the mirror and the other submirror, d3
.
Next, the entry for /opt
in the /etc/vfstab
file
is changed to reference the underlying slice.
In this example the /etc/vfstab file
contains the
following entry for the /opt
file system:
/dev/md/dsk/d4 /dev/md/rdsk/d4 /opt ufs 2 yes -
Change the entry to read as follows:
/dev/md/dsk/d2 /dev/md/rdsk/d2 /opt ufs 2 yes -
By using the submirror name, you can continue to have the file system
mounted on a volume. Finally, the /opt
file system is
remounted.
By using d2
instead of d4
in
the /etc/vfstab
file, you have unmirrored the mirror.
Because d2
consists of a single slice, you can mount
the file system on the slice name (/dev/dsk/c0t0d0s0
)
if you do not want the device to support a volume.
How to Unmirror a File System That Cannot Be Unmounted
Use this task to unmirror file systems, including root (/
), /usr
, /opt
, and swap
,
that cannot be unmounted during normal system operation.
Make sure that you have root privilege and that you have a current backup of all data.
Verify that at least one submirror is in the Okay state.
# metastat mirror
Detach the submirror that will continue to be used for the file system.
# metadetach mirror
submirror
For more information, see the metadetach ( 1M ) man page.
Use one of the following commands, depending the file system you want to unmirror:
For the /usr
, /opt
,
or swap
file systems, change the file system entry in
the /etc/vfstab
file to use a non-Solaris Volume Manager device
(slice).
For the root (/
) file system only:
run the metaroot command.
# metaroot rootslice
For more information, see the metaroot ( 1M ) man page.
Reboot the system.
# reboot
Clear the remaining mirror and submirrors.
# metaclear -r mirror
For more information, see the metaclear ( 1M ) man page.
Example 11.22. Unmirroring the root (/
) File System
#metastat d0
d0: Mirror Submirror 0: d10 State: Okay Submirror 1: d20 State: Okay Pass: 1 Read option: roundrobin (default) Write option: parallel (default) Size: 2100735 blocks (1.0 GB) d10: Submirror of d0 State: Okay Size: 2100735 blocks (1.0 GB) Stripe 0: Device Start Block Dbase State Reloc Hot Spare c0t3d0s0 0 No Okay Yes d20: Submirror of d0 State: Okay Size: 2100735 blocks (1.0 GB) Stripe 0: Device Start Block Dbase State Reloc Hot Spare c1t3d0s0 0 No Okay Yes #metadetach d0 d20
d0: submirror d20 is detached #metaroot /dev/dsk/c0t3d0s0
#reboot
... #metaclear -r d0
d0: Mirror is cleared d10: Concat/Stripe is cleared #metaclear d20
d20: Concat/Stripe is cleared
In this example, the root (/
) file system is a
two-way mirror, d0
. The submirrors of the mirror are d10
and d20
. The submirrors are composed of
slices /dev/dsk/c0t3d0s0
and /dev/dsk/c1t3d0s0
.
The metastat command verifies that at least one submirror
is in the “Okay” state. (A mirror with no submirrors in the “Okay”
state must be repaired first.) Submirror d20
is detached
to make d0
a one-way mirror.
The rootslice is the slice containing the root
(/
) file system. The metaroot command
is run, using the rootslice
from which the system
is going to boot. This command edits the /etc/system
and /etc/vfstab
files. The command removes information that specifies
mirroring of the root (/
) file system.
After rebooting the system, the metaclear
r
command
deletes the mirror and the other submirror, d10
. The
last metaclear command clears submirror d20
.
Example 11.23. Unmirroring the swap
File System
#metastat d1
d1: Mirror Submirror 0: d11 State: Okay Submirror 1: d21 State: Okay ... #metadetach d1 d21
d1: submirror d21 is detached (Edit the /etc/vfstab file to change the entry for swap from metadevice to slice name) #reboot
... #metaclear -r d1
d1: Mirror is cleared d11: Concat/Stripe is cleared #metaclear d21
d21: Concat/stripe is cleared
In this example, the swap
file system is
made of a two-way mirror, d1
. The submirrors of the mirror
are d11
and d21
. The submirrors
are composed of slices /dev/dsk/c0t3d0s1
and /dev/dsk/c1t3d0s1
. The metastat command verifies that at least
one submirror is in the “Okay” state. (A mirror with no submirrors
in the “Okay” state must be repaired first.) Submirror d21
is
detached to make d1
a one-way mirror. Next, the /etc/vfstab
file is edited to change the entry for swap
to
reference the slice that is in submirror d21
.
In this example, the /etc/vfstab file
contains
the following entry for the swap
file system:
/dev/md/dsk/d4 /dev/md/rdsk/d4 /opt ufs 2 yes -
/dev/md/dsk/d1 - - swap - no -
Change the entry to read as follows:
/dev/dsk/c0t3d0s1 - - swap - no -
After rebooting the system, the metaclear
r
command
deletes the mirror and the other submirror, d11
. The
final metaclear command clears submirror d21
.