One can think of Livelli as the acetate sheets that were once used to make animated cartoons. Each Livello can contain one or more objects. The final image is made up of all the (visible) Livelli stacked on top of each other. Livelli can be made visible or invisible, given an opacity, moved up or down relative to other Livelli, locked, deleted, and named.

Internally, Livelli are just SVG Gruppi with a few extra Inkscape specific parameters that Inkscape uses to control the Livello interface. Like Gruppi, Livelli can contain sub-Livelli.

Livelli can be manipulated by using the Livelli dialog, through commands in the Livelli menu, or through items in the Barra di Stato. New in v0.46, the Livelli dialog can also be used to quickly blend a Livello with the background. See below for details.

Layers Dialog

The Livelli dialog is the easiest way to manipulate Livelli. Call up the dialog via the Livello Livelli... (Shift+Ctrl+L) command.

Layer dialog.
Livelli dialog with the default layer.

The dialog will list all the Livelli in the document. The currently selected Livello is highlighted. Selecting an object in a different Livello will select the Livello that object is in. One can also click on a Livello name to select that Livello. Only one Livello can be selected at a time.

In front of the Livello names are two icons that show if a layer is visible ( ) or not ( ) and if a layer is locked ( ) or unlocked ( ). Clicking on one of the icons toggles the state of that icon. A layer need not be selected in order to toggle its states. Objects in locked or invisible Livelli cannot be selected or changed.

The buttons below the Livello list can be used to add or delete a Livello and to move the selected Livello up or down relative to other Livelli. A sub-Livello cannot be moved outside of the Livello it is under; you can use the Editor XML to do this.

  • : Add a new Livello. A dialog will pop up allowing input of the Livello name. A drop-down menu allows you to add the new Livello above, below, or as a sub-Livello of the currently selected layer.

  • : Move selected layer to top.

  • : Move selected layer up one layer.

  • : Move selected layer down one step.

  • : Move selected layer to bottom.

  • : Delete selected layer.

New in v0.46:

Beneath the row of buttons there is a drop-down menu for the Blend mode. This is a short cut to applying the Miscela filter to the entire Livello. The Normal entry corresponds to no Filtro. Selecting one of the other entries creates a Miscela filter with the selected mode. The first input to the filter is the Livello (recall that a Livello is just a Gruppo) and the second input is the Background Image. If the menu is returned to the Normal setting, the Miscela filter is automatically deleted.

Demonstration of layer blending.
A demonstration of using Livello blending. The two texts are in different Livelli with "Layer 1" beneath "Layer 2". The Blend mode is set to Screen for the upper Livello.

At the bottom of the dialog is a slider and an entry box that can be used to change the opacity of the Livello.

Layers Menu

The Livello menu has commands to create, rename, delete, and change the order of Livelli. There are also commands to move objects between Livelli. The commands in the Livelli menu are

  • Livello Aggiungi Livello... : Add a new layer above currently selected layer. A simple dialog opens up where the Livello can be named.

  • Livello Rinomina Livello... : Rename selected layer. A simple dialog opens up where the Livello can be renamed.

  • Livello Passa al Livello Superiore: Select layer above current layer.

  • Livello Passa al Livello Inferiore: Select layer below current layer.

  • Livello Sposta Selezione al Livello Superiore (Shift+Page Up): Move selected object(s) to layer above current layer.

  • Livello Sposta Selezione al Livello Inferiore (Shift+Page Down): Move selected object(s) to layer below current layer.

  • Livello Alza Livello (Shift+Ctrl+Page Up): Move current layer above layer above.

  • Livello Abbassa Livello (Shift+Ctrl+Page Down): Move current layer under layer below.

  • Livello Sposta Livello in Cima (Shift+Ctrl+Home): Move current layer to top of layer stack.

  • Livello Sposta Livello in Fondo (Shift+Ctrl+End): Move current layer to bottom of layer stack.

  • Livello Elimina Livello Attuale: Delete current layer.

Status Bar

The Barra di Stato includes a pull-down menu to select the current Livello. The icons in front of the menu indicate if the layer is visible or hidden and if it is locked or unlocked (see la sezione chiamata «Layers Dialog»). Clicking on an icon toggles the state.